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Siemens Industry Online Support 
This article is taken from the Siemens Industry Online Support. The following link 
takes you directly to the download page of this document: 
http://support.automation.siemens.com/WW/view/en/24023824 
 
Caution 
The functions and solutions described in this article confine themselves to the 
realization of the automation task predominantly. Please take into account 
furthermore that corresponding protective measures have to be taken up in the 
context of Industrial Security when connecting your equipment to other parts of the 
plant, the enterprise network or the Internet. Further information can be found 
under the Item-ID 50203404. 
http://support.automation.siemens.com/WW/view/en/50203404 
 
 

http://support.automation.siemens.com/WW/view/en/24023824
http://support.automation.siemens.com/WW/view/en/50203404
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Warranty and liability 
 

NOTE The Application Examples are not binding and do not claim to be complete 
regarding the circuits shown, equipping and any eventuality. The Application 
Examples do not represent customer-specific solutions. They are only intended 
to provide support for typical applications. You are responsible for ensuring that 
the described products are used correctly. These application examples do not 
relieve you of the responsibility to use safe practices in application, installation, 
operation and maintenance. When using these Application Examples, you 
recognize that we cannot be made liable for any damage/claims beyond the 
liability clause described. We reserve the right to make changes to these 
Application Examples at any time without prior notice.  
If there are any deviations between the recommendations provided in these 
application examples and other Siemens publications – e.g. Catalogs – the 
contents of the other documents have priority. 

 
We do not accept any liability for the information contained in this document. 

Any claims against us – based on whatever legal reason – resulting from the use of 
the examples, information, programs, engineering and performance data etc., 
described in this Application Example shall be excluded. Such an exclusion shall 
not apply in the case of mandatory liability, e.g. under the German Product Liability 
Act (“Produkthaftungsgesetz”), in case of intent, gross negligence, or injury of life, 
body or health, guarantee for the quality of a product, fraudulent concealment of a 
deficiency or breach of a condition which goes to the root of the contract 
(“wesentliche Vertragspflichten”). The damages for a breach of a substantial 
contractual obligation are, however, limited to the foreseeable damage, typical for 
the type of contract, except in the event of intent or gross negligence or injury to 
life, body or health. The above provisions do not imply a change of the burden of 
proof to your detriment. 
 
Any form of duplication or distribution of these Application Examples or excerpts 
hereof is prohibited without the expressed consent of Siemens Industry Sector. 
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Preface 
Purpose of this document 

Typical PCS 7 systems have at least one ES (Engineering Station) on the PC side, 
one or more possibly redundant servers, as well as several OS clients (Operator 
Stations). Apart from the maximum availability of process control and data 
acquisition, the predominant option here is loading program changes or 
expansions quickly into the running process with out any interference. 
In comparison, small systems or stand alone units tend to work with extremely little 
maintenance requirements after commissioning. To reaching a high efficiency 
requires being able to work with as few PC stations as possible. It therefore makes 
sense to use the rarely used ES as an OS in process mode. 
This document is meant as a selection aid during research for the suitable PC 
configuration for small plants. Various minimal configurations (up to a maximum of 
three PCs) are compared regarding their functionality. Since the respective PCS 7 
configuration is not a focus of the system documentation, the activities necessary 
for the setup are given in form of detailed step-by-step instructions. 

Main contents 
The main focus is on the following points: 
 Configuration comparison regarding functionalitiy 

 Activities for engineering of the various configurations 
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1 Minimal Configurations - An Overview 
 
Based upon using the Engineering Station as an Operator Station in process 
mode, or realizing several OS with as few PCs as possible, various constellations 
are possible. The following variants were selected according to feasibility and 
sensibility within the context of PCS 7. 
In connection with the configurations shown here, possible solutions are described, 
where the configurations do not differ considerably. 
Generally, when using the engineering computer as OS, certain functionality losses 
must be taken into account, as for certain activities the OS project must be closed. 
This will also be discussed below in more detail. 
 
 

1.1 ES/OS Stand-alone Systems 

The smallest of all possible configurations requires only one PC station. 
 
Figure 1-1 

 

Process mode / functionality 
Since version 6.1 of PCS 7, the OS project can also be compiled while Runtime is 
activated (delta compilation). This provides the operator function and archiving 
functions permanently. 
 

NOTE The description and configuration instruction for this configuration is available in 
chapter 3 ES/OS Stand-alone Systems. 

 
 

Alternatives / variations 
Alternatively, the complete SIMATIC PCS 7 BOX package is also an option. It 
combines the AS, the OS and the ES in a compact PC system. A PROFIBUS 
interface for connecting the decentralized process periphery is also integrated. 
 

NOTE The stand-alone system ES/OS can also be expanded by the PCS 7 OS Web 
server functionality. The respective instruction can be found in chapter 7 
"Expansion by PCS 7 Web Option" 
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1.2 ES/OS Client and OS Server 

With an additional PC station as the OS server, there is the option of using the ES 
as the OS client. It accesses the data of the OS server in process mode and 
visualizes the data. 
 
Figure 1-2 

 
 

Process mode / functionality 
For PCS 7, the OS server can be used for operator functions if a maximum of four 
OS clients are connected. During server failure, however, the complete OS 
functionality fails in this example. Furthermore, the OS client must be closed for 
later OS project changes. However, the OS server continues working during 
compiling/loading of changes. 
 

NOTE The description and configuration instruction for this configuration is available in 
chapter 4 “ES/OS Client and OS Server”. 

 
 

Alternatives / variations 
Another advantage of this configuration is the option of connecting further clients to 
the OS server in a relative simple and cost-effective way. 
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1.3  ES, OS-Master and OS- Standby 

The PCS 7-conform realization of the OS redundancy requires three PC stations. 
The ES then only fulfills engineering tasks and is only used for testing OS functions 
during that time. 
 
Figure 1-3 

 

Process mode / functionality 
Since the ES is not involved in the process mode, the operator functions of both 
OS Single Stations are permanently available. Even during a complete download 
of project changes, one OS always remains active. The redundancy provides for 
mutual synchronization. Online as well as after failure of one of the partners. 
The COM-Cable (RS 232 Connection) is used for optimization of internal 
communication between both OS Single Stations. 
From PCS 7 V7.0 it is also possible to implement the redundancy connection via 
an Industrial Ethernet connection (BCE or CP1613/CP1623) instead of the COM 
connection. 
 

NOTE The description and configuration instruction for this configuration is available in 
chapter 5 “ES, OS-Master and OS-Standby”. 

 
 

Alternatives / variations 
The low-maintenance systems focused on in this documentation often do not 
require a permanent ES. If a temporary ES is hired for configuration, 
commissioning and project changes. 
The theoretical expansion with additional OS clients is not possible without 
problems in this example, as the two OS have not been installed server operating 
systems. 
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1.4 ES/OS-Master and OS-Standby 

For this configuration with two redundant OS single-user systems one of both 
stations is simultaneously used as ES, which saves a separate third station. 
 
Figure 1-4 

 

Process mode / functionality 
In this example, both PC stations work as redundant stand-alone OS stations in 
process mode, which mutually synchronize each other during operation as well as 
after failure of one of the partners. This also becomes relevant during later OS 
project changes for which the master OS needs to be terminated. In this case, the 
standby OS takes on the master role. It continues working during 
compiling/downloading of the changes and updates the redundancy partner after 
its return. 
The COM-Cable (RS 232 Connection) is used for optimization of internal 
communication between both OS Single Stations. 
From PCS 7 V7.0 it is also possible to implement the redundancy connection via 
an Industrial Ethernet connection (BCE or CP1613/CP1623) instead of the COM 
connection. 
For a complete download, the OS project must be deactivated and closed on both 
stations. During this time, no OS functionalities are available. 
 

NOTE This architecture does not provide the full PCS 7 functionality because the 
redundancy is setup based on WinCC tools. 

The respective restrictions during process operation and differences in system 
behavior can be found together with description and configuration instruction in 
chapter 6 "ES/OS-Master and OS-Standby". 
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Alternatives / variations 
In order to achieve a PCS 7-compliant configuration of the OS redundancy, it is 
recommended to use three PC stations. With the change of the license concept as 
of PCS 7 V8.0, the same side of license packages is required for this purpose. The 
configuration of the redundancy with two PC stations is partly limited (see chapter 
6.1 Configuration Description) and only saves you one hardware compared to the 
PCS 7 compliant configuration with one separate ES and two redundant single 
stations (see chapter “1.3  ES, OS-Master and OS- Standby“). 
 

NOTE The stand-alone system ES/OS can also be expanded by the PCS 7 OS Web 
server functionality. The respective instruction can be found in chapter 7 
"Expansion by PCS 7 Web Option". 
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2 General/Optional System Settings 
The relevant cross-configuration system settings are suggested below. 
 

2.1 Bus Connection of the PC Stations 

Plant bus (system bus) 
In the ES as well as in each server, a network card in “Configured Mode” is 
employed for the plantbus. On this network card, only the ISO protocol is activated 
for Windows. If a CP 1623 exists, it is used as access to the plantbus. The 
configuration occurs in SIMATIC NetPro and HW Config. 

Terminal bus 
Apart from the configuration with only one ES/OS single station, all other PC 
stations are also linked with the terminal bus. The required second network card of 
ES and the server is set to “PG operation”. In SIMATIC NetPro and HW Config this 
card is not configured. PCS 7 finds this network access via the computer names or 
the paths for the target computer, which must be entered at the Object Properties 
of the PC station. For this network card, only the TCP/IP protocol (no ISO) is 
activated for Windows. 
Client-PC stations are generally only equipped with a network card that connects 
them to the terminal bus. For this network card, only the TCP/IP protocol (no ISO) 
is activated for Windows. 
 
 

2.2 WinCC Autostart 

This document contains the step-by-step instructions, that the OS project in the 
WinCC Explorer is opened on the OS servers and clients for the purpose of 
activating Runtime. 
In the system this should be avoided, as normally no configuration licenses (RC 
licenses) exist on the OS. If the WinCC Explorer is hereby opened for more than 
two hours, WinCC goes into demo mode and must be closed entirely for further 
configuration steps (incl. Runtime) and be opened again. 
In order to activate Runtime automatically with the computer start-up without 
opening the WinCC Explorer, an autostart for the project can be configured. 
In conjunction with SIMATIC NET Edition 2005 (as from WinCC V6.0 SP3) the 
WinCC tool "AutoStartRT" should be configured in "Set SIMATIC NET 
Configuration Console PC station" in order to configure the WinCC Autostart: 
http://support.automation.siemens.com/WW/view/en/23061262 

http://support.automation.siemens.com/WW/view/en/23061262
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3 ES/OS Stand-alone Systems 
3.1 Configuration Description 

The stand-alone system is the smallest possible configuration. The same PC is 
used for ES and OS functionalities. 

Hardware configuration 
Figure 3-1 

 
 

PCS 7 configuration 
Figure 3-2 
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3.2 Required Hardware and Software Licenses 

 

Hardware 
The following hardware is recommended for this configuration and can be ordered 
via the Siemens mall. Your selected operating system and the system software 
SIMATIC PCS 7 are then preinstalled accordingly. 
 

Table 3-1 

Station Product information Operating system Plantbus transition 

ES/OS SIMATIC PCS 7 ES/OS 
IPC547D BCE 

Windows 7 RJ45 
network card 

SIMATIC PCS 7 ES/OS 
IPC547D IE 

Windows 7 CP 1632 

 
 

Software licenses 
In the following please find the software/license package necessary for this 
configuration selection. 
In the selected configuration as a stand-alone system, the number of the POs is 
restricted to no more than 2000. 

Table 3-2 

Component Software/license package 

ES/OS  SIMATIC PCS 7 AS/OS Engineering Software V8.0  
(PO unlimited) 

 SIMATIC PCS 7 AS Runtime License  
(max. 2000 POs) 

 SIMATIC PCS 7 OS Software Single Station V8.0 
 SIMATIC PCS 7 OS Runtime License  

(max. 2000 POs) 
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3.3 Step-by-step Configuration 

NOTE The following instruction was generated on the basis of Windows 7 and 
PCS 7 V8.0 SP1. 

For the plantbus transition a CP1623 is used as an example. 

 
 

3.3.1 ES Configuration 

 

Generating the multiproject 
As a basis for the following instruction, all PC stations must be physically 
networked according to Figure 4-1 (S. 14). Furthermore, a multiproject must have 
been created on the ES in which the AS has already been configured regarding 
hardware and software. 
 

Generating a PC station 
In the PCS 7 project, the PC station is generated, which represents the ES as well 
as the OS. 
 

Table 3-3 

Step Activity Screenshot 
1.   In the “Component view”, open the context 

menu of the project and insert a new PC 
station via “Insert New Object > SIMATIC 
PC Station”. 
Change the name of the PC station so that 
it corresponds to the name of the local 
computer in the network. 
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Step Activity Screenshot 
2.   Open the HW Config of the PC station of 

the OS server. 

 
3.   From the object catalog (“View > Catalog”), 

add a “WinCC Application” and a network 
card of the type “CP1623”. 

 
4.   Under “Subnet”, select the plantbus or 

create it with the button “New…” 
Assign the respective MAC address to the 
CP 1623. 
Deactivate the option “IP protocol is being 
used”. 
Confirm the settings with “OK”. 

 
5.   Save and compile the configuration via 

menu item “Station > Save and Compile”. 
Close the HW Config. 
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Configuring the PC station 
The function “Configure PC station” transfers the project configuration to one or 
more target stations. 
 

Table 3-4 

Step Activity Screenshot 
6.   Configure the component configurator of 

the ES. Select the PC station of the ES 
and choose “PLC > Configure…” from the 
context menu. 

 
7.   Under “Accessible computers”, choose 

choose the PC which is provided for 
configuration. 
 
NOTE 
If you chose the option “Computer name 
identical to the PC station name” in the 
component view “Object Properties” for the 
PC station, the component configurator 
directly displays the target computer to be 
configured. 
 
With “Display”, you can have the current 
configuration of the PC station displayed. 
Hit the “Configure…” button. 
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Step Activity Screenshot 
8.   In the displayed window you see how the 

PC station is configured. 
Confirm this with “OK”. 

 
9.   Acknowledge the information with “OK”. 

 
10.  Finally, you receive the following message 

in the bottom window: “Transfer completed 
successfully.” 
Close the configuration dialog box. 
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Configuration and download of the AS/OS communication 
The connection with NetPro is configured below and loaded into the stations. 
 

NOTE For station granular configuration, the subnets of the individual subprojects must 
be joined beforehand. 

 
 

Table 3-5 

Step Activity Screenshot 
11.  Open NetPro. 

Select the WinCC application of the ES 
and open the context menu. Choose 
“Insert New Connection”. 

 
12.  In the “Connection Partner” window, select 

CPU of the AS. 
Make sure that in the “Connection” field, 
“S7 connection” has been selected. 
Confirm the setting with “OK”. 
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Step Activity Screenshot 
13.  In the “General” tab, in “Connection 

identification”, change the “Local ID” into a 
meaningful name, like AS60. 
Confirm the entry with “OK”. 

 
14.  Save and compile “Network” > “Save and 

Compile…”. 
Select “Compile and check everything”. 
Confirm the setting with “OK”. 

 
15.  Mark the ES and then, over the context 

menu item load “Download to Current 
Project > Selected Stations”. 
Download the AS in the same way. 
Then close NetPro. 

 
 
 

Compile and download the user program 
Compile the S7 program and download it into the AS. 
 

Compiling the OS project 
Prior to that compile the OS project in the SIMATIC Manager. 
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3.3.2 OS configuration 

Table 3-6 

Step Activity Screenshot 
1.   Open the OS project. 

In the opened WinCC Explorer, open the 
OS project and select “Properties” in the 
context menu. 
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Step Activity Screenshot 
2.   In the “General” tab under “type:” 

select “Single-User Project”. 
Confirm the selection and the message 
that appears with the “OK” button. 

 

 
3.   Prevent deleting the startup list by pressing 

the “No” button. 

 
4.   Close the WinCC Explorer. 

 
NOTE 
The changes will only become effective 
when the WinCC Explorer has been closed 
and opened again. 
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3.3.3 Activating Runtime 

After the OS project has been closed, you can open it again and activate Runtime. 
 

3.3.4 Particularities at downloading of OS Project Modifications 

If OS and ES are operated in a computer, no load process must be per-formed as 
all of the required data already exists. Here, executing the “Compile OS“ function is 
sufficient. 
Analog to the “Download changes“ function, the “Compile changes“ function can be 
executed at stand-alone systems without terminating the process mode of the OS. 
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4 ES/OS Client and OS Server 
4.1 Configuration Description 

For a server-client structure with only two computers, the ES serves as the OS 
client at the same time. In the configuration, three PC stations are provided for. 
 
Figure 4-1 

 

  

Terminal bus

Plant bus

OSES / OS-Client

 
 

PCS 7 configuration 
Figure 4-2 
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4.2 Required Hardware and Software Licenses 

Hardware 
The following hardware is recommended for this configuration and can be ordered 
via the Siemens mall. Your selected operating system and the system software 
SIMATIC PCS 7 is then preinstalled accordingly. 
 

Table 4-1 

Component Product information Operating system Plantbus 
transition 

ES/OS Client SIMATIC PCS 7 ES/OS 
IPC547D BCE 

Windows 7 RJ45 
network card 

SIMATIC PCS 7 ES/OS 
IPC547D IE 

Windows 7 CP 1623 

OS Server SIMATIC PCS 7 ES/OS 
IPC547D BCE 

Windows Server 2008 R2 RJ45 
network card 

SIMATIC PCS 7 ES/OS 
IPC547D IE 

Windows Server 2008 R2 CP 1623 

 

Software licenses 
In the following the different software/license packages required for this 
configuration selection have been listed. 
An OS server can provide up to 8500 POs with the respective software package - 
depending on the scope of the project. In addition to the Engineering Software, an 
OS client software must be installed on the ES. 

Table 4-2 

Component Software/license packages 

ES/OS Client  SIMATIC PCS 7 AS/OS Engineering Software V8.0 
(PO unlimited) 

 SIMATIC PCS 7 AS Runtime License  
(max. 2000 PO) 

 SIMATIC PCS 7 OS Software Client V8.0 
OS Server  SIMATIC PCS 7 OS Software Server V8.0 

 SIMATIC PCS 7 OS Runtime License  
(max. 8500 PO) 
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4.3 Step-by-step Configuration 

Note The following instruction was generated on the basis of Windows 7 and 
PCS 7 V8.0 SP1. 

For the plantbus transitions, CP1623 is used as an example. A clock 
synchronization is activated. 

The PC stations in the test setup are called: 

 ES/OS client:  ES60 
 OS server:      SV60A 

 
 

4.3.1 Preparatory Steps 

Create a project folder in the OS server and release it. You can then transmit OS 
data configured on the Engineering Station to the OS. 
 

4.3.2 ES Configuration 

Generating the multiproject 
As a basis for the following instruction, all PC stations must be physically 
networked according to Figure 4-1 (S.25). Furthermore, a multiproject must have 
been generated on the ES in which the AS has already been configured regarding 
hardware and software. 
Then you can start with the following CPU and CP settings. 
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AS settings 
This example describes a path where the OS server defines the master time. 
 

NOTE Further options of clock synchronization are described in detail in the Manuals: 

 SIMATIC Process Control System PCS 7 Operator Station (V8.0)  
 SIMATIC Process Control System PCS 7 Time synchronization (V8.0) 

 
Table 4-3 

Step Activity Screenshot 
1.   Open the HW Config of the AS. 

Select the CPU and choose “Object 
Properties…” from the context menu. 

 
2.   Go to the “Diagnostics/clock” tab. 

In the section under “Clock”, set “As 
slave” for the AS under “Synchronization 
Type”. 
Confirm the setting with “OK”. 

 

http://support.automation.siemens.com/WW/view/de/61187410/0/en
http://support.automation.siemens.com/WW/view/de/61189664/0/en
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Step Activity Screenshot 
3.   Open the context menu of the CP and 

select “Object Properties…”. 

 
4.   Go to the “Time-of-Day Synchronization” 

tab. 
Activate the option “Activate SIMATIC 
time-of-day synchronization”. 
Confirm the setting with “OK”. 

 
5.   Save and compile the configuration with 

“Station > Save and Compile”. 
Close the HW Config. 
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Generating the ES PC station 
In order to be able to test the OS project on the ES, generate a PC station for the 
ES with WinCC Application. 
 

Table 4-4 

Step Activity Screenshot 
1.   In the “Component view”, open the context 

menu of the project and insert a new PC 
station via “Insert New Object > SIMATIC 
PC Station”. 
Change the name of the PC station so that 
it corresponds to the name of the local 
computer in the network. 

 
2.   Open the HW Config of the PC station of 

the OS server. 

 
3.   From the object catalog (“View > Catalog”), 

add a “WinCC Application” and a network 
card of the type “CP1623”. 
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Step Activity Screenshot 
4.   Under “Subnet”, select the Plant Bus or 

create it with the button “New”. 
Assign the respective MAC address to the 
CP 1623. 
Deactivate the option “IP protocol is being 
used”. 
Confirm the settings with “OK”. 

 
5.   Open the context menu of the CP 1623 

and select “Object Properties…”. 

 
6.   Select the “Options” tab and checkmark 

the “Time of day” box. 
Confirm the setting with “OK”. 

 
7.   Save and compile via menu item “Station > 

Save and Compile”. 
Close the HW Config. 

 

8.   
optional 

In the SIMATIC Manager, delete the OS 
application of the PC station of the ES as it 
is not required in our example. 
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Generating the OS server PC station 
 

Table 4-5 

Step Activity Screenshot 
1.   In the “Component view”, open the context 

menu of the project and insert a new PC 
station via “Insert New Object > SIMATIC 
PC Station”. You can choose its name 
freely. 

 
2.   Open the HW Config of the PC station with 

the context menu. 

 
3.   From the object catalog (“View > Catalog”), 

add a “WinCC Application” and a network 
card of the type “CP1623”. 
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Step Activity Screenshot 
4.   Under “Subnet”, select the Plant Bus or 

create it with the button “New…”. 
Assign the respective MAC address to the 
CP 1623. 
Deactivate the option “IP protocol is being 
used”. 
Confirm the settings with “OK”. 

 
5.   Open the context menu of the CP1623 and 

select “Object Properties…”. 

 
6.   Switch to the “Options” tab and checkmark 

the “Time of day” box. 
Confirm the setting with “OK”. 

 
7.   Save and compile via menu item “Station > 

Save and Compile”. 
Close the HW Config. 
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Step Activity Screenshot 
8.   In the SIMATIC Manager, open the 

properties dialog of the OS project of the 
OS server. 
Switch to the “Target OS and Standby OS 
Computer” tab. 
Under “Standby-OS”, select  “<none>”. 
Then hit the “Search…” button. 

 
9.   Navigate by the drop down menu to the 

enable project folder of the OS server (see 
4.3.1 Preparatory Steps). 
Hit the “Save” button. 

 
10.  Check the selected path and confirm with 

the “OK” button. 

 
11.  Acknowledge the information dialog with 

“Yes”. 
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Generating the client PC station 
 

Table 4-6 

Step Activity Screenshot 

1.   In the “Component view”, open the context 
menu of the project and insert a new PC 
station via “Insert New Object > SIMATIC 
PC Station”. You can choose its name 
freely. 

 
2.   Open the HW Config of the PC station of 

the OS client. 

 
3.   From the object catalog (“View > Catalog”), 

add a “WinCC Application Client”. 

 
4.   Save and compile via menu item “Station > 

Save and Compile…”. 
Close the HW Config. 

 



4 ES/OS Client and OS Server 
 

 

36 
PCS 7 Minimal Configurations 

V4.4, Item-ID: 24023824   
 

C
op

yr
ig

ht
 

 S
ie

m
en

s 
A

G
 2

01
3 

A
ll 

rig
ht

s 
re

se
rv

ed
 

Step Activity Screenshot 

5.   Open the context menu of the PC station 
of the client in the SIMATIC Manager and 
select “Object Properties”. 

 
6.   Under “Computer name”, enter the name 

of the PC, where the operating of the client 
shall be carried out. In the configuration on 
hand, this is the ES computer 
Confirm the entry with “OK”. 
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Configuring all relevant PC stations 
The function “Configure PC station” transfers the project configuration to one or 
more PLCs. First configure the local components configurator of the ES and then 
the OS connected to the plantbus. 
 

Table 4-7 

Step Activity Screenshot 
1.   Configure the component configurator of 

the ES. Open the ES context menu and 
select “PLC > Configure…”. 

 
2.   Under “Accessible computers”, choose the 

PC which is provided for configuration. 
 
NOTE 
If you chose the option “Computer name 
identical to the PC station name” in the 
component view “Object Properties” for the 
PC station, the component configurator 
directly displays the target computer to be 
configured. 
 
With “Display”, you can have the current 
configuration of the PC station displayed. 
Hit the “Configure…” button. 
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Step Activity Screenshot 
3.   In the displayed window you see how the 

PC station is configured. 
Confirm this setting with “OK”. 

 
4.   Acknowledge the information dialog with 

“OK”. 

 
5.   Finally, you receive the following message 

in the bottom window: “Transfer completed 
successfully.” 
Close the configuration dialog box. 

 
6.   Please configure the component 

configurator of the OS server analog to 
step 1 to 5. 
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Configuration and download of the AS/OS communication 
In the following, the connections between the PC stations and the AS in NetPro are 
configured and downloaded into the individual stations. 
 

NOTE For station granular configuration, the subnets of the individual subprojects must 
be joined beforehand. 

 
 

Table 4-8 

Step Activity Screenshot 
1.   Open NetPro. 

Select the WinCC application of the ES 
and open the context menu. Choose 
“Insert New Connection”. 

 
2.   In the “Connection Partner” window, select 

the CPU of the AS. 
Make sure that in the “Connection” field a 
“S7 connection” has been selected. 
In this example, a fault-tolerant S7 
connection is configured due to the AS 
configuration. 
Confirm the setting with “OK”. 
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Step Activity Screenshot 
3.   In the “General” tab, in “Connection 

identification” change the “Local ID” into a 
meaningful name, like AS60. 
Confirm the entries with “OK”. 

 
4.   Repeat steps 1 to 3 for connecting the OS 

server to the AS. 
It is important here, that the connections of 
the ES and the OS server with the AS 
have identical names. 
Then, save and compile the configuration 
with the menu item “Network > Save and 
compile…”. 
Choose the option “Compile and check 
everything” and confirm with “OK”. 

 

5.   Select the ES and then download the 
connections via the context menu 
“Download to Current Project > Selected 
Stations”. 
Download the OS server and the AS in the 
same way. 
Then close NetPro. 

 

 
 

Compile and download the user program 
Compile the S7 program and download it into the AS. 
 

Compiling the OS server project 
Compile the OS server project in the SIMATIC Manager. 
Look out for the correct OS assignment to the server in Plant View. 
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Assigning the server package 
 

Table 4-9 

Step Activity Screenshot 

1.   Select the OS application of the OS client 
and select “Assign OS server…” in the 
context menu. 

 
2.   Then select the respective OS project and 

acknowledge with “OK”. 
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Step Activity Screenshot 

3.   Confirm the successful download of the 
package with “OK”. 

 

 
 

4.3.3 OS Configuration 

Activating the clock synchronization 
Still on the ES, the necessary settings are activated in the OS projects by OS 
server and OS client. 
 

Table 4-10 

Step Activity Screenshot 

1.   Open the OS server project. 
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Step Activity Screenshot 
2.   Open the editor “Time synchronization” 

with the context menu. 
 
Activate the checkbox “Synchronization via 
System Bus (Master, Slave)”. 
In “Access point 1”, select “CP1623(ISO)” 
and activate the option “Master”. 
Confirm the setting with “OK”. 
 
NOTE 
If the ES server, as opposed to the OS 
server, does not have a CP1623, the 
settings for the clock synchronization 
cannot be executed here. The clock 
synchronization settings must, in this case, 
be executed on the OS server itself after 
the download of the OS project. 

 
3.   Close the OS server project.  
4.   Open the OS client project. 
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Step Activity Screenshot 
5.   Open the editor “Time synchronization” 

with the context menu. 
 
Activate the checkbox “Synchronization via 
Terminal Bus (Slave)” and select “Use the 
time from a connected WinCC server”. 
Confirm the setting with “OK”. 

 

6.   Close the OS client project.  
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Download the OS project to the OS server 
After the clock synchronization has been configured on the ES side, the OS project 
can be downloaded to the OS server. 
 

Table 4-11 

Step Activity Screenshot 
1.   In the SIMATIC Manager, select the OS 

project of the OS server and select  
“PLC > Download” from the context menu. 

 
2.   Downloading the OS project for the first 

time requires a complete download. 
Start the download with “OK”. 
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Step Activity Screenshot 
3.   After the successful download, the OS 

project is located on the OS server in the 
intended folder. 
Confirm this with “OK”. 

 

 
 

OS configuration on the OS server 
After the first download, the following step-by-step instructions for time 
synchronization must be checked and corrected if necessary. 
 

Table 4-12 

Step Activity Screenshot 
1.   Open the OS project on the OS server.  
2.   Open the editor “Time synchronization” 

with the context menu. 
 
Activate the checkbox “Synchronization via 
System Bus (Master, Slave)”. 
In “Access point 1”, check or select 
“CP1623(ISO)” and press the “Master” 
radio button. 
 
Confirm the settings always with “OK”. 
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4.3.4 Activating Runtime 

Open the OS project on the OS server and activate Runtime. 
Then change to the ES computer and open the OS client project. Here, activate 
Runtime, too. 
 
 

4.3.5 Particularities at downloading of OS Project Modifications 

 

Delta-download 
Before OS compilation and download are possible on the ES, the OS client 
Runtime must be deactivated and the WinCC project must be closed. 
 

Entire download 
Before OS compilation and download are possible from the ES, the  
OS client Runtime as well as the OS server Runtime must be deactivated and the 
WinCC projects must be closed 
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5 ES, OS-Master and OS-Standby 
5.1 Configuration Description 

During process operation the server pair runs completely in parallel and absolutely 
independent. If a server fails, there is always an equivalent redundant OS server. 
The servers supervise each other during the runtime and synchronize the project 
archives if necessary. 
The configuration is carried out via the ES. 

Hardware configuration 
 

Figure 5-1 

 

PCS 7 configuration 
Figure 5-2 
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5.2 Required Hardware and Software Licenses 

Hardware 
The following hardware is recommended for this configuration and can be ordered 
via the Siemens mall. Your selected operating system and the system software 
SIMATIC PCS 7 is then preinstalled accordingly. 

Table 5-1 

Station Product information Operating 
system 

Plantbus 
transition 

ES SIMATIC PCS 7 ES/OS IPC547D 
BCE 

Windows 7 RJ45 
network card 

SIMATIC PCS 7 ES/OS IPC547D 
IE 

Windows 7 CP 1623 

2 x OS Single Station  SIMATIC PCS 7 ES/OS IPC547D 
BCE 

Windows 7 RJ45 
network card 

SIMATIC PCS 7 ES/OS IPC547D 
IE 

Windows 7 CP 1623 

 
 

Software licenses 
In the following, the different software/license packages required for this 
configuration selection have been listed. 
In the selected configuration as a redundant stand-alone system, the number of the 
POs is restricted to no more than 5000. 
 

Table 5-2 

Component Software/license packages 

ES  SIMATIC PCS 7 AS/OS Engineering Software V8.0 
(PO unlimited) 

 SIMATIC PCS 7 AS Runtime License 
(max. 2000 POs) 

OS Single Station Redundant  SIMATIC PCS 7 OS Software Single Station 
Redundancy V8.0 (single license for 2 installations) 

 2 x SIMATIC PCS 7 OS Runtime License 
(max. 2000 POs) 
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5.3 Step-by-step Configuration 

 

NOTE The following instruction was generated on the basis of Windows 7 and PCS 7 
V8.0 SP1. 

For the plantbus transitions, CP1623 is used as an example. A clock 
synchronization is activated. 

The PC stations in the test setup are called: 

 ES:                            ES60 
 OS- Server:               SV60A 
 OS-Server Standby:  SV60B 

 
 
 

5.3.1 ES Configuration 

 

Generating the multiproject 
As a basis for the following instruction, all PC stations must be physically 
networked according to Figure 5-1 (S.75). Furthermore, a multiproject must have 
been created on the ES in which the AS has already been configured regarding 
hardware and software. 
Then you can start with the following CPU and CP settings. 
 

AS settings 
Evaluation of the process data requires all components of the process control 
system to work with an identical clock, so that messages can be allocated in the 
correct temporal sequence. 
Below, a path is described where the redundant OS single stations define the 
master time. 
 

NOTE Further options of clock synchronization are described in detail in the following 
manuals: 

 SIMATIC Process Control System PCS 7 Operator Station (V8.0)  
 SIMATIC Process Control System PCS 7 Time synchronization (V8.0) 

 

http://support.automation.siemens.com/WW/view/de/61187410/0/en
http://support.automation.siemens.com/WW/view/de/61189664/0/en
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Table 5-3 

Step Activity Screenshot 
1.   Open the HW Config of the AS. 

Select the CPU and choose “Object 
Properties…” from the context menu. 

 
2.   Go to the “Diagnostics/Clock” tab. 

In the section under “Clock” set “As slave” 
for the AS under “Synchronization Type”. 
Confirm the setting with “OK”. 
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Step Activity Screenshot 
3.   Open the context menu of the CP and 

select “Object Properties…”. 

 
4.   Go to the “Time-of-Day Synchronization” 

tab. 
Activate the option “Activate SIMATIC 
time-of-day synchronization”. 
Confirm the setting with “OK”. 

 
5.   Save and compile the configuration with 

“Station > Save and Compile”. 
Close the HW Config. 
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Generating the ES PC station 
In order to take the OS project on the ES into operation, we generate a PC station 
for the ES with WinCC application. 
 

Table 5-4 

Step Activity Screenshot 
1.   In the “Component view”, open the context 

menu of the project and insert a new PC 
station via “Insert New Object > SIMATIC 
PC Station”. 
Change the name of the PC station so that 
it corresponds to the name of the local 
computer in the network. 

 
2.   Open the HW Config of the PC station of 

the ES with the context menu. 

 
3.   From the object catalog (“View > Catalog”), 

add a “WinCC Application” and a network 
card of the type “CP1623”. 
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Step Activity Screenshot 
4.   Under “Subnet”, select the Plant Bus or 

create it with the button “New…”. 
Assign the respective MAC address to the 
CP 1623. 
Deactivate the option “IP protocol is being 
used”. 
Confirm the settings with “OK”. 

 
5.   Open the context menu of the CP and 

select “Object Properties…”. 

 
6.   Select the “Options” tab and checkmark 

the “Time of day” box. 
Confirm the setting with “OK”. 

 
7.   Save and compile via menu item “Station > 

Save and Compile”. 
Close the HW Config. 

 

8.   
optional 

In the SIMATIC Manager, delete the OS 
project of the PC station of the ES as it is 
not required in our example. 
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Generating the master OS PC station 
 

Table 5-5 

Step Activity Screenshot 
1.   In the “Component view”, open the context 

menu of the project and insert a new PC 
station via “Insert New Object > SIMATIC 
PC Station”. You can choose its name 
freely. 

 
2.   Open the HW Config of the PC station of 

the standby OS with the context menu. 

 
3.   From the object catalog (“View > Catalog”), 

add a “WinCC Application” and a network 
card of the type “CP1623”. 
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Step Activity Screenshot 
4.   Under “Subnet”, select the Plant Bus or 

create it with the button “New…”. 
Assign the respective MAC address to the 
CP 1623. 
Deactivate the option “IP protocol is being 
used”. 
Confirm the settings with “OK”. 

 
5.   Open the context menu of the CP and 

select “Object Properties…”. 

 
6.   Select the “Options” tab and checkmark 

the “Time of day” box. 
Confirm the setting with “OK”. 

 
7.   Save and compile via menu item “Station > 

Save and Compile…”. 
Close the HW Config. 
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Generating the standby OS PC station 
 

Table 5-6 

Step Activity Screenshot 
1.   In the “Component view”, open the context 

menu of the project and insert a new PC 
station via “Insert New Object > SIMATIC 
PC Station”. You can choose its name 
freely. 

 
2.   Open the HW Config of the PC station of 

the standby OS with the context menu. 

 
3.   From the object catalog (“View > Catalog”), 

add a “WinCC Application (stby)” and a 
network card of the type “CP1623”. 
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Step Activity Screenshot 
4.   Under “Subnet”, select the Plant Bus or 

create it with the button “New…”. 
Assign the respective MAC address to the 
CP 1623. 
Deactivate the option “IP protocol is being 
used”. 
Confirm the settings with “OK”. 

 
5.   Open the context menu of the CP and 

select “Object Properties…”. 

 
6.   Select the “Options” tab and checkmark 

the “Time of day” box. 
Confirm the setting with “OK”. 

 
7.   Save and compile via menu item “Station > 

Save and Compile…”. 
Close the HW Config. 
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Configuring all PC stations 
The function “Configure PC station” transfers the project configuration to one or 
more PLCs. First configure the local components configurator of the ES and then 
the OS connected to the plantbus. 
 

Table 5-7 

Step Activity Screenshot 
1.   Configure the component configurator of 

the ES. Select the PC station of the ES 
and choose “PLC > Configure…” from the 
context menu. 

 
2.   Under “Accessible computers”, choose the 

PC which is provided for configuration. 
 
NOTE 
If you chose the option “Computer name 
identical to the PC station name” in the 
component view “Object Properties” for the 
PC station, the component configurator 
directly displays the target computer to be 
configured. 
 
With the button “Display”, you can have the 
current configuration of the PC station 
displayed. 
Hit the “Configure…” button. 
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Step Activity Screenshot 
3.   In the displayed window you see how the 

PC station is configured. 
Confirm this setting with “OK”. 

 
4.   Acknowledge the information dialog with 

“OK”. 

 
5.   Finally, you receive the following message 

in the bottom window:  
“Transfer completed successfully.” 
Close the configuration dialog box. 

 
6.   Please configure the component 

configurator of the master and the standby 
OS analog to steps 1 to 5. 
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Configuration and download of the AS/OS communication 
In the following, the connections between the PC stations and the AS in NetPro are 
configured and downloaded into the individual stations. 
 

NOTE For station granular configuration, the subnets of the individual subprojects must 
be joined beforehand. 

 
 

Table 5-8 

Step Activity Screenshot 
1.   Open NetPro. 

Select the WinCC application of the ES 
and open the context menu. Choose 
“Insert New Connection”. 

 
2.   In the “Connection Partner” window, select 

the CPU of the AS. 
Ensure that in the “Connection” field a “S7 
connection” has been selected. 
In this example, a fault-tolerant S7 
connection is configured due to the AS 
configuration. 
Confirm the setting with “OK”. 
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Step Activity Screenshot 
3.   In the “General” tab, in “Connection 

identification” change the “Local ID” into a 
meaningful name, like AS60. 
Confirm the settings with “OK”. 

 
4.   Repeat steps 1 to 3 for connecting the 

master OS and the standby OS to the AS. 
It is important that the connection of 
master OS, standby OS and ES to the AS 
have identical names. 
Then, save and compile the configuration 
with the menu item “Network > Save and 
compile…”. 
 
Choose the option “Compile and check 
everything” and confirm with “OK”. 

 

5.   Mark the ES and then, over the menu item 
load “PLC > Download to Current Project > 
Selected Stations”. 
Download the AS, master OS, and standby 
OS in the same way. 
Then close NetPro.  
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Master/standby settings on the ES 
Here you make the master/standby assignment and select the download paths. 
 

Table 5-9 

Step Activity Screenshot 

1.   In the SIMATIC Manager, open the 
properties dialog of the master OS. 
Switch to the “Target OS and Standby OS 
Computer” tab. 
In the “Standby-OS” drop-down menu, 
select the Standby OS. 
Checkmark the “Create/update archive 
tags” box and deselected “Transfer to 
central archive server”. 
Press the “Search” button. 

 
2.   Navigate by the drop down menu to the 

enable project folder of the OS server (see 
6.3.1 Preparatory Steps). 
Hit the “Save” button. 

 
3.   Check the path in the box “Path to the 

Target OS Computer”. 
Confirm this with “OK”. 
Also confirm the message box that 
appears with the “OK” button. 

 
4.   Open the Properties dialog of the standby 

OS. 
Switch to the “Target OS and Master OS 
Computers” tab. 
Verify that the master OS has also been 
entered in “Master OS”. 
Hit the “Search…” button to choose the 
storage path of the OS data. 
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Step Activity Screenshot 

5.   Navigate by the drop down menu to the 
enable project folder of the OS standby 
server (see 6.3.1 Preparatory Steps). 
Hit the “Save” button. 

 
6.   Check the path in the box “Path to the 

Target OS Computer” and confirm this with 
“OK”. 
Confirm the message that appears with the 
“OK” button. 

 

 
 

Compile and download the user program 
Compile the S7 program and download it into the AS. 
 

Compiling the OS project 
Compile the OS project of the master OS in the SIMATIC Manager. 
Look out for the correct OS assignment to the server in Plant View. 
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5.3.2 OS Configuration 

 

OS configuration on the Engineering Station 
Conversion from multi to single place systems is made on the ES, as well as 
settings for redundancy and clock synchronization. 
 

Table 5-10 

Step Activity Screenshot 
1.   Open the OS project of the master OS on 

the ES computer. 
In the opened WinCC Explorer, open the 
OS project and select “Properties” in the 
context menu. 
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Step Activity Screenshot 
2.   In the “General” tab under “type:”, select 

“Single-user project”. 
Confirm the selection and the message 
that appears with the “OK” button. 

 

 
3.   Prevent deleting the startup list by pressing 

the “No” button. 

 
4.   Open the editor “Redundancy” with the 

context menu. 
 
Activate the option box “Default Master”. 
Under “Redundanter Partner Sever:” the 
standby OS must be entered. 
Check whether your desired checkboxes 
are activated at “Optional Settings”. 
If you do not wish to operate the RS 232 
redundancy cable at the COM1 interface, 
then these settings must later be 
performed on the OS itself (see section 
“OS configuration on the Operator 
Station”). 
Confirm the settings with “OK”. 
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Step Activity Screenshot 
5.   Open the editor “Time synchronization” 

with the context menu. 
 
Here, activate the checkbox 
“Synchronization via System Bus (Master, 
Slave)”. 
In “Access point 1”, select “CP1623(ISO)” 
and activate the “Master” radio button. 
Activate the option box  
“Display symbolic name of the access 
point”. 
Confirm the settings with “OK”. 
 
NOTE 
If the ES server does not have a CP1623, 
the settings for the clock synchronization 
cannot be executed here. The clock 
synchronization settings must, in this case, 
be executed on both single stations itself 
after downloading the OS project. 

 

6.   Close the OS project.  
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Downloading OS project to the OS computers 
After the redundancy and clock synchronization have been configured on the ES 
side, the OS project can be downloaded to the master and standby OS. 
 

Table 5-11 

Step Activity Screenshot 
1.   In the SIMATIC Manager, select the 

master OS and select “PLC > Download” 
from the context menu. 

 
2.   Downloading the OS project for the first 

time requires a complete download. 
Start the download with “OK”. 
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Step Activity Screenshot 
3.   After the successful download, the OS 

project is located on the master OS in the 
intended folder. 
Confirm this with “OK”. 

 
4.   Repeat steps 1 to 3 to download the OS 

project to the standby OS. 
 

 
 

Configuration of the Operator Station 
If the engineering station has no CP1623 as opposed to the OS, or the RS 232 
redundancy cable is not connected at COM1 there, the following step-by-step 
instructions must be performed. Otherwise, we generally advise you to check the 
project settings after the project download onto the target systems. 
 

NOTE Normally, all configuration works are executed on the ES for the purpose of 
consistent data management, so that no WinCC engineering licenses are 
required on the OS. Nevertheless, a license free time window of one hour is 
available after each opening of the WinCC Explorer for WinCC configuration 
works. 
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Table 5-12 

Step Activity Screenshot 
1.   Open the OS project on the master OS.  
2.   Open the editor “Redundancy” with the 

context menu. 
 
Check the name of the master OS in the 
field “Server”. 
The “Default Master” checkbox must be 
activated. 
Also check whether, under “Redundant 
Partner Server:” the name of the standby 
OS has been entered correctly. 
Check whether your desired checkboxes 
are activated at “Optional Settings”. 
If you are operating the RS 232 
redundancy cable at a location different to 
the COM1 interface, you have to set the 
appropriate interface at “Serial connection 
to redundant partner:”. 
Confirm the settings with “OK”. 

 

3.   Open the editor “Time synchronization” 
with the context menu. 
 
Here, activate the checkbox 
“Synchronization via System Bus (Master, 
Slave)”. 
In “Access point 1”, check or select 
“CP1623(ISO)” and press the “Master” 
radio button. 
 
Confirm the settings always wih “OK”. 

 

4.   If you made any changes in the WinCC 
Explorer project, close the OS project and 
open it again to activate the settings. 
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Step Activity Screenshot 
5.   Repeat steps 1 to 4 on the standby OS 

with the following modifications for step 2 
(redundancy): 
 The “Default Master” checkbox must 

be deactivated. 
 Also check, whether under 

“Redundant Partner Server:” the name 
of the master OS has been entered 
correctly. 

 

 
 

5.3.3 Activating Runtime 

Successively activate the OS project on the master OS as well as on the standby 
OS. It is recommended to wait with activating the second Runtime until the start 
process of the first one is completed entirely. 
Regarding the redundancy, the online synchronization is active immediately. The 
mutual archive update, on the other hand, takes approx. 10-15 min. 
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6 ES/OS-Master and OS-Standby 
6.1 Configuration Description 

For this configuration with two redundant OS single-user systems one of both 
stations is simultaneously used as ES, which saves a separate third station. 
The following two criteria must be followed here, which is why generally a 
configuration with separate ES is advised (see chapter 5 “ES, OS Master and OS 
Standby”): 
 

Comparatively low saving potential 
The saving potential is reduced since PCS 7 V8.0, as the OS Runtime license is no 
longer contained in the ES license. The savings are therefore restricted to the PC 
(Hardware and Windows license). 
 

Particular features for programming 
The configuration deviates from the PCS 7 engineering standard and represents a 
sort of a workaround. 
The PCS 7 standard tools for the redundant OS stations “WinCC application” and 
“WinCC Application Standby” cannot be used, since a delta download would not be 
possible here during runtime. The mechanisms where both systems need to be in 
runtime, and Runtime must be terminated on the ES for the download, mutually 
block each other. 
For this reason, we now configure an OS application, open it on both stations, and 
configure the mutual redundancy respectively local in WinCC. For downloading to 
the OS Single Station, the Runtime and the OS on the ES must be closed,  
 
 

NOTICE This configuration has been tested with a PCS 7 basic installation, including Web 
Option. For the function in conjunction with additional option packages, a 
statement cannot be made. 
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Hardware configuration 
Figure 6-1 

 
 

PCS 7 configuration 
Figure 6-2 
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Particularities / restrictions 
Due to the nontypical PCS 7 configuration with only one OS there are differences 
in the system behavior which must be considered: 
 The first activated OS takes on the master role. 

 For the complete download, Runtime must be deactivated for both computers, 
and the WinCC Explorer must be closed. During this time, neither operator 
actions nor archiving is possible. 

 For a delta-download, Runtime on the ES must be closed again for compiling 
the OS. It can then be re-activated for testing the modified OS functions. For 
the downloading, Runtime must be terminated and the WinCC project must be 
closed.  
The following restrictions result: 

– No operator actions can take place at the ES computer at that time. 
 

NOTICE If Runtime remains active on the ES during the OS compilation, it might 
happen - depending on the changes made - that a subsequent delta-
download is carried out incompletely and results in errors. Afterwards, 
only a complete download will be possible. 

 
 
 Runtime being active on the ES computer results in the runtime archive being 

stored under the multiproject path. Therefore, they are also included into the 
ZIP file during archiving and cause increased storage space as well as 
archiving times. 
Workaround: 

– Deactivate Runtime on the ES computer. 

– Reset archive in the OS project on the ES computer and close the entire 
PCS 7 project. 

After archiving and reactivating Runtime, the archives are updated again. 
Please note that more time will be needed for checking. 
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6.2 Required Hardware and Software Licenses 

 

Hardware 
The following hardware is recommended for this configuration and can be ordered 
via the Siemens mall. Your selected operating system and the system software 
SIMATIC PCS 7 is then preinstalled accordingly. 
 

Table 6-1 

Components Product information Operating 
system 

Plantbus 
transition 

ES/OS SIMATIC PCS 7 ES/OS IPC547D 
BCE 

Windows 7 RJ45 
network card 

SIMATIC PCS 7 ES/OS IPC547D 
IE 

Windows 7 CP 1623 

OS Single Station  SIMATIC PCS 7 ES/OS IPC547D 
BCE 

Windows 7 RJ45 
network card 

SIMATIC PCS 7 ES/OS IPC547D 
IE 

Windows 7 CP 1623 

 

Software licenses 
In the following, the different software/license packages required for this 
configuration selection have been listed.  
 

Table 6-2 

Components Software/license packages 

ES  SIMATIC PCS 7 AS/OS Engineering Software V8.0 
(PO unlimited) 

 SIMATIC PCS 7 AS Runtime License 
(max. 2000 POs) 

OS Single Station Redundant  SIMATIC PCS 7 OS Software Single Station Redundancy 
V8.0 (single license for 2 installations) 

 2 x SIMATIC PCS 7 OS Runtime License 
(max. 2000 POs) 
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6.3 Step-by-step Configuration 

 

NOTE The following instruction was generated on the basis of Windows 7 and 
PCS 7 V8.0 SP1. 

For the plantbus transitions, CP1623 is used as an example. Additionally, the 
clock synchronization is activated.  

The PC stations in the test setup are called: 

 ES/OS-Master: ES60 
 OS-Stanby:       SV60A 

 
 
 

6.3.1 ES Configuration 

 

Generating the multiproject 
As a basis for the following instruction, all PC stations must be physically 
networked according to Figure 6-1. Furthermore, a multiproject must have been 
created on the ES in which the AS has already been configured regarding 
hardware and software. 
Then you can start with the following CPU and CP settings. 
 

AS settings for the clock synchronization 
Evaluation of the process data requires all components of the process control 
system to work with an identical clock, so that messages can be allocated in the 
correct temporal sequence. 
Below, a path is described where the redundant OS single stations define the 
master time. 
 

NOTE Further options of clock synchronization are described in detail in the following 
manuals: 

 SIMATIC Process Control System PCS 7 Operator Station (V8.0)  
 SIMATIC Process Control System PCS 7 Time synchronization (V8.0) 

 

http://support.automation.siemens.com/WW/view/de/61187410/0/en
http://support.automation.siemens.com/WW/view/de/61189664/0/en
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Table 6-3 

Step Activity Screenshot 

1.   Open the HW Config of the AS. 
Select the CPU and choose “Object 
Properties…” from the context menu. 

 
2.   Go to the “Diagnostics/Clock” tab. 

In the section under “Clock”, set “As slave” 
for the AS under “Synchronization Mode”. 
Confirm this setting with “OK”. 
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Step Activity Screenshot 

3.   Open the context menu of the CP and 
select “Object Properties…”. 

 
4.   Go to the “Time-of-Day Synchronization” 

tab. 
Activate the option “Activate SIMATIC 
time-of-day synchronization”. 
Confirm the setting with “OK”. 

 
5.   Save and compile via menu item “Station > 

Save and Compile”. 
Close the HW Config. 
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Generating the ES PC station 
In order to take the OS project on the ES into operation, we generate a PC station 
for the ES with WinCC application. 
 

Table 6-4 

Step Activity Screenshot 

1.   In the “Component view”, open the context 
menu of the project and insert a new PC 
station via “Insert New Object > SIMATIC 
PC Station”. 
Change the name of the PC station so that 
it corresponds to the name of the local 
computer in the network. 

 
2.   Open the HW Config of the PC station of 

the ES with the context menu. 

 
3.   From the object catalog (“View > Catalog”), 

add a “WinCC Application” and a network 
card of the type “CP1623”. 
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Step Activity Screenshot 

4.   Under “Subnet”, select the Plant Bus or 
create it with the button “New…”. 
Assign the respective MAC address to the 
CP 1623. 
Deactivate the option “IP protocol is being 
used”. 
Confirm the settings with “OK”. 

 
5.   Open the context menu of the CP 1623 

and select “Object Properties…”. 

 
6.   Select the “Options” tab and checkmark 

the “Time of day” box. 
Confirm the setting with “OK”. 

 
7.   Save and compile via the menu item 

“Station > Save and Compile…”. 
Close the HW Config. 

 

8.   
 

In the SIMATIC Manager, delete the OS 
project of the PC station of the ES as it is 
not required in our example. 
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Generating the standby OS PC station 
 

Table 6-5 

Step Activity Screenshot 

1.   In the “Component view”, open the context 
menu of the project and insert a new PC 
station via “Insert New Object > SIMATIC 
PC Station”. You can choose its name 
freely. 

 
2.   Open the HW Config of the PC station of 

the standby OS with the context menu. 

 
3.   From the object catalog (“View > Catalog”), 

add a “WinCC Application” (no WinCC 
Application Stby!) and a network card of 
the type “CP1623”. 
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Step Activity Screenshot 

4.   Under “Subnet”, select the Plant Bus or 
create it with the button “New…”. 
Assign the respective MAC address to the 
CP 1623. 
Deactivate the option “IP protocol is being 
used”. 
Confirm the settings with “OK”. 

 
5.   Open the context menu of the CP 1623 

and select “Object Properties…”. 

 
6.   Select the “Options” tab and checkmark 

the “Time of day” box. 
Confirm the setting with “OK”. 

 
7.   Save and compile via menu item “Station > 

Save and Compile…”. 
Close the HW Config. 
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Step Activity Screenshot 

8.   In the SIMATIC Manager, open the 
properties dialog of the OS project. 
Switch to the “Target OS and Standby OS 
Computer” tab. 
Checkmark the “Create/update archive 
tags” box and deselected “Transfer to 
central archive server”. 
Press the “Search” button. 

 
9.   Navigate by the drop down menu to the 

enable project folder of the OS server (see 
5.3.1 Preparatory Steps). 
Hit the “Save” button. 

 
10.  Check the path in the box “Path to the 

Target OS Computerr”. 
Confirm this with “OK”. 

 
11.  Acknowledge the information dialog with 

the “Yes” button. 
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Configuring the PC stations 
The function “Configure PC station” transfers the project configuration to one or 
more PLCs. First configure the local components configurator of the ES and then 
the all the other PC Stations connected with the plantbus. 
 

Table 6-6 

Step Activity Screenshot 

1.   Configure the component configurator of 
the ES. Select the PC station of the ES 
and choose “PLC > Configure…” from the 
context menu. 

 
2.   Under “Accessible computers”, choose the 

PC which is provided for configuration. 
 
NOTE 
If you chose the option “Computer name 
identical to the PC station name” in the 
component view “Object Properties” for the 
PC station, the component configurator 
directly displays the target computer to be 
configured. 
 
With “Display”, you can have the current 
configuration of the PC station displayed. 
Hit the “Configure…” button. 
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Step Activity Screenshot 

3.   In the displayed window you see how the 
PC station is configured. 
Confirm this setting with “OK”. 

 
4.   Acknowledge the information dialog with 

“OK”. 

 
5.   Finally, you receive the following message 

in the bottom window:  
“Transfer completed successfully.” 
Close the configuration dialog box. 

 
6.   Please configure the component 

configurator of the OS server analog to 
steps 1 to 5. 
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Configuration and download of the AS/OS communication 
In the following, the connections between the PC stations and the AS in NetPro are 
configured and downloaded into the individual stations. 
 

NOTE For station granular configuration, the subnets of the individual subprojects must 
be joined beforehand. 

 
 

Table 6-7 

Step Activity Screenshot 

1.   Open NetPro. 
Select the WinCC application of the ES 
and open the context menu. 
Choose “Insert New Connection”. 

 
2.   In the “Connection Partner” window, select 

the CPU of the AS. 
Make sure that in the “Connection” field a 
“S7 connection” has been selected. 
In this example, a fault-tolerant S7 
connection is configured due to the AS 
configuration. 
Confirm the setting with “OK”. 
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Step Activity Screenshot 

3.   In the “General” tab, in “Connection 
identification” change the “Local ID” into a 
meaningful name, like AS60. 
Confirm the settings with “OK”. 

 
4.   Create the connection between the 

standby OS and the AS in the same way, 
by repeating steps 1 to 3. 
It is important that the connection has the 
same name as the connection of the ES to 
the AS. 
Then, save and compile the configuration 
with the menu item “Network > Save and 
compile…”. 
 
Choose the option “Compile and check 
everything” and confirm with “OK”. 

 

5.   Mark the ES and then download the 
connections via the context menu 
“Download to Current Project > Selected 
Stations”. 
Download the standby OS and the AS in 
the same way. 
Then close NetPro. 

 

 
 

Compile and download the user program 
Compile the S7 program and download it into the AS. 
 

Compiling the OS project 
Compile the OS project in the SIMATIC Manager. 
Look out for the correct OS assignment to the server in Plant View. 
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6.3.2 OS Configuration 

OS configuration on the Engineering Station 
Conversion from multi-place to single-place systems is made on the ES, as well as 
settings for redundancy and clock synchronization. 
 

NOTE For this particular configuration, it is necessary to complete the redundancy 
setting in the WinCC Explorer of the standby OS after the entire download. 

 
 

Table 6-8 

Step Activity Screenshot 

1.   Open the OS-Standby project on the ES 
computer. 
In the opened WinCC Explorer, open the 
OS project and select “Properties” in the 
context menu. 
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Step Activity Screenshot 

2.   In the “General” tab, under “type:”, select 
“Single-user project”. 
 

 
3.   Confirm the selection and the message 

that appears with the “OK” button. 

 
4.   Via the “Options” tab, checkmark the OS 

project option “Allow activation on ES”. 
With this setting Runtime can be simulated 
on the ES. 
Press the “OK” button. 

 

5.   Prevent deleting the startup list by pressing 
the “No” button. 
Confirm the message that appears with the 
“OK” button. 
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Step Activity Screenshot 

6.   Open the editor “Redundancy” with the 
context menu. Activate the option box 
“Activate Redundancy”. 
 
Activate the option box “Default Master”. 
If necessary, adjust the redundancy 
properties in “Optional Settings” to your 
requirements. 
If you do not wish to operate the RS 232 
redundancy cable at the COM1 interface, 
then these settings must later be 
performed on the OS itself (see section 
“OS configuration on the OS”). 

 
7.   To complete the redundancy settings for 

the ES, the partner server must be 
selected. 
Select the standby OS as redundant 
partner via the “Browse…” button out of 
the PC network. 
Confirm the settings with “OK”. 
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Step Activity Screenshot 

8.   Control the redundancy settings before you 
confirm via “OK” button. 

 
9.   Confirm the message that appears with the 

“OK” button. 

 
10.  Open the “Time Synchronization” editor. 

 
Here, activate the checkbox 
“Synchronization via System Bus (Master, 
Slave)”. 
In “Access point 1”, select “CP1623(ISO)” 
and activate the “Master” radio button. 
Confirm the settings with “OK”. 
 
NOTE 
If the ES server does not have a CP 1623, 
the settings for the clock synchronization 
cannot be executed here. The clock 
synchronization settings must, in this case, 
be executed on the standby OS itself after 
downloading the OS project. 

 
11.  Close the OS project.  
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Loading OS project to the standby OS 
After the redundancy and clock synchronization have been configured on the ES 
side, and the OS project has been closed, download the OS project onto the 
standby OS. 
 

Table 6-9 

Step Activity Screenshot 

1.   In the SIMATIC Manager, select the 
standby OS and select “PLC > Download” 
from the context menu. 

 
2.   Downloading the OS project for the first 

time requires a complete download. 
Start the download with “OK”. 

 
3.   After the successful download, the OS 

project is located on the standby OS in the 
intended folder. 
Confirm this with “OK”. 
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OS configuration on the standby OS 
For this special configuration, it is necessary to make the redundancy settings 
before the download. 
If the engineering station has no CP 1623 as opposed to the OS, or the RS 232 
redundancy cable is not connected at COM1 there, the following step-by-step 
instructions must be performed. Otherwise, we generally advise you to check those 
after the project download onto the target system. 
 

NOTE Normally, all configuration works are executed on the ES for the purpose of 
consistent data management, so that no WinCC engineering licenses are 
required on the OS. Nevertheless, a license free time window of two hours is 
available after each opening of the WinCC Explorer for WinCC configuration 
works. 

 
 

Table 6-10 

Step Activity Screenshot 

1.   Open the WinCC Explorer on the standby 
OS. 

 

2.   Open the editor “Redundancy” with the 
context menu. 
 
Select the standby OS as redundant 
partner via the “Browse…” button out of 
the PC network. 
Confirm the settings with “OK”. 
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Step Activity Screenshot 

Here, uncheck the “Default Master” 
checkbox. 
Select the ES computer as redundant 
partner via the “Browse…” button. 
Check whether your desired checkboxes 
are activated at “Optional Settings”. 
 
Confirm the settings with “OK”. 

 
Confirm the information dialog with the 
“OK” button. 

 
3.   Open the editor “Time synchronization” 

with the context menu. 
 
Here, activate the checkbox 
“Synchronization via System Bus (Master, 
Slave)”. 
In “Access point 1”, check or select 
“CP1623(ISO)” and press the “Master” 
radio button. 
 
Confirm the settings always wih “OK”. 
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Step Activity Screenshot 

4.   If you made any changes in the WinCC 
Explorer project, close the OS project and 
open it again to activate the settings. 

 

 
 

6.3.3 Activating Runtime 

Successively start the OS project on the ES as well as on the standby OS. It is 
recommended to wait with activating the second Runtime until the start process of 
the first one is completed entirely. 
Regarding the redundancy, the online synchronization is active immediately. The 
mutual archive update, on the other hand, takes approx. 10-15 min. 
 
 

6.3.4 Particularities at downloading of OS Project Modifications 

 

Delta-download 
For a delta-download, Runtime on the ES must be closed again for compiling the 
OS. It can then be re-activated for testing the modified OS functions. 
 

NOTICE If Runtime remains active on the ES during the OS compilation, it might 
happen - depending on the changes made - that a subsequent delta-
download is carried out incompletely and results in errors. Afterwards, 
only a complete download will be possible. 

 
For the downloading, Runtime must be terminated and the WinCC project must be 
closed. 
The following restrictions result: 

– No operator actions can take place at the ES computer at that time. 

Complete download 
For downloading the complete program, please note: 
1. Runtime must be deactivated on both PC stations and the WinCC project must 

be closed. 

2. Before Runtime is activated again on the standby OS, the redundancy settings 
must be made. 
Repeat the steps from Table 6-10 
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7 Expansion by PCS 7 Web Option 
 

Positioning 
To control automated processes via the Internet/Intranet, SIMATIC PCS 7 offers 
control and monitoring options, the so called Web options. 
This chapter describes the configuration of the Web Option on an ES/OS stand-
alone system. The instruction can therefore be used as expansion for the following 
minimal configurations: 
 ES/OS stand-alone system (chapter 3) 

 Master ES/OS and Standby OS (chapter 5) 

 

NOTE In the following we configured exemplified the ES/OS stand-alone system as 
Web server for stand alone systems with Web Options. Analog is it possible to 
configure the partner-OS as Web server, without reservation of functionality for 
the Web clients. 

If one of the redundant operator stations acts as Web server, the redundancy is 
not available for the Web clients. If this OS is in STOP mode, then Web clients 
have no connection to the process either. 

 
 

Function 
All relevant pictures and scripts are stored on the Web server, so that they can be 
displayed and run via a Web client. 
At the same time the Web client accesses the stored process cell data on the 
Web server via a TCP/IP connection. The user interface looks like an OS standard 
client with overview, work and key area. 
Among others, the following functions are available via the web: 
 Control and monitoring functions that are also used on an OS client 

 Message lists which can be called user-dependent just like on an OS client. 
Messages can be acknowledged user-dependent. 

 Display of picture hierarchy according to plant hierarchy 

 Group display function including “Loop-in-Alarm” function. 

 Advanced status display 

 

NOTE You can find further information regarding PCS 7 Web Options in the manual: 

 SIMATIC Process Control System PCS 7 Web Option for OS (V8.0) 
 

 

http://support.automation.siemens.com/WW/view/de/61187433/0/en
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7.1 Web Configurations 

In our example, the configuration of the Web Option represents an extension of the 
hard- and software configurations of chapter 3 "ES/OS Stand-alone Systems" and 
chapter 5 "ES/OS-Master and OS-Standby". 
 

ES/OS stand-alone system as OS Web server 
To control and monitor the process in the Internet Explorer, the OS Web clients 
retrieve their data from the Web server via the Intranet/Internet. 
 
Figure 7-1: Web Option Configuration in stand-alone system 
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ES/OS Master as OS Web server 
To control and monitor the process in the Internet Explorer, the OS Web clients 
retrieve their data from the Web server via the Intranet/Internet. 
Furthermore, the system process has a redundant design to offer the plant 
operation the greatest possible failure protection. 
 

NOTICE The redundancy of the Operator Stations is not available for the Web clients. 
If the OS with the Web server option is in STOP, the Web clients have no 
process connection. 

 
 

Figure 7-2: Web Option Configuration in redundant stand-alone system 
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7.2 Web-Specific Hardware and Software Requirements 

Stand-alone system with Web server option 
Tabelle 7-1 

Component Requirement 
Operating system  Windows XP Professional SP3 (32Bit) 

 Windows Server 2003 SP2 Standard 
Edition (32Bit) 

 Windows Server 2003 R2 SP2 Standard 
Edition (32Bit) 

 Windows 7 Ultimate SP1 (32Bit) 
 Windows 7 Ultimate SP1 (64Bit) 
 Windows Server 2008 SP2 Standard 

Edition (32Bit) 
 Windows Server 2008 R2 SP1 Standard 

Edition (64 Bit) 
 
You can find additional information on this in 
the document  
„SIMATIC Process Control System PCS 7 
PCS 7 Readme V8.0 SP1“. 

Hardware  Windows XP Professional SP3 (32Bit) 
 Windows Server 2003 SP2 Standard 

Edition (32Bit) 
 Windows Server 2003 R2 SP2 Standard 

Edition (32Bit) 
 Windows 7 Ultimate SP1 (32Bit) 
 Windows 7 Ultimate SP1 (64Bit) 
 Windows Server 2008 SP2 Standard 

Edition (32Bit) 
 Windows Server 2008 R2 SP1 Standard 

Edition (64 Bit) 
 
You can find information on this in the 
document  
„SIMATIC Process Control System PCS 7 
PCS 7 Readme V8.0 SP1“. 

Software  Internet Explorer 
 Internet Information Services (IIS) 

Miscellaneous Fast access (>= 64 kbit/s) to Web client over 
Intranet/Internet or via TCP/IP connection 

http://support.automation.siemens.com/WW/view/en/66807356
http://support.automation.siemens.com/WW/view/en/66807356
http://support.automation.siemens.com/WW/view/en/66807356
http://support.automation.siemens.com/WW/view/en/66807356
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Web client 
Tabelle 7-2  

Component Requirement 
Operating system You can find information on this in the 

document  
„SIMATIC Process Control System PCS 7 
PCS 7 Readme V8.0 SP1“. 

Minimum hardware 
requirement 

No PDAs, tablet PCs etc. 

Software Internet Explorer 
Miscellaneous Fast access (>= 64 kbit/s) to Web server via 

Internet/Intranet or TCP/IP connection 

 

NOTE Choose the Internet Explorer Version according to the PCS 7 version. You can 
find further information in the following FAQ: 

http://support.automation.siemens.com/WW/view/en/2334224 

 
 
 
 

7.3 Maximal number of Web client accesses 

The following numbers of simultaneous Web client accesses are tested and 
released: 
 
Table 7-3 

Operating system on the stand-alone system 
with Web server option 

Maximal number of simultaneous 
Web accesses 

Windows XP 2 
Windows 7 3 
Windows Server 2003 3 
Windows Server 2008 3 

 

http://support.automation.siemens.com/WW/view/en/66807356
http://support.automation.siemens.com/WW/view/en/66807356
http://support.automation.siemens.com/WW/view/en/2334224
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7.4 Configuration of OS Web server 

 

Configuration steps on the ES 
 Publishing of pictures by means of Web View Publisher 

 Configuring user rights, start screen and language of website in user 
administrator 

 Loading and compiling of Web server 

 

Publishing of OS data 
Pictures and scripts which are supposed to run on the Web clients later are 
published on the OS Web server using the Web Publisher. Doing this, the following 
actions are carried out: 
 Project data is compressed and stored 

 Screen windows are transferred into web-enabled ActiveX components 

 Scripts are converted so that they can be run on the web 

 

Requirements 
To be able to publish the Web server data the following prerequisites have to be 
fulfilled: 
 The requirements mentioned in chapter 7.2 are met. 

 The software package “PCS 7 Web server” is installed on the ES/OS stand 
alone system. 

 PCS 7 project is readily configured 

 OS has already been compiled 

 Scripts which the Web clients access are available 

 Process pictures do not have a double underscore (e.g. yy__xx.pdl) 

 Variable name in plain text (inverted commas) in C scripts contain no spaces 

 

NOTE For a stand-alone system only one publishing process for the publishing of local 
data on the Web server is necessary. 

Information regarding the issue of "Supported script normal functions" can be 
found in the manual: 

 SIMATIC Process Control System PCS 7 Web Option for OS (V8.0)  
(chapter  „Web-Executable Functions for PCS 7 OS Web Option“) 

 
 

http://support.automation.siemens.com/WW/view/de/61187433/0/en
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7.4.1 Publishing of Project Data 

Table 7-4 

Step Action Note 
1.  Open the OS project of the OS Web server in 

WinCC Explorer. 
Select the command "Web View Publisher" 
via the context menu of the "Web Navigator" 
editor. 
The "WinCC Web Publishing Wizard – 
Introduction" dialog field opens up. 
Click the "Next" button. 

 
2.  The "WinCC Web Publishing Wizard – Select 

directories" dialog field opens up. 
Disable the option "Server Prefix" since you 
want to publish local data. 
Accept the preset target and source path. If 
you would like to change the respective path, 
click the button behind the shaded input 
fields. Navigate to the desired target or 
source file. 
Click the "Next" button. 

 
3.  The "WinCC Web Publishing Wizard – Select 

pictures" dialog field opens up. 
Select all pictures you want to publish. We 
generally recommend to publish all standard 
pictures. 
Via the ">>", "<<", ">" and "<" buttons you 
can select the pictures. 
Click the "Next" button. 

 
4.  The "WinCC Web Publishing Wizard – Select 

functions" dialog field opens up. 
Select all functions you want to publish. Only 
the scripts which were selected in the last 
publishing process are available in the 
pictures. This is why you select all necessary 
function for each publishing process. 
Via the ">>", "<<", ">" and "<" buttons you 
can select the functions. 
Click the "Next" button. 
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Step Action Note 
5.  The "WinCC Web Publishing Wizard – 

Referenced Graphics" dialog field opens up. 
Select all graphics you want to publish. We 
generally recommend to publish all graphics. 
Via the ">>", "<<", ">" and "<" buttons you 
can select the graphics. 
Click the "Next" button. 

 
6.  The "WinCC Web Publishing Wizard – 

Finish" dialog field opens up. 
Click the "Finish" button. 

 

 
7.  Pictures and functions which contain faulty 

scripts are marked with a red cross. 
Double-click each faulty picture to open and 
correct the picture in the "PdlPad" editor. 
Confirm the message after each publishing 
process by clicking the "OK" button. 
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Step Action Note 
8.  The transferred pictures are listed in the 

"WinCC Web Publishing Wizard – Finish" 
dialog field. 
Click the "Finish" button. 

 
9.  The published pictures are displayed in the 

data window of the Web Navigator. 
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7.4.2 Setting of User Rights, Website Start Screen and Language 

 

Access restriction 
Accesses of the Web clients on the OS Web server are controlled via user rights. 
User rights are assigned in the "User Administrator" editor. The user rights 
correspond to those of the standard clients. 
 

Settings in the "User Administrator" Editor 
 

Table 7-5 

Step Action Note 
1.   Open the "User administration" in the opened 

OS project of the WinCC Explorer. 
Create new users and/or new user groups 
and assign them respective authorizations. 
In addition, enable the option "WebNavigator" 
for the user/user group and enter the "Start 
Picture" and "Language" in the respective 
input fields. 

 
2.   Select the start picture from the published 

graphics via the "…" button. 
“…\OS Web Server\<wincc project release 
name>\Web Navigator\pictures” 
Select the "@screen.pd_" graphic as start 
picture. 
Confirm your selection with the "Open" 
button. 
This is also how you determine a language for 
the control and monitor interface of the Web 
clients. To do this, click the respective "…" 
button. 
Confirm your selection with the "OK" button. 

 
3.   Close the User Administration editor.  
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7.4.3 Configuring with the Web Configurator 

 

Tasks of the Web Configurator 
The Web Configurator sets up and manages the Internet Information Service (IIS) 
and therefore the website of the OS Web server. This setup is carried out on the 
Web server after you have loaded the project on the Web server. This setup and 
configuration is necessary to set up an operator station (OS) as OS Web server 
and to make it accessible for Web clients via the Intranet/Internet. 
With the Web Configurator you can make the necessary firewall settings for the 
network card, if the firewall is enabled. 
 

Requirements of the stand-alone system 
 PCS 7 Web server software is installed on the stand-alone system 

 the OS project is loaded on the stand-alone system 

 settings in the OS are completed 

 pictures, functions and graphics have been published 

 user rights have been assigned/created 

 

NOTE Further information regarding the setup of a standard website can be found in 
the manual: 

 “SIMATIC Process Control System PCS 7 Web Option for OS (V8.0)”  
(chapter „Completing configuration on the OS Web server“) 

 
 

http://support.automation.siemens.com/WW/view/de/61187433/0/en
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Settings in the "Web Navigator" editor 
Table 7-6 

Step Action Note 

1.  Open the OS project on the OS Web server 
in the WinCC Explorer. 
Select the command "Web Configurator" via 
the context menu of the "Web Navigator" 
editor. 
The "WinCC Web Configurator" dialog field 
opens up. 
Click the "Next" button. 

 
2.  In the next window select the option "Create 

a new standard web site (stand-alone)". 
Click the "Next" button. 

 
3.  Specify a name for your web site in the 

"Name of web site" input field. 
Also assign the IP address and the 
connection port of the computer via the 
"Port" and "IP Address" input fields. 
Select "MainControl" from the drop-down list 
of the "Default web-Page" input field. 
Also enter a time in the "Reconnect Interval" 
input field 
Enable the option "Start the web-site after 
being configured". 
Click the "Next" button.  

4.  If the Windows-Firewall is not enabled, 
continue with step 8. 
Otherwise click the "Windows-Firewall" 
button (the button is only visible when the 
Firewall is enabled). 
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Step Action Note 
5.  In the "Windows-Firewall" dialog field select 

the "Advanced settings" tab. 

 
6.  Make sure that the inbound rule „World Wide 

Web Services (HTTP Traffic-In)” is activated. 
If deactivated, select the function and click 
on “Activate” in the context menu. 

 
7.  Click the "Finish" button. 

 
8.  Click the "OK" button. 

Afterwards close the WinCC Explorer and 
restart your computer to accept all settings. 
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7.4.4 Loading and Compiling of Web server 

 

Loading of Web server 
Since the OS Web server is a stand-alone system (ES/OS/Web server), a loading 
and/or delta download of project data is not necessary because local data is 
already present through "Compile OS". 
 

Compiling 
The "Compile changes" function can be carried out for stand-alone systems without 
having to interrupt the process operation of the Web server. 
 

NOTE Further information regarding the configuration of the OS Web server can be 
found in the manual: 

 SIMATIC Process Control System PCS 7 OS Web Option 
(chapter “Configuration of the OS Web server on an ES”) 

 
 

http://support.automation.siemens.com/WW/view/de/61187433/0/en
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7.5 Settings on Web client 

 

Settings of web content zone "Internet" or "Local Intranet" 
You have to make or check the settings for the web content page in the Internet 
Explorer to be able to install the plug-ins for the Web client of the OS Web cerver 
later. 
 

Table 7-7 

Step Action Note 

1.  Open the Internet Explorer. 
Select the command “Tools > Internet 
Options” 

 
2.  Click the "Security" tab. 

Select the web content zone in which the 
Web server is located ("Internet" or "Local 
intranet"). 
Click the "Custom level..." button. 
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Step Action Note 
3.  Enable the option under "Execute ActiveX 

controls safe for scripting" and "Download 
signed ActiveX controls" 

 
4.  Click the respective "OK" buttons for the 

dialog fields "Security Settings" and "Internet 
Options" to close them. 
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Settings of web content zone "Trusted sites" 
 

Table 7-8 

Step Action Note 
1.  Open the Internet Explorer. 

Select the command “Tools > Internet 
Options”. 

 
2.  Click the "Security" tab. 

Select the web content zone "Trusted sites". 
Click "Sites" to open the dialog field. 

 
3.  Enter the address of the OS Web cerver in 

the "Add this website to the zone" input field 
e.g. *://172.61.0.1 or http://*.microsoft.com 
Additionally, disable the option "Require 
server verification (https:) for all sites in 
zone". 
Click the "Add" and "Close" buttons. 
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Step Action Note 
4.  Select the web content zone "Trusted sites". 

Click the "Default level" and afterwards the 
"Custom level…" button. 

 
5.  Enable the option "Initialize and script 

ActiveX controls not marked as safe for 
scripting" in the dialog field "Security 
Settings". 

 
6.  Click the respective "OK" buttons for the 

dialog fields "Security Settings" and "Internet 
Options" to close them. 

 

 
Therefore the requirements for a connection of Web client to Web server have 
been created. 
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7.6 Installation of Web client plugins 

 

Installation paths 
When installing the plugins for the Internet Explorer you can choose between two 
installation paths: 
 Remote installation – installation via the Intranet/Internet of the Web server 

 Local installation – installation via the Windows Installer Package of the 
Web client 

In application example we look at the "Remote installation". 
 

Requirements 
 The OS Web server is in runtime. 

 The Web client has access to the Web server. 

 You know the Web server address. 

 You know the domain, user name and password. 

 The user authorizations are valid for PCS 7 Web Options. 

 The login on the PC has the rights of a main user. 

 

Installation 
 

Table 7-9 

Step Action Note 
1.  Open the Internet Explorer. 

Enter the Web server address (http://<Server 
name or IP>) in the "Address" input field. 

 
2.  Enter the access data in the "Connect to 

<severname>" dialog field which was 
determined on the Web server in the "User 
Administrator" editor. 
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Step Action Note 
3.  During the first connection the "Security 

Warning" dialog field will open up. 
Continue by clicking the "Install" button. 

 
4.  Now all available plugins for the Web client 

will be displayed in the Internet Explorer 
window. 
In the "Install" column, click the arrow before 
the version number to install the plugin. 
The plugins: 
 WinCC Basic Process Control 
 WinCC Basic Process Control 
 PCS 7 Faceplates 
 PCS 7 Advanced Faceplates 

should be installed to guarantee minimum 
process control. 
During installation the displayed sequence is 
to be observed. 

 

5.  Installation of the Web client is complete. 
Close the Internet Explorer and reopen it to 
register for process control. 
As soon as the Web client has established a 
connection with the Web server, the process 
pictures can be called. 

 

 
 

Note Further information regarding the installation of the Web client, process control 
on the Web client and settings can be found in the manual: 

 SIMATIC Process Control System PCS 7 OS Web Option 
(chapter “Installation and Settings for the Web client”) 

 
 

http://support.automation.siemens.com/WW/view/de/61187433/0/en
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8 History 
 
Table 8-1 

Version Date Change 

V1.0 10/2006 First release V6.1 SP1 
V1.1 11/2006 Revision V6.1 SP1 
V1.2 05/2009 Revision V6.1 SP1 
V2.1 09/2008 First release V7.0 SP1 
V2.2 12/2008 Correction in table 6-2 
V2.3 05/2009 Revision V7.0 SP1 
V3.0 05/2009 First release V7.1 
V3.1 05/2009 Revision V7.1 
V3.2 11/2009 Expansion of the documentation to V7.1 by the PCS 7 Web 

Option (tested for PCS 7 V7.1 and V7.0 SP2) 
V2.4 12/2010 Notice inserted: 

In PCS 7 V7.0 SP3 the configuration, which is described in 
chapter 5 „ES/OS-Master and OS-Standby“ only works only 
with WinCC V6.2 SP3 HF8 or higher. 

V3.3 09/2011 Notice inserted: 
In PCS 7 V7.1 SP2 and SP3 the configuration, which is 
described in chapter 5 „ES/OS-Master and OS-Standby“ 
only works with WinCC V7.0 SP2 HF5 or higher. 

V4.0 10/2012 First release V8.0 Upd1 
V4.1 11/2012 Modified chapters: 

 Chapter 7 “Expansion by PCS 7 Web Option” 
 Chapter 7.1 “Web Configuration“ 
 Chapter 7.2 “Web-Specific Hardware and Software 

Requirements“ 
New Chapter: 
 Chapter 7.3 “Maximal number of Web client accesses” 

V4.2 01/2013 Introduction of the chapter 6 “ES/OS-Master and OS-
Standby“ is modified. 

V4.3 05/2013 Test and declaration for PCS7 V8.0 SP1 
V4.4 09/2013 Modified information about the needed licenses in chapter 

7.1 “Web Configurations” in the figure 7-1 “Web Option 
Configuration in stand-alone system” 
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