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Warranty and Liability 
 

Note The application examples are not binding and do not claim to be complete with 
regard to configuration, equipment or any contingencies. The application 
examples do not represent customer-specific solutions; they are only intended to 
provide support for typical applications. You are solely responsible for the correct 
operation of the described products. These application examples do not relieve 
you of your responsibility to use sound practices in application, installation, 
operation and maintenance. When using these application examples, you 
recognize that we cannot be made liable for any damage/claims beyond the 
liability clause described. We reserve the right to make changes to these 
application examples at any time without prior notice. If there are any deviations 
between the recommendations provided in this application example and other 
Siemens publications (e.g. catalogs), the contents of the other documents have 
priority. 

 
We do not accept any liability for the information contained in this document. 

Any claims against us – based on whatever legal reason – resulting from the use of 
the examples, information, programs, engineering and performance data etc., 
described in this Application Example shall be excluded. Such an exclusion shall 
not apply in the case of mandatory liability, e.g. under the German Product Liability 
Act (“Produkthaftungsgesetz”), in case of intent, gross negligence, or injury of life, 
body or health, guarantee for the quality of a product, fraudulent concealment of a 
deficiency or breach of a condition which goes to the root of the contract 
(“wesentliche Vertragspflichten”). Damages for a breach of a substantial 
contractual obligation are, however, limited to the foreseeable damage, typical for 
the type of contract, except in the event of intent or gross negligence or injury to 
life, body or health. The above provisions do not imply a change in the burden of 
proof to your detriment. 

 

It is not permissible to transfer or copy these Application Examples or excerpts 
thereof without express authorization from Siemens Industry Sector. 

 

 

 



Preface
 

Multiprojekt / Multi user-Engineering 
Version 3.0, Entry ID: 22258951 5
 

C
op

yr
ig

ht
 ©

 S
ie

m
en

s 
A

G
 2

01
1 

A
ll 

rig
ht

s 
re

se
rv

ed
 

  

Preface 
 

This document provides an overview of the different variants and positioning of 
multiproject and multi-user engineering. 

Multiproject engineering provides options for the flexible and performant 
engineering of plants. For this purpose the automation solution is distributed 
technologically to several projects. The projects are created within a multiproject on 
a central engineering station. Apart from the projects it also manages the master 
data library here which contains all commonly used objects. Individual AS projects 
of the multiproject are distributed to further engineering stations for decentralized 
editing. 

Figure 1-1 

 

 

Multi-user engineering additionally provides the option to work at the same user 
program (CFC/SFC of an AS project) in parallel. The respective project may remain 
at its storage location then. It is opened and edited from several engineering 
stations via network at the same time. 

Figure 1-2 
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1 Multiproject Engineering 
1.1 General information 

The multiproject functionality of SIMATIC PCS 7 provides the option of flexible and 
performant configuration of systems. The main emphasis is placed on parallel and 
time saving processing of projects which can be managed, divided and merged 
with system support. 

Principle of multiproject 

Multiproject is a higher-level structure in the SIMATIC Manager of the central 
Engineering Server. It comprises all projects of an automation solution with its 
subordinate objects (automation systems (AS), operator stations (OS), programs, 
plans, etc.) as well as master data library. 

For processing the contained projects they are distributed between decentralized 
Engineering Stations (ES). The engineering process is optimized using additional 
memory resources and computer performance. The projects can remain in the 
multiproject or be separated from it for the duration of processing. The Engineering 
Server on which the multiproject is filed is a complete engineering station in itself, 
on which a project or the master data library can be processed. 

 

Figure 1-1 

 

 

Despite of the decentralized storage, the projects can have interproject relations 
such as S7 connections. 



1 Multiproject Engineering 
1.1 General information 

 

8 
Multiprojekt / Multi user-Engineering 

Version 3.0, Entry ID: 22258951 
 

C
op

yr
ig

ht
 ©

 S
ie

m
en

s 
A

G
 2

01
1 

A
ll 

rig
ht

s 
re

se
rv

ed
 

Advantages of the multiproject 

If projects are part of a multiproject, they can be generated in smaller scope and for 
better overview. Interproject mechanisms ensure that a multiproject can be used as 
one project. 

Examples of such interproject mechanisms are: 

• Master data library for central data management of data block types, 
measuring location types and example solutions for all projects 

• Updating the Plant Hierarchy across all projects or for selected projects 

• Considering all related AS and OS components in the entire multiproject for the 
functions “Create/Update block symbols“ and “Create/Update diagnostics 
screen“ (for identically named PH) 

• Merging subnets and connections with text references of all contained projects 

• OS compiling with configuration data of several projects 

• Save as (copy of the multiproject with all projects) 

• Archiving (zip-archive of the multiproject with all projects) 

 

Note In the PCS 7 environment it is always recommended to set a multiproject with 
master data library even if only one project is contained. 
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1.2 Project structures 

The structures of a multiproject are mainly distinguished as project-specific and 
station-specific setups. 

In practice a combination of both variants is often a suitable choice as shown in the 
following example figure: 

 

Figure 1-2 

 

 

Note Further information on the creation of a multiproject is available in the document 
"PCS 7 Compendium Part A - Configuration Guidelines". 
http://support.automation.siemens.com/WW/view/en/35016996 

 

http://support.automation.siemens.com/WW/view/en/35016996�
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1.2.1 Boundary conditions 

To be able to perform the project work as efficiently as possible later, some 
preliminary considerations are required. 

When considering how to separate the overall task into subprojects suitably, 
individual project conditions as well as conditions of the available engineering 
environment must be taken into account. Here some examples: 

• Number of project engineers 

• Number of available Engineering Stations (while meeting the PCS 7 ES system 
requirements) 

• Networking the Engineering Stations 

• Complexity of the project 

• Time duration / configuration effort 

 

Furthermore, certain rules should be followed such as the rules given below: 

• Only those project components (AS, OS) required for the respective 
processing, should be moved to a decentralized ES. The other objects of the 
multiproject hence remain available for other uses. 

• Only whole projects can be moved to a decentralized ES. 

 

The structure of the multiproject can be determined now using these considerations 
and the background information from the above comparison as a basis. 
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1.2.2 Station-specific structure 

All AS and OS are stored separately in an individual project in the case of the 
station-specific structure. 

 

Figure 1-3 

 

 

Hence, there are no OS objects (pictures, reports, ...) in the AS project and no AS 
objects (CFC, SFC, ...) in the OS project. 

 

Figure 1-4 
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Advantages 

• The largest possible division ensures highest flexibility during allocation of the 
individual projects to the project engineers, and additionally offers the best 
performance for the processing speed. 

• Engineering Stations can be added or removed during the commissioning 
process in order to be able to react flexibly to varying staff availability. 

Note 

• Tests of AS and OS during the configuration process are performed on 
separate computers (provided that the decentralization took place). 

• Changes in the Plant Hierarchies (PH) of projects have to be updated again in 
the multiproject after the processing. 

• It is not possible to copy entire subsystems including the update of the OS 
objects. 

 

1.2.3 Project-specific structure 

Every project of the project-specific structure contains, for instance, one AS and 
one OS or all AS and OS which a project engineer has to edit. 

 

Figure 1-5 

 

 

From a technical point of view, the project contains AS objects (CFC, SFC, ...) as 
well as OS objects (pictures, reports, ...), as illustrated in the figure below. 
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Figure 1-6 

 

 

Advantages 

• Testing and configuration is possible entirely within the project with AS and 
OS. 

• The work procedure during the project engineering and commissioning is the 
same. 

• Copying entire subsystems is possible including the update of the OS objects. 

• There is a uniform view in the Plant Hierarchy which includes AS and OS in a 
project. 

Note 

Further division (removing single AS or OS from a project) at a later time requires 
detailed knowledge of the involved work steps. For that reason the project should 
be distributed to the largest extent possible from the start. 
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1.3 Decentralized project division 

The decentralized division of projects is a suitable choice for larger project 
engineering work. The system performance is highest when every project engineer 
has access to the project parts which are relevant for him locally on his computer. 

 

Figure 1-7 

 

 

The availability of the communication partners must be explicitly paid attention to 
especially for interproject activities, such as establishing AS-AS communication or 
OS compilation. 

Decentralized project engineering with and without network interconnection is 
considered in the following. 

 

Note For the actual work steps for shifting the projects refer to the PCS 7 
Configuration Manual Engineering System. 

http://support.automation.siemens.com/WW/view/en/36050990 

 
 

http://support.automation.siemens.com/WW/view/en/36050990�
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1.3.1 Division in the network interconnection 

If the network is permanently available, project parts can be shifted to distributed 
Engineering Stations for processing while still remaining in the multiproject. 

The project engineers can access all components of the multiproject at any time 
then. Apart from the necessary network connection, all of the PCs managing such 
components must be switched on and be enabled accordingly. 

 

Figure 1-8 

 

 

A project is moved via the system function "Save as" with the option that the 
project which is integrated in the multiproject is replaced by the created copy. 

Advantages 

• An OS server can be compiled with data from AS stations of other projects at 
any time. 

• All used program parts are stored in the master data library which can be 
accessed via the network. 

• The entire project and all distributed projects can simply be archived on the 
Engineering Server. 

• A project structure which is station-specific to the largest extent and its 
decentralized division are the most performant configuration option if the 
network is permanently available. 

Note 

• If a project should not be available in the network, this may lead to extended 
delays and waiting times.  

• When performing interproject functions, it must be ensured with the project 
engineers that none of the relevant projects is being worked at during this time. 
Otherwise inconsistencies could result. 
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1.3.2 Division without network interconnection 

The multiproject functions of SIMATIC PCS 7 are based on the permanent 
availability of all contained projects. If a contained component is not reached, 
extended waiting times can result, for example when opening the multiproject or 
working with NetPro. 

If a permanent network connection cannot be guaranteed, the projects should be 
removed from the multiproject for the duration of the decentralized editing. Possible 
reasons for this are that not all computers are permanently connected to the 
network or the projects are edited externally on purpose (e.g. outsourcing to an 
engineering firm / system integrator). 

 

Figure 1-9 

 

 

The projects are removed via the system function "Remove from Multiproject". 
Projects are integrated with the function "Insert into Multiproject". 

Advantages 

• There are no unexpected delays and waiting times due to missing projects.  

• During the distributed processing, the project cannot be accessed by accident 
(e.g. due to executing interproject functions). 

Note 

• When working with NetPro, connections which have already been configured 
can create warning messages due to the missing communication partners. 
New connections can only be created as unspecified connections via 
references for the period of project division. 

• In order to compile an OS server, all relevant projects (AS projects and 
corresponding OS project) must be recombined centrally. 

• The master data library is not contained in the project. The only blocks which 
are available are those blocks which have already been used and which are 
filed in the block folder. To use the functions of the master data library on the 
decentralized Engineering Stations, it must be managed as local backup. 

• The projects must be archived locally. 
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1.3.3 Dividing the multiproject without network interconnection 

With this variant you divide the multiproject including master data library and the 
project which is to be engineered. The other projects should be removed from the 
multiproject. This is the preferred method for multiproject engineering. 

 

Figure 1-10 

 

To distribute the multiproject, archive it and shift the created ZIP archive to the 
decentralized ES with Windows means. After dearchiving remove the projects 
which are not required from the multiproject and delete them. 

When you have edited the project on the decentralized ES, remove it from the 
multiproject and re-integrate it into the multiproject on the Engineering Server. 

Advantages 

• The project engineer can access the master data library. 

• The import/export assistant (IEA) functions are available. 

• During the distributed editing, the project is protected against undesired access 
on the Engineering Server (e.g. due to executing interproject functions). 

Note 

• Changes in the master data library may only be made at the Engineering 
Server. The changes must be made to all decentralized Engineering Stations 
then. 

• If all projects which are not required were deleted according to the 
recommendation, connections which have already been configured can create 
warning messages due to missing communication partners when you work with 
NetPro. New connections can only be created as unspecified connections via 
references for the period of project division. 

• In order to compile an OS server, all relevant projects (AS projects and 
corresponding OS projects) must be recombined centrally. 
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1.4 Shared engineering work step-by-step 

General information on interproject activities 

The actual processing of the projects is performed decentralized. Interproject data 
updates and functions on the other hand are always made in the SIMATIC 
Manager of the central Engineering Server where the multiproject is managed. 
These tasks may be executed before or after dividing the project, as well as during 
dividing if the projects have not been removed from the multiproject and are not 
currently being worked at. 

Whether the decentralized projects remain in the multiproject or are removed 
depends on to what extent a stable network can be guaranteed between the PCs. 

Overview of project engineering steps 

This is meant to provide an overview of the work processes required within the 
framework of multiproject engineering. We recommend the following procedure; 
however, it may vary according to individual conditions and experience. These 
steps are further described in the following chapters. 

 

Table 1-1 

 Activity Location 

1. Project planning: 

• Determining the number of project engineers 
• Determining the available ES 
• Networking of the ES 
• Determining the project complexity 

 

2. Preparatory project works: 
• Creating the multiproject 
• Configuring the SIMATIC stations and the PC stations 
• Creating and updating the Plant Hierarchy (PH) 
• Generating interproject networks 

• Generating interproject connections 

Engineering 
Server 

3. Dividing the projects: 
• Shifting projects in the network interconnection 

• Removing projects from the multiproject 
• Distributing the project including the multiproject 

Engineering 
Server 

4. Decentralized project works Decentralized 
ES 

5. Merging the projects: 
• Shifting projects back into the multiproject 
• Re-integrating projects into the multiproject 

Engineering 
Server 
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 Activity Location 

6. Final project works: 
• Updating the Plant Hierarchy (PH) 

• Remerging referenced connections 
• Checking the interproject consistency 
• Compiling and loading 

Engineering 
Server 

 

Note The individual steps are described in detail in the manual "Process Control 
System PCS 7 Engineering System". 

http://support.automation.siemens.com/WW/view/en/36050990 

 
 

1.4.1 Project planning 

To be able to perform the project work as efficiently as possible later, some 
preliminary considerations are required. 

When considering how to most suitably separate the overall task into subprojects, 
individual project conditions as well as conditions of the available engineering 
environment must be taken into account. Here some examples: 

• Number of project engineers 

• Number of available Engineering Stations (while meeting the PCS 7 ES system 
requirements) 

• Networking the Engineering Stations 

• Complexity of the project 

• Time duration of project engineering 

 

Furthermore, certain rules should be followed such as below: 

• Only those project components (AS, OS) required for the respective 
processing, should be moved to a decentralized ES. The other objects of the 
multiproject hence remain available for other uses. 

• Only whole projects can be moved to a decentralized ES. 

• A project must generally only be edited by one project engineer at a time. 

 

Determine the multiproject structure by means of these considerations. 

http://support.automation.siemens.com/WW/view/en/36050990�
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1.4.2 Preparatory project works 

Creating new multiproject 

The PCS 7 wizard creates a multiproject as well as a subproject whose objects 
(AS, OS, programs, plans, etc.) are integrated on demand via queries. Additionally, 
a master data library with the following content is created: 

• An S7 program with folders for sources, blocks and plans (component view) 

• One folder each for measuring location types and example solutions (Plant 
Hierarchy) 

 

Start the PCS 7 wizard ("File > 'New project' wizard"). The wizard will prompt you to 
the multiproject creation with 4 steps. 

 

Figure 1-11 

 

 

1. Introduction and project preview 

2. Configuring automation system 
Here you can select an existing AS of your plant in advance already. 

3. Plant Hierarchy and Operator Station 
In this step you determine the number of hierarchy levels and you can also 
define whether an OS will be created. If you want to create your multiproject as 
a station-specific multiproject, do not select any PCS 7 OS here. 

4. Project name and storage location 
Assign a name to your project in this step and select the directory for filing the 
multiproject. 

 

Create further projects in the multiproject using the planned structure. For this 
purpose select the menu option "File > Multiproject > Create in Multiproject...". 
Alternatively you can copy and customize the project which has been created by 
the wizard. 
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Figure 1-12 

 

 

Configuring SIMATIC and PC stations 

Configure the individual stations and their network connections according to your 
project planning and the hardware conditions. 

Create the required stations with the menu option "Insert > Station > ..." or use the 
PCS 7 wizard "Insert > Preconfigured station...". 

 

Figure 1-13 

 

 

Note You can also use the PCS 7 wizard to create preconfigured stations for manually 
created projects. In the case of existing projects start the wizard with the menu 
option "Insert > Preconfigured station...". 
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Configuring the Plant Hierarchy 

Handling of the Plant Hierarchy in a multiproject will be simplified from version 6.1 
of PCS 7. If the folders of the PH are, at least partly, to be created identically in all 
projects or in individual projects of the multiproject, then this work step is only 
necessary once in a project. The other projects take on the PH when performing 
the update. 

In the individual projects, hierarchy folders not named identically are created anew 
and provided with the properties of the template folder. Hierarchy folders of 
identical name are recognized and will not be created anew, but they also receive 
the properties of the template folder. 

1. Configure the complete Plant Hierarchy in a project. 

2. Mark the multiproject and select the menu option "Options > Plant Hierarchy > 
Update in Multiproject". 

 

Figure 1-14 

 

 

There are two options for updating the Plant Hierarchy: 

• "Merge the PH of all projects in the multiproject" 
The PH will be updated in the entire multiproject. 

• "Export the PH of one project in other projects" 
The PH of a selected project will be updated with the PH of the target projects. 

 

The updated projects have referenced (linked) folders now which are shown in the 
tree structure with a small arrow. These folders cannot be renamed or deleted. 
However, depending on the project, plans and/or pictures can be added. 
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Figure 1-15 

 

 

If the Plant Hierarchy of referenced projects shall be changed, the link must be 
removed prior to that. This is done with the function "Options > Plant Hierarchy > 
Remove link". You can remove the PH link in the whole multiproject by selecting 
the multiproject or you can remove it in the project by selecting the respective 
project. 

Generating interproject networks 

To ensure that the stations of the individual projects in PCS 7 can communicate 
with each other, their subnets have to be merged. For this purpose, interproject 
networks are created in the multiproject. 

The dialog for merging subnets is reached via the menu option "File > Multiproject 
> Adjust Projects..." or from out of NetPro via "Edit > Merge / Unmerge 
Subnetworks > ...". 

1. Select the network type "Industrial Ethernet". Click the "Execute" button. 

2. Select those subnets which are to be merged as a global network. With the 
arrow button "->" (to the right) they are added to the global network. 

3. Click "OK" or "Apply" to confirm your settings. 
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Figure 1-16 

 

 

Generating interproject connections 

Interproject connections between AS - AS, OS - AS or also ES - AS (in order to test 
the OS functions on the ES using the OS simulation) can now be generated as 
usual. 

As far as the later decentralized project planning occurs in the multiproject, the 
connections can also be made after the projects have been divided. 

If projects which have been removed from the multiproject shall be edited, it is 
advisable to generate the known connections in advance already. Unspecified 
connections can also be added using text references later. The connections can 
then be closed after remerging the projects on the central Engineering Server. 
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Figure 1-17 

 

 

1.4.3 Distributing the projects 

Depending on whether the decentralized editing of the projects is to occur in the 
multiproject with network interconnection, in the multiproject without network 
interconnection or without multiproject and without network interconnection, three 
ways of distributing the projects are described below. 

However, we recommend using the variant in which you copy and distribute the 
multiproject. 

Distributing a project including multiproject 

This option describes how you distribute the multiproject to the decentralized ES. 
This has the advantage that the project engineer has unrestricted access to the 
master data library and that he can use the import/export assistant (IEA) for the 
configuration work. 
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With this variant a copy of the multiproject is distributed. Projects which are not 
required will be removed from the multiproject on the decentralized ES then. 
Proceed as follows: 

 

1. Archive the multiproject ("File > Archiving..."). 

2. Copy or move the archived multiproject to an external data carrier. Unzip the 
multiproject on the decentralized ES ("File > Retrieve..."). 

3. Remove from the multiproject all projects which the project engineer does not 
need ("File > Multiproject > Remove from Multiproject"). 

4. On the Engineering Server add the removed projects to the multiproject again 
("File > Multiproject > Insert into Multiproject..."). 

 

Note The master data library must not be changed on the decentralized ES as it must 
not be returned into the multiproject of the Engineering Server anymore. 

The master data library should be changed on the Engineering Server by an 
authorized person only. After changing, it must be distributed to the 
decentralized ES once again. 

 
 

Moving a project in the network interconnection 

Below, a project is moved within a multiproject from the central Engineering Server 
via the network to a remote ES. To do this, a copy of the project is generated on 
the remote PC and integrated into the multiproject. The original is then removed 
from the multiproject and can physically remain on the hard disk of the central 
Engineering Server as a backup. 

1. Select the project which is to be moved to a decentralized ES, in the SIMATIC 
Manager. 

2. Select the menu command "File > Save as...". 

3. Make the following settings in the "Save as" dialog: 

– Set option "Add to multiproject" 

– Select "Current multiproject" 

– Option "Replace current project" 

– Select storage location 

4. Save the project with "OK". 
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Figure 1-18 

 

 

The existing original project was removed from the multiproject and stored on the 
central Engineering Server. There it can remain as a backup or be deleted. The 
backup copy can be removed via the menu option "File > Delete..." of the SIMATIC 
Manager. 

 

Removing a project from the multiproject 

A project is completely removed from the multiproject. The removed project can 
then be moved to an external data storage medium for transport purposes. 

1. Select the project to be removed from the multiproject. 

2. Select the menu command "File > Multiproject > Remove from Multiproject". 

 

Even if the project was removed from the multiproject, it is still stored as a project 
in the folder which was created during generation. In order to transfer the project to 
an external medium, it must be archived. 

1. Execute the menu option "File > Archive...". 

2. Select the project in the tab "User projects". 

3. Start archiving with "OK". 
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After these steps the removed project is located on the drive it was generated on, 
as a zip-file as well as in original form. Both can remain here as backup or be 
deleted. The original project can be removed via the menu option "File > Delete...". 
The zip archive can be deleted, moved or backed up with Windows means. 

To allow the project engineer access to the master data library on the decentralized 
ES, you also have to copy it to the decentralized ES. Changes in the master data 
library should only be made at the Engineering Server. After that the library has to 
be distributed to the decentralized ES again. 

The master data library can be distributed as follows: 

1. Execute the menu option "File > Archive...". 

2. Select the master data library of the multiproject on the tab "Libraries". Master 
data libraries are marked with a blue book icon. 

3. Start archiving with "OK". 

 

Figure 1-19 

 

 

The zip archive of the master data library can be copied to all decentralized 
Engineering Stations via an external data carrier in the usual way. After unzipping 
the master data library on the Engineering Stations you can use it just like a normal 
library. 
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Note The SIMATIC Manager provides another functionality for temporary network 
connections between the Engineering Stations. 

A selected project can be moved to the remote ES via "File > Multiproject > 
Remove for editing..." and at the same time be removed from the multiproject. 
The project is marked in the multiproject as "Project removed for editing" and 
displayed in gray. 

On the one hand this saves the deleting process and on the other hand it 
simplifies the re-integration after the editing process as the original work path 
was memorized (reducing the administrative work). 

 

1.4.4 Decentralized project works 

Editing projects without network interconnection 

The following functions are available for the editing of projects on the decentralized 
ES: 

• Non-interproject functions 

• Connections to an unknown project 
A text reference is specified for these connections in NetPro. A connection with 
the same text reference has to be stored at the connection partner. After 
integrating the connection into the multiproject it can be established with the 
function "Merge connection". 

• Pure editing processes 

• Compiling and loading an AS via a fixed parameterized PG/PC interface (e.g. 
CP1613[ISO]) 

 

If the project was distributed without a multiproject, it is only possible to access the 
master data library if they are copied too. Changes at the master data library 
should only be made at the Engineering Server by a person who is responsible for 
this. After changing, it must be distributed to the decentralized ES once again. 

Interproject functions or specified relations on the other hand require availability of 
the partner project. 

If you want to download the AS via the interface module "PC internal (local)" from 
the decentralized EC, you have to perform the following work beforehand: 

1. Add to the project a local PC station with a matching CP. 

2. Configure the S7 connection between AS and OS. 

 

If you want to test an OS on the decentralized ES in process operation (OS 
simulation), you have to adapt the computer name in the WinCC Explorer. 
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Note Before you copy or move the project on the Engineering Server again, you have 
to undo these changes. 

 

Editing projects in the network interconnection 

Decentralized processing of projects of a multiproject corresponds largely to 
processing several projects on the same Engineering Station, providing there is a 
permanent and quick network connection. AS compiling and loading or OS 
compiling are also possible as well as generating interproject connections and the 
access to the master data library. 

Backing up the multiproject on the Engineering Server also contains the distributed 
projects. During archiving, the project must not be processed on the decentralized 
Engineering Stations. 

From PCS 7 V6.1 SP1 the option package Version Trail is available in addition. 
Here, project data, i.e. complete multiprojects, individual projects or libraries can be 
archived, and the data be provided with a version identification as well as a 
comment. Furthermore, already versioned project data can be dearchived and 
reused. Version Trail also takes on the complete management of the version 
history. This means that for example a once completed version cannot be changed 
anymore. 

 

1.4.5 Final project works 

After merging the decentrally processed projects, the overall project planning can 
be completed by first time or repeated execution of interproject functions. 

Updating the Plant Hierarchy (PH) 

If the PH of all projects shall be kept identical, but it was changed during the 
decentralized processing in a project (e.g. through the adding of a new hierarchy 
folder), you can update the other projects with this once again. 

Mark the multiproject and select the menu option "Options > Plant Hierarchy > 
Update in Multiproject". 

Merging interproject connections 

Connections which were created with a text reference on the decentralized 
Engineering Stations can be closed after integrating the projects into the 
multiproject on the Engineering Server: 

There are two procedures for merging interproject connections. 

To merge the interproject connections of all projects in the entire multiproject, 
proceed as follows: 
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1. In the SIMATIC Manager select the menu command "File > Multiproject > 
Update projects...". 

2. Mark the entry "Merge connections" in the tree view. 

3. Click the "Execute" button. In "Result" all interproject connections are displayed 
which can be merged. 

4. Click the "Apply" button. Thus, all displayed connections are merged. 

 

Figure 1-20 

 

 

To merge the interproject connections of individual projects, proceed as follows: 

1. In the SIMATIC Manager select the project whose connections you want to 
merge. 

2. Start "NetPro". 

3. Select the menu command "Edit > Merge connections...". 

4. Select the connections which you want to merge and click the "Merge" button. 
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Figure 1-21 

 

 

Compiling and loading 

Perform the following activities in accordance with the system documentation: 

 

1. Compiling the AS program 
You can skip this step if the program has already been compiled on the 
decentralized ES. 

2. Compiling the OS server with access to the respective AS components 

3. Loading the OS server data to the OS clients 
(Must be carried out manually once. Any later changes of the server 
configuration will be updated automatically on the clients.) 

4. Loading all target systems 
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2 Multi-user Engineering 
2.1 Functional mechanisms 

In multi-user engineering several project engineers work on the same project 
regardless of the selected project structure and distribution. The respective project 
is located on an Engineering Server which is accessed by the individual 
Engineering Stations via the network. It is not important here whether it is part of a 
multiproject or has been removed for editing. 

 

Figure 2-1 

 

 

Real multi-user engineering is presently available only for editing CFC/SFC. These 
objects can be changed by several project engineers in parallel where changes are 
written directly into the system database. Further information is available in chapter 
"2.4.1 CFC/SFC". 

The following applies generally to all other objects in the PCS 7 project: When 
these objects are worked on, they are given a status which prevents that the data 
consistency will be lost. If several users access the same object, e.g. the symbol 
table, it will be editable only by one user. The other users may open only a write-
protected version of the symbol table. 

Here it is not important either which way one takes to open an object. The symbol 
table can be opened, for instance, from the component view, process object view 
or the menu option of an editor (e.g. SCL Editor). The table will be displayed in the 
Symbol Editor and edited there as a rule. 

 



2 Multi-user Engineering 
2.1 Functional mechanisms 

 

34 
Multiprojekt / Multi user-Engineering 

Version 3.0, Entry ID: 22258951 
 

C
op

yr
ig

ht
 ©

 S
ie

m
en

s 
A

G
 2

01
1 

A
ll 

rig
ht

s 
re

se
rv

ed
 

Figure 2-2 

 

 

Basically it can be said that all objects can be opened as write-protected versions 
by all users, whereas they may be edited only by one user. The privilege of saving 
the changes rests with the user who made a change first. All other users receive 
the message that the object is already being edited and that they can save their 
changes only with the function "Save as...". Only after the change was saved by 
the project engineer, the respective object can be edited by another user again. 

If changes were made by another user while an object was displayed, these 
changes will only be visible when the display is updated (F5). 

There will usually be no conflict when different objects are edited in the same 
project. However, you have to be careful if actions such as AS compiling shall be 
executed throughout the project. If a user tries to change a CFC chart while the AS 
program is being compiled, a conflict will occur. 

With an OS project the respective editor (WinCC Explorer) will prevent multiple 
opening of the object. Multi-user engineering is not available for these objects. 



2 Multi-user Engineering
2.2 System requirements 

 

Multiprojekt / Multi user-Engineering 
Version 3.0, Entry ID: 22258951 35
 

C
op

yr
ig

ht
 ©

 S
ie

m
en

s 
A

G
 2

01
1 

A
ll 

rig
ht

s 
re

se
rv

ed
 

2.2 System requirements 

Engineering Server 

• For performance reasons we recommend using the operating system Windows 
Server 2003 on the Engineering Server. 

• The project engineers of the decentralized Engineering Stations must be given 
write permissions for the Engineering Server and specifically on the project 
folder. 

Decentralized Engineering Stations 

• The decentralized Engineering Stations can use the operating systems 
Windows XP Professional or Windows Server 2003. 

• The same PCS 7 version must be installed on all Engineering Stations with the 
same options as on the Engineering Server. 

• The ES licenses can be installed locally (license type "Single"), or free licenses 
are used which are accessed via network (license type "Floating"). The floating 
licenses can be located on the Engineering Server or on an additional license 
server. The RT licenses which are required for testing OS functions must be 
installed locally. 

Networking 

• For loading the AS or for testing OS functions the Engineering Stations which 
can be used for this must be connected directly with the plant bus. (Routing 
through the Engineering Server is not possible.) 

• A stable network connection must exist between the involved Engineering 
Stations. 

 

Note Working via network increases the potential hazards for a smooth workflow. If 
the network connection should fail during a writing process, long waiting times 
and inconsistencies in data management may occur. 
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2.3 Overview of project engineering steps 

Generally, the first project engineering steps, such as creating the multiproject, 
must be carried out on the Engineering Server.  

By working via the network the risks of data inconsistencies may increase. A stable 
network connection is mandatory between the Engineering Stations in the multi-
user operation. 

Generally we recommend performing interproject functions on the Engineering 
Server where the project or the multiproject is managed. 

• Creating and updating the Plant Hierarchy (PH) 

• Managing the master data library 

• Remerging subnets and connections 

• Creating and updating the block icons 

• Compiling and loading all contained components (AS, OS, ...) 

 

The following procedure is recommended, however, it may vary according to 
individual conditions and experience. 

Table 2-1 

 Activity Location 

1. Preparatory project works: 
 
• Configuring the network release for the project folder 

• Creating the multiproject 
• Configuring the SIMATIC stations and the PC stations 
• Creating and updating the Plant Hierarchy (PH) 
• Generating interproject networks 

• Generating interproject connections 
• Filling the master data library (parameterized function 

blocks, measuring location types, ...) 

ES server 

2. Parallel project editing 
 
• Parallel opening of the project via network release 
• Editing process objects 

Decentralized ES 

3. Final project works: 
 
• Updating the Plant Hierarchy (PH) 
• Remerging interproject connections 

• Checking the interproject consistency 
• Compiling and loading 

ES server 
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Note When interproject functions are to be executed, the project engineers must be 
informed because they must not work on the projects during that time. The 
individual steps are described in detail in the PCS 7 Configuration Manual 
"Engineering System". 

Further information on the creation of a multiproject is available in the document 
"PCS 7 Compendium Part A - Configuration Guidelines". 
http://support.automation.siemens.com/WW/view/en/35016996 

http://support.automation.siemens.com/WW/view/en/35016996�
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2.4 Working in parallel 

The multiproject, or individual projects of the multiproject, is opened via network 
access on several Engineering Stations when working in parallel in the multi-user 
mode. The Engineering Server on which the project is located may also be used as 
a host. 

 

Access scenarios / peculiarities 

The following cases are distinguished for editing objects: 

• Editing objects of different stations 

• Editing different objects of one and the same station 

• Editing one and the same object of one and the same station 

No inconsistencies should occur when working in different stations. 

The probability of inconsistencies is also small if different objects of one and the 
same station are worked on. However, conflicts may not be circumvented entirely 
because, for instance, all CFC charts access common resources, such as symbol 
tables, run sequence etc. 

If several project engineers work on the same object though, mutual interferences 
may occur. For instance, if two project engineers access one and the same input 
mask in a CFC chart at the same time, the action of the project engineer will be 
carried out who presses "Apply" or finishes the dialog with "OK" last. 

 

Note If several project engineers work on the same object, the view should be 
refreshed more frequently (F5). This ensures that the actual current state is 
displayed. 

 
 

This mode of operation should generally be avoided. Simultaneous access to the 
same resources should be restricted to short actions, for instance, the 
parameterization of the same I/Os of a certain block type. The project engineers 
should talk and coordinate long reading or writing actions. 
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Conflict handling 

A typical conflict situation is, for instance, a parallel change on the same object. 
Here, the user is privileged to save the change as a rule who was the first to make 
the change. All other users will usually get a message that the object is write-
protected or that it is being used by another process. 

 

Figure 2-3 

 

 

Parallel opening (reading) of objects or of its properties will normally not result in 
any conflict and can be executed by all users. 

 

2.4.1 CFC/SFC 

Prioritizing the actions 

The individual transactions are assigned different priorities: 

 

Table 2-2 

Action type Prio Examples 

Short reading 3 • Opening charts 

• Opening run sequence 
• Opening dialog fields 

Short writing 2 • Instancing, parameterizing 
• Closing dialog fields with OK 

Long reading 
(with resource use) 

1 • AS-OS data transfer 
(OS compilation) 

• Creating chart reference data 
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Action type Prio Examples 

Long writing 
(with resource use) 

1 • Optimizing the run sequence 
• Compiling and loading (AS and OS) 
• Updating or cleaning up type import 

and block types 
• Updating the global declarations 

• Creating module drivers 
• Reading back 
• Creating block icons 
• Creating diagnostic screens 

• Updating PH in the multiproject 
• Import / export functions of the IEA 

and of the process object view 
• Import / export functions of ES objects 

of the VCM 

 

Signaling conflicts 

The same chart (CFC or SFC) can theoretically be edited by several project 
engineers at the same time. However, only one user at a time may access the 
database for writing actions. If an action cannot be executed, a message like this 
will be displayed: 

 

Figure 2-4 

 

 

Such conflicts are very rare due to the shortness of the time which is required for 
writing into the database. 
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Note Warnings will appear only in the case of conflict (no notification when opening an 
already opened CFC / SFC chart). 

The project engineers should generally coordinate their actions when editing the 
same CFC / SFC charts. Agreement among the project engineers as to what 
change should be saved will be required in the case of conflict at the latest. 

 

ATTENTION Special care should be taken when you load the automation system. Make 
sure that actually all work on the AS program has been completed. 
Otherwise, semi-finished compiled intermediate states could be loaded 
into the AS which might cause dangerous situations. 

 
 

Typical conflict situations within CFC and SFC are, for instance: 

• Cutting connections 

• Parameterization of blocks 

• Locating blocks 

• Defining steps / transitions 

 

Note The operation will be denied in the case of access conflicts outside the CFC/SFC 
(no multi-user-conform message). Simultaneous work in the SIMATIC Manager 
is not supported outside the PCS 7 ES. 

 
 

Conflict dealing in accordance with the priority of the action 

As a matter of principle, the higher-priority action will always be executed in the 
case of access conflict. The lower-priority action is aborted in this case. 

• Prio 3 (short reading actions) 
If further short reading actions are carried out in parallel, no conflicts are to be 
expected. 
If a short or long writing action is carried out in parallel, access conflicts may 
occur, i.e. the short reading action will be aborted. 

• Prio 2 (short writing action) 
If a short or long writing action is carried out in parallel, access conflicts may 
occur for the action which has been started later. 

• Prio 1 (long reading or writing actions) 
Long reading or writing actions will be executed without any access conflict if 
upon the start of such actions no access conflict occurs immediately due to, for 
instance, a parallel reading or writing action. (as to exceptions refer to the 
reference below) 
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If parallel actions have the same priority the action which has been started first will 
be carried out. 

 

Note For further information about how the system responds to conflicts refer to the 
PCS 7 Function Manual "CFC for SIMATIC S7", chapter 6 "Multi-User 
Engineering" under the heading "Notes relating to system behavior". 

You will find information on: 

• Conflicts due to access to the same resources outside the CFC 
• Conflicts when using the test mode 

 

Locking mechanisms 

Every transaction has an ID and is protected via it (allocated), i.e., further writing 
actions made to the same location in the database will be blocked. 

 

Note The actions on the individual program units are allocated line by line in the 
process object view (table layout). 

 
 

2.4.2 Process object view 

When working in the process object view changes are written directly into the 
database, i.e. dialogs for confirming the change will not be displayed. If several ES 
are being worked on in the process object view in parallel, the changes made by 
other users will only become visible after the view has been refreshed. 

A conflict of access to the parameters of an object in the process object view will 
only occur if these parameters are written into the database by different ES at the 
same time. A message will appear then that the process is being used by another 
application already. The message also contains the information what user blocks 
the process on which computer. 
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Figure 2-5 

 

 

Your own changes will be lost in this case and the changes of the displayed user 
will be written into the database. Upon updating the display (F5) the inputs of the 
other user will be displayed in the process object view then. 
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2.4.3 Hardware components and connections 

Hardware 

On principle, it is possible to have the hardware components (AS, OS, connections, 
other stations, ...) configured and edited by several users. If a hardware object is 
edited and opened with the respective editor (HW Config, NetPro), this object is 
blocked against changes of other users. These users can open the object only as a 
write-protected version. 

 

Figure 2-6 

 

 

Note We recommend making the complete hardware configuration on the Engineering 
Server. 

 
 

Process Device Manager (SIMATIC PDM) 

In order to parameterize a field device with PDM, a device configuration file must 
be installed on the ES. If the project is loaded on an ES with configured PDM 
device without an installed device configuration file, a note appears informing about 
the missing software when HW Config is opened. HW Config can be opened only 
for reading access then. Changes in HW Config cannot be saved. 
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Figure 2-7 

 

 

Field devices which were configured with the Process Device Manager can only be 
opened by one user at a time for editing. Other users can open the device 
configuration only for reading access then. 

 

Figure 2-8 

 

 

ATTENTION When editing PDM devices on different ES there is the risk of data 
inconsistency. 

We recommend editing the PDM field devices as a rule only from one ES 
(e.g. the Engineering Server) since SIMATIC PDM saves the configuration 
data of the field devices only locally. Editing the device configuration on 
another ES requires a manual update of the configuration data with the 
import/export function or via an explicit reading-in of the data. After an 
import of the configuration data an upload or download of the data should 
be carried out to ensure that no different configuration status will be 
reported later. 
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2.4.4 Other ES components 

Generally, the user who made a change to objects in the PCS 7 project first can 
save the change. This applies to the objects specified below. As long as the 
change has not been saved, all other users have only reading access to the object. 
This is indicated by a respective message. 

 

 

 

• Connections 

• Sources (STL, SCL, LAD, FBD) 

• Blocks 

• Symbol table 

 

Figure 2-9 
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2.4.5 OS project 

WinCC Explorer prevents that the OS project is opened in parallel. The project can 
be opened only once at a time as a rule. WinCC Explorer cannot be used in the 
multi-user operation. When you attempt to open the OS project once again, the 
following message appears: 

 

Figure 2-10 

 

 

 

 

 

 

The OS pictures are an exception. They can be opened out of the Graphics 
Designer from another project. However, only one user has the right to edit the 
picture. Other users have only write-protected access to the picture. 

 

Figure 2-11 
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2.4.6 Compiling and loading objects 

Options 

In PCS 7 you can start the functions for compiling and loading from different 
editors. There are differences in the function scope. The following table provides an 
overview of the options for compilation and loading of PCS 7 components: 

 

Table 2-3 

Editor Function 

HW Config Compiling and loading the hardware configuration 
NetPro Compiling and loading the network and connection configuration 

and hardware configurations 
CFC and SFC Compiling and loading the AS program 
SIMATIC Manager Compiling and loading individual or all objects of a multiproject 

 

 

 

 

 

 

Compiling and loading stations individually 

As a rule, different AS/OS can be compiled on different ES. However, conflicts may 
occur when compiling different OS if the OS visualize the process of the same AS. 
It is not possible to compile the same AS/OS on different ES simultaneously. A 
conflict will occur. 

 

Figure 2-12 
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Compiling and loading objects (Make) 

You can compile and load all objects, connections and programs of a multiproject 
with the dialog "Compiling and loading objects". 

 

Note We recommend compiling and loading all objects always from the Engineering 
Server. Coordinate your work with the other project engineers as a rule. The 
multiproject or the integrated projects must not be opened on all ES as otherwise 
a conflict will occur and the overall compilation will be aborted. 
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3 References 
3.1 Internet links 

The following list is by no means complete and only provides a selection of 
appropriate sources. 

 

Table 3-1  

 Topic Title 

\1\ Reference to this entry http://support.automation.siemens.com/WW/view/
en/22258951 

\2\ Siemens I IA/DT Customer 
Support 

http://support.automation.siemens.com 

\3\ Entry: 
PCS 7 Compendium Part A – 
Configuration Guidelines 

http://support.automation.siemens.com/WW/view/
en/35016996 

\4\ Manual: 
PCS 7 Engineering System 
(V7.1) 

http://support.automation.siemens.com/WW/view/
en/36050990 

\5\ Manual: 
PCS 7 CFC for SIMATIC S7 

http://support.automation.siemens.com/WW/view/
en/27002752 

 

3.2 Bibliographic references 

The following list is by no means complete and only provides a selection of 
appropriate sources. 

 

Table 3-2  

 Topic Title 

/1/ STEP7 Automating with STEP7 in STL and SCL 
Hans Berger 
Publicis MCD Verlag 
ISBN 3-89578-113-4 

/2/ CFC for SIMATIC S7 Chapter 6 "Multi-user Engineering" 

 

http://support.automation.siemens.com/WW/view/en/22258951�
http://support.automation.siemens.com/WW/view/en/22258951�
http://support.automation.siemens.com/�
http://support.automation.siemens.com/WW/view/en/35016996�
http://support.automation.siemens.com/WW/view/en/35016996�
http://support.automation.siemens.com/WW/view/en/36050990�
http://support.automation.siemens.com/WW/view/en/36050990�
http://support.automation.siemens.com/WW/view/en/27002752�
http://support.automation.siemens.com/WW/view/en/27002752�
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4 List of Revisions 
 

Table 4-1  

Version Date Revisions  

V1.0 12.09.2007 First edition on the DVD PCS 7 V7.0 SP1 
V2.0 05.11.2009 Layout adaptation to Applications & Tools Design 
V3.0 30.11.2011 Multi-user-Engineering for CFC/SFC extended by additional 

ES / OS components 
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