Mostrar lista de artículos
S7-SCL -- Creación de programas S7 -- Elaboración de fuentes
¿Cómo se puede comprobar Online la fuente S7-SCL con ayuda del Debugger (depurador)?
¿Cómo se puede ajustar la protección de módulo en un módulo de S7-SCL?
¿Cómo se puede comprobar Online la fuente S7-SCL con ayuda del Debugger (depurador)?
Referencia:

Instrucciones:
El Debugger posibilita realizar una comprobación sencilla del programa en la fuente S7-SCL. Si la fuente S7-SCL se ha ejecutado correctamente, se pueden buscar los errores lógicos con ayuda de los puntos de paro y de esta forma comprobar la funcionalidad correcta del código S7-SCL en tiempo de ejecución. La siguiente tabla describe el procedimiento necesario para ello:
 
Procedimiento:
1 En la fuente S7-SCL, abra el diálogo "Configuración" con ayuda de la opción del menú "Herramientas -> Configuración" y elija el registro "Compilador". Active la opción "Creación de la información de depuración" y confirme todo con "OK".


Figura 01

Advertencia:
Con ayuda de esta opción, se crean automáticamente los datos de referencia necesarios para el test al realizar la compilación, de forma que aumenta la memoria necesaria para el programa y los tiempos de ejecución del sistema de automatización.

2 Ajuste el modo de servicio de la CPU al modo Test seleccionando la opción del menú "Test -> Modo de servicio -> Modo de servicio de test".

Advertencia:
En el modo de servicio de test, a través de la PG/PC se pueden utilizar sin limitación todas las funciones de test que puede hacer que se alargue ampliamente el tiempo de ejecución. Si la CPU se encuentra en modo de test, hay que tener en cuenta que la CPU o el proceso puedan soportar el "alargamiento" del tiempo de ciclo. En este modo de servicio, pueden aparecer aumentos de los tiempos de ciclo de la CPU, ya que por ejemplo se consulta el estado de las instrucciones en cada paso los los bucles programados.

3 Guarde el programa con ayuda de la opción "Archivo -> Guardar" o pulsando sobre el icono del disquete.
4 Compile el programa con ayuda de la opción "Archivo -> Compilar" o pulsando sobre el icono "Compilar".
5 Cargue el programa en la CPU con ayuda de la opción "Sistema destino -> Cargar" o pulsando sobre el icono "Cargar".
6 Coloque el cursor en la línea de programa, a partir de la cual se quiere comprobar éste, y elija la opción del menú "Test -> Activar punto de paro". Ahora aparece el punto de paro como un pequeño círculo coloreado a la izquierda junto a la instrucción S7-SCL.
7 Si se utilizan varias instancias para un módulo de función y se quiere comprobar la función con una determinada instancia, primero hay que especificar el DB de instancia correspondiente.

Abra el "Entorno de llamada del módulo" con la opción del menú "Test -> Entorno de llamada de los módulos" y active la opción "Módulos de datos abiertos". Indique el número del DB de instancia, tal como se ve en la figura 02, y confirme todo con OK.


Figura 02

De esta forma se visualiza el módulo de función cuando se llama con el DB de instancia indicado.

8 Abra el diálogo "Editar los puntos de paro" con ayuda de la opción del menú "Test -> Editar puntos de paro", y active la opción "Módulo de datos abierto". Indique el número del DB de instancia, tal como se ve en la figura 03, y confirme todo con OK.


Figura 03

El punto de paro ya está activo con este ajuste, cuando el módulo de función se llama con el módulo de datos indicado.

9 Para adaptar la ventana del Debugger, abra los ajustes con ayuda de la opción del menú "Herramientas -> Configuración ..." y elija el registro "Formato". Aquí se puede adaptar el tipo de letra y el color de la ventana del Debugger. Se puede definir colores diferentes para las variables que modifican y para las variables que permanecen invariables.


Figura 04

10 Active los puntos de paro ajustados por usted con ayuda de la opción del menú "Test -> Puntos de paro activos".
11 Con ayuda de la barra del menú, tal como se muestra en la figura 05, ya se puede comprobar el programa S7-SCL instrucción por instrucción. Haga clic sobre el icono "Siguiente instrucción". La instrucción S7-SCL se ejecuta en la posición actual tras el punto de paro.


Figura 05

12 Si se quiere cerrar el test del programa con el Debugger, ejecute los siguientes comandos:
  1. "Test -> Borrar todos los puntos de paro"
  2. "Test -> Cerrar test".

Advertencia:
Ajuste el modo de servicio de la CPU de nuevo al modo de proceso (opción del menú "Test -> Modo de servicio -> Modo de proceso") y desactive la opción "Creación de la información de depuración" (desde "Herramientas -> Configuración -> Registro: Compilador"). De esta forma se reduce la memoria necesaria y los tiempos de ejecución del módulo. A continuación, hay que volver a compilar el programa y cargarlo en la CPU.

Información adicional está disponible en la ayuda Online del S7-SCL, bajo los puntos:

  • Fundamentos para comprobar en el modo paso a paso / con puntos de paro
  • Pasos para comprobar con puntos de paro
  • Comprobar en el modo paso a paso

Conceptos de búsqueda:
Búsqueda de errores

 Nr. de identificación (ID):30335737   Fecha:2008-08-12 
Este artículo...me ayudóno me ayudó                                 
mySupport
My Documentation Manager 
Boletín 
CAx-Download-Manager 
Support Request
Sobre este artículo
Imprimir
Crear PDF 
Enviar artículo
QuickLinks
Herramienta de compatibilidad 
Temas
Ayuda
Ayuda en línea
Guided Tour