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WinCC flexible ES -- Entwicklungsumgebung einrichten -- Software installieren und hochrüsten
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Welche Ursache kann es haben, dass nicht alle Oberflächensprachen zur Verfügung/Auswahl stehen?
Welche Ursachen kann eine nicht erfolgreiche MSDE-Installation (Microsoft Desktop Engine) haben?
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Wie kann man WinCC flexible 2004 deinstallieren?
Wie erfolgt die Installation von ProAgent unter SIMATIC WinCC flexible?
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Wie lässt sich WinCC flexible von der Festplatte aus installieren?
Welche Ursachen kann eine nicht erfolgreiche MSDE-Installation (Microsoft Desktop Engine) haben?
Bestellnummer:

Konfigurationshinweis:
Eine fehlerhafte oder beschädigte Datenbankinstallation kann vielfältige Ursachen haben.

Wenn die Installation oder Konfiguration der MSDE (Microsoft Desktop Engine) nicht erfolgreich war oder beschädigt wurde (z.B. durch eine andere Installation), dann reicht es in der Regel aus, die MSDE neu zu installieren bzw. zu konfigurieren.

Informationen dazu finden Sie in der folgenden Beschreibung "MSDE-Installation neu starten".

Inhalt:

1. MSDE-Installation neu starten

1.1 Installationsvorbereitung
1.2 Hinweise für WinCC flexible 2007
     
(Micro/Compact/Standard/Advanced)
1.3 Hinweise für WinCC flexible 2005 mit SP1
     
(Compact/Standard/Advanced)
1.4 Hinweise für WinCC flexible 2005 Micro mit SP1

      (Micro)
1.5 Hinweise für WinCC flexible 2004 und 2005 ohne SP1
      (Micro/Compact/Standard/Advanced)

2. Meldungen beim Starten von WinCC flexible

2.1 Fehlerhafte Datenbank-Installation

3. Meldungen während der Installation von WinCC flexible 2007

3.1 Installationsabbruch bei Microsoft SQL Server Desktop Engine

4. Meldungen während der Installation von der MSDE

4.1 Unterbrechung des Wizards bei der MSDE-Installation
4.2 Konfiguration des SQL-Servers fehlgeschlagen

4.3 Installationsabbruch mit einer selbstständigen Deinstallation
4.4 MSDE-Installation bleibt mit laufender Sanduhr stehen
4.5 SQL Server existiert nicht oder Zugriff verweigert
4.6 Probleme bei bereits installierten SQL-Server Editionen

1. MSDE-Installation neu starten
 
Nr. MSDE Installation neu starten 
1.1 Installationsvorbereitung
Stellen Sie sicher, dass zum Zeitpunkt der MSDE-Installation der Dienst "Server" aktiviert und gestartet ist. Nach der Installation der MSDE können Sie den Dienst wieder stoppen bzw. deaktiviert lassen (sofern nicht anderweitig erforderlich).

Den Dienst "Server" finden Sie unter "Start > Systemsteuerung > Verwaltung > Dienste". Wählen Sie hier den Dienst "Server" mit einem Doppelklick an. Als Startup-Einstellung wählen Sie "Automatisch" oder "Manuell". Starten Sie den Dienst durch Klick auf die Schaltfläche "Start".

Bevor Sie WinCC flexible neu installieren, muss die alte MSDE von Ihrem System deinstalliert werden. Zum Deinstallieren der MSDE verwenden Sie bitte das "Cleanup Support Tool", das Sie unter folgender Beitrags-ID 28465761 kostenlos herunterladen können.

1.2

Hinweise für WinCC flexible 2007
(Compact/Standard/Advanced und Micro)

  • Starten Sie auf CD1 die Applikation
    "MSDE DISK1\MSDE_WCF_setup.exe".
  • Bei Windows 2000 führen Sie zusätzlich einen Reboot aus.
  • Anschließend starten Sie auf der CD1 "MDSE\DISK1\MSDE_WCF_Conf.exe".

    Hinweis:
    Die Konfiguration des SQL-Servers ist notwendig, um die den Server zu schützen.
1.3

Hinweise für WinCC flexible 2005 mit SP1
(Compact/Standard/Advanced)

  • Sie müssen als Administrator am System angemeldet sein.
  • Starten Sie auf  CD2 die Applikation "WinCCflexible\Setup\MSDE\DISK1\setup.exe".
    Nach erfolgreicher Installation erfolgt hier auch eine Konfiguration der Datenbank.

Alternativ:
Starten Sie auf CD2 "WinCCflexible\Setup\MSDE\DISK1\MSDE\setup.exe"
Hiermit installieren Sie die MSDE neu. Nach erfolgreicher Installation und Reboot starten Sie von CD2 "WinCCflexible\Setup\MSDE\DISK1\setup.exe", um die Datenbank zu konfigurieren.

1.4

Hinweise für WinCC flexible 2005 Micro mit SP1

  • Starten Sie auf CD1 "WinCCflexible\Setup\MSDE\DISK1\setup.exe".
    Nach erfolgreicher Installation erfolgt hier auch eine Konfiguration der Datenbank.

Alternativ:
Starten Sie auf CD1 "WinCCflexible\Setup\MSDE\DISK1\MSDE\setup.exe".
Hiermit installieren Sie die MSDE neu.

Nach erfolgreicher Installation und Reboot starten Sie von CD1 "WinCCflexible\Setup\MSDE\DISK1\setup.exe", um die Datenbank zu konfigurieren.

1.5

Hinweise für WinCC flexible 2004 und 2005 ohne SP1
(Compact/Standard/Advanced und Micro)

  • Download des SQL-Servers direkt von Microsoft (ca.70 MB): Link zu den Microsoft-Seiten
  • WinCC flexible unterstützt ausschließlich die englischsprachige (EN-US) Version der MSDE.
  • Sie müssen während der Installation und der Konfiguration der MSDE als Administrator am System angemeldet sein.
  • Ausführen der Applikation "sql2kdesksp3.exe".
    Geben Sie ein beliebiges, lokales Zielverzeichnis an, in welches die Installationsdaten entpackt werden.
  • Vor dem nächsten Schritt führen Sie einen "Neustart" des Rechners durch.
  • Wechseln Sie in einem DOS-Eingabefenster in das gerade angegebene Zielverzeichnis und von dort in das Unterverzeichnis "MSDE".
  • Führen Sie folgendes Kommando aus, um die WinCC-flexible-Instanz des SQL-Server zu installieren.

    Setup.exe BLANKSAPWD=1 SECURITYMODE=SQL DISABLENETWORKPROTOCOLS=0 INSTANCENAME="WinCCflexible"

Durch die Verwendung von BLANKSAPWD ist der SQL-Server noch ungeschützt (ohne Passwort). Deshalb sind die nachfolgenden Schritte notwendig.

  • Starten Sie den SQL-Server durch Eingabe des Kommandos:
    Net.exe start MSSQL$WinCCflexible
  • Legen Sie die Datei WinCCflexibleSetup.dts in einem beliebigen Verzeichnis ab. Führen Sie in diesem Verzeichnis folgendes Kommando aus:
    Dtsrun.exe /FWinCCflexibleSetup.dts /MWinCCFlexibleSetup /L%WINDIR%\WinCCFlexibleMSDE.log

Damit wird der SQL-Server für WinCC flexible endkonfiguriert und erhält ein Passwort für den Administrator.

2. Meldungen beim Starten von WinCC flexible
Nachfolgend werden einige mögliche Meldungen in Zusammenhang mit der MSDE sowie deren Ursache und Abhilfen aufgezeigt.
  
Nr. Meldungen

2.1

Fehlerhafte Datenbank-Installation

Beschreibung:
  • Beim Start von WinCC flexible erscheint die Meldung
    "Der Dienst MSSQL$WinCCflexible ist nicht installiert"
  • Beim Öffnen eines vorhandenen Projektes erscheint die Meldung
    "Die Serverklasse SQLDMO kann nicht initialisiert werden".

Mögliche Ursache:
Diese Meldungen deuten normalerweise auf eine fehlerhafte Datenbankinstallation hin.

Abhilfe:
Installieren Sie den WinCC flexible Datenbankserver neu.
(Siehe "MSDE Installation neu starten").

Anmerkung:
Sollte das Cleanup Support Tool den Fehler nicht behoben haben, dann sollten Sie die Abhilfen unter Punkt 4 - Meldungen während der Installation von der MSDE - beachten.

3. Meldungen während der Installation von WinCC flexible 2007
In der nachfolgenden Tabelle werden einige mögliche Meldungen während der Installation von WinCC flexible 2007 in Zusammenhang mit der MSDE sowie deren Ursache und Abhilfen aufgezeigt.

Wichtig:
In der Beschreibung werden an einigen Stellen Änderungen in der "Registry" vorgenommen. Beachten Sie hierzu, dass grundsätzlich für direkte Änderungen in der Registrierdatenbank keine Gewähr übernommen werden kann, da dies in der Hand des Anwenders liegt.
Es ist auf jeden Fall empfehlenswert, vor den beschriebenen Zugriffen eine Sicherung der Registry anzulegen.
 
Nr. Meldungen

3.1

Installationsabbruch bei Microsoft SQL Server Desktop Engine

Beschreibung:
  • Bei der Installation von WinCC flexible 2007 wird bei der Installation der MSDE von der CD "Microsoft Tool & ServicePacks for WinCC flexible 2007" folgende Fehlermeldung angezeigt:


Bild. 01

  • Bei der Installation von WinCC flexible von der WinCC flexible 2007 DVD folgende Fehlermeldung angezeigt:


Bild. 01

Mögliche Ursache:
Auf dem Rechner ist eine Vorgängerversion der MSDE installiert. Diese verhindert die Installation der Microsoft SQL Server Desktop Engine 2000 SP4.

Abhilfe:

  1. Führen Sie das herunterladbare "Cleanup Support Tool", welches unter folgender Beitrags-ID 28465761 heruntergeladen werden kann, aus.
    Entpacken Sie die Datei und führen Sie anschließend die "CleanupSupportTool.exe" aus. 
  2. Starten Sie anschließend den Rechner neu und installieren Sie SIMATIC WinCC flexible 2007 wie im Booklet, bzw. der Installationsanleitung, beschrieben.

Hinweis:
Sollte das "Cleanup Support Tool" den Fehler nicht behoben haben, dann sollten Sie die Abhilfen unter Punkt 4 - Meldungen während der Installation von der MSDE - beachten.

4. Meldungen während der Installation von der MSDE
Nachfolgend werden einige mögliche Meldungen in Zusammenhang mit der MSDE sowie deren Ursache und Abhilfen geschildert. Die gelisteten Fehlermeldungen werden mit dem "Cleanup Support Tool" nicht behoben.

Wichtig:
In der Beschreibung werden an einigen Stellen Änderungen in der "Registry" vorgenommen. Beachten Sie hierzu, dass grundsätzlich für direkte Änderungen in der Registrierdatenbank keine Gewähr übernommen werden kann, da dies in der Hand des Anwenders liegt.
Es ist auf jeden Fall empfehlenswert, vor den beschriebenen Zugriffen eine Sicherung der Registry anzulegen.
 
Nr. Meldungen

4.1

Unterbrechung des Wizards bei der MSDE-Installation

Beschreibung:
Die Installationsroutine der MSDE bricht mit folgender Meldung ab:
"The wizard was interrupted before MSDE could be successfully installed"

Mögliche Ursache:
Der Grund der Meldung kann eine frühere oder fehlerhafte bzw. beschädigte Installation der MSDE sein.

Abhilfe:
Deinstallieren Sie die MSDE und starten Sie danach die Installation von MSDE erneut.
Beachten Sie bitte, dass Sie während der Deinstallation und der Installation als Administrator am System angemeldet sind.

Links zu weiterführenden Informationen zu diesem Thema (Microsoft Support Seiten):
Englisch: http://support.microsoft.com/kb/275309/en-us
Deutsch: http://support.microsoft.com/kb/275309/de

Hinweis:
Beachten Sie bitte, dass sich Links von Fremdherstellern ändern können. Gehen Sie in diesem Fall bitte direkt auf die Startseite des Fremdherstellers und suchen Sie von dort das gewünschte Thema.

4.2

Konfiguration des SQL-Servers fehlgeschlagen

Beschreibung:

Die Installationsroutine der MSDE bricht mit folgender Meldung ab:
"Setup failed to configure the server. Refer to the server error logs and setup error logs for more information."

Mögliche Ursachen:

  1. Bei der Installation werden Funktionen benutzt, die den Computernamen auslesen und den Namen dabei in eine Schreibweise mit Großbuchstaben umwandeln. Dies kann bei Computernamen, die Kleinbuchstaben beinhalten, zu einem Abbruch der Installation führen.

Abhilfe:
Ändern Sie den Computernamen (keine Kleinbuchstaben verwenden) und starten Sie die Installation von MSDE erneut. 

Links zu weiterführenden Informationen zu diesem Thema (Microsoft Support Seiten):
Englisch: http://support.microsoft.com/kb/285100/en-us
Deutsch: http://support.microsoft.com/kb/285100/de

  1. Es existiert bereits ein Verzeichnis mit dem Namen:
    "Microsoft SQL Server\ MSSQL$WINCCFLEXIBLE"  im Installationspfad.
    Das Verzeichnis kann von einer vorherigen unvollständigen Deinstallation der MSDE stammen.

Abhilfe:
Nennen Sie das Verzeichnis um.
Beispiel:
"C:\Program Files\Microsoft SQL Server\MSSQL$WINCCFLEXIBLE" in
"C:\Program Files\Microsoft SQL Server\MSSQL$WINCCFLEXIBLE _old"

Danach starten Sie die Installation von MSDE erneut. 

Links zu weiterführenden Informationen zu diesem Thema (Microsoft Support Seiten):
Englisch: http://support.microsoft.com/kb/816499/en-us
Deutsch: http://support.microsoft.com/kb/816499/de

Hinweis:
Beachten Sie bitte, dass sich Links von Fremdherstellern ändern können. Gehen Sie in diesem Fall bitte direkt auf die Startseite des Fremdherstellers und suchen von dort das gewünschte Thema.

4.3

Installationsabbruch mit einer selbstständigen Deinstallation

Beschreibung:

Die Installationsroutine der MSDE bricht mit einer selbstständigen Deinstallation (Rollback) wieder ab.
Beim "Rollback" sehen Sie den Installationsbalken "rückwärts" laufen, nachdem er fast bis zum Ende "vorwärts" gelaufen war.

Mögliche Ursachen:

  1. Der Dienst "Server" ist desaktiviert bzw. während der MSE-Installation nicht aktiv.

Abhilfe:
Stellen Sie sicher, dass zum Zeitpunkt der MSDE-Installation der Dienst "Server" aktiviert und gestartet ist. Nach der Installation der MSDE können Sie den Dienst wieder stoppen bzw. desaktiviert lassen (sofern nicht anderweitig erforderlich).

Den Dienst "Server" finden Sie unter "Start > Systemsteuerung > Verwaltung > Dienste". Wählen Sie hier den Dienst "Server" mit einem Doppelklick an. Als Startup-Einstellung wählen Sie "Automatisch" oder "Manuell". Starten Sie den Dienst durch Klick auf die Schaltfläche "Start".

  1. Probleme mit dem Performance Monitor Counter.

Abhilfe:
Mögliche Abhilfen finden Sie auf den Supportseiten von Microsoft.
Um die Registry an dieser Stelle zu reparieren, führen Sie auf der Kommandozeile ("Start > Ausführen") folgenden Befehl aus: 

lodctr/r:PerfStringBackup.ini 

Weiterhin benötigen Sie volle Benutzerrechte auf dem Registry-Key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Perflib\009

Nach Reparatur der Registry starten Sie die Installation von MSDE erneut.

Links zu weiterführenden Informationen zu diesem Thema (Microsoft Support Seiten):
Englisch: http://support.microsoft.com/kb/315083/en-us
Deutsch: http://support.microsoft.com/kb/315083/de

  1. Dieses Verhalten kann auftreten, wenn Sie die MSDE von einem Microsoft Terminal Server Client auf den Terminal Server installieren möchten. Dabei kann ein Konflikt mit der temporären Umgebungsvariable auftreten.
    Das gleiche Verhalten kann ebenfalls auftreten, wenn bei den 
    Benutzer-Umgebungsvariablen TMP und TEMP nicht dieselben Pfade eingestellt sind, wie bei den System-Umgebungsvariablen.

Abhilfe:
Starten Sie die Installation der MSDE von einem Terminal Server und nicht von einem Terminal Client. Stellen Sie sicher, dass die System- und lokale Umgebungsvariable TEMP und die System- und lokale Umgebungsvariable TMP gleich sind.

Die Variablen "TMP" und "TEMP" finden Sie unter: "Start > Einstellungen > Systemsteuerung> System".
Öffnen Sie den Ordner "Erweitert". Öffnen Sie anschließend den Unterordner "Umgebungsvariablen". Es werden Ihnen nun die "Benutzervariablen" sowie die "Systemvariablen" angezeigt.

Links zu weiterführenden Informationen zu diesem Thema (Microsoft Support Seiten):
Englisch: http://support.microsoft.com/kb/830629/en-us
Deutsch: http://support.microsoft.com/kb/830629/de 

Hinweis:
Beachten Sie bitte, dass sich Links von Fremdherstellern ändern können. Gehen Sie in diesem Fall bitte direkt auf die Startseite des Fremdherstellers und suchen von dort das gewünschte Thema.

  1. Folgender Registry-Eintrag fehlt oder es fehlen seine Untereinträge:
    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI.

Abhilfe:
Wenden Sie sich bitte an Ihren Systemadministrator mit den angegebenen Links.

Links zu weiterführenden Informationen zu diesem Thema (Microsoft Support Seiten):
Englisch: http://support.microsoft.com/kb/818954/en-us
Deutsch: http://support.microsoft.com/kb/818954/de

Hinweis:
Beachten Sie bitte, dass sich Links von Fremdherstellern ändern können. Gehen Sie in diesem Fall bitte direkt auf die Startseite des Fremdherstellers und suchen von dort das gewünschte Thema.

4.4

MSDE Installation bleibt mit laufender Sanduhr stehen

Beschreibung:
Die Installationsroutine der MSDE bleibt nach dem Kopieren der Dateien mit laufender Sanduhr stehen.

Ursache:
Dieses Verhalten kann durch einen Ressourcenkonflikt mit Diensten hervorgerufen werden, welche auch die ODBC (Open Database Connectivity) nutzen.

Abhilfe:

  1. Stoppen Sie alle Dienste, die auch ODBC nutzen könnten.
  • Microsoft Internet Information Server (IIS) services
    - Certificate Authority
    - Content Index
    - FTP Publishing Service 
    - Gopher
    - IIS Admin Service
    - World Wide Web (WWW) Publishing
    - Microsoft NNTP Service
    - Microsoft SMTP Service
    - Microsoft Message Queue Service (MMSQ)
    - MSDTC
  • Microsoft Exchange Server 
  • DBWeb
  • ARCserve backup
  • InocuLAN virus protection
  • McAfee antivirus services
  • UniCenter system monitoring
  1. Wenn Sie das Setup nicht abgebrochen haben, sollte es jetzt weiter laufen und die Installation der MSDE erfolgreich durchführen. Falls Sie das Setup abgebrochen haben, starten Sie die Installation von MSDE erneut. 

Links zu weiterführenden Informationen zu diesem Thema (Microsoft Support Seiten):
Englisch: http://support.microsoft.com/kb/183692/en-us
Deutsch: http://support.microsoft.com/kb/183692/de

Hinweis:
Beachten Sie bitte, dass sich Links von Fremdherstellern ändern können. Gehen Sie in diesem Fall bitte direkt auf die Startseite des Fremdherstellers und suchen von dort das gewünschte Thema.

4.5

SQL-Server existiert nicht oder Zugriff verweigert

Beschreibung:
Sie erhalten während der Installationsroutine der MSDE folgende Meldung:
"SQL Server does not exist or access denied".
Nach der Installation können Sie mit der Datenbank arbeiten, erhalten aber Meldungen. 

Ursache:
Die MSDE wurde während der Installation nicht richtig konfiguriert.

Abhilfe:

  • Für WinCC flexible 2007 starten Sie auf der CD1 "MDSE\DISK1\MSDE_WCF_Conf.exe".
  • Für WinCC flexible 2005 mit SP1 - Neukonfiguration nach Reboot
    Für WinCC flexible 2005 SP1 starten Sie auf CD2 "WinCCflexible\Setup\MSDE\DISK1\setup.exe".
  • Für WinCC flexible 2005 SP1 Micro starten Sie auf CD1 "WinCCflexible\Setup\MSDE\DISK1\setup.exe".
4.6 Probleme bei bereits installierten SQL-Server Editionen

Beschreibung:
Wenn eine beliebige Edition von SQL Server 2000 mit Service Pack 1 oder Service Pack 2 bereits installiert ist, schlägt die Installation von SQL Server 2000 Desktop Engine RTM (auch MSDE 2000) auf Systemen fehl.

Ursache:
Auf einem System, auf dem bereits der Service Pack 1 oder Service Pack 2 des SQL-Servers 2000 installiert ist, werden wichtige Dateien nicht in das erforderliche Verzeichnis kopiert.

Abhilfe:
Führen Sie eine Vollinstallation des relevanten SQL Server 2000 Desktop Engine Service Packs durch, um dieses Problem zu beheben. Eine genauere Beschreibung finden Sie unter den folgenden Links:

Links zu weiterführenden Informationen zu diesem Thema (Microsoft Support Seiten):
Englisch: http://support.microsoft.com/kb/299351/en-us
Deutsch: http://support.microsoft.com/kb/299351/de

 Beitrags-ID:24435650   Datum:2008-08-27 
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