afficher la liste des articles
STEP 7 -- Travailler avec des projets -- Création et édition de projets
Comment comparer des blocs dans un multi-projet ?
Quelles sont les conditions requises pour migrer un projet STEP 7 V5.x dans STEP 7 Professional (TIA Portal) ?
Comment s'effectue la liaison dans STEP 7 V5.x entre un bloc programme et une aide en ligne créée par l'utilisateur ?
Comment peut-on afficher, sur un pupitre SIMATIC, le tampon de diagnostic d’une CPU SIMATIC disposant d’un serveur Web intégré?
Comment mettre en œuvre la nouvelle méthode plus performante pour la protection des blocs FB’s et FC’s à partir de STEP 7 V5.5 ?
Pourquoi la fenêtre de dialogue "Rechercher/Remplacer" ne s'affiche-t-elle pas dans l'éditeur "CONT-LOG-LIST" de STEP 7?
Comment intégrer un projet WinCC flexible dans STEP 7 ?
Comment faire pour améliorer les performances dans le SIMATIC Manager et des projets STEP 7 ?
Pourquoi les options ( Afficher, Filtrer, Générer, Effacer ) sous le menu "Outils > Données de référence > " ne peuvent-elles plus être sélectionnées ?
Comment enregistrer un projet STEP 7 protégé en lecture sur la MMC d'une CPU S7-300 ?
Comment activer la protection d'accès pour un projet STEP7 et établir un utilisateur comme éditeur de projet ?
Comment actualiser le catalogue matériel de STEP7 à partir de la version STEP7 V5.2 ?
Comment stocker et récupérer les projets sur une carte mémoire ?
Informations sur le thème "Démarrage et test de Projet "
Comment un projet WinCC existant peut-il être intégré dans un projet STEP 7 ?
Quels sont les avantages de la fonction "multiprojet" pour les grands projets en réseau?
Quelle est la signification des valeurs initiales et des valeurs en cours d'un bloc de données ?
Pourquoi des projets, des blocs ou la configuration matérielle ne peuvent-ils pas être ouverts ou alors avec des messages d'erreurs ou en lecture seule ?
Pourquoi des projets, des blocs ou la configuration matérielle ne peuvent-ils pas être ouverts ou alors avec des messages d'erreurs ou en lecture seule ?
Nº de référence:

Description:
Cet article décrit certaines caractéristiques qu'il faut prendre en compte lors de l'ouverture et de l'enregistrement de projets, de blocs et dans la configuration matérielle de STEP 7. Si vous ne pouvez pas du tout ouvrir qu'avec un message d'erreur ou juste ouvrir en lecture les boîtes de dialogue des blocs et de la configuration matérielle, c'est que probablement les sujets suivants sont la cause de ce comportement.

  1. Modifier un projet STEP 7 d'une version actuelle dans une version antérieure
  2. Mise à jour du catalogue du matériel
  3. Logiciels optionnels absents ou incompatibles
  4. Droits d'utilisateur
  5. Besoin en mémoire
  6. Fichiers défectueux dans le projet STEP 7
  7. Copie du projet STEP 7 dans l'explorateur depuis le répertoire S7Proj
  8. Ouverture d'un bloc dont le projet se trouve sur un serveur
  9. Date système erronée dans Windows
  10. Ouverture d'un projet, créé dans une autre langue du système d'exploitation, qui ne correspond pas à une des langues actuelles de STEP 7 et de Windows
  11. Activation de la protection en écriture
  12. Ouverture ou restauration de projets effacés 

Pour que vous puissiez continuer à travailler avec le projet ou pour que vous puissez effectuer des modifications dans la configuration matérielle ainsi qu'exécuter le menu "enregistrer et compiler", nous vous recommandons les remèdes du tableau suivant :

 
Remarques sur le traitement de projets STEP 7 :
1

Modifier un projet STEP 7 d'une version actuelle dans une version antérieure
La version par exemple V5.3 de STEP 7 est compatible de manière descendante vers la version V5.2 de STEP 7. Les projets qui ont été créés, par exemple avec la version V5.3, peuvent être modifiés avec la version V5.2 à la condition que le projet V5.3 ne contiennent aucun composant ni fonction qui n'étaient pas pris en charge dans les versions précédentes de STEP 7, comme par exemple les nouvelles CPU ou les nouvelles fonctionnalités.

  • Si un projet créé avec STEP 7 V5.3 doit être modifié avec par exemple STEP 7 V5.2, il ne faut pas y utiliser de modules dont la référence n'est pas connue de la version V5.2. Dans certains cas, les nouveaux modules doivent être configurés avec les "anciennes références".
  • A partir de STEP 7 V5.2, de nouveaux modules peuvent être "rajoutés".

Veuillez également consulter les informations du fichier lisez-moi au chapitre 2.6 "Changement de version STEP 7", "Nouveaux modules dans des versions anciennes de STEP 7". Si, avec STEP 7 version V5.2, vous ouvrez ou désarchivez un projet qui a été créé avec la version V5.3 ou V5.4, les messages suivants peuvent apparaître ce qui conduit au fait que la configuration matérielle ne peut être ouverte qu'en lecture.

  • Mise à jour matérielle optionnelle absente
  • Le projet contient des objets du logiciel optionnel "HW-Update" qui ne peuvent pas être modifiés car le logiciel optionnel n'est pas présent ou est installé dans une version ancienne
2

Mise à jour du catalogue du matériel
Nous vous conseillons d'installer les mises à jour manquantes pour le catalogue du matériel. Dans la configuration matérielle, exécutez la fonction "Outils > Installer des mises à jour matérielles...". Vous trouverez d'autres informations à ce sujet sur Internet aux articles :

  • "Comment mettre à jour le catalogue du matériel dans STEP 7 V5.2 ou V5.3 ?", article ID : 17581199
  • "Comment mettre à jour le catalogue du matériel de STEP 7 sur un ordinateur sans connexion Internet ?", article ID : 22374877

Note :
Dans la boîte de dialogue "installer des mises à jour matérielles" qui s'ouvre depuis la configuration matérielle avec le menu "Outils > Installer des mises à jour matérielles..." vous pouvez déterminer à partir de quelle version de STEP 7 la mise à jour peut être installée.


Figure 01

3

Logiciels optionnels absents ou incompatibles
Vérifiez avec quels logiciels optionnels le projet STEP 7 a été créé. Sélectionnez le nom du projet avec le curseur et cliquez sur le bouton droit de la souris. Dans le menu contextuel, choisissez "propriétés de l'objet". Choisissez alors l'onglet "logiciels optionnels requis" dans la fenêtre "propriétés - projet". Vous y trouverez un liste des logiciels requis pour la modification du projet ainsi que l'information s'ils sont installés sur le PC ou non.


Figure 02

Installez les logiciels optionnels correspondants comme, dans l'exemple (figure 02) S7-HiGraph.

Les logiciels requis doivent être compatibles avec la version de STEP 7 installée et avec le système d'exploitation. Comparez avec le tableau de compatibilité qui vous indiquera si les logiciels optionnels installés sont compatibles ou si vous devez installer une mise à jour. Le tableau de compatibilité se trouve sous Windows :

  • "Démarrer > SIMATIC > Information > français > Tableau de compatibilité"

Dans le tableau de compatibilité, vous trouverez la version nécessaire pour le logiciel optionnel, par exemple S7-GRAPH (figure 03) pour votre STEP 7 installé et pour le système d'exploitation. Si le logiciel correspondant devait ne pas être compatible avec votre version de STEP 7, vous devez le mettre à jour.


Figure 03

Vous trouverez dans l'article -ID: 18734363 une vue d'ensemble complète de la compatibilité des produits logiciels SIMATIC avec les systèmes d'exploitation Microsoft Windows et avec STEP7 V5.3 et V5.4.

4 Droits d'utilisateur
Consultez les informations du fichier lisez-moi au chapitre 3.1 "Environnement", "droits d'utilisateur". A partir de STEP 7 V5.3 SP2, vous devez être enregistré sous Windows 2000/2003/XP au moins en tant qu'utilisateur (pas d'accès invité). Pour toutes les autres versions antérieures de STEP 7, vous devez au moins être enregistré en tant qu'utilisateur avec pouvoir. Vous avez besoin des droits d'administrateur pour l'installation de STEP 7 et des logiciels optionnels ainsi que pour les réglages de l'interface PG/PC.
5 Besoin en mémoire
STEP 7 V5.4 a besoin d'entre 650 et 900 Mo de place mémoire libre sur votre disque dur.

Les systèmes d’exploitation Windows pris en charge ont besoin, selon l'étendue de mémoire, d'espace libre supplémentaire sur le disque dur (généralement le disque C:) pour leur fichier d'échange (fichier Swap). Vous devez disposer au moins du double de la taille de la mémoire principale. (Exemple : pour une mémoire principale de 512 Mo, il faut 1024 Mo d'espace disque libre pour le fichier d'échange après l'installation de STEP 7). Selon la taille du projet, un fichier d'échange plus important peut être nécessaire, par exemple pour copier le projet entier (prévoir un espace disque supplémentaire équivalent au double de la taille du projet). Des erreurs (p. ex. des abandons du programme) peuvent se produire si vous n'avez pas prévu un fichier d'échange assez grand. Les autres applications Windows s'exécutant simultanément à STEP 7 (p. ex. MS Word) nécessitent de l'espace disque supplémentaire pour leur fichier d'échange.

Vous trouverez d'autres informations sur le sujet "réglage de la mémoire virtuelle sous Windows" dans notre article 

  • "Comment peut-on régler la mémoire virtuelle dans MS Windows XP/2000/ME/NT/9x ?",
    à l'article ID : 20440472.
6 Fichiers défectueux dans le projet STEP 7
Faites une copie de votre projet avec la command "fichier > enregistrer sous..." avec l'option "avec réorganisation (lente)". Cela permettra de supprimer les trous laissés par les programmes et comprimera le projet. Le stockage des données sera optimisé et la place mémoire occupée par le projet sera réduite.


Figure 04

7 Copie du projet STEP 7 dans l'explorateur depuis le répertoire S7Proj
Pour chaque projet STEP 7, un répertoire pour les données de projet est créé par le SIMATIC Manager sur le disque dur sous "<NomDuLecteur C ou D, ...>:\Program Files\Siemens\Step7\S7Proj". Il faut éviter dans tous les cas de copier le projet STEP 7 via l'Explorateur depuis ce répertoire vers un autre ou vers un serveur.

Lors de la copie du répertoire de projet depuis "S7Proj", toutes les parties du projet ainsi que toutes les parties de la base de données ne sont pas copiées. Cela peut donc endommager le projet. Les projets STEP 7 doivent toujours être

  • copiés via "Fichier > Enregistrer sous ...", pour les stocker sur un autre disque ou répertoire
  • archivés via "Fichier > Archiver ...". Le fichier zip ainsi créé peut ensuite être transféré sur un autre PC pour y être désarchivé par le STEP 7.
8 Ouverture d'un bloc dont le projet se trouve sur un serveur
Si vous travaillez avec une ancienne version de STEP 7 (V4.x, V5.0 ou V5.1), vous devez associer une lettre de lecteur pour la liaison vers un autre ordinateur. Pour créer une liaison avec le serveur, veuillez tout d'abord fermer toutes les applications STEP 7, créez un raccourci vers le serveur depuis l'Explorateur via la fonction "Outils > Connecter un lecteur réseau" en attribuant une lettre au lecteur. Une fois que vous avez créé cette liaison, l'accès complet au projet est possible (lecture et écriture).

Note :
A partir de STEP 7 V5.2, il est possible d'utiliser des noms UNC.

9 Date système erronée dans Windows
Vérifiez le réglage de l'heure de votre PC. Dans certains cas, si la date système n'est pas correcte, il peut arriver que des messages d'erreurs apparaissent à l'ouverture d'un bloc après avoir désarchivé un projet STEP 7. Dans ce cas, nous vous conseillons de fermer toutes les applications STEP 7 puis de corriger l'heure dans le panneau de configuration Après avoir redémarrer le PC, le problème devrait avoir disparu.
10 Ouverture d'un projet, créé dans une autre langue du système d'exploitation, qui ne correspond pas à une des langues actuelles de STEP 7 et de Windows
A partir de la version V5.3 SP2 de STEP 7, il apparaît le message système que le projet ne peut être ouvert que sous la langue système de Windows indiquée,
  • avec des projets, qui ont été créés à partir de STEP 7 V5.3 SP2 et
  • qui ont été créés sous une langue du système d'exploitation qui n'est pas une des 5 langues de STEP 7 et
  • qui ne correspond pas à la langue actuelle de Windows et 
  • si le projet n'a pas été paramétré en indépendant de la langue.

Si vous ouvrez un projet STEP 7 qui a été précédemment créé sous un système d'exploitation avec un réglage de langue différent par exemple le russe, vous devez avant l'ouverture régler aussi le russe dans le panneau de configuration de votre système d'exploitation. Dans le cas ou vous voudriez ouvrir votre projet STEP 7 ou votre bibliothèque sous n'importe réglage au point de vue linguistique, vous devez caractériser votre projet comme "indépendant de la langue".

Vous trouverez une notice et des informations supplémentaires dans notre contribution :

  • "Pourquoi est ce qu'un message apparaît indiquant qu'une langue étrangère doit être installée, lorsque j'ouvre un projet STEP 7 avec STEP 7 V5.3 SP2 ?"
    (sous la contribution ID  : 22635865).

Vous trouverez aussi des informations complémentaires dans l'aide en ligne de  STEP 7, sous "Utilisation de jeux de caractères de langues étrangères".

11 Activation de la protection en écriture
Si dans la version V5.4 de STEP 7, vous activez la protection d'accès  pour un projet ("Outils > Protection d'accès > Activer"), vous ne pourrez plus ouvrir ce projet avec une version de STEP 7 précédente. Dans ce cas, vous devez avant, désactiver la protection d'accès dans SIMATIC Manager de STEP 7 V5.4 ("Outils > Protection d'accès > Désactiver"). Pour ouvrir un projet avec la protection d'accès dans STEP 7 V5.4, vous devez entrer dans le dialogue "SIMATIC Logon Service" votre nom d'utilisateur, votre mot de passe et le domaine.

Vous trouverez des informations complémentaires dans notre contribution :

  • "Comment activer la protection d'accès pour un projet STEP7 et établir un utilisateur comme éditeur de projet ?"
    (sous la contribution ID : 25470496).
12 Ouverture ou restauration de projets effacés 
Des projets STEP 7 effacés ne peuvent pas être restaurés.

Mots-clefs :
Programme d'archivage, interruption de programme, système multipostes, fonctionnement multi-utilisateurs, multi-projets, conflits de version

 ID contribution:22809379   Date:2009-07-27 
Cette contribution...m´a aidéne m´a pas aidé                                 
mySupport
My Documentation Manager 
Lettre d'information 
CAx-Download-Manager 
Demande d'assistance technique
A propos de cet article
Imprimer
Créer PDF 
Envoyer l'article
QuickLinks
Outil de compatibilité 
Thèmes
Aide
Aide en ligne
Guided Tour