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WinCC Web Navigator -- Operation and maintenance -- Diagnosing errors 
How can you disable the Protected Mode of the Internet Explorer when using the WinCC WebNavigator? 
With WinCC Web Navigator, how can you have a display of which users are currently accessing the web project? 
What is the meaning of the message "You must enable ActiveX Controls on your browser before you are able to install the WinCC Web Navigator Client software" and what can you do about it? 
What causes the error message "Network request not supported" when starting the client Web Navigator site from the IIS? 
Why do you get the error message "The maximum count of allowed users is connected to the WinCC server"? 
Why aren't any tags updated on the WinCC web client? 
How can you avoid the "DEMO mode" of the WinCC Web Navigator client? 
Why, after migration of a WinCC project from WinCC V5.1 to WinCC V6.0 SP1, is the text originally configured no longer displayed on the Web Navigator client, but only "TEXT" in buttons and in static texts? 
How can you prevent an empty page being displayed when you call the diagnostics information saved by the WinCC Web Navigator from the STATUS.HTML page? 
Why, after a Microsoft update, can you no longer connect the Web Navigator clients to the Web Navigator server? 
Why is there no automatic reconnect between a Web Navigator client and the Web Navigator server via a firewall or a proxy server? 
Why can WinCC/Web Navigator or WinCC/Dat@Monitor clients no longer connect to the WinCC/Web Navigator or WinCC/Dat@Monitor server? 

How can you disable the Protected Mode of the Internet Explorer when using the WinCC WebNavigator?Go to beginning
Part number:

Description
The "Protected Mode" of the Internet Explorer (V7.8) is a feature that reduces the ability of malicious software being installed on your computer. The "Protected Mode" also affects the execution and display of ActiveX control elements used by the WinCC WebNavigator. The "Protected Mode" must therefore be disabled for the trusted sites, otherwise you get this error message displayed: "Low integrity level not supported - please disable Protected Mode".

Instructions
Below is the procedure for disabling the "Protected Mode" of the Internet Explorer for trusted sites.
 
No. Procedure
1 Start the Internet Explorer and open the settings of the Microsoft Internet Explorers by way of "Tools > Internet options".
2 Switch to the "Security" tab.
3 Mark the "Trusted sites" zone and disable the option "Enable Protected Mode (requires restarting the Internet Explorer)".


Fig. 01: Security settings of the Internet Explorer

4 Apply the settings and restart the Internet Explorer.
Table 01

Creation environment
The screens in this FAQ response were created with Windows 7 Ultimate.

Note on security
Caution
The functions and solutions described in this article confine themselves predominantly to the realization of the automation task. Furthermore, please take into account that corresponding protective measures have to be taken in the context of Industrial Security when connecting your equipment to other parts of the plant, the enterprise network or the internet. More information can be found in Entry ID: 50203404.

Additional Keywords
Protected Mode

With WinCC Web Navigator, how can you have a display of which users are currently accessing the web project?Go to beginning
Part number:

Description:
The "Status.html" page is for diagnosing the WinCC Web Navigator server and its active connected clients.

The status information is displayed in blocks.

  • One information block for the server
  • One information block for each client or diagnostics client connected.

You call the page in the Internet Explorer with the following address: "http://server_name/status.html". The display is in English only.
Access to this page is protected and is restricted to only those users who have access rights to the pages of the Web Navigator server.

More information is also available in the "WinCC Web Navigator - Documentation", in the chapter entitled "Diagnosis of connections with "Status.html"".

Keywords:
Monitoring, Test functions

What is the meaning of the message "You must enable ActiveX Controls on your browser before you are able to install the WinCC Web Navigator Client software" and what can you do about it?Go to beginning
Part number:

Description:
Although you can load ActiveX Controls from other applications, you still get the message from the WinCC Web Navigator: "You must enable ActiveX Controls on your browser before you are able to install the WinCC Web Navigator Client software".

Check the following points:
In Internet Explorer, go to "Tools > Internet Options... > [Temporary Internet Files] > Settings... > View Objects".
If the "Check Installation Class" file is not there, you must change the security settings of your Internet Explorer in " Tools > Internet Options... > Tab: Security > [Internet/Intranet] > Custom Level..." to allow loading.

For information on the kind of security level you must set, please refer to the "WinCC Web Navigator" documentation, in the chapter entitled "Installing the WinCC Web Navigator Client > Settings in the Internet Explorer". As from WinCC V7.0, the security level settings are in the section entitled "WinCC/Web Navigator Installation Notes > Installing the WinCC Web Navigator Client > Settings in Internet Explorer".

What causes the error message "Network request not supported" when starting the client Web Navigator site from the IIS?Go to beginning
Part number:

Description
In the Internet Service Manager (for Windows NT Workstation) or Internet Information Service (for Windows NT Server) on the WinCC server you want to start the website for the Web Navigator client  and you get the error message: "Network request not supported".


Fig. 01

Cause
Another website with the same port number as the Web Navigator website has already been started in the Internet Service Manager or Internet Information Service.


Fig. 02

Remedy
Close the website with the same port number as the website of the Web Navigator. The port number for the Web Navigator is usually 80, which corresponds to the port number of the standard website.

Keywords
WebNavigator server, WebNavigator client, SIMATIC WinCC

Why do you get the error message "The maximum count of allowed users is connected to the WinCC server"?Go to beginning
Part number:

Description
You are using WinCC V5/SP1 and Web Navigator V1.0 and you get the error message "The maximum count of allowed users is connected to the WinCC server".

Cause:

  • There is a larger number of clients connected to the WinCC server than the license permits.
    Remedy
    Upgrade the license for the Web Navigator with a power pack.
  • A license is missing: In WinCC, you are presented with a message box saying that a license is missing (all licenses are checked, not only the licenses for the Web Navigator).
    Remedy
    Procure the remaining licenses.
  • The "WebNavigatorRT.exe" file is missing in the startup list.
    Remedy
    Enter the file into the startup list of WinCC. Here, you must make sure that you specify the complete path when you enter the "WebNavigatorRT.exe"!

Why aren't any tags updated on the WinCC web client?Go to beginning
Part number:

Description:
SIMATIC NET 2006 has been installed on the Web Navigator server version V6.1 SP1. These software versions are not compatible with each other.
To clear the behavior you must uninstall Web Navigator V6.1 SP1, WinCC V6.0 SP4 and SIMATIC NET 2006. Then you can install SIMATIC NET 2005 HF1, WinCC V6.0 SP4 and WinCC Web Navigator V6.1 SP1 again.

Notes:

  • Please also refer to the WinCC compatibility matrix in Entry ID: 21927773.
  • The SIMATIC NET 2006 licenses cannot be used for SIMATIC NET version 2005 HF1. More information on this is available in Entry ID: 24640176.

How can you avoid the "DEMO mode" of the WinCC Web Navigator client?Go to beginning
Part number:

Description
The mouse pointer on the Web Navigator client changes to a triangle with "NO INPUT" written in it although the Web Navigator client authorization is installed and the quantity framework has been kept to.

Procedure

Procedure as from WinCC Web Navigator V7.0
You have set the authorization "1002 Web Access - monitoring only" for your user. This authorization permits the user to monitor, but not to operate.


Fig. 01

Proceed as follows to assign the "Operate" authorization to this user. Open the WinCC User Administrator and remove the check mark for the authorization "1002 Web Access - monitoring only" of the user concerned. Now assign the required authorizations to this user.
Restart the WinCC Web Navigator client.

Procedure up to WinCC Web Navigator V6.2
You have set the authorization "1002 DataMonitor - Just monitor!" for your user. This authorization is reserved for the "SIMATIC WinCC/DataMonitor" option and requires a separate authorization.


Fig. 02

Proceed as follows to assign the "Operate" authorization to this user. Open the WinCC User Administrator and remove the check mark for the authorization "1002 DataMonitor - Just monitor!" of the user concerned. Now assign the required authorizations to this user.
Restart the WinCC Web Navigator client.

Why, after migration of a WinCC project from WinCC V5.1 to WinCC V6.0 SP1, is the text originally configured no longer displayed on the Web Navigator client, but only "TEXT" in buttons and in static texts?Go to beginning
Part number:

Description
Contrary to version V5.x, the Web Navigator users of WinCC V6.x are no longer managed in the Web Administrator, but along with other configurable WinCC users in the WinCC User Administrator. Regarding users already created in WinCC V5.1, the migration to V6.0 SP1 causes a loss of allocations between user and configured language, thus resulting in displaying the text as "TEXT". 

Remedy:
Delete the old users and recreate them with their corresponding language.
The Web Navigator CD provides the migration tool "WebNavV6Migration" to make use of the web users from Web Navigator V1.x in a WinCC V6.x Project. A description of the migration is available in the Web Navigator Help in the path "Configuration of the user administration > Migration of user data from old projects".

Note:
More information on WinCC and WinCC/Web Navigator compatibility is available in Entry ID: 17204272.

Keywords:
Language change, Login, User administration, Login window, Internet Explorer

How can you prevent an empty page being displayed when you call the diagnostics information saved by the WinCC Web Navigator from the STATUS.HTML page?Go to beginning
Part number:

Description
If you have saved the STATUS.HTML page from the Internet Explorer using "File > Save as > Web page, complete (*.htm,*.html)" and you then open this, the display is empty.

Remedy
You must save the STATUS.HTML page using "File > Save as > Text file (*.txt)". This page provides you with the relevant status data that is also displayed in the STATUS.HTML.


Fig. 01

Keywords
Log file, Server data, Web server

Why, after a Microsoft update, can you no longer connect the Web Navigator clients to the Web Navigator server?Go to beginning
Part number:

Description 
If you have upgraded WinCC V6.0 SP1 and WinCC Web Navigator V6.0 to WinCC V6.0 SP2 and WinCC Web Navigator V6.0 SP1 respectively and have made a Microsoft update, the Web Navigator clients can no longer connect to the Web Navigator server.
The following error message is displayed:
"Microsoft VBScript runtime error '800a01b6' 
Object does not support this property or method: 'rx.Multiline' 
/Language.asp, line 218"

Sometimes in an Microsoft update routine not all the Dynamic Link Libraries (DLL) can be updated to the latest version. In this case, an older version of vbscript.dll is on the system, but the latest version is required. 

Remedy
Reinstall the Microsoft Internet Explorer to clear the error message. Then the Web Navigator client can once again connect to the Web Navigator server without any problems.

Why is there no automatic reconnect between a Web Navigator client and the Web Navigator server via a firewall or a proxy server?Go to beginning
Part number:

Description
For a reconnect the Web Navigator client uses the ICMP ping, which can be blocked by the firewall or the proxy server.

Remedy 
Disable use of the ICMP ping via a Registry Key on the Web Navigator client. Install the attached Registry Key for this. 

Note
Set "ICMP_Ping" to "no" in the directory "HKEY_LOCAL_MACHINE\SOFTWARE\Siemens\WinCCWebNavigator".

 DeactivatePing.zip ( 287 bytes )

Important
In general, no warranty can be given for direct changes in the Registry, because this is entirely the responsibility of the user. In any event, you are advised to make a backup of the Registry before undertaking the actions described here. Furthermore, these settings are computer-specific.  This means that when you copy the project to another computer, you must make the settings again.

Keywords
Connect, Connection

 

Why can WinCC/Web Navigator or WinCC/Dat@Monitor clients no longer connect to the WinCC/Web Navigator or WinCC/Dat@Monitor server?Go to beginning
Part number:

Description
After initial installation of the WinCC/Web Navigator V6.0 SP1 or WinCC/Dat@Monitor V6.0 SP1 (less than HF4) server, the WinCC/Web Navigator or WinCC/Dat@Monitor client can no longer connect to the server after an arbitrary time (depending on the policy settings). This behavior depends on the user settings in the Windows User Administration.

Remedy
To make the WinCC Web Navigator environment run again you must run the attached program on the WinCC/Web Navigator or WinCC/Dat@Monitor server:

 AdjustingUserSetting.zip ( 12 KB )

Keywords
WebNavigator, DatMonitor, DataMonitor 

 Entry ID:22679730   Date:2012-04-16 
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