visualizza l'elenco degli articoli

STEP 7 -- Creazione programma S7 -- Caricamento e test del programma S7  
Come è possibile stabilire due connessioni online in parallelo tra STEP 7 V5.5 e un S7-300 e tra STEP 7 V11 e un S7-1200? 
Come è possibile commutare tra una CPU-S7 e S7-PLCSIM ? 
Come si possono visualizzare le segnalazioni in STEP 7 tramite la funzione "CPU messages..."? 
Perché dopo la messa in servizio del programma STEP7 il tipo di funzionamento della CPU deve essere commutato da funzionamento di test a funzionamento di processo? 
Tips & Tricks per il caricamento ed il test di programmi S7 
Come si può effettuare il test di un programma STEP 7 con punti di alt? 
Come si può ristabilire la connessione online tra il PG e la CPU? 
Come è possibile modificare i dati di avviamento o quelli attuali in modo sicuro da caduta rete opp. cancellazione totale solo tramite operazioni su un OP? 
Come si può effettuare il forzamento di variabili a partire da STEP 7 Versione V5.2? 
Come si può sorvegliare un blocco con l'ambiente di richiamo desiderato con STEP 7 V5.3? 
Informazioni sull'argomento "Caricamento e test del programma S7" 
Perché negli editor KOP e FUP, nella Sorveglianza lo stato del segmento viene visualizzato solo in parte? 
Qual è la differenza tra la modifica offline e quella online nell'editor KOP/AWL/FUP? 

Come è possibile stabilire due connessioni online in parallelo tra STEP 7 V5.5 e un S7-300 e tra STEP 7 V11 e un S7-1200?Vai all'inizio
Numero di ordinazione:

Descrizione
In STEP 7 V5.5 è possibile stabilire una connessione online a S7-300 o a S7-400 e contemporaneamente un'altra connessione online tra STEP 7 V11 e un S7-1200. Per realizzare la connessione online al sistema di destinazione, è necessario assegnare all'interfaccia PG/PC un accesso di rete appropriato. Le interfacce riportate di seguito sono supportate automaticamente:

  • MPI;
  • PROFIBUS;
  • Industrial Ethernet (ISO e TCP/IP).

Aprire l'interfaccia PG/PC in SIMATIC Manager di STEP 7 V5.5 utilizzando il comando menu "Options > Set PG/PC interface...", quindi nella finestra "Interface Parameter Assignment Used:", selezionare il punto di accesso per la connessione online, come mostrato nella figura 01.


Figura 01

In STEP 7 V11, tutti gli accessi di rete attivi dell'interfaccia PG/PC si trovano nella finestra di navigazione del progetto, nell'area accessi "Online". Con il comando menu "Go online", è possibile visualizzare tutte le interfacce disponibili in un elenco riepilogativo. Nella finestra di dialogo "Go online", selezionare il tipo di interfaccia PG/PC con cui stabilire la connessione online, come mostrato nella figura 02.


Figura 02

Per ulteriori informazioni, consultare la Guida in linea di STEP 7 V11, alle seguenti voci:

  • Connect PG/PC interface with a subnet;
  • Assign an IP address to a PROFINET IO device;
  • Go online with multiple devices;
  • Define PG/PC interface, go online;
  • Displaying accessible nodes.

Come è possibile commutare tra una CPU-S7 e S7-PLCSIM ?Vai all'inizio
Numero di ordinazione:

Istruzioni
Dalla versione V5.1 SP6 dello STEP 7 è possibile attivare e disattivare la simulazione nel SIMATIC Manager o nello STEP 7 Lite, senza dover precedentemente chiudere il progetto S7.

Affinché non sussista qualsiasi possibile confusione tra la CPU simulata e quella reale, quando si impiegano i tool STEP 7, è sempre possibile solo uno stato Online. È anche possibile operare o nel mondo "reale" o in quello "simulato". La commutazione tra questi due mondi avviene a livello della comunicazione di rete MPI.

La rete MPI reale viene in questo modo sostituita da una rete virtuale, in cui è rappresentata solo una CPU simulata (p.es. nella finestra "Nodi raggiungibili"). Altrettanto non viene visualizzata nessuna CPU simulata, se sono visibili CPU reali. Prima di poter commutare lo stato Online, lo STEP 7 o lo STEP 7 Lite visualizzano una segnalazione in cui si richiede di chiudere tutti i collegamenti verso questo tipo di CPU.

Informazioni dettagliate riguardanti questi argomenti si trovano nell’Help Online dell’S7-PLCSIM o nel manuale elettronico.

Per l’attivazione / disattivazione della simulazione nel SIMATIC Manager, procedere secondo i modi seguenti.

Attivazione

  • Chiudere tutti i collegamenti Online esistenti verso le CPU "reali"
  • Selezionare il comando di menù Strumenti > Simula unità oppure cliccare sul bottone "Simulazione on/off", nella barra delle funzioni, per avviare la simulazione.
  • Trasferire la Config.HW e i blocchi di programma su S7-PLCSIM.

Disattivazione

  • Chiudere l’S7-PLCSIM concludendo il programma software, selezionando il comando di menù Strumenti > Simula unità oppure cliccando sul pulsante "Simulazione on/off" nella barra delle funzioni dello STEP 7.
  • Lo STEP 7 si collega ora nuovamente con la CPU "reale".

Avvertenza
Non viene supportata la simulazione di due o più unità CPU contemporaneamente su un PC, così come la comunicazione tra due unità CPU.È possibile simulare solo una CPU.

Ricerca
PLCSIM, Simulazione


Come si possono visualizzare le segnalazioni in STEP 7 tramite la funzione "CPU messages..."?Vai all'inizio
Numero di ordinazione:

Istruzioni
La tabella seguente descrive la procedura da seguire per consentire la visualizzazione delle segnalazioni in STEP 7 con la funzione "CPU messages...":
 
N. Procedura
1 Per poter utilizzare la funzione "CPU messages", occorre innanzitutto configurare la segnalazione degli errori di sistema. Terminata la configurazione hardware, selezionare nella configurazione stessa la CPU, quindi aprire la finestra di dialogo "Tools > Report system error...".
2 Nella scheda "General", inserire le cifre per i blocchi di diagnostica da generare. Per default viene generato il blocco FB49 con il relativo DB49 di istanza, il blocco FC49 e il blocco globale DB50.


Figura 01

3 Nella scheda "OB Configuration" vengono visualizzati gli OB di errore già disponibili e supportati dall'unità configurata. È possibile determinare quali OB devono essere richiamati in caso di errore.
4 Nella scheda "Messages", definire la struttura delle segnalazioni. In "Available Message Information", selezionare le registrazioni che si desidera utilizzare e fare clic sul tasto freccia. Le informazioni sulle segnalazioni vengono visualizzate nella finestra "Message text". Qui è possibile posizionare il cursore nel punto desiderato e modificare il testo della segnalazione.


Figura 02

5 Passare alla scheda "User block", quindi determinare se dal blocco di diagnostica deve essere richiamato un proprio blocco utente.


Figura 03

6 Fare clic sul pulsante "Generate" e confermare i relativi avvertimenti e avvertenze con OK. I blocchi generati vengono ora visualizzati nella cartella dei blocchi del programma STEP 7.


Figura 04

7 Aprire OB1 e verificare se il blocco di diagnostica per la segnalazione degli errori è stato richiamato automaticamente, come mostrato nella figura 05. In caso contrario, è necessario inserire in OB1 l'istruzione di richiamo per il blocco funzionale con il suo blocco dati di istanza (ad esempio FB49 e DB49).


Figura 05

8 La configurazione delle segnalazioni di sistema è ora conclusa. Dopo aver caricato i blocchi nella CPU, è possibile consentire la visualizzazione delle segnalazioni di errore nella finestra "CPU messages". Evidenziare la CPU nel progetto ed eseguire il comando di menu "Target System > CPU Messages...".
9 Nell'elenco unità della finestra di dialogo "CPU Messages" è possibile inserire le CPU per le quali in SIMATIC Manager è stato eseguito il comando di menu "Target system > CPU messages...". Nell'esempio mostrato nella figura 06, è presente solo l'unità CPU 315-2PN/DP.

Selezionare le caselle "W" e "A":

  • "W" si riferisce agli eventi di diagnostica e consente l'attivazione delle segnalazioni di diagnostica del sistema e dell'utente.
  • "A" si riferisce alle segnalazioni con o senza obbligo di conferma (ALARM_S/SQ).

Se la CPU si trova allo stato RUN, nella finestra delle segnalazioni compaiono le seguenti segnalazioni:


Figura 06

Avvertenza
L'articolo con ID 24037531 fornisce informazioni sui passaggi di configurazione necessari per la visualizzazione delle segnalazioni Alarm_S con WinCC flexible Runtime.

Ulteriori informazioni sono disponibili nella Guida in linea di STEP 7 alle seguenti voci:

  • Configurazione di messaggi CPU
  • Visualizzazione di messaggi CPU e di messaggi di diagnostica personalizzati.

 

Perché dopo la messa in servizio del programma STEP7 il tipo di funzionamento della CPU deve essere commutato da funzionamento di test a funzionamento di processo?Vai all'inizio
Numero di ordinazione:

Descrizione
Differenze tra funzionamento di test e funzionamento di processo (estratto dalla Guida in linea dello STEP 7).

  • nel funzionamento di processo le funzioni di test come Stato programma o Comando/sorveglianza variabili è limitato così che l'aumento del tempo di ciclo ammesso impostato non viene superato. Il test con punti di alt e l'esecuzione del programma a passi non possono essere eseguiti.
  • Nel funzionamento di test tutte le funzioni di test sono utilizzabili senza limitazioni tramite il PG/PC, anche quelle che possono causare grossi aumenti del tempo di ciclo. Se la CPU si trova nel funzionamento di test, occorre fare attenzione che la CPU opp. il processo possano " tollerare" aumenti del tempo di ciclo. In questa modalità possono comparire aumenti dei tempi di ciclo della CPU, poiché p. es. lo stato di istruzioni in loop programmati viene rilevato ad ogni giro.

Con le CPU SIMATIC S7-300 è impostato come standard il funzionamento di test (Stato dopo l'innesto della CPU).

Commutazione da funzionamento di test a funzionamento di processo:
Il tipo di funzionamento viene impostato nella HW Config, nelle Proprietà della CPU, nella cartella Protezione. La Configurazione hardware deve poi essere nuovamente compilata ed i blocchi dati di sistema (HW Config) devono essere caricati nella CPU.

Avvertenza
Assicurarsi che dopo il test i punti di alt vengano nuovamente cancellati, se non è possibile il caricamento dei relativi blocchi nel sistema di automazione.

Tips & Tricks per il caricamento ed il test di programmi S7Vai all'inizio
Numero di ordinazione:

Istruzioni
Questo articolo contiene alcuni suggerimenti e trucchi per il caricamento ed il test di programmi S7.

  1. Perché gli eventi del buffer di diagnostica sotto Windows 2000 vengono visualizzati solo in formato esadecimale?
  2. Perché con una cartella dei blocchi selezionata il pulsante di download è grigio?
  3. Come avviene la sorveglianza dei valori attuali delle variabili OUT, che sono parametrizzati in una PAW (parola di periferia di uscita)?
  4. Come si può ripristinare la colonna "Valore attuale" nella vista dati del blocco dati?
  5. A cosa occorre fare attenzione con "Carica stazione in PG" in relazione a multiistanze da STEP7 V5.2?
  6. Quale significato ha la funzione "Node flashing test" nel SIMATIC Manager da STEP 7 V5.3?
  7. Come si può riattivare la richiesta di sistema, p. es. se un blocco esistente durante il caricamento deve essere sovrascritto?
  8. Perché con STEP7 non è possibile stabilire alcuna connessione online, se deve essere impostata una parametrizzazione automatica dell’interfaccia DP?

La tabella seguente contiene informazioni e rimedi sull'argomento.

N.

Tips & Tricks per il caricamento e il test dei programmi S7

1

Perché gli eventi del buffer di diagnostica sotto Windows 2000 vengono visualizzati solo in formato esadecimale?
Probabilmente la configurazione DCOM è stata modificata sotto Windows 2000. Questa variazione può essere stata eseguita automaticamente da un software di terzi.

Rimedio
Sotto Windows 2000 aprire le "Proprietà della configurazione DCOM" tramite "Start > Esegui> dcomcnfg" e nel registro "Proprietà standard" modificare la voce "Livello di scambio di identità standard" da "Anonimo" a "Identificazione". Poi è necessario un riavviamento del computer.


Figura 01

Avvertenza
Sotto Windows XP si può arrivare alla segnalazione di errore "Errore OLE interno (256:26)". Informazioni sugli errori OLE interni si trovano nell’articolo con ID: 10208766.

2

Perché nella cartella di blocchi selezionata il pulsante di download è grigio?
La causa è qui probabilmente l'impostazione del progetto come progetto PCS 7. Dopo che un progetto è stato utilizzato per STEP7 opp. per PCS 7, il SIMATIC Manager adatta funzioni e comandi di menù rilevanti per PCS 7. Nell'impostazione come progetto PCS 7 si può scaricare in STEP 7 solo l'intera stazione S7. Il caricamento dei singoli blocchi senza che la CPU vada nello stato di STOP non è possibile in questa impostazione. Con cartella di blocchi selezionata il pulsante di download opp. la funzione "PLC > Carica" non è attivabile (è grigia).

Rimedio
Fare clic con il tasto destro del mouse sul progetto opp. sul nome del progetto e nel menù contestuale che si apre aprire le proprietà oggetto. Nel dialogo successivo "Proprietà progetto" nel registro "Generale" si può impostare l'utilizzo. Passare qui dall'impiego di PCS 7 a STEP 7.


Figura 02

Dopo la memorizzazione con OK il pulsante di download opp. la funzione "PLC > Carica" sono attivabili e si possono caricare singoli blocchi nella CPU.

3

Come avviene la sorveglianza dei valori attuali delle variabili OUT, che sono parametrizzati in una PAW (parola di periferia di uscita)?
Se i valori attuali delle variabili OUT di FB e FC sono parametrizzati con una PAW (parola di uscita di periferia), essi non possono essere sorvegliati direttamente. Questi valori devono essere precedentemente memorizzati in merker, parole di merker o doppie parole di merker. La Figura 03 mostra un esempio di come si possono copiare, con istruzioni di caricamento e trasferimento, i valori dalle parole di merker nelle parole di uscita di periferia. I parametri di OUT della funzione non vengono parametrizzati direttamente con PAW0 e PAW2, ma bensì precedentemente sottoposti a memorizzazione intermedia in MW10 e MW12. In questo modo è possibile nell'editor KOP/FUP/AWL, tramite "Test > Sorveglianza" opp. anche tramite "PLC > Sorveglianza/forzamento variabili" effettuare la sorveglianza di variabili.


Figura 03

4

Come si può ripristinare la colonna "Valore attuale" nella vista dati del blocco dati?
Se nella Vista dati del proprio blocco dati non è visibile la colonna "Valore attuale", allora la colonna è semplicemente nascosta. La colonna diventa nuovamente visibile tramite il punto di menù "Vista > Fattore di zoom" si imposta la vista su un altro valore, p. es. sul 200%. Poi la colonna diventa nuovamente visibile e si può impostare la vista nuovamente sul valore originario. Tenere conto anche delle informazioni contenute nell'articolo: 16719968.

5

A cosa occorre fare attenzione con "Carica stazione in PG" in relazione a multiistanze da STEP7 V5.2?
Informazioni di struttura (UDT, istanza, ecc.) non vengono caricate in STEP7 nel sistema di automazione, ma bensì solamente depositate nel progetto offline. Se si carica un programma con multiistanze tramite "Carica stazione in PG" dal sistema di automazione nel PC, le dichiarazioni di multiistanze vengono evidenziate come non consistenti ed i blocchi non possono essere modificati opp. memorizzati.

Esempio
Un blocco funzionale FB2 viene richiamato come multiistanza in un FB1. Se questo programma viene caricato nel PC, allora la riga con FB2 viene evidenziata in rosso. Lo FB1 non può essere modificato opp. memorizzato, poiché la dichiarazione dell'FB2 viene rappresentata come inconsistente.

Rimedio
Affinché la struttura della multiistanza venga rappresentata nella dichiarazione, la multiistanza deve essere nuovamente memorizzata. Per memorizzare tutte le multiistanze nel progetto, si può utilizzare la funzione "Verifica consistenza dei blocchi".

6

Quale significato ha la funzione "Node flashing test" nel SIMATIC Manager da STEP 7 V5.3?
Con la funzione "Node flashing test..." si può definire verso quale delle diverse stazioni S7 che sono collegate al bus sussiste una connessione diretta. Con il comando di menù "PLC > Diagnostica/Impostazione > Node flashing test..." sulla base del LED FORCE che pulsa si identifica il nodo collegato direttamente al PG/PC. Devono essere soddisfatti i seguenti requisiti.

  • Il Flashing test è eseguibile solo se precedentemente è stata attivata nel SIMATIC Manager la funzione "PLC > Visualizza nodi raggiungibili".
  • L'unità attuale che deve essere raggiunta deve supportare la funzione "Node flashing test".
  • Il flashing test non è eseguibile se è attivata la funzione FORCE.


Figura 04

Nel dialogo "Node flashing test" si può impostare una durata della pulsazione da 3 a 60 secondi ed avviare il Flashing test. Il nodo collegato direttamente viene riconosciuto dal LED FORCE che pulsa.

7

Come si può riattivare la richiesta di sistema, p. es. se durante il caricamento un blocco esistente deve essere sovrascritto?
Se si carica nella CPU un blocco che è già presente, prima del caricamento compare la segnalazione:

  • Caricamento (294:103) Il blocco ... esiste già. Sovrascrivere?

Con la casella di controllo della segnalazione è possibile disattivare questa domanda, in modo che questa segnalazione non venga più visualizzata in futuro. Per ripristinare nuovamente questa segnalazione, aprire nel SIMATIC Manager il dialogo "Strumenti > Impostazioni... > Registro: Generale" e in corrispondenza di "Segnalazioni di sistema disattivate" fare clic sul pulsante "Attiva". Le segnalazioni di sistema allora ricompaiono prima del caricamento di blocchi esistenti.

8

Perché con STEP7 non è possibile stabilire alcuna connessione online, se deve essere impostata una parametrizzazione automatica dell’interfaccia DP?
Se compare la segnalazione di errore 33:16931 "Non è stato possibile rilevare automaticamente (online) i parametri di bus", allora la causa di questa segnalazione di errore è legata al fatto che sul PROFIBUS non viene inviato alcun telegramma di parametrizzazione del bus, su cui STEP7 possa effettuare il trigger. I parametri sono necessari per lo STEP7, per poter andare online su PROFIBUS. Questi parametri da un lato possono essere comunicati manualmente allo STEP7 (assegnazione di una parametrizzazione speciale nell'impostazione dell'interfaccia PC/PC, p. es. CP5611 PROFIBUS) opp. essi vengono creati dall'analisi del telegramma dei parametri di bus (nella parametrizzazione automatica).
In generale nella progettazione di una rete PROFIBUS la distribuzione ciclica dei parametri di bus viene attivata automaticamente, non appena un nodo sulla rete supporta questa funzione.
Se, a causa di condizioni particolari (p. es. ottimizzazione dei tempi di ciclo del basso, ecc.), essa è stata disattivata opp. nessun nodo sul bus supporta questa funzione, allora il profilo del bus deve essere impostato manualmente, perché sia possibile andare online.

Come si può effettuare il test di un programma STEP 7 con punti di alt?Vai all'inizio
Numero di ordinazione:

Istruzioni
Il punto di alt è comparabile al break point, che è disponibile nel debug con altri editor. Con SIMATIC STEP 7 c'è nel funzionamento di test la possibilità di impostare un numero limitato di punti di alt. Tramite i punti di alt è possibile fermare l'elaborazione del programma in determinati punti del programma applicativo. Quando la CPU raggiunge il punto di alt nel programma applicativo, essa va nello stato di funzionamento ALT. Nel funzionamento di ALT l'utente può verificare, tramite tabelle delle variabili, se il proprio programma fino al punto di alt ha ottenuto gli effetti desiderati (tabella delle variabili: in determinate circostanze occorre prima eseguire la funzione "Aggiorna valori di stato"). Tramite "Test/Forzamento operando..." l'utente può anche modificare valori di variabili nel programma applicativo per manipolare per scopi di test l'andamento del programma. Dal punto di alt poi l'elaborazione del programma può essere eseguita in passi singoli, dove l'utente può verificare gli effetti del proprio programma dopo ogni istruzione. Nei loop l'utente p. es. può anche seguire l'avanzamento dell'elaborazione del tool ed analizzare con precisione perché ad esempio un loop non viene abbandonato.

Nella tabella seguente viene descritto come in STEP7, nella finestra "KOP/AWL/FUP: programmazione di blocchi" si possono impostare i punti di alt.
 

N.

Modo di procedere

1

Verificare se il blocco da verificare è stato memorizzato e caricato nella CPU.

2

Per prima cosa porre l'interruttore del tipo di funzionamento della CPU su "RUN" o, se disponibile sulla CPU, su "RUN-P".

3

Aprire il blocco da verificare nell'editor dei blocchi e, tramite Apri partner offline/online, metterlo nella Vista online.


Figura 01

Avvertenza

  • Generalmente è possibile impostare ed operare sui punti di alt solo nella Vista online (lettura online dalla CPU) nella rappresentazione AWL opp. in S7-SCL. Se si apre un blocco offline, allora la lista dei punti di alt risulta completamente grigia e non è operabile.
  • Dopo l'esecuzione di modifica nella finestra online, il comando dei punti di alt per la tensione attuale viene disattivato. Le modifiche devono essere memorizzate e caricate nel sistema di automazione. Poi aprire nuovamente il blocco nella Vista online, in modo che sia nuovamente possibile il comando dei punti di alt.

4

CPU SIMATIC S7-400
Utilizzare una CPU SIMATIC S7-400 opp. la CPU 318-2 DP, sotto il punto di menù Test > Funzionamento, impostare il tipo di funzionamento Funzionamento di test.


Figura 02

CPU SIMATIC S7-300
Se si utilizza una CPU SIMATIC S7-300 (non una CPU 318-2 DP), questa impostazione deve essere stata effettuata nella HW Config, nelle Proprietà della CPU.


Figura 03

Avvertenza
L'impostazione standard per le CPU SIMATIC S7-300 è il funzionamento di test. Modifiche di questa impostazione hanno effetto solo dopo una nuova compilazione e caricamento della Configurazione hardware.

5

Nell'editor KOP/AWL/FUP commutare la vista su AWL

Avvertenza
L'impostazione di punti di alt non è possibile se i segmenti vengono si visualizzati in AWL - nel menù però è selezionata la vista KOP opp. FUP e la visualizzazione avviene in AWL solo perché le istruzioni non sono rappresentabili in KOP/FUP. In questo caso commutare, tramite Vista > AWL, la vista nella rappresentazione in AWL.

6

Attivare la lista dei punti di alt sotto Vista > Lista dei punti di alt


Figura 04

7

Porre ora il cursore nella riga di istruzioni dove deve essere posto il punto di alt.

8

Tramite il punto di menù Test > Imposta punto di alt impostare il punto di alt. Questa riga di istruzioni viene poi marcata con un cerchio.


Figura 05

9

Attivare poi il punto di alt tramite il punto di menù Test > Punti di alt attivi.

Quando il programma arriva su questo punto di alt, il sistema di automazione va nello stato di funzionamento ALT.

Avvertenza
Tenere conto tassativamente dei rischi che nascono nell'impianto con la modifica di variabili, in particolare nel comando di uscite!

Ulteriori informazioni si trovano nel manuale "Programmazione con STEP 7 V5.5" nell’articolo con ID 45531107 e nella Guida in linea online dello STEP7 sotto la voce "Passi per il test con punti di alt".

Come si può ristabilire la connessione online tra il PG e la CPU?Vai all'inizio
Numero di ordinazione:

Istruzioni
In alcuni casi può succedere che la connessione online tra il PG e l'unità non possa più essere stabilita, per cui compare una segnalazione di errore. Con l'aiuto delle avvertenze contenute nella Guida online con un clic sul tasto "?" Si possono individuare le maggiori cause di questo. La tabella che segue descrive alcune misure o rimedi, nel caso non sia possibile alcuna comunicazione o connessione online tra il dispositivo di programmazione e la CPU. le cause più frequenti che portano ad una perdita della connessione online sono:

  1. Unità progettata in modo errato nella HW Config
  2. Indirizzo progettato in modo errato
  3. Interfaccia PG/PC impostata in modo errato
  4. Il baudrate non coincide con il baudrate di rete
  5. Troppo poco spazio di memoria sul disco per il file di swap
  6. Interfaccia PROFIBUS DP impostata in modo errato
  7. Interfaccia MPI impostata in modo errato
  8. Differenze nel programma tra online e offline
  9. Aumento del ciclo ammesso impostato troppo basso
  10. Impostazione errata del profilo di bus
  11. Più di una interfaccia Ethernet nella stessa subrete IP

N.

Rimedi per la stesura della connessione online

1

Unità progettata in modo errato nella HW Config
Verificare se per le unità innestata nel rack (CPU, CP) è stata creata la Configurazione hardware corretta. I tipi di CPU e CP devono coincidere con la progettazione. Se è stata progettata una unità errata, l'operazione di caricamento dei blocchi dati di sistema può essere interrotta e si ottiene una segnalazione di errore, p. es.:

  • Caricamento (13:4589)
    I dati di sistema non possono essere caricati sulla unità ... nella stazione.
    "SDB 200 non può essere caricato",
    opp. "(D225) Il blocco dati di sistema DP contiene parametri non validi".

Rimedio
Nella Configurazione hardware progettare le unità con il N. di ordinazione corretto (p. es. 6ES7315-2AF03-0AB0 per una CPU 315-2DP). Memorizzare e compilare la Configurazione hardware e ripetere l'operazione di caricamento.

2

Indirizzo progettato in modo errato
Se nella Configurazione hardware è stato progettato un indirizzo MPI opp. PROFIBUS, che non corrisponde all'indirizzo di partner (CPU), si ottiene la segnalazione di errore:

  • Caricamento (33:16656)
    "Online: Non è stato possibile stabilire una connessione. Il partner di connessione non risponde"

Eseguire la funzione "PLC > Visualizza partner raggiungibili". Nella finestra "Partner raggiungibili" si trovano gli indirizzi per MPI e PROFIBUS, sotto i quali le unità sono raggiungibili. Se p. es. nella finestra c'è l'indirizzo MPI=2, allora anche nella Configurazione hardware per la CPU deve essere impostato l'indirizzo MPI 2.


Figura 01

Rimedio
In questo caso modificare l'indirizzo MPI per la CPU nella HW Config. Salvare e compilare e poi caricare nuovamente la HW Config nell'unità.

Ulteriori e complete informazioni sulla segnalazione di errore sopra citata si trovano nella Guida in linea. Con la segnalazione di errore fare clic sul pulsante "Guida" e seguire la descrizione per l'eliminazione dell'errore, p. es.

  • verifica dei connettori ad innesto e del collegamento alla rete.
  • Verifica della tensione presente.

3

Interfaccia PG/PC impostata in modo errato
Se nell'interfaccia PG/PC la parametrizzazioni di interfaccia utilizzata non coincide con la connessione online opp. se l'interfaccia non è ancora installata, allora si ottiene la segnalazione di errore:

  • Caricamento (288:47)
    "L'unità ... non può essere raggiunta tramite l'interfaccia online impostata".

Aprire l'interfaccia PG/PC tramite il comando di menù "Strumenti > Imposta interfaccia PG/PC ..." e, nella finestra "Parametrizzazione interfaccia utilizzata:", verificare se per la connessione online è stata impostata l'interfaccia corretta.


Figura 02

Se l'interfaccia necessaria non dovesse essere presente, fare clic sul pulsante "Selezione" e nel dialogo "Installa/disinstalla interfaccia" installare il driver corrispondente. In questo caso selezionare nella finestra di sinistra "Selezione" l'interfaccia desiderata e fare clic sul pulsante "Installa -->". Dopo l'installazione compare l'interfaccia nella finestra di destra "Installato:".


Figura 03

Chiudere poi il dialogo e scegliere l'interfaccia nella finestra "Parametrizzazione di interfaccia utilizzata:". Chiudere l'interfaccia PG/PC con OK.

4

Il baudrate non coincide con il baudrate di rete
Se nella HW Config per l'unità è stato impostato un baudrate che non coincide con il baudrate di rete, arriva la segnalazione di errore:

  • Caricamento nell'unità (33:17075)
    "Online: L'indirizzo MPI locale del PG/PC è maggiore del massimo indirizzo di partner opp. è stato impostato un baudrate errato o un interrupt errato."

Aprire l'interfaccia Interfaccia PG/PC tramite il comando di menù "Strumenti > Imposta interfaccia PG/PC..." e fare clic sul pulsante "Diagnostica...". Con il pulsante "Test" si ottiene la diagnostica di rete PROFIBUS - MPI. La Figura 04 mostra un esempio se il baudrate opp. l'interrupt non coincidono (errore 0x0313).


Figura 04

Nel registro "Hardware" con il pulsante "Test si può effettuare la diagnostica " di quali risorse fa uso l'unità. Prima di questa diagnostica tenere conto dell'avvertenza contenuta nella Guida in linea (sotto "Guida") e prima del test chiudere tutte le applicazioni e memorizzare i propri dati.


Figura 05

Chiudere il dialogo con OK e nel dialogo "Imposta interfaccia PG/PC" fare clic sul pulsante "Proprietà". Nel dialogo "Proprietà" scegliere la velocità di trasferimento corretta per la rete.


Figura 06

5

Troppo poco spazio di memoria sul disco per il file swap
Verificare la memoria di lavoro virtuale e tenere conto per questo anche dell'avvertenza contenuta nel file Readme (capitolo 3.2 Impegno di memoria). Si raccomanda una dimensione di 1000 ... 1500 MB. Ulteriori informazioni sull'impostazione della memoria di lavoro virtuale sotto i diversi sistemi operativi Windows si trovano anche nell’articolo con ID 20440472 (Avvertenze per l'ottimizzazione della performance).

6

Interfaccia PROFIBUS DP impostata in modo errato
Si vorrebbe p. es. tramite l'interfaccia PROFIBUS DP di una CPU 317-2-PN/DP stabilire una connessione on-line e nella Configurazione hardware è progettata anche l'interfaccia PROFIBUS DP. La stesura della connessione on-line viene interrotta se la parametrizzazione dell'interfaccia non è corretta opp. l'indirizzo PROFIBUS nella HW Config è sbagliato. Compaiono le seguenti segnalazioni di errore:

  • "Caricamento nel PG (13:4337): La connessione con l'unità ... nella Station ... non ha potuto essere stesa"
    (all'interno della Configurazione hardware), opp.
  • "Sorveglianza (288:47): L'unità ... non può essere raggiunta tramite l'interfaccia on-line impostata" (nell'editor KOP/AWL/FUP)

Rimedio
Aprire l'interfaccia PG/PC tramite il comando di menù "Strumenti > Imposta interfaccia PG/PC..." e scegliere per la propria interfaccia il punto di accesso corretto, p. es. CP5512(PROFIBUS). Si raccomanda di scegliere una interfaccia con un riconoscimento automatico dei parametri di bus, p. es. CP5512(Auto). Tramite questa strada di accesso si può collegare il PG a MPI opp. PROFIBUS, senza dover impostare parametri di bus. Qui occorre tenere conto anche delle avvertenze della Guida in linea sotto "Impostazione dell’interfaccia PG/PC".


Figura 07

Tramite "PLC > Visualizza partner raggiungibili" vengono visualizzati gli indirizzi raggiungibili (p. es. "PROFIBUS = 2). Questi indirizzi devono essere impostati nella Configurazione hardware per la CPU, in modo da poterla raggiungere online.

7

Interfaccia MPI impostata in modo errato
Se l'interfaccia MPI non è impostata nella interfaccia PG/PC, nell'editor KOP/AWL/FUP e nella Configurazione hardware viene interrotta la stesura della connessione on-line con le segnalazioni di errore descritte sotto il punto 6. Per la connessione MPI progettata nell’interfaccia PG/PC probabilmente è ancora parametrizzata l'interfaccia per PROFIBUS.

Rimedio
Nella interfaccia PG/PC per l'interfaccia utilizzata scegliere il punto di accesso per MPI (p. es. CP5512(MPI)), opp. l'interfaccia con riconoscimento automatico dei parametri di bus (p. es. CP5512(Auto)). Qui tenere conto anche, come descritto nei punti 2 e 6, degli indirizzi MPI corretti che si possono individuare tramite il comando di menù "Visualizza partner raggiungibili".

8

Differenze nel programma tra online e offline
Se durante il test del programma nella modalità on-line non si può più attivare la funzione "Sorveglianza" (Monitoring), allora verificare se ci sono differenze nel programma tra la rappresentazione on-line e offline. Il pulsante per la lente, con il quale viene scelta questa funzione, è poi inattivo opp. grigio.

Se vengono eseguite modifiche nella modalità offline, allora dopo la modifica occorre per prima cosa caricare il programma nella CPU, prima di poter attivare la funzione Sorveglianza ON".

9

Aumento del ciclo ammesso impostato troppo basso
Nel funzionamento di processo per l'elaborazione del programma serve solo il tempo di ciclo, ma per il test del programma con la tabella delle variabili (VAT) è necessario un aumento addizionale del tempo di ciclo. Se si ha solo un programma breve ed una tabella delle variabili di grosse dimensioni con un aumento del tempo di ciclo impostato piccolo, allora durante la sorveglianza ed il comando della tabella delle variabili si ha una interruzione con la segnalazione di errore "(D0AA) Limite di tempo nel funzionamento di processo superato".


Figura 08

Rimedio
Nella Configurazione hardware aprire le proprietà oggetto della CPU e scegliere il registro "Protezione". Qui per il funzionamento ci sono due possibilità:

  1. per il test scegliere il funzionamento di test, opp.
  2. scegliere per il funzionamento di processo un aumento del tempo di ciclo ammesso maggiore.

Confermare il dialogo con OK e memorizzare e compilare la Configurazione hardware.


Figura 09

Dopo il caricamento della Configurazione hardware nella CPU si può effettuare il test del programma con la tabella delle variabili.

10

Impostazione errata del profilo di bus
Se le impostazione del profilo di bus nell’interfaccia PG/PC si discosta dalla progettazione del profilo di bus nella Configurazione hardware, la stesura della connessione on-line viene interrotta con la segnalazione di errore:

  • "Sorveglianza (33:16945), Online: Il bus è in anomalia" opp.
  • "Visualizza partner raggiungibili (33:16914), Online: La stazione non è online".

Verificare per la propria interfaccia PROFIBUS DP se il profilo di bus della CPU progettata coincide con l'impostazione nella interfaccia PG/PC. Nella Configurazione hardware aprire le proprietà oggetto dell'interfaccia DP della CPU progettata e scegliere il dialogo "Proprietà - PROFIBUS" tramite

  • "Registro: Generale > Proprietà > Registro: Parametri > Proprietà > Registro: Impostazioni di rete".

La progettazione per il profilo (p. es. "DP" opp. "Standard") deve essere impostata anche nella interfaccia PG/PC.


Figura 10

Nel SIMATIC Manager aprire l'interfaccia PG/PC e fare clic sul pulsante "Proprietà". Per l'interfaccia PROFIBUS DP scegliere il profilo corrispondente (p. es. "DP" opp. "Standard").


Figura 11

11

Più di una interfaccia Ethernet nella stessa subrete IP
La segnalazione di errore (33:16656) descritta nel punto N. 2 può comparire anche se con una connessione TCP/IP è stata predisposta più di una interfaccia Ethernet nella stessa subrete IP. Per stabilire l’interfaccia Ethernet scelta per una connessione online, si deve prima disattivare l’interfaccia Ethernet non utilizzata.

Rimedio
In Windows XP aprire il dialogo "Start > Impostazioni > Connessioni di rete" e fare clic con il tasto destro del mouse sulla connessione Ethernet che non viene utilizzata. Fare poi clic nel menù contestuale sul pulsante "Disattiva".

Avvertenza
Ulteriori informazioni sulla stesura della connessione on-line si trovano anche nelle nostre FAQ elencate nel seguito.

  • "Come avviene la diagnostica e qual è il rimedio in STEP 7 se non è possibile alcuna connessione on-line con il CP5511?"
    nell’articolo con ID 11492532
  • "Perché dopo l'installazione di STEP7 Versione V5.4 non è più possibile stendere una connessione on-line con un PC-Adapter opp. TS-Adapter?"
    nell’articolo con ID 23933965
  • "C'è una checklist per l'impiego di un PC-Adapter?"
    nell’articolo con ID 10420976

Ricerca
Stesura della connessione, stesura della comunicazione, sviluppo di programmi.

Come è possibile modificare i dati di avviamento o quelli attuali in modo sicuro da caduta rete opp. cancellazione totale solo tramite operazioni su un OP?Vai all'inizio
Numero di ordinazione:

Istruzioni
Nel SIMATIC Manager è possibile, con la funzione "PLC > Copia RAM in ROM", scrivere un blocco dati dalla memoria di lavoro nella memoria di caricamento. In questo modo parametri modificati in questo blocco dati sono nuovamente disponibili, p. es. anche dopo Rete OFF.

I blocchi nella memoria di caricamento vengono mantenuti sulla memory card dopo una mancanza rete mentre vanno perduti i dati su merker non rimanenti, con l'esclusione dell’avviamento delle CPU S7-400. Tenere conto per questo anche delle informazioni contenute nella Guida in linea STEP7:

  • Capitolo "Stato di funzionamento Avviamento" sotto "Campi dati rimanenti dopo mancanza rete".

Per trasferire parametri da un DB nella memoria di caricamento senza l'uso di PC/PG con STEP 7 - p. es. operando su un OP, si può utilizzare, con le CPU dotate di micro memory card (MMC), la funzione di sistema SFC 84 "WRIT_DBL". Con il seguente richiamo di esempio, 10 byte da DB 1 (nella memoria di lavoro) vengono scritti in DB2 (nella memoria di caricamento).



Figura 01

Il blocco dati DB2 nell'esempio deve essere dichiarato come "unlinked", perché in caso contrario esso si trova nella memoria di lavoro. Questa impostazione può essere eseguita al momento dell'inserimento del blocco dati, utilizzando il campo "Proprietà - Blocco dati" nel registro "Generale - Parte 2".
Ulteriori informazioni sul caricamento nella memoria di caricamento della CPU di un blocco dati con la dichiarazione "Unlinked" si trovano nell'articolo:

  • "Quali rimedi ci sono se la memoria di lavoro della CPU è troppo piccola per il programma STEP7 rilevante per l'esecuzione?"
    (nell’articolo con ID: 19413912)

Per modificare, in modo sicuro da mancanza rete opp. da cancellazione totale, valori di avviamento tramite l'impiego di un OP, si può realizzare il seguente modo di procedere:

N.

Modo di procedere

1

Modificare i parametri tramite l'OP.

2

Tramite un OP scrivere in un DB, posto nella memoria di caricamento, i parametri modificati e rilevanti per l'avviamento (possibile anche per i parametri che si trovino in DB diversi).

3

Leggere in OB100, posto nella memoria di caricamento, i valori di avviamento con SFC 83 "READ_DBL" e riscriverli nel DB originale. Impostando un flag è possibile ritardare l'elaborazione del programma applicativo fino a quando tutti i valori di avviamento sono stati scritti nei corrispondenti DB.

Importante
Per motivi di consistenza, il campo sorgente non può essere modificato durante l'elaborazione dell'SFC 84. Inoltre l'SFC 84 viene elaborato in modo asincrono, cioè l'elaborazione può avvenire tramite più richiami di SFC. Per questi motivi, durante l'esecuzione dell'SFC 84, l'elaborazione del programma applicativo dovrebbe essere rinviata per garantire la consistenza dei dati.

Avvertenza
Accessi di scrittura con l'SFC 84 dovrebbero aver luogo solo a fronte di una notevole quantità di dati, perché non sono previsti accessi di scrittura frequenti alla memoria di caricamento.

Ricerca
RAM to ROM


Come si può effettuare il forzamento di variabili a partire da STEP 7 Versione V5.2?Vai all'inizio
Numero di ordinazione:

Istruzioni
Il forzamento di operandi è possibile sia nella vista online dell'editor KOP/FUP/AWL che anche tramite la tabella delle variabili. Per forzare variabili nell'editor KOP/FUP/AWL, si può scegliere tra le visteAWL e KOP/FUP. 
 

N.

Forzamento di operandi da STEP 7 V5.2

1

Forzamento di operandi in AWL
Nella vista online selezionare la riga con gli operandi e, tramite il menù contestuale del tasto destro del mouse, eseguire il comando Forzamento su 0 / 1, per forzare una variabile del tipo BOOL. Se la variabile è di un altro tipo dati (p. es. WORD), nel menù contestuale viene proposto il comando Forzamento.... Il valore di comando può essere digitato nel dialogo che si apre.


Figura 01

2

Forzamento di operandi in KOP/FUP
Per forzare un operando nella vista online in KOP opp. FUP, occorre selezionare il corrispondente collegamento opp. contatto. Nel menù contestuale del tasto destro del mouse in funzione del tipo dati dell'operando si può scegliere il corrispondente comando (p. es. Figura 02: esempio per WORD).


Figura 02

Avvertenza
La funzione "Forzamento..." del menù contestuale funziona con il programma di simulazione S7-PLCSIM solo se è stata progettata una Configurazione hardware (S7-300 opp. S7-400) per i blocchi da sottoporre a test.

3

Forzamento di operandi nella tabella delle variabili
Nella vista online dalla tabella delle variabili c'è una ulteriore possibilità di comandare variabili tramite combinazione di tasti. Variabili booleane possono essere impostate su Uno opp. Zero tramite la combinazione di tasti CTRL+1 e CTRL+0. Se si vogliono attivare tutti i valori di comando, allora si può utilizzare il tasto F9. Per trasferire una volta i valori di comando, premere la combinazione di tasti CTRL+F9. La possibilità del comando tramite il tasto destro del mouse è, come sopra descritto" anch'essa possibile. Nel menù si trovano le opzioni di comando sotto il punto di menù Variable.

Avvertenza
Il comando di variabili tramite combinazione di tasti non è possibile nell'editor KOP/FUP/AWL.

Come si può sorvegliare un blocco con l'ambiente di richiamo desiderato con STEP 7 V5.3?Vai all'inizio
Numero di ordinazione:

Guida
In caso di richiami multipli di un blocco c'è la possibilità di sorvegliare il blocco in un ben determinato richiamo.
Per la sorveglianza di un blocco con l'ambiente di richiamo desiderato, con STEP 7 V5.3 procedere come segue.
 

N.

Modo di procedere

1

  • Caricare il progetto nella CPU.
  • Aprire il blocco desiderato.
  • Scegliere il comando di menù Test > Funzionamento


Figura 01

2

Nella finestra di dialogo "Funzionamento" attivare l'opzione "Funzionamento di test" e confermare con "OK".


Figura 02

3

  • Scegliere il comando di menù Test > Ambiente di richiamo.
  • Se dovesse comparire una segnalazione, nella quale viene richiesto se si vogliono generare i Dati di riferimento, confermare con "Si".


Figura 03

4

Nel campo di dialogo visualizzato definire le condizioni di trigger e confermare con "OK".


Figura 04

Per la definizione della condizione di trigger c’è la seguente possibilità che viene chiarita nel seguito:

  • Percorso di richiamo da Rimandi incrociati
  • Percorso di richiamo manuale
  • Blocchi dati aperti
  • Sorveglianza con Percorso di richiamo dal blocco che chiama

5

Percorso di richiamo da Rimandi incrociati

Vengono visualizzati i percorsi di richiamo dal blocco attuale che è stato rilevato tramite la funzione Dati di riferimento.

  • Attivare "Percorso di richiamo".
  • Selezionare il registro "Da rimandi incrociati".
  • Nell’albero visualizzato selezionare con un clic il percorso di richiamo desiderato.


Figura 05

Disattivare l’opzione “Blocchi dati aperti”, se la condizione di blocco dati deve essere esclusa.

6

Percorso di richiamo Manuale

Qui si può scegliere manualmente il percorso di richiamo del blocco attuale e anche indicare percorsi di richiamo che non possono essere visualizzati nel registro "Da rimandi incrociati", perché nel richiamo il numero di blocco viene generato dinamicamente solo durante l'esecuzione.

  • Attivare "Percorso di richiamo".
  • Selezionare il registro "Manuale".
  • Nel campo di destra (blocchi presenti) selezionare i blocchi necessari; fare clic su "Aggiungi" e aggiungere questo percorso di richiamo. Per la cancellazione di un blocco dal percorso di richiamo selezionarlo nella campo di sinistra e scegliere "Cancella". 


Figura 06

Disattivare l'opzione "Percorso di richiamo", se la condizione di percorso del richiamo deve essere esclusa.

7

Blocchi dati aperti

Qui si definisce l’ambiente di richiamo con l'indicazione di uno opp. due blocchi dati. La registrazione di stato avviene se il blocco da verificare è stato richiamato con ciascuno dei blocchi dati indicati.

  • Attivare "Blocchi dati aperti".
  • Indicare il numero del DB globale nel campo a sinistra in basso e/o il numero del DB di istanza nel campo a destra in basso.


Figura 07

Disattivare l'opzione "Blocchi dati aperti", se la condizione di blocco dati deve essere esclusa.

8

Sorveglianza con percorso di richiamo dal blocco che richiama

Lo Stato programma di un blocco richiamato può essere visualizzato direttamente dal suo richiamo. In questo modo si può anche sorvegliare una istanza di blocco, se il blocco da sorvegliare viene richiamato più volte dallo stesso blocco.

  • Il blocco da sorvegliare non può stare su "Sorveglianza"; all'occorrenza commutare su "Sorveglianza" per questo blocco tramite il comando di menù Test > Sorveglianza.
  • Aprire online il blocco che richiama opp. caricarlo nuovamente dopo l'apertura nel sistema di destinazione e posizionare il cursore sulla istruzione di richiamo desiderata (riga CALL in AWL opp. box del blocco in KOP/FUP).
  • Tramite il tasto destro del mouse scegliere il menù contestuale e scegliere la funzione Blocco richiamato > Sorveglianza con percorso di richiamo.


Figura 08

Il blocco richiamato viene aperto, nelle condizioni di trigger del blocco viene registrato il richiamo con l'indirizzo come criterio e viene attivato lo Stato per questa istanza del blocco. 
Attenzione Condizioni di trigger eventualmente già presenti per i blocchi dati rimangono invariate; se non più richieste esse devono essere disattivate manualmente.

Chiarimenti alla modalità di funzionamento

  • Funzionamento di test
    Tutte le funzioni di test sono utilizzabili senza limitazioni. Possono comparire grandi aumenti del tempo di ciclo della CPU, poiché lo stato di istruzioni nei loop programmati viene rilevato ad ogni ciclo di esecuzione.
  • Funzionamento di processo
    La funzione di test per Stato programma viene limitata per garantire un carico possibilmente ridotto del tempo di ciclo. Così p. es. non sono consentite condizioni di richiamo. La visualizzazione di un loop programmato viene interrotta sul punto di ritorno. Le funzioni di test "ALT" e l’esecuzione a passi del programma non possono essere eseguite.

Avvertenza

Se la modalità di funzionamento era stata definita nell'ambito della parametrizzazione della CPU (Configurazione hardware) (non rilevante per S7-400 e CPU 318-2), è possibile cambiare la modalità di funzionamento solo tramite una modifica della parametrizzazione della CPU nella Configurazione hardware.


Figura 09

Avvertenza
La funzionalità descritta è possibile senza limitazioni con S7-400, mentre con S7-300 solo a partire dalle versioni 10/2000.

Avvertenza sullo STEP 7 V5.0
Per sorvegliare una funzione con il parametro desiderato, occorre effettuare una selezione tramite il numero di Global-DB. Per questo è però necessario che per il funzionamento di test si provveda a determinate modifiche nel proprio programma applicativo.
 

N.

Modo di procedere

1

Nell'editor KOP/AWL/FUP attivare con il comando di menù "Test > Esercizio" il funzionamento di test della CPU ed poi, tramite la barra dei menù "Test > Ambiente di richiamo", aprire la finestra in basso (Figura 10).


Figura 10

2

Un segno distintivo per i corrispondenti richiami di funzione dello stesso livello di richiamo sono i blocchi dati aperti. Se si vuole sorvegliare una richiamo speciale di blocco funzionale si deve, tramite il punto di scelta "Blocchi dati aperti > Numero del DB di istanza", indicare il blocco dati di istanza corrispondente.


Figura 11

3

Per trovare una differenziazione delle singole funzioni, dichiarare nella funzione una "variabile di ingresso dummy" (p. es. del tipo INT). Nei richiami delle funzioni passare al parametro di ingresso dummy una variabile Word, ciascuna in blocchi dati diversi (p. es. DB10.DBW0). Questi blocchi dati devono essere creati anche nel progetto. In questo modo ad ogni richiamo di funzione viene aperto un altro blocco dati. Sulla base dei diversi blocchi dati aperti, con l'indicazione del numero nel campo di input "Numero di Global-DB", si può sorvegliare l'esecuzione della funzione con il parametro di richiamo desiderato.


Figura 12


Informazioni sull'argomento "Caricamento e test del programma S7"Vai all'inizio
Numero di ordinazione:

Avvertenze di riferimento
Informazioni sull'argomento "Caricamento e test del programma S7" si trovano nei seguenti manuali e capitoli.
 
Documento

Edizione

Capitolo Articolo con ID
Manuale
"Programmazione con STEP 7 V5.5"
05/2010 05: "Avvio e utilizzo"
10: "Creazione di blocchi di codice"
13: "Creazione di sorgenti AWL"
18: "Attivazione del collegamento online e impostazione della CPU"
19: "Caricamento"
20: "Test con la tabella delle variabili"
21: "Test con lo stato di programma"
22: "Test con il programma di simulazione S7-PLCSIM"
45531107
Manuale
"Schema logico (FUP) per S7-300/400"
05/2010 10: "Operazioni di controllo del programma" 45522487
Manuale
"Lista di istruzioni (AWL) per S7-300/400"
05/2010 10: "Operazioni di controllo del programma" 45523446
Manuale
"Schema a contatti (KOP) per S7-300/400"
05/2010 10: "Operazioni di controllo del programma" 45523822
Manuale
"Configurazione dell'hardware e progettazione di collegamenti con STEP 7 V5.5"
05/2010 10: "Collegamento in rete di stazioni"
13: "Caricamento"
15: "Lavorare con i progetti nel multiprogetto"
45531110

Perché negli editor KOP e FUP, nella Sorveglianza lo stato del segmento viene visualizzato solo in parte?Vai all'inizio
Numero di ordinazione:

 
Descrizione
La seguente tabella descrive i motivi (e fornisce i rimedi) per cui, nella sorveglianza con gli editor KOP e FUP, una parte del programma non compare sul display del PC opp. del PG e perché lo stato del segmento viene visualizzato solo parzialmente.
 

N.

Modo di procedere

1

Risorse insufficienti lato PLC
Una causa per cui nella sorveglianza viene visualizzata solo una parte del segmento dipende dalla distribuzione delle risorse della CPU. Verificare se la sorveglianza del programma STEP7 ha luogo nel funzionamento di programma opp. nel funzionamento di test. Il passaggio dal funzionamento di processo al funzionamento di test nell’editor KOP/AWL/FUP avviene tramite il comando di menù "Test > Funzionamento...". Attivare come in Figura 01 il funzionamento di test e confermare con OK. Poi memorizzare il blocco e caricarlo nella CPU.


Figura 01

Con le CPU SIMATIC S7-400 è di norma impostato il funzionamento di processo (stato dopo l'innesto della CPU). Se la modalità di funzionamento è stata definita nell'ambito della parametrizzazione della CPU (Configurazione hardware) (non rilevante per S7-400 e CPU 318-2), la modalità di funzionamento può essere modificata solo modificando la parametrizzazione della CPU nella Configurazione hardware.

Chiarimenti sulle modalità di funzionamento di test e di processo

  • Funzionamento di test
    Tutte le funzioni di test sono eseguibili senza limitazioni. Allungamenti maggiori del tempo di ciclo della CPU possono comparire poiché p. es. ad ogni ciclo di esecuzione viene rilevato lo stato delle istruzioni nei loop programmati.
  • Funzionamento di processo
    La funzione di test Stato di programma viene limitata per garantire il carico più ridotto possibile del tempo di ciclo. Per questo non sono consentite condizioni di richiamo. La visualizzazione di stato di un loop programmato viene interrotta al punto del salto di ritorno. La funzione di test "ALT" e l'esecuzione a passi del programma non possono essere eseguite.

2

Risorse insufficienti lato PC
Se, durante il funzionamento dello STEP7, la memoria virtuale disponibile diventa insufficiente, in determinate circostanze si può arrivare ad anomalie nel funzionamento dello STEP7. Per questo motivo può essere vantaggioso disattivare la gestione automatica del file di scambio e definire manualmente la dimensione minima e la dimensione massima. Verificare qui la dimensione iniziale e massima della memoria di lavoro virtuale nel sistema operativo.

Informazioni sul file di scambio di Windows si trovano anche nel file Readme di STEP7, sotto "3.2 Fabbisogno di memoria". Si raccomanda una impostazione di min. 1500 MB, anche nella definizione del massimo campo si può indicare 1500MB oppure un campo maggiore.


Figura 02

Ulteriori informazioni sull'impostazione della dimensione necessaria della memoria di lavoro virtuale sotto Windows 2000/XP/NT/9x si trova nella nostra FAQ "Avvertenze per l'ottimizzazione delle performance" nell’articolo con ID: 20440472.

3

Influenza della PDU-Size
Le informazioni di Stato blocco dipendono dalla cosiddetta PDU-Size (Protocol Data Unit), che è assegnata dalla CPU S7. La quantità delle variabili massime necessarie fa riferimento alla lunghezza attuale della PDU ed al tipo dati delle variabili. Una CPU S7-300 può elaborare lunghezze di PDU di 240 byte e una CPU S7-400 può elaborare lunghezze di PDU di 480 byte.

  • Protocolli MPI e PROFIBUS per le CPU 300/400
    Dimensione PDU: 240 byte
    Dimensione intestazione: 17 byte per campo dati
  • Protocollo Ethernet per le CPU 300
    Dimensione PDU: 240 byte
    Dimensione intestazione: 17 byte per campo dati
  • Protocollo Ethernet per le CPU 400
    Dimensione PDU: 480 byte
    Dimensione intestazione: 17 byte per campo dati

Rimedio
Segmenti che sono stati programmati in KOP opp. FUP, contengono più istruzioni rispetto ad AWL. In KOP e  FUP si arriva al segmento selezionato, poiché da questo viene richiesta l'informazione di Stato. Tramite un rimpicciolimento della finestra del blocco si può ottenere allo stesso modo un miglioramento.

La CPU 318 e le CPU della serie 400 dispongono di 4 punti di trigger che vengono occupati nel modo seguente.

  • Lo Stato blocco occupa per ogni job 2 punti di trigger per cui è possibile sorvegliare contemporaneamente solo 2 blocchi.
  • Le CPU inferiori alla 318 e la CPU 319 sono dotate di 2 punti di trigger, perciò è possibile visualizzare sempre solo 1 Stato blocco.

Se si deve sorvegliare un ulteriore blocco, compare come nella Figura 03 la seguente finestra di dialogo. Qui i viene richiesto per quale blocco si deve concludere lo stato del programma affinché si possa visualizzare lo stato del blocco ricercato.


Figura 03

Avvertenza
La tabella delle variabili per ogni monitoring, scrittura/forcen e il punto di alt occupano un punto di trigger. Con la funzione "Esegui" è necessario temporaneamente un ulteriore punto di trigger.

Qual è la differenza tra la modifica offline e quella online nell'editor KOP/AWL/FUP?Vai all'inizio
Numero di ordinazione:

Avvertenze di configurazione
Durante la fase di test opp. di messa in servizio spesso sono necessarie piccole modifiche nei blocchi. Se il corrispondente programma applicativo è disponibile su un dispositivo di programmazione, di principio ci sono due modi diversi di procedere per effettuare le modifiche.
 

N.

Differenza tra modifica di blocchi off-line e on-line

1

Modifica online
Il blocco viene aperto dalla cartella dei blocchi nella finestra on-line del SIMATIC Manager e poi modificato. Nell'editor KOP/AWL/FUP le modifiche vengono memorizzate offline sul dispositivo di programmazione tramite

  • "File > Salva" opp. il simbolo del dischetto nella barra degli strumenti.

Poi il programma viene caricato nella CPU tramite

  • "PLC > Carica" opp. tramite con l’icona del caricamento nella barra degli strumenti.

2

Modifica offline
Il blocco viene aperto dalla cartella off-line dei blocchi, viene modificato e memorizzato. Dopo il caricamento nell’editor KOP/AWL/FUP tramite

  • "PLC > Carica" opp. con l’icona del caricamento nella barra degli strumenti.

Poi il blocco può essere caricato nella CPU e qui sottoposto a sorveglianza.

Di principio conviene preferire la modifica off-line, poiché la maggioranza dei passi operativi avviene off-line. In questo modo si ha anche un piccolo vantaggio di tempo nella modifica. Nel caso che il programma applicativo non sia disponibile nel dispositivo di programmazione, è possibile tramite

  • "PLC > Carica nel PG" opp. tramite
  • "PLC > Carica stazione nel PG..."

caricare i blocchi dalla CPU nel dispositivo di programmazione e modificarli. In questo caso però non sono disponibili le informazioni sui simbolici ed i commenti. Questa variante è legata quindi principalmente al caso del service.

Avvertenza
Ulteriori informazioni sull'argomento si trovano anche nella Guida on-line dello STEP7 sotto "Modifica nel PG/PC di blocchi caricati ".

Se nell’editor KOP/AWL/FUP sono state eseguite modifiche del programma, allora la funzione "Test > Sorveglianza" ed il pulsante con gli occhiali non è attivabile e visualizzato in grigio. Dopo la memorizzazione è possibile attivare nuovamente la funzione "Sorveglianza". Se si attiva la funzione "Sorveglianza", compare la segnalazione che il blocco modificato visualizzato non può essere sorvegliato, poiché esso non coincide con il blocco nella CPU. Fare clic sul pulsante "Si", così il blocco visualizzato viene caricato nella CPU è quindi possibile sorvegliarlo.


Figura 01

Se si vuole però solo sorvegliare il blocco sulla CPU (senza modifiche nel progetto offline), allora fare clic sul pulsante "No" e scegliere il menù "File > Apri on-line". Il blocco presente nella CPU viene visualizzato e si può nuovamente avviare la funzione.

Avvertenza
In certi casi si deve prima cancellare il vecchio blocco nella CPU, prima di caricare il blocco modificato. Può succedere che la memoria della CPU sia piena quasi al limite. Per poter consentire la caricabilità on-line senza interruzione del programma, la nuova versione del blocco nella sovrascrittura deve essere depositata una seconda volta nella memoria di lavoro. Solo quando la nuova versione del blocco è completamente scritta nella CPU, viene cancellata la vecchia versione. Se pero viene superato il limite della memoria di lavoro, il caricamento può essere effettuato solo dopo una cancellazione manuale del vecchio blocco nel container on-line. Questo significa che un blocco non può essere sovrascritto nella CPU, se la memoria necessaria per la nuova versione è maggiore di quella ancora libera nella CPU.

Aggiornamento di un blocco dati nel progetto offline
Si utilizza un DB globale e si vorrebbero ricaricare nel progetto offline le modifiche che sono state effettuate nel DB online. Se le variabili coincidono, allora viene solo sovrascritto il contenuto del DB offline. Confermare per questo il dialogo (Figura 02) con "Si".


Figura 02

Se però è stata modificata la struttura del DB nella CPU (p. es. sono state aggiunte ulteriori variabili nel DB online), allora è necessario rinominare il DB offline e poi caricare il DB online. Poi si possono aprire entrambi i DB ed eventualmente copiare le nuove variabili dal DB online nel DB offline.

Ricerca
30:484, segnalazione 294:103, sviluppo del programma, funzioni di test

 Articolo con ID:22380254   Data:2012-04-30 
Questo articoloè stato utilenon è stato utile                                 






























mySupport
My Documentation Manager 
Newsletter 
CAx-Download-Manager 
Support Request
Vai all'articolo
Stampa
Creazione PDF 
Invia l'articolo
QuickLinks
Strumento di compatibilità 
Aiuto
Aiuto on-line
Guided Tour