Beitragsliste anzeigen

S7-PDIAG -- S7-Programm erstellen -- Überwachung projektieren 
Anzahl der S7-PDIAG-Meldungen ermitteln 
Wie kann nach dem Löschen der S7-PDIAG-Überwachungen das gelbe Dreieck im Bausteinordner am entsprechenden Baustein entfernt werden? 
Hinweise zu S7-PDIAG-Meldungen 
Erzeugen von PDIAG-Meldungen aus Multiinstanz-Bausteinen  
Welche Regeln sind bei der Programmierung bezüglich der Option "Erstwerterfassung" zu beachten? 
Warum erscheint für den Formalparameter "$$CpuName$$" nicht der CPU-Name im Dialog "Operandenüberwachung", wenn die Meldung mit diesem Formalparameter in einem FC projektiert wurde? 
Wie können Bausteine mit Meldungen von einem Projekt in ein neues Projekt kopiert werden? 
Warum sollten die Bausteine FB0 und FC0 bei der Projektierung mit S7-PDIAG nicht verwendet werden? 
Wie kann die fehlende Gelbmarkierung für die zu überwachenden Operanden im KOP AWL FUP Editor wieder aktiviert werden? 
Warum werden die Diagnosedaten nur mit "#####" am MP370 angezeigt? 

Anzahl der S7-PDIAG-Meldungen ermittelnzum Beginn
Bestellnummer:

FRAGE:
Wie kann ich feststellen, wie viele Meldungen in S7-PDIAG projektiert sind?

ANTWORT:
Um zu sehen, wie viele S7-PDIAG-Meldungen projektiert sind, gehen Sie nach folgenden Schritten vor:

  1. Öffnen Sie im SIMATIC Manager Ihr Projekt, in  welchem Sie die projektierten Meldungen sehen möchten.
  2. Wählen Sie den Menübefehl "Extras > Prozessüberwachung projektieren" aus.

Bild 1: S7-PDIAG starten

  1. Selektieren Sie Ihr Projekt, rufen Sie das Kontextmenü mit der rechten Maustaste auf und wählen Sie "Suchen..." aus.

 

Bild 2: Suchen-Dialog im Kontextmenü aufrufen

  1. Wählen Sie im Dialogfenster "S7-PDIAG Fehlerdefinition" (1) und "Instanzen ( DB )" (2) an. Setzen Sie außerdem ein Häkchen bei "Untergeordnete Objekte mit einbeziehen" (3).
  2. Wenn Sie alle Einstellungen vorgenommen haben, klicken Sie auf "Starten" (4).

Bild 3: S7-PDIAG-Meldungen suchen

Im Listenfenster sehen Sie dann alle projektierten Meldungen und können diese auch - z.B. nach Meldenummern - sortieren .

Wie kann nach dem Löschen der S7-PDIAG-Überwachungen das gelbe Dreieck im Bausteinordner am entsprechenden Baustein entfernt werden?zum Beginn
Bestellnummer:

Anleitung:
Wenn Sie alle Überwachungen im Baustein gelöscht haben und das gelbe Dreieck ist noch am entsprechenden Baustein im Bausteinordner vorhanden, empfehlen wir Ihnen die folgende Vorgehensweise:

  1. Klicken Sie mit der rechten Maustaste auf den entsprechenden Baustein und öffnen Sie aus dem Kontextmenü die "Objekteigenschaften...".
  2. Wechseln Sie in das Register "Attribute" und löschen Sie die Zeile mit dem Attribut "S7_pdiag" über die Schaltfläche "Zeile löschen".
  3. Beenden Sie den Dialog mit OK. Das gelbe Dreieck am Baustein ist nun gelöscht.


Bild 01

Weitere Informationen zum Löschen von Überwachungen finden Sie in der Onlinehilfe von S7-PDIAG, unter "Löschen von Fehlerdefinitionen".

Hinweise zu S7-PDIAG-Meldungenzum Beginn
Bestellnummer:
> --> -->

FRAGE:
Wie kann man eine Reihe von vielen Meldungen, die mit S7-PDIAG projektiert wurden, "rational" quittieren und warum braucht man einzelne Meldungen gar nicht quittieren?

ANTWORT:
Wenn Sie in S7-PDIAG gerätespezifische Meldungen projektiert haben, können Sie unter "Attribute" neben den Anzeigeklassen auch die Quittiergruppen projektieren. Bei Quittierung einer Meldung einer solchen Quittiergruppe gelten auch alle anderen anstehenden Meldungen dieser Gruppe als quittiert.

Markieren Sie im KOP/AWL/FUP-Editor den zu überwachenden Operanden. Mit der rechten Maustaste gelangen Sie über "Spezielle Objekteigenschaften > Überwachung" in die Maske "Prozessüberwachung". Anschließend markieren Sie mit dem Cursor die zu bearbeitende vorhandene Überwachung und betätigen die Schaltfläche "Bearbeiten". Sie kommen dann in die Maske "S7-PDIAG Aktionsüberwachung" (Bild 1).



Bild 1: Dialogfenster für die Aktionsüberwachung

Wenn Sie das Kontrollkästchen "Mit Quittierung" aktivieren, dann projektieren Sie eine Fehlerdefinition mit einer quittierungspflichtigen Alarm_S-Meldung. Bei Meldungen, die sofort quittiert sind, wurde bei der Meldungsprojektierung der Haken "Quittierpflicht" nicht gesetzt.

Klicken Sie dann auf die Schaltfläche "Projektieren", Sie gelangen dann in die Maske "Meldungsprojektierung". Vorausgesetzt, Sie haben unter "Neues Gerät" ein Anzeigegerät projektiert, können Sie nun die Quittiergruppe eingeben.

Bild_2_Meldungsprojektierung ( 9 KB )  

Die Eingabe der Quittiergruppe gibt eine Gruppe von Meldungen an, die gemeinsam quittiert werden. Die Gruppe wird spezifiziert durch den Wert, der der Quittiergruppe zugewiesen wurde. Bei der Quittiergruppe geben Sie dann die Gruppennummer ein, die für ein bestimmtes ProTool-Anzeigegerät (z.B. OP35) festgelegt ist.

Weitere Informationen finden Sie auch in der Onlinehilfe (Hilfe zum Kontext, Taste: F1):

  • Register "Definition" (Aktionsüberwachung).

  • Register "Attribute" (ProTool)

  • ProTool-Attibute

Suchbegriffe:
ProTool-Meldung, Meldungsprojektierung

Erzeugen von PDIAG-Meldungen aus Multiinstanz-Bausteinen zum Beginn
Bestellnummer:

FRAGE:
Warum bekomme ich keine Meldungen über PDIAG, aus Bausteinen die als Multiinstanz projektiert sind?

ANTWORT:  
Sind die Meldungen nur in den Multiinstanzen projektiert und keine im aufrufenden Funktionsbaustein, dann fehlt für PDIAG die Kennung, dass im aufrufenden Funktionsbaustein etwas bearbeitet werden muss.
Für diesen Fall, müssen Sie die Kennung nachträglich projektieren. Gehen Sie dazu folgendermaßen vor:

  • Markieren Sie den Multiinstanz - FB mit PDIAG-Kennzeichnung.
  • Wählen Sie über die rechte Maustaste und Objekteigenschaften die Registrierkarte "Attribut".
  • Kopieren Sie die Zeile "S7_pdiag" mit dem Wert "true"  an die gleiche Stelle im aufrufenden Funktionsbaustein.
  • Öffnen Sie alle Funktionsbausteine der Aufrufhierarchie  im Editor und speichern Sie diese erneut ab.
  • Generieren Sie den Instanz-Datenbaustein neu.
  • Anschließend müssen Sie in S7-PDIAG alles noch einmal komplett übersetzen ("Prozessdiagnose > Vollständig übersetzen").

Suchbegriffe:
Diagnosemeldung, Prozessdiagnose

Welche Regeln sind bei der Programmierung bezüglich der Option "Erstwerterfassung" zu beachten?zum Beginn
Bestellnummer:

Beschreibung:
Dienachstehende Tabelle beschreibt einige Hinweise bezüglich der Option "Erstwerterfassung", die zur Programmierung im KOP / AWL / FUP Editor zu beachten sind:
 
Nr. Hinweise zur Programmierung in Bezug zur "Erstwerterfassung":
1 Verknüpfung zwischen Timern und Zählern
Bei einer Verknüpfung von Zählern oder Timern wie im Bild 01 erscheint nach der Übersetzung in S7-PDIAG für das erste und zweite Netzwerk die Warnmeldung, dass die Erstwerterfassung für den Merker M1.1 nicht möglich ist. Die Erstwerterfassung ist systembedingt nicht möglich, wenn die Verknüpfung der Timer T1 und T2 mit dem selben Merker wie im Beispiel Bild 01 programmiert wurde.


Bild 01

Abhilfe:
Legen Sie den Ein- oder Ausgang von Timern und Zählern auf einen Merker als Zwischenspeicher, wie hier im Beispiel Bild 02. Nach der Verknüpfung des Zwischenspeichers (Merker M1.3) und Projektierung der Operandenüberwachung für diesen Merker ist die Erstwerterfassung möglich.


Bild 02

2 Erstwerterfassung nicht komplett aufgelöst bzw. zurückverfolgt
Falls Sie in Ihrem Projekt einen Operanden überwachen, kann die Erstwerterfassung nur so weit zurückverfolgt werden, wie die Regeln für die Diagnose dies erlauben. Es ist nicht möglich, eine Erstwerterfassung für solche Operanden durchzuführen, bei denen in der Versorgung eine Zuweisung in einem Klammerausdruck steht. Zu erkennen ist dies in der AWL-Ansicht des Bausteins. Wird hier eine Zuweisung innerhalb eines Klammerausdrucks beschrieben, kann S7-PDIAG die Erstwerterfassung nicht mehr durchführen.

Beispiel:
Das folgende Netzwerk wurde in FUP erstellt. Nachdem die Erstwerterfassung für In1 nur bis zum Merker M0.3 durchgeführt werden konnte, wurde das Netzwerk in AWL umgewandelt (Bild 03).


Bild 03

Das AWL Programm beinhaltet eine Zuweisung innerhalb eines Klammerausdrucks - in Bild 04 rot umrandet gekennzeichnet. Bitte vermeiden Sie eine solche Zuweisung, wenn die Zuweisung in einer Erstwerterfassung abgefragt wird.


Bild 04

Abhilfe:
Verteilen Sie die Anweisungen auf zwei Netzwerke. Das in Bild 04 dargestellte Netzwerk wird hierfür am Konnektor getrennt, wobei der Konnektor durch eine Zuweisung zu ersetzen ist. Nach der Umwandlung in AWL wird jetzt keine Zuweisung mehr in einem Klammerausdruck verwendet. Die Erstwerterfassung ist somit uneingeschränkt möglich.


Bild 05

Hinweis:
In den folgenden Fällen ist eine Erstwerterfassung ebenfalls nicht möglich:

  • in Netzwerken, bei denen die Überwachung hinter einem Timer, Zähler oder Vergleicher projektiert wurde, ist eine Diagnose und Darstellung in ProAgent nicht möglich.
  • ein Ausdruck mit "NOT" und einer Zuweisung ist aus S7-PDIAG-Sicht kein gültiger Ausdruck. Somit ist hier auch keine Erstwerterfassung möglich. Beachten Sie hierzu auch die Informationen aus der S7-PDIAG Onlinehilfe "Set- und Reset-Zuweisungen".

Warum erscheint für den Formalparameter "$$CpuName$$" nicht der CPU-Name im Dialog "Operandenüberwachung", wenn die Meldung mit diesem Formalparameter in einem FC projektiert wurde?zum Beginn
Bestellnummer:

Beschreibung:
Wird für die Projektierung einer Meldung der Formaloperand "$$CpuName$$" verwendet, so erscheint nach der Übersetzung in S7-PDIAG und nach dem Öffnen des Dialoges "Operandenüberwachung" der CPU-Name nicht als Meldetext, wenn die Projektierung in einer Funktion erstellt wurde. Stattdessen wird weiterhin nur der Formalparameter angezeigt. Der Name der CPU, z.B. "CPU 314C-2PtP" erscheint aber als Meldetext für den selben Formaloperanden, wenn der Meldetext in einem Funktionsbaustein projektiert wurde.

Der Grund für das oben beschriebene Systemverhalten ist, das die Daten für den Meldetext beim Funktionsbaustein in seinem Instanzdatenbaustein abgelegt werden. Somit steht der Meldetext beim FB fertig ausgetauscht zur Verfügung. Die Funktion hat aber keinen Speicherort in Form eines Instanzdatenbausteins, an dem der Wert angehängt wird. Daher erfolgt der Austausch des Strings erst bei der Übergabe an ProTool, WinCC oder WinCC Flexible.

Bild 01 zeigt den Dialog einer Operandenüberwachung, die in einer Funktion projektiert wurde.


Bild 01

Abhilfe:
Um den zugehörigen Meldetext für den eingetragenen Formaloperanden "$$CpuName$$" zu sehen, klicken Sie im Dialog "Operandenüberwachung" auf die Schaltfläche "Textvorschau". Der CPU-Name, wie hier im Beispiel "CPU 314C-2PtP" wird angezeigt.


Bild 02

Über die Schaltfläche "Textvorschau" können Sie sich die Ersetzungen für die im Meldetext verwendeten Formaloperanden anzeigen lassen. Dieser Text wird nach der Generierung oder dem Transferieren der Daten im Anzeigegerät (HMI) angezeigt.

Hinweis:
Die Formaloperanden mit "$$xx$$" werden bei der S7-PDIAG-Generierung in FCs und OBs nicht ersetzt. Der Textvorschau dient nur zur Anzeige. Auch mit der Funktion "CPU Melden" kann der CPU-Name mit FCs und OBs (wie im Bild 03) nicht dargestellt werden.


Bild 03

Die Ersetzung der Formaloperanden im FC oder OB erfolgt mit der Generierung der HMI-Software für die Anzeigesysteme.

Diese Beschreibung wurde mit S7-PDIAG V5.3 verifiziert.

Wie können Bausteine mit Meldungen von einem Projekt in ein neues Projekt kopiert werden?zum Beginn
Bestellnummer:

Anleitung:
Die nachstehende Tabelle beschreibt ein Beispiel, wie Sie die Bausteine mit den projektierten Meldungen (Alarm_S/SQ bzw. Alarm_D/DQ) von einem Projekt zum anderen kopieren können, ohne dass Sie das gesamte Projekt kopieren bzw. die Bausteine in dem neuen Projekt vorher löschen müssen.
 
Nr. Vorgehensweise
1

Sie können die benötigten Bausteine mit den Meldungen über die Funktion "Quelle generieren" in Ihren Quellordner legen. Öffnen Sie den entsprechenden Baustein (FB/FC) und generieren Sie eine Quelle über "Datei > Quelle generieren...". Die S7-PDIAG-Meldungsprojektierung wird beim Erzeugen der Quelle als grüner Code an die Quelle angehängt (Bild 01).


Bild 01

2

Kopieren Sie die Quelle in den Quellordner des neuen zu bearbeitenden Projektes.

3 Übersetzen Sie die Quelle im Quellordner des neuen zu bearbeitenden Projektes. Hierzu haben Sie zwei Möglichkeiten:
  • markieren Sie die Quelle im Quellordner und klicken Sie auf die rechte Maustaste. Wählen Sie im folgenden Kontextmenü "Übersetzen".
     
  • öffnen Sie die Quelle und übersetzen Sie die Quelle im Editor über "Datei > Übersetzen".

Nun haben Sie auch die Meldungen in Ihrem neuen Projekt und können die Bausteine beliebig verändern.

Hinweis:
Es ist nicht möglich, nur die Meldungen zu kopieren, da die Meldungen der logischen Struktur des Projektes angehören und keine eigenständige Datei sind.

Diese Anleitung wurde mit S7-PDIAG V5.3 erstellt.

Warum sollten die Bausteine FB0 und FC0 bei der Projektierung mit S7-PDIAG nicht verwendet werden?zum Beginn
Bestellnummer:

Beschreibung:
Die Verwendung der Bausteine FB0 und FC0 mit dem Bausteinattribut "s7_pdiag=true" in den Bausteineigenschaften ist systembedingt nicht erlaubt. Somit sollte die Nummer "0" für die Funktionsbausteine und Funktionen bei der Projektierung mit S7-PDIAG nicht verwendet werden.
Bild 01 zeigt die unterschiedliche Darstellung bei der Übersetzung in S7-PDIAG zwischen der Projektierung mit FB1 und FC1 und der Projektierung mit FB0 und FC0.


Bild 01

Die Funktionen FC0 und FC1 sowie die Funktionsbausteine FB0 und FB1 enthalten jeweils den gleichen Programmcode. Nach den Übersetzungen wird der Warnhinweis zur Erstwerterfassung für den Merker M1.1 vom Baustein FB0 nicht angezeigt (0 Warnungen). Außerdem fehlen bei den Bausteinen FB0 und FC0 die Namen der Objekte, diese werden dann nur mit " dargestellt.

Abhilfe:
Um das oben beschriebene Verhalten zu vermeiden, ist das Umbenennen der Bausteine FB0 und FC0 erforderlich, z.B. in FB2 und FC2. Außerdem empfehlen wir Ihnen, den ursprünglich erzeugten Instanz-DB vom FB0 zu löschen und für den umbenannten Funktionsbaustein (z.B. FB2) neu zu erzeugen.

Diese Beschreibung wurde mit S7-PDIAG V5.1 und V5.3 verifiziert.

Wie kann die fehlende Gelbmarkierung für die zu überwachenden Operanden im KOP AWL FUP Editor wieder aktiviert werden?zum Beginn
Bestellnummer:

Anleitung:
In der nachstehenden Tabelle ist die Vorgehensweise beschrieben, wie nach der Projektierung der zu überwachenden Operanden bei der STEP 7 Version V5.3 SP2 (Service Pack 2) und der S7-PDIAG Version V5.1 die Gelbmarkierung aktiviert werden kann.
 
Nr. Vorgehensweise
1 Nach der Projektierung der Prozessdiagnose für die Operanden kann es vorkommen, dass die Gelbmarkierungen fehlen, obwohl im Detailregister "Diagnose" die Fehlerdefinitionen (z.B. Operandenüberwachungen wie im Bild 01) dargestellt sind.


Bild 01

2 Aktivieren Sie die "Operandenkennzeichnung" im KOP AWL FUP Editor über "Ansicht > Anzeigen mit > Operandenkennzeichnung".


Bild 02

3 Nach dem Aktivieren der "Operandenkennzeichnung" erscheint sofort die Gelbmarkierung.


Bild 03

Warum werden die Diagnosedaten nur mit "#####" am MP370 angezeigt?zum Beginn
Bestellnummer:

Beschreibung
Wenn zur Darstellung eines Textwertes ein Begleitwert aufgerufen wird und dieser Begleitwert in S7-PDIAG nicht aktiviert ist, werden die mit S7-PDIAG erstellten Diagnosedaten mit "#####" am MP370 angezeigt (Fehlercode: #####@#####).

Abhilfe:
Überprüfen Sie im Überwachungsdialog für den entsprechenden Operanden (z.B. "S7-PDIAG: Operandenüberwachung" gemäß Bild 01), ob die Option "Begleitwert erfassen" aktiviert ist.


Bild 01

Nach dieser Änderung müssen Sie die Prozessdiagnoseinformationen in S7-PDIAG noch mal neu übersetzen.

 Beitrags-ID:21692495   Datum:2009-08-24 
Dieser Artikel...hat mir geholfenhat mir nicht geholfen                                 






























mySupport
My Documentation Manager 
Newsletter 
CAx-Download-Manager 
Support Request
Zu diesem Beitrag
Drucken
PDF erstellen 
Beitrag versenden
QuickLinks
Kompatibilitäts-Tool 
Hilfe
Online Hilfe
Guided Tour