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Based on a concrete example, this primer guides you through five steps in which you install and start up a
functioning application with which you can execute a travel operation via channel 1 and then try out and
test the basic hardware and software functions of your FM 451 and obtain and check the
application-dependent parameters. The references to the manual will also help you to get a general
overview of the information it contains.

Depending on your degree of experience, working through the sample will take between one and two
hours.

Requirements
The following requirements must be met:

� You have an S7-400 station consisting of a power supply and a CPU.

� You have installed STEP 7 (≥V4.02) correctly on your programming device. Please note, however, that
the instructions below relate to STEP 7 (V5.0).

� You have created a project for the S7-400 station.

� The programming device is connected to the CPU.

� You have an FM 451 module, the configuration package belonging to the FM 451, an external 24 V DC
power supply, an encoder, a drive, and the required accessories such as front connectors, and wiring.

� To protect both your equipment and personnel, you have provided hardware limit switches and an
EMERGENCY STOP switch.

Install the Configuration Package on the Programming Device
The configuration package contains the configuration software for the FM 451, the required functions
(FCs) and the data structures (UDTs) as well as a sample project with sample programs.

Insert the CD in your CD drive.

Start the software installation dialog in Windows by double-clicking the “Add/Remove Programs” icon in
the “Control Panel”.

Click the Install... button, select the Setup.exe file in the FMx51\Disk1 folder on the CD and follow the
instructions displayed by the installation program.

Install and Wire up the FM 451
Turn off the power supply and change the mode selector on the CPU to STOP.

Hook the top of the FM 451 onto the intended slot in the rack, swing it down and secure it with screws (for
more detailed information, refer to Chapter 3 of the manual).

Wire up the front connector as shown in the following picture (the full pinout of the front connector is
described in Chapter 4.3 of the manual).
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Plug in the wired-up front connector on the FM 451 and screw it securely.

Connect your encoder to the “ENCODER CH1” sub-D connector: Whenever possible, use a
preassembled connecting cable (refer to Appendix B of the manual; the complete pinout of the sub-D
connector is described in Section 4.1 of the manual).

Test: Turn on the power supply module and the external 24 V DC power supply. The red LED EXTF of
the FM 451 is lit briefly and then goes off. The red LED INTF remains on since the FM 451 has not
yet been entered in the hardware configuration.

Set the Parameters for the FM 451
Open your project in the SIMATIC Manager.

Open the HW Config configuration table in your project.

Select the FM 451 with the correct order number from the hardware catalog and drag it to the slot you
want to use in your hardware configuration. Note down the module address. You require this value for
your user program.

By double-clicking on this FM 451, you open the window “Positioning Module – [FM 451 FIX. SPEED
(slot) (parameter assignment) –– project name\station name]” of the configuration software.

Select the following settings in the parameter assignment dialogs (please leave all other settings
unchanged since they are not yet required during the commissioning phase):

� Channel: 1 (you have only wired up this channel)

� System of units: mm (3 decimal places)

� Drive: Control mode: 1

Target range: 1.000 mm

Monitoring time: 2000 ms

Stationary range: 1.000 mm

Stationary speed: 30.000 mm/min

Switchover difference plus: > Switch-off difference plus

Switchover difference minus: > Switch-off difference minus

Switch-off difference plus: > 1/2 x target range

Switch-off difference minus: > 1/2 x target range

The correct values for the switchover difference plus, switchover difference minus,
switch-off difference plus and switch-off difference minus for your particular system are
obtained following the basic parameter assignment and can then be adapted to the
requirements of your system.

� Axis Linear axis/rotary axis: Application-dependent

Software limit switch: Application-dependent

End of the rotary axis: Application-dependent

� Encoder Encoder type: Select the type of encoder you are using.

All further encoder settings depend on 
the encoder used and your equipment.

Enter the parameter settings for the FM 451 with File > Save in your configuration and close the
configuration software with File > Exit.

Save the configuration you have created with Station > Save and Compile in your project.

Transfer the configuration with the CPU in the STOP mode with PLC > Download to module....



The data are then transferred directly to the CPU and the FM 451. The LED INTF on the FM 451 goes off.
From now on, as long as the configuration on the CPU remains battery backed, the data will always be
transferred from the CPU to the FM 451 whenever the CPU changes from STOP to RUN.

Test the FM 451
Double-click the FM 451 again in HW Config to open the window “Positioning Module –
[FM 451 FIX. SPEED (slot) (parameter assignment) –– project name\station name]”.

Select Test > Commissioning to open the commissioning dialog [FM 451 FIX. SPEED (slot)
(Commissioning) –– project name\station name]”.

For “Operating mode” select the “Jogging” setting and enter the required speed (rapid or creep).

Click the “On” button for “Drive Enable”. As a reaction to this setting, the “Start enable” indicator in the
commissioning dialog is displayed in green. If you have not wired the enable input on the FM 451, activate
the option “Do not evaluate enable input” under the “Function Switches” of the “Further Test Functions”
and click the “Apply” button.

Click the DIR_M or DIR_P button: The drive moves as long as you hold down the mouse button. You can
now monitor the actual value and the actual speed.

Note:  The actual value changes according to the direction selected: DIR_M (move in a minus direction) or
DIR_P (move in a plus direction). If the count direction is incorrect, open the “Encoder” window in the
“Change Parameters for” group box and change the count direction from “normal” to “inverted”. You can
download the changed setting to the CPU and the FM 451 with PLC >  Download Channel > 1. The
displayed actual speed for the rapid speed and creep speed indicates whether or not the digital outputs of
the FM 451 are correctly wired up.

If errors occur during the test, these are indicated by the “Error” display. You can acknowledge these
errors with Test > Error Evaluation and then continue with the test.

To allow correct positioning, you must now adapt the switchover differences and switch-off differences to
your system.

Select the “Absolute Incremental Approach ” setting for the “Operating Mode” and enter the number 255
as the “Incremental dimension number”. The boxes “Incremental dimension”, “Switchover difference” and
“Switch-Off difference” are displayed. In the “Incremental Dimension” box, enter a positive value for the
location at which you want to position. In the switchover difference and switch-off difference boxes, enter
the values set as defaults in the drive dialog. Make sure that the incremental dimension you select is
higher than the switchover and switch-off difference.

In “Further Test Functions” select the “Set Reference Point” setting, enter 0.000 mm as the reference
point and click the “Apply” button. The axis is then synchronized. The message “Channel Synchronized” is
displayed.

Select “Further Test Functions > Function Switches > Do Not Evaluate Enable Input” and click the “Apply”
button.

Activate the drive enable. The message “Start Enable” is displayed. When you click the “Start” button, the
axis starts to move to the specified incremental dimension. The “remaining distance” and “position
reached - hold” LEDs indicate the accuracy of the positioning.

By reducing or increasing the switchover and switch-off difference, you can improve the accuracy of the
positioning. You can also obtain the “position reached - hold” signal by increasing the target range.
Change the parameters until you obtain the “position reached - hold” signal and the actual value of the
positioning is close enough to the incremental dimension. Note down the current settings for the positive
switchover and switch-off difference.

To obtain the negative switchover and switch-off difference, select a negative incremental dimension.

Select “Change Parameters For > Drive” to open the window with the drive parameters and enter the
values you obtained by trial and error for the appropriate parameters.

Enter the settings with File > Save and close the configuration software with File > Exit.

Save the configuration you have created with Station > Save and Compile in your project.

Transfer the configuration with the CPU in the STOP mode with PLC > Download to module....



Linking into your User Program

Open the FMx51LIB in the library in the SIMATIC Manager with File > Open... > Libraries.

Copy FC0, FC1 and UDT1 from the blocks folder of the FMx51LIB library to the “Blocks” folder of your
project.

Select the menu command Insert > S7 Block > Data Block and insert DB1 in the “Blocks” folder of your
project and then select the menu command Insert > S7 Block > Organization Block and insert OB100.

Open DB1 and create it with the assigned user-defined data type UDT1. This creates the channel DB.

Select View→ Data View and enter the decimal module address in the “Actual Value” column of the
MOD_ADDR parameter and the channel number 1 for the CH_NO parameter in DB1.

Save DB1 with File > Save and close the DB editor with File > Exit.

Now open OB100 and OB1 in your project. Call FC0 in OB100 and FC1 in OB1 and supply the FCs with
parameters (refer to the manual, Section 6.2 or 6.3):

OB100:

CALL  FC0
DB_NO    := 1

OB1:

CALL  FC1
DB_NO    := 1
RET_VAL := MW0

Save both OB100 and OB1 with File > Save.

Select the blocks FC0, FC1, DB1, OB1 and OB100 in your project.

Download the your program to the CPU with PLC > Download.

Test: Using “Monitor/modify variables” you can now monitor the selected channel as follows:

Create a symbol with the name “ABS” for DB 1 using the symbol editor.

Select the “Blocks” folder in your project. Using the menu command Insert > S7 Block > Variable
Table  insert the variable table VAT 1 and confirm with OK.

Open the variable table VAT1 and make the following entries in the  “Symbol”, “Monitor Format” and
“Modify Value” columns:

Address Symbol Mon
Format

Mon
Value

Modify
Value

Meaning

DB1.DBX 22.3 ABS.OT_ERR BIN 0 Operator error occurred

DB1.DBX 14.3 ABS.OT_ERR_A BIN 0 Acknowledge operator error

DB1.DBX 15.0 ABS.START BIN 0 Start positioning

DB1.DBX 15.1 ABS.STOP BIN 0 Stop currently active traverse

DB1.DBX 15.2 ABS.DIR_M BIN 0 Direction minus

DB1.DBX 15.3 ABS.DIR_P BIN 1 Direction plus

DB1.DBX 15.7 ABS.DRV_EN BIN 1 Enable drive on

DB1.DBX 34.2 ABS.EI_OFF BIN 1 Do not evaluate enable input

DB1.DBB 16 ABS.MODE_IN DEC 1 Requested mode: 1 = jogging

DB1.DBB 17 ABS.MODE_TYPE DEC 1 Initial speed for jogging

DB1.DBD 26 ABS.ACT_POS DEC Current position of the axis



Save the variable table VAT 1 with Table > Save.

Switch to online with  PLC > Connect to > Configured CPU.

Switch to monitoring with  Variable > Monitor.

!
Caution

With the next two steps in the test you start the drive.

You can stop the drive again in one of the following ways:

� Set the control value for the direction to 0 again and activate it

� Set the control value for the drive enable to 0 again and activate it

� Change the CPU to the STOP mode

Change the CPU to RUN-P.

With  Variable > Activate Modify Values, you make the modify values valid.

The drive is started. In the “Modify Value” column, you can now monitor the current actual value
(ACT_POS)  of the position.

Diagnostics
Errors can occur due to incorrect operator input, incorrect wiring, or conflicting parameter settings.

How to analyze such errors and messages is described in Section 6.4 and Chapter 11 of the manual.

Example
The project zEn18_01_FMx51 contains further samples that you can use as a basis and adapt to your
application. 
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