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Safety Guidelines 

This manual contains notices intended to ensure personal safety, as well as to protect the products and 
connected equipment against damage. These notices are highlighted by the symbols shown below and 
graded according to severity by the following texts: 

 

!  
Danger 
indicates that death, severe personal injury or substantial property damage will result if proper 
precautions are not taken. 

 

!  
Warning 
indicates that death, severe personal injury or substantial property damage can result if proper 
precautions are not taken. 

 

!  
Caution 
indicates that minor personal injury can result if proper precautions are not taken. 

 
 Caution 

indicates that property damage can result if proper precautions are not taken. 
 

 Notice 
draws your attention to particularly important information on the product, handling the product, or to a 
particular part of the documentation. 

Qualified Personnel 

Only qualified personnel should be allowed to install and work on this equipment. Qualified persons 
are defined as persons who are authorized to commission, to ground and to tag circuits, equipment, and 
systems in accordance with established safety practices and standards. 

Correct Usage 

Note the following: 
 

!  
Warning 
This device and its components may only be used for the applications described in the catalog or the 
technical description, and only in connection with devices or components from other manufacturers 
which have been approved or recommended by Siemens. 
 
This product can only function correctly and safely if it is transported, stored, set up, and installed 
correctly, and operated and maintained as recommended. 

Trademarks 

SIMATIC®, SIMATIC HMI® and SIMATIC NET® are registered trademarks of SIEMENS AG.  

Third parties using for their own purposes any other names in this document which refer to trademarks 
might infringe upon the rights of the trademark owners. 
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Preface 

Purpose of the manual 
The goal of this description is to give you an overview of working with 
SIMATIC iMap using practical automation tasks.  

Required basic knowledge 
You require a general knowledge of automation to understand this manual.  

Validity of this manual 
This manual is valid for the software package SIMATIC iMap V2.0. 

Your guide through the manual 
This manual contains: 

• a description of the automation task 

• a brief description of creating a PROFInet component 

• the general procedure during plant configuration, online monitoring and process 
data visualization. 

Place of this documentation in the information environment 
This manual is part of the SIMATIC iMap documentation package. The 
documentation is supplied with the software and includes the electronic manuals in 
PDF format: 

• Component-based automation, configuring plants with SIMATIC iMap  

• Getting Started with SIMATIC iMap � this manual 

• Commissioning Systems, Tutorial 

• Creating PROFInet Components 

In addition, the entire documentation is available as an HTML Basic Help. 

Conventions 
Menu commands are written in bold letters, for example: Project> Save. 
Placeholders are set in angle brackets, for example <File name>. 
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Further support 
Please contact your local SIEMENS partner if you have any further queries on the 
products described in this manual.  

http://www.siemens.com/automation/partner 

http://www.ad.siemens.de/cba/ 

Training centers  
To give you an easy start with SIMATIC iMap, we offer corresponding courses. 
Please contact your local training center or the central training center in D 90327 
Nuremberg.  
Phone: +49 (911) 895-3200  
Internet: http://www.sitrain.com 

 

http://www.siemens.com/automation/partner
http://www.ad.siemens.de/cba/index_76.htm
http://www.sitrain.com
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A&D Technical Support 
Open round the clock, worldwide:  

  

Beijing 

 Nuremberg

Johnson City 

  
Worldwide (Nuernberg) 
Technical Support  
 

24 hours a day, 365 days a year 

Phone: +49 (180) 5050-222 

Fax: +49 (180) 5050-223 

E-Mail: adsupport@
 siemens.com 

GMT: +1:00 

  

Europe / Africa (Nuernberg) 
Authorization 
 
Local time: Mon.-Fri. 8:00 to 5:00 PM 

Phone: +49 (180) 5050-222 

Fax: +49 (180) 5050-223 

E-Mail: adsupport@
 siemens.com 

GMT: +1:00 

United States (Johnson City) 
Technical Support and 
Authorization 
Local time: Mon.-Fri. 8:00 to 5:00 PM 

Phone: +1 (423) 262 2522 

Fax: +1 (423) 262 2289 

E-Mail: simatic.hotline@ 

 sea.siemens.com 

GMT: -5:00 

Asia / Australia (Beijing) 
Technical Support and 
Authorization 
Local time: Mon.-Fri. 8:00 to 5:00 
PM 

Phone: +86 10 64 75 75 75 

Fax: +86 10 64 74 74 74 

E-Mail: adsupport.asia@ 

 siemens.com 

GMT: +8:00 

The languages of the SIMATIC Hotlines and the authorization hotline are generally German and English. 
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Service & Support on the Internet 
In addition to our documentation services, we also offer you our knowledge base 
on the Internet. 
http://www.siemens.com/automation/service&support 

Here, you will find: 

• the newsletter which constantly provides you with up-to-date information about 
your products. 

• your appropriate documentation via our Service & Support search engine 

• a forum for the exchange of information between users and specialists 
worldwide 

• your local Automation & Drives partner via our partner database. 

• information on repairs, replacement parts and on-site service. You will find 
more information under "Services�. 

 

 

http://www.siemens.com/automation/service&support
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Getting Started - Introduction 1
Aims and Target Groups 

These instructions are intended to provide an overview of working with SIMATIC 
iMap based on actual automation tasks.  

These instructions can be subdivided into two groups of tasks: 

 
Task Target group 

Creating PROFInet components with 
SIMATIC iMap STEP 7 add-on 

Plant and machine constructors 

• Planning and commissioning a plant with 
SIMATIC iMap  

• Visualizing and analyzing process data 

Plant planners and operators 

Description of the automation task 

4

1 2 3 6

5

Machine 2Machine 1

Engineering and

Visualization

ProcessingConveyor Conveyor Scanning

Coordinator

CPU 317-2 PN/DP

 
Figure 1-1 Automation task 

In the machining station of a machine, workpieces are fed in (1), machined (2) and 
then removed (3). An upstream controller (4) coordinates the individual partial 
functions, and makes the necessary data available via integral operator monitoring 
and control functions (5). The machined workpieces are then moved on to a 
second machine (6). The number of transported workpieces should also be 
recorded on the analysis PC (5). 
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Steps of the solution 
The automation task can be broken down into individual steps of the solution, from 
analysis of the plant through to analysis of the process data. These tasks are 
generally carried out by different users, each using the necessary software. 

You can also select and edit individual steps for this example project when such 
steps are relevant for your specific tasks. 

Table 1-1 Steps of the solution for the automation task 

Steps Tasks Users Software 

Step 1 Defining PROFInet 
components 

Component creator - 

Step 2 Creating PROFInet 
components 

PLC programmers,  
STEP 7 users, 

STEP 7 

Step 3 Importing PROFInet 
components into a library 

Planners, commissioning 
engineers and plant operators 

SIMATIC iMap 

Step 4 Inserting PROFInet 
components into the 
project 

Planners, commissioning 
engineers and plant operators 

SIMATIC iMap 

Step 5 Assigning addresses Planners, commissioning 
engineers and plant operators 

SIMATIC iMap 

Step 6 Interconnecting 
technological functions 

Planners, commissioning 
engineers and plant operators 

SIMATIC iMap 

Step 7 Generating and 
downloading 

Planners, commissioning 
engineers and plant operators 

SIMATIC iMap 

Step 8 Diagnostics Planners, commissioning 
engineers and plant operators 

SIMATIC iMap 

Step 9 Visualizing and analyzing 
process data 

Plant operators, analysis level 
(instrumentation and control) 

SIMATIC iMap, 
OPC Server 
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Additional information 
The following illustration shows you where to find additional information about 
SIMATIC iMap and related topics. 

 
Figure 1-2 Notes 

 
Information Address (URL) 

SIMATIC Manual Collection http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.c
sinfo&lang=en&objId=12283375&lang=en  

SIMATIC Service and Support http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.c
sinfo2&siteid=cseus&lang=en  

Next Steps 
You can get started with SIMATIC iMap in the following ways: 

 
If you want to learn about... Read ... 

How to create PROFInet components Steps 1 and 2 

How to plan a plant with SIMATIC iMap  Steps 3 to 8 

How to visualize and analyse process data Step 9 

 

http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo&lang=en&objId=12283375&lang=en
http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo2&siteid=cseus&lang=en
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Step 1: Defining PROFInet Components  2
2.1 Dividing Plants into Modules 

Dividing the Plant into Technological Modules 
Before you can create PROFInet components using STEP 7 and interconnect the 
associated technological functions in SIMATIC iMap, you must first break down the 
plant into reusable modules. These technological modules should form a single 
unit consisting of electrical, mechanical and control functions. The plant described 
in the automation task section can be broken down as follows: 

4

1 2 3

5

6

Processing

CPU 314C-2 DP

Processing Scanning

Conveyor_1

ET 200X

Conveyor_2

ET 200X

Scan

ET 200S

Coordinator

CPU 317-2 PN/DP

Machine 1 Machine 2

Engineering and

Visualization

 
Figure 2-1 Dividing the plant into technological modules 
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Machine 1 

Table 2-1 Technological module, Machine 1 

Modules Designation Stations 

Coordination station 
(4) 

Coordinator PROFIBUS master: CPU 317-2 PN/DP 

Transport module  
(1) and (3) 

ET200X_Conveyor Intelligent DP slave: SIMATIC ET 200X with 
basic module BM 147/CPU 

Processing station 
(2) 

Processing PROFIBUS slave: CPU 314C-2 DP as 
intelligent DP slave 

 

Machine 2 

Table 2-2 Technological module, Machine 2 

Modules Designation Stations 

Transport module 

like (1) and (3) 

ET200X_Conveyor Intelligent DP slave:  

SIMATIC ET 200X with basic module BM 
147/CPU 

Scan station (6) ET200S_Scan Intelligent DP slave:  

ET 200S with interface module IM 151/CPU 

Network gateway IE/PB Link Network gateway Industrial Ethernet / 
PROFIBUS IE/PB Link  

Machine 2 is listed for the sake of completeness and is not mentioned further in the following 
descriptions. 

Analysis and Visualization  

Analysis and visualization of the process data is performed on the engineering PC 
(5) on the Industrial Ethernet. 



Step 1: Defining PROFInet Components 

Getting Started with SIMATIC iMap 
A5E00248810-01 2-3 

Configuration of the plant 
The following illustration shows the configuration of a plant for the described 
automation task.  

Scan
ET 200S

Coordinator
CPU 317-2 PN/DP

Conveyor
ET 200X

Conveyor
ET 200X

Conveyor
ET 200X

IE/PB Link

Processing
CPU 314C-2 DP

Industrial Ethernet

PROFIBUS 1

PROFIBUS 2

Machine 1
Processing

Machine 2
Scanning

Engineering and
Visualization

Figure 2-2 Configuration of the plant from the example project 
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Reusable modules 
Breaking down the plant gives the following reusable modules: 

• One coordination station 

• Several transport modules 

• One machining station 

• One scan station. 

PROFInet components must be created for these modules. 

The next step is to define the devices and technological functions for the PROFInet 
components of Machine 1 to be created. 
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2.2 Defining Devices and Technological Functions 

Devices and component interfaces of the modules 
Once you have identified the modules in the plant, you can then define the 
component interfaces, sometimes referred to as PROFInet interfaces. In STEP 7, 
the component interface of a PROFInet component is implemented by the interface 
DB that determines the connections between PROFInet components in SIMATIC 
iMap.  

Interface definitions for the Coordinator, Processing and ET200X_Conveyor 
components are needed for the plant described in the automation task.  

Component coordinator 

Table 2-3 Component interface of the coordinator component 

Name Type Initial value Description 

Inputs    

ON BOOL FALSE Off/On pulse 

Ext_Stop BOOL FALSE External Stop signal (e.g. via HMI) 

Counter_In DINT 0 Number or workpieces 

Data_In STRUCT default Input data from another coordinator 

The data is transmitted as a structure 
with 2 elements. 

Ext_Delay INT 0 Conveyor switch-off delay, variable, 
e.g. via HMI 

Outputs    

StandBy BYTE 0 Display of the standby mode  

Ext_OStop BOOL FALSE Stop signal to next device 

Counter_Out DINT 0 Number of workpieces (looped-through 
input Counter_In) 

Data_Out STRUCT default Output data to another coordinator 

The data is transmitted as a structure 
with 2 elements. 

Delay INT 0 Control signal for shutdown delay of 
the conveyor 

Running BOOL FALSE Display of the operating mode (for 
HMI) 

 

The coordinator contains the upstream functions of a plant. It is switched on and off 
at the On input. An emergency-off signal can be connected to the Ext_Stop input. 
The number of workpiece in processing is entered at the Counter_In input. The 
number is made available for other purposes at the Counter_Out output. 

The device is a CPU 317-2 PN/DP serving as a PROFInet device with proxy 
functionality. The device has a PROFInet connector on the Industrial Ethernet and 
a PROFIBUS connector as DP master. 
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ET200X_Conveyor Component 
The conveyor is a conveyor element that transports workpieces at a certain speed 
in one direction. It has a sensor on both the input and the output side. 

Table 2-4 Component Interface of the ET200X_Conveyor Component 

Name Type Initial value Description 

Inputs    

Ext_Start BOOL FALSE External Start signal (e.g. via HMI) 

Ext_Stop BOOL FALSE External Stop signal (e.g. via HMI) 

Run_Delay BOOL FALSE Shutdown delay  

Counter_In DINT 0 Number or workpieces 

Outputs    

Start_Next BOOL FALSE Start next conveyor  

Running BOOL FALSE Display of the conveyor mode 

Counter_Out DINT 0 Number of workpieces (looped-through 
input Counter_In) 

 

The device is an ET 200X with a basic module BM 147/CPU that acts as an 
intelligent DP slave on the PROFIBUS. 

Component processing 
The processing station stops the conveyor. The cylinder then moves to the work 
position and then returns to the idle position once the processing time has finished. 
The conveyor is then released. 

Table 2-5 Component interface of the processing component 

Name Type Initial value Description 

Inputs    

Ext_Start BOOL FALSE External Start signal (e.g. via HMI) 

Ext_Stop BOOL FALSE External Stop signal (e.g. via HMI) 

Run_Delay BOOL FALSE Shutdown delay 

Proc_In DINT 0 Number of workpieces to be processed

Outputs    

Start_Next BOOL FALSE Start next conveyor  

Running BOOL FALSE Display of the operating mode 

Proc_Out DINT 0 Number of processed workpieces 
(looped-through input Proc_In) 

Processing BOOL FALSE Display of the processing mode 

 

The device is a CPU 314C-2 DP as an intelligent DP slave on the PROFIBUS. 
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Interconnection diagram 

Figure 2-3 Interconnection diagram 

Next Steps 
• If you want to create your own PROFInet components using STEP 7, go to  

Step 2. 

• If you prefer to design a plant with SIMATIC iMap using preassembled 
PROFInet components, go to Step 3. 
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Step 2: Creating PROFInet Components 
with STEP 7 3
3.1 Basic Procedure for Creating a PROFInet Component 

 

 Note 
The "Creating PROFInet Components with STEP 7" chapter is only relevant to 
users who create their own PROFInet components.  

Which PROFInet components are created? 
Three PROFInet components need to be created for Machine 1 in the example 
project.  

Table 3-1 PROFInet components for the example project 

Creating 
PROFInet 

components from 
... 

Device type Function Designation of the 
PROFInet 

component 

CPU 317-2 PN/DP PROFInet device with 
proxy functionality (DP 
master)  

Plant controller Coordinator  

ET 200X  
with BM 147/CPU 

PROFIBUS device 
(intelligent DP slave) 

Workpiece feeder ET200X_Conveyor 

CPU 314C-2 DP PROFIBUS device 
(intelligent DP slave) 

Workpiece 
machining 

Processing 

Requirement 
The devices and functions of the technological modules must be defined. 
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Basic procedure 
The PROFInet components are created using STEP 7. Carry out the following 
basic steps: 

1. In SIMATIC Manager, create a basic project for a PROFInet component and 
configure the station hardware in HW Config.  

2. Create the interface DB for the component interface.  

3. Create the S7 program.  

4. Create the PROFInet component using a menu command and save it in a 
directory.  

Tip: Procedure with STEP 7 example projects  
You can find example projects for the described automation task in the directory 
Step7\Examples\. This completes steps 1 to 3 as described above for this project. 
You can open and view individual blocks of the STEP 7 projects supplied but you 
do not have to copy any blocks or type out sections of the program. 

Next Steps 
Creating a PROFInet "Coordinator" component based on the example of a CPU 
317-2 PN/DP. The STEP 7 example project for the "Coordinator" component is 
located in the directory Step7\Examples\ZDT27_01. 
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3.2 Creating a PROFInet Component Based on an Example of a CPU 
317-2PN/DP 

Creating the PROFInet "Coordinator" component for coordination of Machine 1.  

Content of the PROFInet component 
The PROFInet "Coordinator" component contains:  

PROFInet component PROFInet device Technological function 

Coordinator SIMATIC 300 station with 
CPU 317-2 PN/DP 

(PROFInet device with 
proxy functionality) 

Coordination of Machine 1 

(S7 program with the component 
interface)  

How to configure the hardware 
 

Task Procedure 

1. Create a project in SIMATIC Manager and insert a SIMATIC 300 station with the name 
"Coordinator". 

2. Configure the hardware based on the following illustration: 

 
Note: The DP master system (X1) must be connected to a network. 
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How to create the interface DB 
 

Task Procedure 

1. In SIMATIC Manager, mark the "Coordinator" station and then select the Create PROFInet 
Interface command from the context menu. 

 
The "New/Open PROFInet Interface" dialog opens. 

2. Select CPU 317-2 PN/DP in the left window of the "New/Open PROFInet Interface" dialog. 
Activate the "New" option and confirm this by pressing the "OK" button.  

Result: The properties dialog of the newly created block opens. 

3. In the "Name and type" field, enter the desired block number, DB100 for example, and select 
the block type, "Global DB".  

Confirm by clicking on the "OK" button. Result: The interface DB is opened in the PROFInet 
Interface Editor. 



Step 2: Creating PROFInet Components with STEP 7 

Getting Started with SIMATIC iMap 
A5E00248810-01 3-5 

Task Procedure 
4. Enter the inputs of the technological function in the PN Input section and assign the entries the 

required properties: Name, Data type, Connectable, HMI/MES, as shown in the following 
illustration:  

 
The Data_In structure is marked in the picture. 

Result: The interconnectable connections are graphically display in the right window of the 
Interface Editor as in the plant view of SIMATIC iMap. 

5. Enter the outputs of the technological function in the PN Output section and assign the entries 
the required properties: Name, Data type, Connectable, HMI/MES, as shown in the following 
illustration: 

 
The Data_Out structure is marked in the picture. 

Result: The interconnectable connections are graphically display in the right window of the 
Interface Editor as in the plant view of SIMATIC iMap. 
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Task Procedure 
 The PROFInet interface (technological function) is displayed in the right window of the 

Interface Editor: 

6. Save the PROFInet interface DB using the menu command File > Save.  

7. Close the PROFInet interface DB using the menu command File > Close. 
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Additional information... 
about the interface DB can be found under "Properties of the Interface DB" in the 
SIMATIC iMap or SIMATIC Manager basic help. 

How to create the S7 program  
 

Task Procedure 

1. Copy all blocks from the "CPU 317-2 PN/DP" block folder of the PROFInet System Library into 
the block folder of the CPU. 

2. Create the program. The following is an example based on a section from OB1. You can see 
the reference to the PROFInet interface DB there. The sources can be found in the completed 
STEP 7 example project. 

�  

//enable component 
A "PN_Interface_DB".On 
JCN noon 
= "PN_Interface_DB".Standby 

//forward HMIStop to Ooutput HMIStop 
A "PN_Interface_DB".Ext_StoP 
= "PN_Interface_DB".Ext_Ostop 

//increments OCnt if Cnt==Ocnt 
L "PN_Interface_DB".Counter_In 
L "PN_Interface_DB".Counter_Out 
<>D  
JC GO 
L "PN_Interface_DB".Counter_Out 
L 1 
+D 
T "PN_Interface_DB".Counter_OutGO: NOP 0 

�  

3. Compile and test the S7 program. 
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How to create the PROFInet component 
 

Task Procedure 

1. In SIMATIC Manager, mark the "Coordinator" station and then select the Create PROFInet 
Component command from the context menu. 
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Task Procedure 
2. In the "General" tab, mark the option "Identification" and enter the following name: 

"Coordinator�. 
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Task Procedure 
3. In the "Component type" tab, select "Standard component with proxy functionality" and 

"Updating PN interfaces automatic (at cycle control point)". 
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Task Procedure 
4. In the "Storage areas" tab, enter the desired path, for example, D:\cba_tutorial (D stands for 

a drive of your choice). 
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Task Procedure 
5. In the "Additional properties" tab, enter the path of the icon files and optionally the path of the 

documentation link. 

You can use the supplied icons as needed (default path: Step7\s7data\s7cbac1x). 

 Result: The PROFInet component is saved as an XML file at the specified location and the 
archived component project is saved. 

 

 Note 
The completed PROFInet component can be found in the installation directory of 
the tutorial under  

\CBA_Tutorial\PROFInet_Components\coordinator-{...} 

We recommend this as a basis for the next steps to ensure correct performance of 
the tutorial examples. 

Next Steps 
You can create the PROFInet "ET200X_Conveyor" and "Processing" components 
by repeating the steps described above. 

Then you can configure the plant using SIMATIC iMap. 
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Example: "ET200X_Conveyor" component from an ET 200X 
The STEP 7 example project is located in the directory 
\Step7\Examples\ZDT27_07. 

The PROFInet interface is shown in the following illustration. 

Example: "Processing" Component from a CPU 314C-2 DP 
The STEP 7 example project is located in the directory 
\Step7\Examples\ZDT27_04. 

The PROFInet interface is shown in the following illustration. 
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Steps 3 to 6: Configuring a Plant with 
SIMATIC iMap 4
4.1 Step 3: Importing PROFInet Components into a Library 

Before you can edit the PROFInet components in the example project, you must 
first import them from the file system into a SIMATIC iMap library.  

Requirements  
• SIMATIC iMap must be installed on your PC/PG. 

• The PROFInet components have been created and stored in the file system or  

• the path to the off-the-shelf PROFInet components is already known, generally 
Programs\Siemens\iMap\examples\components. 

Alternative procedures 
There are two ways to insert PROFInet components from the example project into 
a SIMATIC iMap project: 

• Create a new project in SIMATIC iMap, then import the PROFInet components 
created in STEP 7 from the file system into the project library. 

or 

• Open the supplied "Tutorial_Lib" library with the preassembled PROFInet 
components. 
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How to import PROFInet components into the project library 

Table 4-1 Importing components into the project library 

Step Description 

1. Start SIMATIC iMap. Select Start > Programs > Component based 
Automation > SIMATIC iMap or click on the iMap icon on the desktop.  

2. In SIMATIC iMap select the menu command  

Project > New to create a new project. 

When a new project is created, the corresponding project library is also opened. 
You import the required PROFInet component into this project library.  

3. In the project library window, select the command Import components... from 
the context menu. 

4. Under �Search in�, select the path Programs\Siemens\iMap\components. 
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Step Description 
5. Select the "coordinator.xml" file from the "Coordinator..." folder. Click on the 

"Open" button to confirm your entry. 

 The "Coordinator" PROFInet component is imported into the library and 
displayed as an icon. 
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Step Description 
6. Repeat steps 3 to 5 with the ET200X_Conveyor" and "Processing" PROFInet 

components. Now all the required PROFInet components have been imported 
into the project library. 

 

Tip: Open the supplied library 
A SIMATIC iMap library is available with preassembled PROFInet components in 
the installation directory of iMap, usually under iMap\Examples\libs\. 

Table 4-2 Opening the preassembled library 

Step Description 

1. In SIMATIC iMap, select the menu command Library > Open....  
2. Under �Search in�, select from the SIMATIC iMap install path 

\iMap\examples\libs. 

3. Open the folder "Tutorial_Lib" and select the library �Tutorial_Lib.cbl". Click on 
the "Open" button to confirm your entry. 

The library opens in the library window. 
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Tips 
• In the preview window, the PROFInet component selected in the library window 

is displayed as a technological function with inputs and outputs or as a device 
with bus connections (see illustration above). 

• You can change the appearance and position of the components and display 
details using the View context menu in the library window. 

Next Steps 
How to insert instances of PROFInet components into the project from the project 
library. 

4.2 Step 4: Inserting PROFInet Components into the Project 

Instances of a PROFInet component 
When you insert a PROFInet component from a library into the SIMATIC iMap 
project, it creates an instance of the PROFInet component in the project, i.e. a 
copy of the component. One or more instances of a PROFInet component may be 
inserted into a project. Each instance is assigned additional properties, for 
example, a name and address.  

Requirements  
• The PROFInet components must be imported into the project library.  

or 

• The "Tutorial_Lib" library must be open.  

When you insert the PROFInet components from the "Tutorial_Lib" library into a 
project, they are also automatically inserted into the project library, if it does not 
already contain them.  

The project library is used in the following description. 
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How to insert PROFInet components from the library into the project 
PROFInet components can be inserted into the plant view or into the net view for 
the project in one of the following ways: 

• Mark a PROFInet component in the library window and select the menu 
commands Copy and Paste from the context menu. 

• Drag the PROFInet component from the library into one of the windows � net 
view, plant view or project window.  

Table 4-3 Inserting the PROFInet Components into the Project 

Step Description 

1. Switch from the plant view to the net view. 

2. In the library window, highlight the "Coordinator" component and use drag-and-
drop to move it to the project net view. 

The Ethernet is represented by a green line and the PROFIBUS by a violet line 
in the net view. The "Coordinator" is automatically coupled to the Ethernet and 
displayed with a PROFIBUS master system.  

3. Drag the "ET200X_Conveyor" component from the library into the net view. The 
possible destinations on the PROFIBUS are indicated by green segments. 
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Step Description 
4. Repeat Step 3 for components "Processing" and once again the 

"ET200X_Conveyor". Now you have inserted all the components that you need 
for your project.  

The technological function is displayed in the project tree under the tab "Plant 
tree" and the device is shown in the "Net tree " tab. 

 

 Note 
If a PROFIBUS device (DP slave, e.g. ET 200X) is inserted into the net view first, 
this device will then appear in the net view above a separating line. It can then be 
connected to the PROFIBUS using Drag and Drop. 

Example of uncoupled PROFIBUS device 

Figure 4-1 Example of uncoupled PROFIBUS device 
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Tip 
Close the windows that you do not need. They can be opened again with the icons 
or the View menu. 

Next Steps 
How to assign addresses to devices 

4.3 Step 5: Assigning Addresses 

The IP or PROFIBUS addresses of the devices in the plant are assigned to the 
devices in the SIMATIC iMap project. Addresses are needed in order to provide 
unique identification for each PROFInet and PROFIBUS device, and thus enable 
communication (downloading, online monitoring) between SIMATIC iMap and the 
devices in the plant.  

Requirements 
• The PROFInet components have been inserted into the project. 

• The IP address and subnet mask for the CPU 317-2 PN/DP are known and 
assigned. 

• The PROFIBUS addresses of the devices are known and assigned. 

The addresses must be assigned to the target devices in the plant using the 
device-specific resources normally used for commissioning.  
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How to assign addresses 

Table 4-4 Assigning addresses in SIMATIC iMap 

Step Description 

1. Mark the CPU 317-2 PN/DP device in the net view, then select Edit > 
Properties....  
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Step Description 
2. Enter the IP address and the subnet mask of the CPU 317-2 PN/DP in the 

"Addresses" tab. This has to match the IP address and subnet mask of the 
target device. Select the PROFIBUS address from the drop-down list in the 
"PROFIBUS address" field.  

 
3. In the net view, highlight the "ET200X_Conveyor" device and select Edit > 

Properties.... On the "Addresses" tab, enter the PROFIBUS address, and click 
on the "OK" button to confirm your input.  
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Step Description 
4. Repeat Step 3 for the "ProcessStation" and "ET200X_Conveyor_1" 

components. All the addresses are now assigned, 

 

 Note 
You can assign any names you wish to the devices.  

Next Steps 
Interconnecting the technological functions in the plant view of the project. 
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4.4 Step 6: Interconnecting Technological Functions 

Requirements  
• The PROFInet components must be correctly coupled to the networks. 

• The component interfaces, i.e. the connector assignments and the 
interconnection diagram, must be known.  

Interconnection rules 
• You must always connect an output to an input but an output may be 

interconnected to several inputs. 

• The two connectors of an interconnection must be of the same data type, e.g. 
both of type I2 or type U12. 

How to interconnect technological functions 
You can interconnect technological functions in the plant view.  

Table 4-5 Interconnecting technological functions 

Step Description 

1. Switch from the net view to the plant view. When the technological functions first 
appear in the plant view, they overlap.  

2. Use Drag and Drop to arrange the technological functions to make the plant 
clearer and easier to understand. To drag a function, click on its title bar. 
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Step Description 
3. a) Click on the "Delay" output of the Coordinator and on the "RunDelay" input of 

the ET200_Conveyor. 

a) Click on the "StartNext" output of the Coordinator and on the "Ext_Start" input 
of the processing component. The interconnection is represented by a line. 
Connection points of the same type, e.g. BOOL, are shown in green when the 
mouse pointer moves over a component. The selected output and the currently 
selected input are also shown in green.  

4. Interconnect the inputs and outputs of the technological functions as shown in 
the following connection diagram. 

 

 Note 
Interconnections are replaced by numbered continuation lines if a line cannot be 
represented. You can change the representation of the lines by moving the 
technological functions as required. 
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Tips 
• You can use the Properties...  context menu to display information about the 

connectors of a selected technological function. 

• Select View > Plant view > Dot screen to display a dot screen that can 
facilitate positioning the technological functions. 

• Select View > Zoom to change the size of the plant view on screen. 

Next Steps 
Saving and generating the project 
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Step 7: Generating and Download 5
5.1 Saving and Generating the Project 

When you generate the SIMATIC iMap project, the current data is prepared for 
downloading to the target devices of the plant. The PROFInet components used 
only contain controller units and no HMI parts. Only the controller unit will therefore 
be generated for the project. 

Requirement 
STEP 7 must be installed on the same computer as SIMATIC iMap. 

Saving and generating a project 

Table 5-1 Saving and Generating the Project 

Step Description 

1. Select Project > Generate > Control unit > Changes only or the "Generate 
project" icon (see illustration). 

A message appears to tell you that the project must be automatically saved 
before generating. You are asked whether you wish to continue. Click on "Yes" 
to confirm. The "Save SIMATIC iMap Project As" dialog opens. 
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Step Description 
2. Select any path under "Search in", e.g. Programs\Siemens\iMap\projects. 

3. Enter a file name for the project, for example, "Plant_1" and confirm your entry 
by pressing the "Save" button. The project is saved and generated. 

The complete project is generated when you call the Project > Generate > 
Control unit > Changes only menu command for the first time. Thereafter, only 
the changes are generated when you call this menu command again. 

4. You can follow the generation progress messages in the information window of 
the "Generate" tab.  

 

 Note 
Generation can take a long time for large projects, You can cancel generation at 
any time by clicking on the "Cancel" button in the message box.  

Tip 
If generation is successful, all the objects in the project are assigned the 
generation status "Created" in their properties. The generation status is displayed 
in the project view. 

 
Figure 5-1 Generation status in the project view 
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Next Steps 
Downloading the project data from SIMATIC iMap into the target device of the plant 

5.2 Downloading Programs and Interconnections 

Downloading - Introduction 
Downloading transfers data from SIMATIC iMap to the devices of the plant. All or 
just the selected instances of the PROFInet components may be downloaded. The 
following data may be downloaded using the Online menu: 

• The user programs you have created, including the hardware and network 
configuration 

• The interconnections between technological functions 

• All, i.e.both programs and interconnections 

The program must be downloaded when a device is commissioned. 
Interconnections can be downloaded later if required, in order to test PROFInet 
communication between the components, for example. 

How to download programs and interconnections 
For the example project, the programs and interconnections of all the PROFInet 
components will be downloaded to the devices of the plant. 

Table 5-2 Downloading Programs and Interconnections 

Step Description 

1. Select Online > Download all instances > All in the net view. 

The program and interconnections are downloaded to all target devices. 
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Step Description 
2. Messages concerning the progress of the download and asking whether you 

wish to cancel the action appear in the information window. 

Tips 
• The online-offline comparison is used to determine the devices for which a 

program download or interconnection download is required. 

• If you have only changed interconnections in the project, then only the 
interconnections have to be downloaded. You do not have to download the 
program again. 

• A program download is generally needed only once, while the interconnections 
can be downloaded as often as required.  

• The devices and technological functions that require interconnections to be 
downloaded are identified by a "download" symbol in the online view and are 
listed in the "Devices" or "Functions" tab in the diagnostic window. 

Next Steps 
Learning how to represent the diagnostic information in the diagnostic window with 
reference to an example. 
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Step 8: Diagnostics 6
6.1 Monitoring the Plant Online 

Requirements 
• The SIMATIC iMap project "Plant_1" has been generated.  

• The PG/PC is connected to the plant via the Ethernet. 

• The programs and interconnections of all the PROFInet components in the 
project have been downloaded to the devices in the plant.  
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Diagnostics 
When the online view is active in SIMATIC iMap, in the plant view and the net view 
you can see information about the status of the PROFInet communication partners, 
the interconnections and the operating states of the devices (depending on the 
type of device) in the diagnostic window. 

Table 6-1 Diagnostics 

Step Description 

1. Select Online > Monitor. The online view is activated in SIMATIC iMap. A fault 
displayed in the diagnostic window is identified by a diagnostic symbol on the 
affected device in the plant and net views. 

2. All faulty functions are displayed on the "Functions" tab in the diagnostic 
window.  
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Step Description 
3. All faulty devices are displayed in the "Devices" tab in the diagnostic window. 

Information on the currently selected object is displayed in the right-hand 
window. Click on the "Diagnostics" button to access the device-specific 
diagnostics. 

4. In the net view, highlight the "CPU 317-2 PN/DP" device and select Online-
offline comparison > Interconnections only from the context menu. The 
online and offline data for the interconnections are compared and the result 
appears in the information window of the "Online/offline comparison" tab. 

The illustration shows a display in which interconnections have yet to be 
downloaded. 
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Step Description 
5. The variable table provides an overview of the online values and allows you to 

control the online values of the inputs (menu command Online > Variable 
Table > Monitor All Variables). 

 

Possible Errors 
Possible errors in functions and devices are identified by symbols in the plant and 
net views. The type of error is described in the diagnostic window. 

• Functions 

� The interconnection is faulty. 

� Interconnection download is required. 

• Device 

� The device is not available.  

� The device has a fault. 

� Program download is required. 

Tips 
• Click on the column headers, e.g. on "Reference object", in the information 

window to create the optimal column width. 

• Double click on a faulty function in the diagnostic window to display the affected 
technological function in the plant view. 

• If you double-click on a faulty device in the diagnostic window, the affected 
device is displayed in the net view. 

• If "Download necessary" is signalled as a fault, you can click on the "Download" 
button to start downloading the interconnections immediately. 

Next Steps 
Visualizing the process data. 
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Step 9: Visualizing Process Data  7
7.1 Analyzing with OPC 

OPC: OLE for Process Control 
In SIMATIC iMap, you can create an OPC symbol file for the project. The OPC 
symbol file contains address information about individual process data so that it 
may be accessed via OPC.  

Anyone in the office can use an OPC client program to access the data for 
PROFInet devices at the control and production levels.  

 
Figure 7-1 Using OPC 

Requirements 
• An OPC client program must be installed, e.g.OPC Scout from SIMATIC Net. 

• The SIMATIC iMap project "Plant_1" is open and has been generated without 
error. 
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How to analyze process data 

Table 7-1 Creating and editing the OPC symbol file 

Step Description 

1. In SIMATIC iMap, select Options > Create OPC Symbol File.... 
2. Select a folder as the storage Iocation in the "Save OPC symbol file As" dialog field. 

The OPC symbol file Plant_1.sti will be saved in this folder. 

You can then close SIMATIC iMap. 

3. A table with the selected OPC variables and their status information appears in OPC Scout. 

 

 
 



 

Getting Started with SIMATIC iMap 
A5E00248810-01 Index-1 

 Index 

A 
Analyzing process data 

Getting Started .................................. 7-2 
Assign IP address 

CPU 317-2 PN/DP........................... 4-10 
Assign PROFIBUS address ................. 4-10 
Assign subnet mask 

CPU 317-2 PN/DP........................... 4-10 
Assigning addresses 

Getting Started .................................. 4-9 

C 
component interface 

Define ................................................ 2-5 
Component interface 

Coordinator  component.................... 2-5 
ET200X_Conveyor component ......... 2-6 
Processing component...................... 2-6 

Configuration of the plant 
Getting Started .................................. 2-3 

Continuation lines................................. 4-13 
Create OPC Symbol File 

Getting Started .................................. 7-2 

D 
Diagnostic window 

Getting Started .................................. 6-2 
Diagnostics 

Getting Started .................................. 6-2 
Dividing the plant 

Getting Started .................................. 2-1 
Download................................................ 6-4 
Downloading........................................... 5-3 
Downloading programs and 

interconnections ................................ 5-3 

E 
Example project...................................... 3-2 

G 
Generation ..............................................5-2 
Getting Started 

Steps of the solution ..........................1-2 

I 
Importing 

Getting Started...................................4-2 
Importing component into the  

project library 
Getting Started...................................4-2 

Interconnecting technological  
functions 
Getting Started.................................4-12 

Interconnection 
Getting Started.................................4-13 

Interconnection diagram 
Getting Started...................................2-7 

L 
Library window........................................4-5 

N 
Net view 

Getting Started...................................4-6 

O 
Online-offline comparison .......................5-4 
OPC 

OLE for Process Control....................7-1 
Opening the sample library 

Getting Started...................................4-4 



Index 

 Getting Started with SIMATIC iMap 
Index-2 A5E00248810-01 

P 
Plant view ............................................. 4-12 
Possible errors 

Getting Started .................................. 6-4 
Preview window...................................... 4-5 
PROFInet components 

Inserting into a project....................... 4-6 
PROFInet components for the example 

project................................................ 3-1 
PROFInet interface................................. 2-5 

S 
Saving a project ......................................5-1 
Saving and generating a project .............5-1 

T 
Target groups..........................................1-1 
Technological functions ........................4-12 
technological modules 

Dividing the plant ...............................2-1 
 


	Title
	Preface
	Contents
	1 Getting Started - Introduction
	2 Step 1: Defining PROFInet Components
	2.1 Dividing Plants into Modules
	2.2 Defining Devices and Technological Functions

	3 Step 2: Creating PROFInet Components with STEP 7
	3.1 Basic Procedure for Creating a PROFInet Component
	3.2 Creating a PROFInet Component Based on an Example of a CPU 317-2PN/DP

	4 Steps 3 to 6: Configuring a Plant with SIMATIC iMap
	4.1 Step 3: Importing PROFInet Components into a Library
	4.2 Step 4: Inserting PROFInet Components into the Project
	4.3 Step 5: Assigning Addresses
	4.4 Step 6: Interconnecting Technological Functions

	5 Step 7: Generating and Download
	5.1 Saving and Generating the Project
	5.2 Downloading Programs and Interconnections

	6 Step 8: Diagnostics
	6.1 Monitoring the Plant Online

	7 Step 9: Visualizing Process Data
	7.1 Analyzing with OPC

	Index
	A
	C
	D
	E
	G
	I
	L
	N
	O
	P S
	T


