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    Safety Guidelines 
This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring to property damage only have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

   
Danger 

indicates that death or severe personal injury will result if proper precautions are not taken. 

   
Warning 

indicates that death or severe personal injury may result if proper precautions are not taken. 

   
Caution 

with a safety alert symbol, indicates that minor personal injury can result if proper precautions are not taken. 

 Caution 

without a safety alert symbol, indicates that property damage can result if proper precautions are not taken. 

 Notice 

indicates that an unintended result or situation can occur if the corresponding information is not taken into 
account. 

If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The device/system may only be set up and used in conjunction with this documentation. Commissioning and 
operation of a device/system may only be performed by qualified personnel. Within the context of the safety notes 
in this documentation qualified persons are defined as persons who are authorized to commission, ground and 
label devices, systems and circuits in accordance with established safety practices and standards. 

Prescribed Usage 
Note the following: 

   
Warning 

This device may only be used for the applications described in the catalog or the technical description and only in 
connection with devices or components from other manufacturers which have been approved or recommended 
by Siemens. Correct, reliable operation of the product requires proper transport, storage, positioning and 
assembly as well as careful operation and maintenance. 

Trademarks 
All names identified by ® are registered trademarks of the Siemens AG. The remaining trademarks in this 
publication may be trademarks whose use by third parties for their own purposes could violate the rights of the 
owner. 

Copyright Siemens AG 2005. All rights reserved. 
The distribution and duplication of this document or the utilization and transmission of its 
contents are not permitted without express written permission. Offenders will be liable for 
damages. All rights, including rights created by patent grant or registration of a utility 
model or design, are reserved. 

 Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the 
hardware and software described. Since variance cannot be precluded entirely, we cannot 
guarantee full consistency. However, the information in this publication is reviewed 
regularly and any necessary corrections are included in subsequent editions. 

Siemens AG  
Automation and Drives 
Postfach 4848, 90327 Nuremberg, Germany  

© Siemens AG 2005  
Technical data subject to change 

 
 
Siemens Aktiengesellschaft   A5E00369899-01  
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First Steps in Commissioning 

Preface 
These instructions show you how to output messages from a CP 340 to a printer step-by-
step on the basis of a concrete example. In the process you also get to know the basic 
functions of the CP 340 printer driver. 

The time required amounts to one to two hours, depending on your experience, plus the time 
required for procurement, wiring and supply with auxiliary power. 

 

 
Warning 

As a component of plants or systems your PLC requires special rules and regulations to be 
observed, depending on the field of use. 

The non-compliance with these regulations could result in severe injury as well as damage 
to machines and equipment. 

Observe the applicable regulations on safety and the prevention of accidents, for example 
IEC 204 (EMERGENCY-OFF equipment). 

 

 

 
Warning 

You may come into contact with live cables and wires if the power supply module of your 
PLC is activated or if the supply cable is connected to the power system. 

Only wire your PLC when it is de-energized. 
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Requirements 
• You have an S7-300 station consisting of 

– Rack 

– Power supply unit 

– CPU 

– CP 340 with RS 232C port and printer option 

• You have an IBM-compatible printer with RS 232 interface. The printer is prepared for 
serial data transfer and is connected by means of an RS 232 connecting cable to the 
CP 340.  
An appropriate configuration of the printer should only be carried out by specialist 
personnel. 

• STEP 7 V5.1+ Service pack 2 are installed correctly on the programming device. Ensure 
that all the components are compatible, starting from the operating system + service pack 
up to the STEP7 package + service pack + hotfix and the version of the configuration 
software with its updates. 

• You have set up a printer output sample project for the S7–300 station. 

• The programming device is connected to the CPU of the PLC. 

 
Figure 1-1 Example setup 

 
➀ Power supply unit 
➁ CPU 3xx 
➂ CP 340 
➃ RS 232 connecting cable / CP 340 - printer 
➄ IBM-compatible printer 
➅ Programming device 
➆ MPI connecting cable / CPU - programming device 
➇ S7-300 station 
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Purpose of the Getting Started Document 
The purpose of the Getting Started document is to output the following messages at the 
following printer: 

• At xx:xx:xx.xxx the value reached the limit of 1500 liters 

• At xx:xx:xx.xxx the value exceeded the limit of 1500 liters 

• At xx:xx:xx.xxx the value dropped below the limit of 1500 liters 

Whereby xx:xx:xx.xxx is the current time of day. 

The messages are created in this Getting Started by using a format string with 3 variables: 

 
Whereby: 

• %Z: Is the conversion instruction for the data type TIME_OF_DAY 

• %i: Is the conversion instruction for the data type INT, WORD, DINT, DWORD 

• %N: Is the conversion instruction for outputting a message configured in HW Config 

In this Getting Started 

• The format string is defined by the DB 10, 

• The variables 1, 2 and 3 are defined by the DBs 6, 7 and 8, 

• The DB 5 contains the pointer DB, the pointers to the DBs 6 to 10. 

1. Step: Installing the configuration software on the programming device 
The configuration software contains the function blocks required to connect to your user 
program as well as programming examples. 

The configuration software can be found alternatively 

• On the supplied CD 

• In the Internet at: http://www.ad.siemens.de/simatic-cs Contribution ID: 12310504 
 
Step Action Result 

1 Start the installation program by double-clicking the file called 
SETUP.EXE in the SETUP folder. 

The installation program is started. 

2 Follow the instructions issued by the installation program.  

 



First Steps in Commissioning  

 CP 340 PtP Printer Driver 
1-4 Getting Started, 04/2005, A5E00369899-01 

2. Step: configure the CP 340 
 
Step Action Result 

1 Open your project in the SIMATIC Manager.  
2 In your project, call the HWCONFIG configuration table.  
3 Double-click on the CP340 RS232C. The dialog box"CP 340-RS232C 

properties" opens. 
4 Note the module address in the "Addresses" tab. This value is 

required as a parameter when calling the FB P_PRINT in your user 
program. 

 

5 Click on the Parameters command button. The dialog box "Configure point-to-point 
coupling CP 340-RS232C" opens. 

6 Select the protocol PRINTER and confirm with Yes. The printer protocol is loaded with the 
following default settings: 9600 bits/s, 8 
data bits, 1 stop bit, parity even, no data 
flow control, activate BREAK monitoring 
. 

7 Double-click on the Protocol envelope. The "Protocol" dialog box opens. 
8 If necessary, adapt the default protocol settings to your printer 

protocol and confirm with OK. 
 

9 Double click the page layout. The "Page layout" dialog box opens. 
10 Specify the page layout and confirm with OK.  
11 Double click on Messages and then SDB. The "Messages" dialog box opens. 
12 Assign a name consisting of a maximum of 8 ASCII characters for the 

text SDB. 
 

Enter the following message numbers and message texts 
consecutively at "Edit message:" and click the Enter command button 
after each entry. 
Number Text 
0 reached 
1 exceeded 

13 

2 dropped below 

The message texts entered at "Edit 
message:" are imported into the 
"Message texts" overview. 

14 Click the command buttons OK and SDB. The "Messages" dialog box closes. 
15 Save the configuration with File > Save and exit the configuration 

dialog box with File > Exit. 
 

16 In the "Properties CP 340-RS232C" dialog box click on the OK 
command button. 

 

17 Save the configuration you have created with Station > Save and 
compile in your project. 

 

18 Transfer the configuration with the CPU in STOP mode by choosing 
PLC > Download to Module. 

The data are transferred directly to the 
CPU and the CP 340. The "SF" LED 
goes out to indicate the successful 
completion of downloading. 

19 Use Station > Exit to close the HW Config.  
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3. Step: creating blocks in the block folder 
 
Step Action Result 

1 In SIMATIC Manager use File > Open ... > Libraries in the catalog 
Siemens\STEP7\S7libs\CP PtP to open the blocks folder CP 340 and 
its blocks container.  

A two-section window is opened with the 
title of the library and the FBs and FCs 
belonging to the CP 340. 

2 Copy the FB 4 into the block folder of your project.  
3 In SIMATIC Manager use File > Open ... > Libraries in the catalog 

Siemens\STEP7\S7libs\StdLib30 to open the blocks folder IEC 
Function Blocks and its blocks container. 

A two-section window is opened with the 
title of the library and the IEC functions. 

4 Copy the FC 8 into the block folder of your project.  
5 In SIMATIC Manager use File > Open ... > Libraries in the catalog 

Siemens\STEP7\S7libs\StdLib30 to open the blocks folder IEC 
Function Blocks and its blocks container. 

A two-section window is opened with the 
title of the library and the SFBs and 
SFCs. 

6 Copy the SFC 1 into the block folder of your project.  
In the blocks container of your project, use Insert > S7 block > Data 
blocks the following data blocks: 
DB Meaning in the Printer output project 
DB 5 Pointer DB 
DB 6 DB for the Variable 1 
DB 7 DB for the Variable 2 
DB 8 DB for the Variable 3 
DB 9 DB for the Variable 4 

7 

DB 10 DB for the format string 

 

8 In the blocks container of your project, use Insert > S7 block > 
Variable table to create the variable table VAT_1. 
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4. Step: calling blocks in the OB 1 
 
Step Action 

1 In your project open the OB 1. 
2 In the declaration table create the variable of the data type DATE_AND_TIME called "Time". 

In the OB 1 call the SFC 1, the FC 8 and the FB 4 and assign parameters to the blocks as follows: 
CALL  "READ_CLK" SFC1 //Read date and time 

 RET_VAL  :=MW3   
 CDT  := #Time  Enter //date and time in the "Time" variable 

CALL  ”DT_TOD" FC8 //Convert the date and time into the time of day 
 IN  := #Time   

 RET_VAL  := DB6.DBD0  //Placeholder for the time of day (Variable 1 in the 
DB 6) 

CALL  ”P_PRINT", DB4 FB4 //FB for the printer output of message texts 
 REQ  :=M1.0  Trigger bit, positive edge required 

 R  :=  //Reset bit 
 LADDR  := 256  //Module address of the CP 340 (from HW Config) 
 DB_N0  := 5  //Number of the Pointer DB 

 DBB_N0  := 0  //Offset in the Pointer DB 
 DONE  := M1.1  //Job finished without errors 

 ERROR  := M1.2  //Job finished with errors 

3 

 STATUS  := MW2  //Specification of the error 
4 Save the OB 1 with File > Save.  
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5. Step: specifying the data structure of the blocks (also refer to the manual, section 
"Outputting Message Texts to a Printer") 

Now specify the data structure of the blocks DB 5 to 10 and enter the initial values. 
 

 Note 

Please observe the following points when entering and changing initial values in data blocks:
1. Enter the initial values in the Declaration view of the data blocks. 

2. Use  Data > View to change over to the Data view. 

3. Initialize the data blocks with  Edit > Initialize Data Block. 
 

 

Table 1-1 Data structure of the DB 5 (pointer DB): 

Address Name Type Initial value Remark 

  STRUCT   
+0.0 DB_VAR1 ARRAY[0..2]  6, 0, 4 Pointer to the DB 6 with offset 0 and length 4(DB 6 = DB for 

the Variable 1: "Time of day") 
*2.0  INT   
+6.0 DB_VAR2 ARRAY[0..2] 7, 0, 2 Pointer to the DB 7 with offset 0 and length 2(DB 7 = DB for 

the Variable 2: "1500") 
*2.0  INT   
+12.0 DB_VAR3 ARRAY[0..2] 8, 0, 1 Pointer to the DB 8 with offset 0 and length 1(DB 8 = DB for 

the Variable 3: "Number of the configured message") 
*2.0  INT   
+18.0 DB_VAR4 ARRAY[0..2] 0, 0, 0 DB No. 0: The pointer is interpreted as non-existing and is 

skipped. Variable 4 is not used. 
*2.0  INT   
+24.0 DB_String ARRAY[0..2] 10, 2, 41 Pointer to the DB 10 with offset 2 and length 41(DB 10 = DB 

for the format string); 
The specification offset 2 is necessary, since the length 
information of the string is container in the Byte 0 and 1. 
The length (in this case 41) must correspond to the number of 
characters which are entered at "Initial value" in the format 
string (in this case DB 10). 

*2.0  INT   
=30.0  END_STRUCT   

Save the DB 5 with File > Save. 
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Table 1-2 Data structure of the DB 6 for the Variable 1: 

Address Name Type Initial value Remark 

0.0  STRUCT   
+0.0 DB_VAR TIME_OF_DAY TOD#0:0:0.0 Time of day 
=4.0  END_STRUCT    

Save the DB 6 with File > Save. 

 

Table 1-3 Data structure of the DB 7 for the Variable 2: 

Address Name Type Initial value Remark 

0.0  STRUCT   
+0.0 DB_VAR INT 1500 Limit 1500 liters 
=2.0  END_STRUCT    

Save the DB 7 with File > Save. 

 

Table 1-4 Data structure of the DB 8 for the Variable 3: 

Address Name Type Initial value Remark 

0.0  STRUCT   
+0.0 DB_VAR Byte  B#16#0 0 = Number of the configured message(Text of Message No. 

0 = "reached") 
=2.0  END_STRUCT    

Save the DB 8 with File > Save. 

 

Table 1-5 Data structure of the DB 9 for the Variable 4: 

Address Name Type Initial value Remark 

0.0  STRUCT   
+0.0 DB_VAR Byte  0 DB 9 for the Variable 4 is not used. 
=2.0  END_STRUCT    

Save the DB 9 with File > Save. 
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Table 1-6 Data structure of the DB 10 for the format string:(also refer to the manual, section "Conversion and Control 
Statements for Printer Output") 

Address Name Type Initial value Remark 

0.0  STRUCT   
+0.0 DB_VAR STRING[41]  'At %Z the 

value %N the 
limit of %i 
liters' 

%Z: variable 1 in the format string (time of day) 
%i: variable 2 in the format string (1500) 
%N: variable 3 in the format string (number of configured 
message) 
The format string entered at Initial value comprises 41 
characters (including the blanks).  
The following applies for the string length to be specified at 
the type: 
Number of characters at the initial value ≤ string length at 
type ≤ 254 

=2.0  END_STRUCT    

Save the DB 10 with File > Save. 

6. Step: creating the variable table 
Open the variable table VAT_1 and carry out the following entries: 

 
 Address Symbol Display format Status value Modify value Remarks 

1 M 1.0  BIN  2#0 Trigger bit (0-1 edge required) 
2 M 1.1  BIN    
3 M 1.2  BIN    
4 DB6.DBD0  TIME   Current time of day 
5 MW 2  HEX    
6 DB8.DBB0  HEX  B#16#00 Number of the configured message 

Save the variable table VAT_1 with Table > Save. 

7. Step: downloading the program 
 
Step Action 

1 In SIMATIC Manager in your project select the blocks container. 
2 In the STOP state of the CPU, download these blocks to your CPU by using PLC > Load. 
3 Switch the CPU to the RUN state. 
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8. Step: testing the program 
 
Step Action Result 

1 In the variable table switch to online by using PLC > 
Create connection to > Configured CPU.> 

 

2 Switch to monitor mode with Variable > Observe. You can observe the current time of day at the status 
value of the address DB6.DBD0. 

3 Create 0–1 edges at the address M 1.0, the trigger bit 
for the FB 4, by alternatively entering 0 and 1 as the 
modify value and making hte respective modify value 
valid by using Variable > Modify value activate. 

At every 0–1 edge on the trigger bit, the following 
message is output at the printer: At xx:xx:xx.xxx the 
value reached the limit of 1500 liters. 

4 At the address DB8.DBB0, change the modify value to 
1 and make it valid by using Variable > Modify 
valueactivate. 

 

5 Create 0-1 edges at the address M 1.0 At every 0–1 edge on the trigger bit, the following 
message is output at the printer: At xx:xx:xx.xxx the 
value reached the limit of 1500 liters. 

6 At the address DB8.DBB0, change the modify value to 
2 and make it valid by using Variable > Modify 
valueactivate. 

 

7 Create 0-1 edges at the address M 1.0 At every 0–1 edge on the trigger bit, the following 
message is output at the printer: At xx:xx:xx.xxx the 
value reached the limit of 1500 liters. 
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