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1 Prerequisites
This is what you read about:

• The target readers for these brief instructions
• Which software and hardware components you require
• Which technological task/function is to be solved

These brief instructions are intended for introductory level personnel and
it outlines the basic procedure when generating a project. The emphasis
is on the FM 458-1 DP application module. As far as generating the
SIMATIC program, only the steps, necessary to link-in the FM 458-1 DP
application module are discussed. These instructions assume that you
are already experienced in using SIMATIC S7 controls and are
knowledgeable about the SIMATIC Manager.

This document does not replace the Manuals on STEP7, CFC, D7-SYS,
FM 458-1 DP, etc. This is the reason that it is essential that you observe
the statements made in the appropriate Manuals, especially those
statements relating to safety.

1.1 Software and hardware

You must have at least the following three software packages on your
PG/PC with Windows 95/98/ME/NT 4.0/2000

• STEP 7, from Version 5.2 onwards

• CFC, from Version 6.0 onwards

• D7-SYS, from Version 6.0 onwards

installed precisely in this sequence.

NOTE Authorization is required for STEP7 and CFC.

The installation and user instructions are provided in the particular
"readme" files.

Please carefully observe the compatibility between the different
versions!

While installing STEP7 you will be prompted for the online interface. In
this case, please install the MPI interface (e.g. CP5511 communications
processor (MPI/PROFIBUS) for PG/PCs (PCMCIA))

Contents of this
section

Introduction

Software
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You will require the following hardware components for the "My First
Project” project example:

Components Function Order No.
Central rack UR2
9 slots

... if the subrack is for an S7-400
station.
... it is used to mechanically
accommodate the modules and
supply them with power.

6ES7 400-1JA00-0AA0

PS 407 power supply, 10A
(at slot 1)

... supplies the modules in the
subracks with power.

6ES7 407-0KA01-0AA0

SIMATIC S7-400
CPU module CPU 412-1

... runs the SIMATIC user
program.
... exchanges data with other
modules via the backplane PC
board of the subrack.
... communicates with a PG/PC
via the serial interface.

6ES7 412-1XF03-0AB0

MPI cable ... connects the SIMATIC CPU
module to the PG/PC.

6ES7 901-0BF00-0AA0

SIMATIC NET CP 5511 PROFI-
BUS, MPI interface card for PC,
S7 couplings, DP master, DP
slave, PG functions, PCMCIA

... connects the PC to the
SIMATIC CPU module through
the MPI cable.

(as an alternative, also SIMATIC
NET CP 5611 PROFIBUS,
6GK1 561-1AA00, can be used
for the PCI bus)

6GK1 551-1AA00

SIMATIC S7-400 application
module
FM  458-1 DP

... runs the user program of the
FM 458-1 DP application module.
... communicates with the
SIMATIC CPU and a PG/PC via
the backplane bus.

6DD1 607-0AA1

MMC program memory module
(for the FM 458-1 DP application
module)
Micro Memory Card, 2 Mbyte
Flash

... saves the operating system,
the user program and the online
changes for the FM 458-1 DP
application module.

6ES7 953-8LL00-0AA0

PROFIBUS DP bus interface
IM 153

... connects the S7-300 I/O to
PROFIBUS DP an.

6ES7 153-1AA00-0XB0

SM 322 digital output module ... outputs the values received via
PROFIBUS DP .

6ES7 322-1BH01-0AA0

EXM 438-1 expansion module
for the FM 458-1 DP application
module
(located directly next to FM 458-
1 DP)
Digital I/O, analog I/O
incremental encoder inputs.

... expands the FM 458-1 DP
application module by
technology-specific interfaces.
This is especially fast as it is
directly inserted onto the FM 458-
1 DP application module and
uses a local bus independent of
the backplane bus.

6DD1 607-0CA1

Hardware
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Components Function Order No.
Interface cable SC 52
Length: 2 m

... connects the I/O of the EXM
438-1 module with up to 5
interface modules SBxx or SU12.

6DD1 684-0GC0

SB10 interface module
2 x 8 screw terminals,
LED displays

... allows you to test the user
program during start-up and in
operation as the states of the
digital outputs are displayed
using LEDs.

6DD1 681-0AE2

Fig. 1-1 Module list for the project example "My First Project”

NOTE It is also possible to use other hardware platforms of the SIMATIC
control system if this is appropriately taken into account in the
engineering and when configuring the system.
Additional information and technical data are provided in the
SIMATIC Control Systems Catalog ST DA or in Catalog CA 01.

1.2 What you can expect

The example "My First Project” guides you step-by-step to a project
which can actually run.

1. Analyze the particular task
This allows you to identify the function blocks, inputs and outputs
which you require and which hardware:

2. Define the hardware
You will use this hardware information in STEP7 in order to enter the
modules and define your particular properties.

3. Configure and compile
You generate the user program for the SIMATIC CPU in STEP7 using
the standard SIMATIC languages LAD/FBD/STL.
In CFC, you generate the application software for the FM 458-1 DP
application module using function blocks. This application software is
then compiled.
You can configure the hardware after all of the checks have been
made.

4. Test the configuring software
You can now run the program, test it online and change it on the
configured modules.

5. Archive the project
You can subsequently apply this procedure for you own applications.

The task comprises three sections:

1. Data exchange between the SIMATIC CPU and the FM 458-
1 DP application module via the backplane bus.
This influences the behavior of the sawtooth generator.

From the task to
the first project

The task
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2. A sawtooth generator outputs its value via a D/A converter.

3. Running Lights with 8 channels. Output using an ET200 digital
output module connected to PROFIBUS DP.

To start off with, define the individual functions for the appropriate sub-
tasks and define the necessary hardware:

1. Data exchange
The SIMATIC CPU enters the upper limit value of the sawtooth
generator running on the FM 458-1 DP application module. The actual
integrator value is sent back to the SIMATIC CPU.

2. Sawtooth generator
A sawtooth waveform is generated by an integrator, which resets itself
after an upper limit has been exceeded. The value of the integrator is
output on the EXM 438-1 via an analog output.

3. Running light
Eight comparators compare the sawtooth value with constant values.
The results are output through PROFIBUS DP and control the LEDs
on the ET200 module.

The running light has the following phases:

• All of the LEDs are dark.

• The LEDs are switched bright and then dark again so that only one
is bright at any one time.
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2 Creating a new project
Step Procedure Result

1
Double-click on the symbol .
(if the STEP 7 Assistant starts, cancel this.)

The SIMATIC Manager is opened.
2 Select

File > New.
Enter "My First Project"
into the dialog box, Project.
In the dialog box, select the path
„LW:\Siemens\Step7\S7proj“.
Click on OK. Your new project is displayed.

3 Select
Insert > Station > SIMATIC-400

The "SIMATIC-400(1)" hardware object is
inserted.
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3 Defining the hardware
Here you will read about:

• how you start the hardware configuration
• which settings you must carry-out for the individual modules
• how you configure PROFIBUS DP

The SIMATIC subrack structure is entered in STEP 7
(HW Config).

Step Procedure Result
4 Select the hardware object

"SIMATIC-400(1)" and select
Edit > Open object. HW Config is called-up.

5 Open the hardware catalog, if required with
View > Catalog .

The hardware catalog with all of the available
family of modules is opened.

6 Select the "UR2" from the
"SIMATIC 400" family of modules and
Catalog "RACK 400" and drag it to the
(upper) window The subrack is displayed with 9 slots.

7 Locate them one after the other
> PS-400 > Standard PS-400 > PS 407 10A
at slot 1
>CPU-400  > CPU 412-1 > 6ES7 412-
1XF03-0AB0 at slot 3
> FM-400 > FM 458 components  >
FM 458-1 DP at slot 4
With the following dialog box "Properties,
PROFIBUS interface DP“ set-up a "New“
PROFIBUS DP interface using "new" and
acknowledge twice with "OK"
> FM-400 > FM 458 components > EXM
438-1 at slot 5

This means that you have assigned a
PROFIBUS DP interface to the FM 458-
1 DP.

The subrack is equipped.
8 Open the properties dialog box of the FM

458-1 DP application module with
Edit > Object properties.

The FM 458-1 DP dialog box with general
module information and the setting registers
for addresses, basic clock cycle, cyclic tasks
and interrupt tasks are displayed.

9 Select the basic sampling time T0 (in this
case: 1 ms) ein.
Click on the cyclic tasks tab and set the
sampling time T1 to 2 ms and T2 to 4 ms.
Click on OK.

The required sampling times are entered.

The Properties dialog box is closed.
10 Open the properties dialog box of the EXM

438-1 module with
Edit > Object properties.

The EXM 438-1 dialog box with general
module information and the setting tab for
addresses is displayed.

Contents of this
section
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11 Under the Peripheral addresses tab, click
on the Pre-assign button.
Click on OK.

All of the addresses are assigned symbolic
names for subsequent use in CFC charts.

12 Now configure PROFIBUS DP.
Locate
> PROFIBUS DP > ET 200M > IM 153 at the
PROFIBUS DP line assigned to the FM 458-
1 DP by dragging and dropping
In the "Properties" dialog box
"PROFIBUS interface IM 153“ change the
address to 3.
Click on OK. This means that you have assigned the IM

153 module the slave address on the
PROFIBUS DP line.

13 Locate
> PROFIBUS DP > ET 200M > IM 153 > DO-
300 > SM 322 DO16xDC24V/0.5A at slot 4 in
the lower window by dragging and dropping.

This means that you have assigned the
digital output module SM 322 to the IM 153
station.

14 Check your hardware with
Station > Check consistency.

If fault/error-free, continue with Step 15,
otherwise check the hardware configuration.

15 Compile your hardware configuration with
Station > Save and compile. The hardware has been fully configured.
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4 Generating a STEP7 program

Step Procedure Result
16 Now generate the user program for the SIMATIC CPU module as you know it from

STEP7.

In the following (Fig. 1: OB1 of SIMATIC CPU) OB1 program example – only the points
necessary for data exchange with the FM 458-1 DP application module are discussed.

Fig. 1: OB1 of SIMATIC CPU
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5 Creating a CFC chart
Here you will read about:

• how you create CFC charts for the project example
• the possibilities which you have when parameterizing and

interconnecting the function blocks

5.1 Creating a new chart

Step Procedure Result
17 Go into the SIMATIC Manager and open the

project tree down to the Charts object below
the  FM 458-1 DP application module.
Select the charts by clicking on them.

18 Create a new CFC chart three times with
Insert > S7 software > CFC .

The CFC 1, CFC 2 and CFC3 charts are
displayed as new objects at the righthand
side of the project window.

19 Select chart CFC2 in the project window and
open the properties dialog box with
Edit > Object properties .
Enter the "data exchange" name.
Click on OK.

You obtain the properties dialog box of the
CNC chart.

The Properties dialog box is closed.
20 Repeat step 17 with the CFC2 chart and re-

name it "sawtooth generator". The charts appear in the project window
under their new name.

21 Repeat step 17 with the CFC2 chart and re-
name it "Running lights". The charts appear in the project window

under their new name.

Contents of this
section
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5.2 Inserting, parameterizing and inter-connecting function
blocks

Step Procedure Result
22 Select the "sawtooth generator“ chart and

open the "CFC Editor with
Edit > Open object.

The CFC Editor is opened with the working
area (>1 sheet) and the block catalog.
(Catalog missing? Select View > Catalog)
(>1 Sheet? Select View > Sheet view)

23 Open the family of blocks Closed-loop
control and drag the function block INT
(integrator) to the working area.

The block is now located on the sheet and
has the ID for running in cyclic task T1.

24 Open the properties dialog box of function
block INT with Edit > Object properties .

The INT dialog box with general block
information and the setting tab I/O appears.

25 Under the General tab, change the name to
„sawtooth“.

26 Under the I/O tab, enter the values for the
block inputs, e.g.
• X = 1
• TI = 5 ms
Click on OK.

The Properties dialog box is closed and the
function block inputs now have values
assigned.

27 First click on output QU and then on input S. The output QU (upper limit) is now coupled
back to input S (set).

28 Select DAC (analog output) from the block
family ON/OFF and locate it next to function
block INT.
Open the dialog box using Edit > Object
properties and change the name to "analog
output“.
Enter, for example under the I/O tab:
• DM = 0
• OFF= 0
• SF = 1E4
Click on OK.
Select connection AD (hardware address),
and call-up the dialog box to interconnect the
object with
Insert > Connect to operand. Then mark
the selection window. Select the
X438_1_AOut1 entry and click on OK

The block inputs are parameterized.

The hardware address of the first analog
output channel is assigned.

29 In the "sawtooth“ block, click on output Y
and after this on input X in the "analog
output" block.

The sawtooth generator is connected to the
analog output.

All changes made in the CFC chart are immediately saved.
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Proceed the same (from Step 22) for the other two sub-tasks (data
exchange, running light).
Change into the SIMATIC Manager, open the CFC chart "data exchange"
or "running lights", insert the function blocks into the CFC chart,
parameterize and connect them.
You can take all of the necessary information and data (block number,
type and parameters) from the "My first project" project provided on the
CD. Arrange the first function block and all others, via Edit > Run
sequence in cyclic task T2. A CFC window changeover (Window > ...) is
used to interconnect from the "sawtooth" block to the send/receive
function blocks (Chart "data exchange") or comparators (Chart "running
lights").
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6 Testing, compiling and downloading the project
Here you will read about:

• how you can check your project to ensure that it is free of errors
• the possibilities you have of downloading the user program into

the FM 458-1 DP application module

6.1 Checking the project consistency and compiling

Step Procedure Result
30 Now please check the consistency of the SIMATIC CPU module as you know it from

STEP7.
31 Go into the SIMATIC Manager and open the

project tree down to the Object Charts below
 FM 458-1 DP application module.
Select the charts by clicking on them.
Start to check the consistency of your project
with
Edit > Check consistency.
Click on OK.
Acknowledge the dialog window or evaluate
the error messages using Details.

The result is displayed in a dialog window.
32 After a successful consistency check, start

compilation of the project with
Edit > Compile .
Select "Compile everything“ and click on OK.

Acknowledge the dialog window or evaluate
the error messages using Details.

This means that all charts (your user
program on the FM 458-1 DP) are compiled.

The result is displayed in a dialog window.

You have created your first user project.

Contents of this
section
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6.2 Downloading the user project into the FM 458-1 DP
application module

Now load the SIMATIC CPU module as you know it from STEP7.

For the FM 458-1 DP application module, you can download your user
project, either

• online or
• offline into the FM 458-1 DP memory module.

Maybe you do not have a connection from your PC/PG to the
SIMATIC station, which is why you can use the possibility of downloading
into a memory module.

Step Procedure Result
33 Go into the SIMATIC Manager and open the

project tree down to the Object Charts below
 FM 458-1 DP application module.
Select the charts by clicking on them.
Select Target system > Download.

You obtain the dialog window with options.
34 Select the "System and user program",

"Online” and initialization when first
downloading the user program.
Note: If a user program is downloaded
again, you can also specify "Only user
program" without "Initialization".
Insert the memory module into the
appropriate slot of the PG/PC.
Start to download with OK.

A progress display shows how the system
and your user program are being
downloaded into the memory module.

35 Move the memory module into the FM 458-
1 DP application module and re-start the
station. Your user programs are now started on the

SIMATIC CPU module and on the FM 458-
1 DP application module.

Introduction

Downloading
offline
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You have established a connection from your PC/PG to the SIMATIC
station and you can download the program memory module into the
application module.

Step Procedure Result
36 Result Check whether your SIMATIC station

(hardware) is correctly configured,
assembled and connected.

Observe the configuration instructions and
connection possibilities for the individual
hardware components in the appropriate
hardware documentation!

37 Insert the memory module into the FM 458-
1 DP application module and start the
SIMATIC station.

The STOP LED goes bright on the FM 458-
1 DP application module

38 In the SIMATIC Manager, install the interface
between the SIMATIC station and the PC
using the following menu command
Options > Set PG/PC interfaces....

You obtain a dialog window "Install/uninstall
interfaces" in which the various interfaces
are listed.

39 In the dialog box window select "CP5611
(MPI)” and install this protocol with Install
Acknowledge with "yes" and then close the
dialog window.
Select the interface used and acknowledge
with "OK".

You obtain a dialog window in which you can
decide, by entering either
"Yes" or "No" whether you wish to
immediately go online.
The "Set PG interface dialog window" is
displayed where you can select the access
route S7ONLINE (STEP 7) > CP5611(MPI)".

40 Select the
Target system > Download.

You obtain the dialog window with options.

41 Select the "System and user program",
"Online (COM1)” and initialization when first
downloading the user program.
Note: If a user program is downloaded
again, you can also specify "User program"
without "initialization".
Start with "download"

A progress display shows how the system
and your user program are being
downloaded into the memory module.
A dialog window is displayed where you can
select whether the FM458 should go into
STOP by either entering a "yes" or "no".

41a If you select yes If the download has been completed, the
dialog window "Operating state" is displayed
with "STOP" and you can make a warm start
with RESTART. STOP is displayed on the
CPU module.

41b If you select restart A dialog window is displayed where you can
select whether you want to restart by
entering either "Yes" or "No".

42 Start the FM 458-1 DP application module
with "Yes” then select "Close".

Your user program is started and  "RUN" is
displayed on the FM458.

Downloading online
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7 Testing the user project on the FM 458-1 DP
Here you will read about:

• how you can test your user program
• the possibilities which you have of testing your user program

Now test the program, which has been downloaded into the SIMATIC
CPU module. The test procedure is the same as you already know for.

The test mode of the FM 458-1 DP application module offers you an
extensive range of functions. You can

• monitor the values of block I/O and change the values of block
inputs,

• generate and delete connections, and
• insert and delete blocks.

The values which are registered for test, have a yellow background. You
can easily monitor the behavior by changing parameters at the block
inputs.

Before you start the test, please check whether the following
prerequisites are fulfilled:

• You have established a connection between the PG/PC and your
SIMATIC station.

• You have downloaded the actual project into the memory module,
which is located in the FM 458-1 DP module.

• The associated CFC chart (e.g. "running lights”) has been opened.

Step Procedure Result
43 Select the menu command:

Target system > Compare, to display the
"Compare" dialog field.

The CPU name with data and time of the last
compilation between the actual configured
software and the current CPU program are
displayed. If they match, the result is: "The
configuring and the CPU program match".
You have checked that the PG/PC and the
FM 458-1 DP application module can
communicate.

44 Select the menu command:
Test > Test settings
Enter the refresh period for the screen
display in tenths of seconds.
Acknowledge the change with "OK".

In the test mode, the values of the I/O are
updated cyclically on the screen with the
selected refresh period.
If the computation time is not sufficient to
fulfill the refresh periods, then you will be
warned. The closed-loop control always has
the higher priority

Contents of this
section

Introduction
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45 Before you go into the test mode, change
over the test mode from "Process operation"
to "laboratory operation" with
Test > Laboratory operation.
Note: In "Process operation", the default
setting is that no I/O are registered for
monitoring. In this test mode, you must select
the appropriate blocks and explicitly log
them-on for monitoring.

This means that all of the block I/O are
automatically switched-in for "monitoring"
(the values have a yellow background).

46 Select the menu command:
Test > Test mode:

The "Test: RUN (laboratory)" appears in
green in the status bar.
In the test mode, you can monitor and
change the dynamic behavior (online).

7.1 Disconnecting the connections between the block I/O
online

In the CFC chart, using the mouse pointing device, select the block I/O
which you wish to disconnect. Then remove this with Edit > Delete.

The connecting line between the I/O disappears and at the I/O, the last
value, which was transferred on the connection, is displayed as
parameter value.

NOTE Connections to global operands can neither be generated online nor
deleted.

7.2 Establishing the connections between block I/O online

In the CFC chart, using the mouse pointing device, select the block I/O
where you wish to establish a connection.
With the changeover key pressed, now select the block I/O to which this
connection should be made.

The connecting line between the selected I/O is generated, and the
actual parameter value, which is presently being transferred, is displayed
at the output.

7.3 Changing the parameterization of block I/O online

Select the block input whose parameter value is to be changed, by
double-clicking. The dialog box "Properties I/O" is displayed in which you
can change the value.

You can immediately identify the effect of the change in the CFC Chart

Procedure

Result

Procedure

Result

Procedure

Result
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7.4 Inserting a block online

Using the command View > Catalog, call-up the block catalog. Open the
block family and drag the selected function block to the working area.

NOTE Not all of the function blocks can be inserted online. Refer under
"configuring data" in the online help for the block.

7.5 Deleting blocks online

Select the function block and remove it using the command Edit >
Delete.

Procedure

Procedure
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8 Results
You have now got to know some of the simple handling operations in the
CFC configuring. You now know how a project is created using the
SIMATIC Manager, how a CFC Chart is generated and function blocks
inserted from a library. You have interconnected and parameterized the
function blocks. You have generated a program which can run and which
has been downloaded into the SIMATIC station. You can observe and
modify the dynamic behavior in the test mode

You can now review the results for the project example "My First Project“
in process operation if you have assembled and connected-up the
necessary hardware of the SIMATIC station (refer to Table 1-1, Section
1.1.2).

In order to view the sawtooth, you must first connect an oscilloscope to
the SIMATIC station. The assignment of the pins at output connector X1
of the EXM 438-1 expansion module is shown in the following table. The
output voltage range extends from -10 V to +10 V.

You can monitor the change of the upper integrator limit value as a result
of your SIMATIC CPU program at this analog input (e.g. a change which
is made using a SIMATIC OperatorPanel which is not part of this simple
example).

Pin Function Output
11/12 Analog output 1 Sawtooth

20 Ground

Table 8-1 Excerpt from the pin assignment of EXM 438-1, connector X1

You can observe the running light function at the LED display of the
ET200 module SM 322.

Sawtooth
generator

Running light
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9 Archiving the project
Step Procedure Result
47 In the SIMATIC Manager, select

File > Archive.
The "archiving" dialog field is displayed.

48 In the dialog field "Archiving", select the user
project with "My First Project“.
Click on OK.

The "archiving - select archive dialog field" is
displayed.
The default file "My_first.zip" has already
been entered with archiving path.

49 In the dialog field "archiving - select archive",
when required, change the file name and/or
the path and then click on "save"

The project is now saved in the selected path
and filenames as zip file.

NOTE When you select menu bar File > De-archive, the archived project can
always be re-established with this particular release.
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10 Background information on FM 458-1 DP
Here you will read about:

• which basic system properties the FM 458-1 DP application
module can offer you

Detailed information about all of the properties/features of the FM 458-
1 DP application module are provided in the User Documentation which
is installed in the system (Start->Simatic-> Documentation)

10.1 The coupling to SIMATIC CPU

The FM 458-1 DP application module has a RAM memory (128 Kbytes)
which is used to connect it to the P bus. You can exchange data with one
SIMATIC S7-CPU via this P-bus memory. In this case, the FM 458-1 DP
application module is passive on the P bus. This means that you cannot
directly access other SIMATIC station modules using the FM 458-1 DP
application module.

You have 3 ways of exchanging data with the SIMATIC-CPU:
• You can transfer 4 bytes to the SIMATIC CPU using a process

interrupt
• You can send and receive 128 bytes using SIMATIC I/O access

operations (in our "my first project“ project, we use this type of
data exchange to transfer the upper limit value of the integrator
from the SIMATIC CPU to the FM 458-1 DP application module)

• Using data sets, you can send and receive a large quantity of
data

Contents of this
section

Note
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Designation Number of data Configuring Speed Computation time
(on the FM 458)

Process
interrupt

4 bytes to the
SIMATIC-CPU

FM 458-1 DP:
Function block
PAS7

SIMATIC CPU:
OB40, etc.

When PAS7 is
called, an interrupt
is immediately
initiated on the
SIMATIC-CPU,
e.g. OB40 (if a
higher-priority
interrupt is not
being presently
processed).

Extremely low (only
for PAS7)

Data transfer
with I/O
access
operations

128 bytes in both
the send and
receive directions

FM 458: Blocks
S7RD, S7WR

SIMATIC-CPU:
Transfer commands
for the I/O

When a block is
called, data is
immediately read-
out of the memory
or written into the
memory.

Computation times of
all configured
S7RD/S7WR blocks:
approx. 5µs.

Transfer of
data sets

For extremely
high quantities of
data: Max.
approx. 125 data
sets, each with
max. 240 bytes

FM 458: Virtual
connections with
the blocks @CPB,
CRV/CTV

SIMATIC-CPU:
System functions
SFC58/59

Consistency: All
data associated
with a telegram are
consistent with one
another, i.e. they
are transferred in a
data package.

When the block is
called, the data to
a telegram are
read or sent.

For each data set,
there is a computation
time to process the
telegram (approx.
30µs for each
CRV/CTV) and
copying the net data
into/out of the P bus
memory.

For large data
quantities and a high
P bus utilization,
increased
computation time
must be expected.

Fig. 2:Overview of the 3 ways to exchange data
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10.2 The run properties

With the FM 458-1 DP application module, you can define up to 5 cyclic
sampling times. A cyclic sampling time Tx is always a power of 2 to the
basic sampling time T0. The cyclic sampling time T1 is always the
fastest, the T5 the slowest sampling time. The blocks are computed in
these sampling times. The call of the individual sampling times is shown
in the following diagram:

T1

T2

T1+T2 T1+T2T1+T3 T1+T4 T1+T2

T3

This Example:
T1 = 1 * T0
T2 = 2 * T0
T3 = 4 * T0
T4 = 8 * T0

T1

T2

T3

T1

T2

T1 T1

T4

T4

Fig. 3: Run properties of the FM 458-1 DP

Using these properties, you can split-up your complete application into
individual sub-tasks. You can arrange that these sub-tasks are computed
at different speeds. This allows you to finely distribute the available
computation performance to the particular application. Such a distribution
can, for example, look like this:

Sampling
time Functions

T1 1 ms Closed-loop speed control
T2 4 ms Higher-level closed-loop position control
T3 8 ms Communications
T4 32 ms Reading-in binary signals of an input field
T5 256 ms System blocks



Background information on FM 458-1 DP

Getting started with FM 458-1 DP 10-23
Edition 03.2003

10.3 Addressing the hardware

For the FM 458-1 DP application module, you can address all of the
hardware inputs and outputs using symbolic addresses. You designate
the inputs and outputs in the HWConfig hardware configuration. These
symbolic addresses are then available in CFC. Inputs/outputs, which you
do not designate in HW Config, are not available in CFC.

Fig. 4: Example of a completed address field with reference to the CFC
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10.4 Process data communications

You (almost) always configure the process data communications (e.g. for
PROFIBUS DP) on the FM 458-1 DP application module in the same
way:

You require the following
• one central block (e.g. @PRODP for the PROFIBUS DP

coupling) which initializes and monitors the communications. You
configure communication-specific tasks (e.g. the baud rate) and
the (Port) at this central block.

• Send and receive blocks CTV and CRV. Using these function
blocks, you send/receive net data to/from the hardware.

• Virtual connections. The connections (I/O) of the function
blocks which you configured, are used as data sources or data
drains (receivers). These virtual connections represent the
interrelationship between the data to be sent/received (function
block connections) and the send/receive function blocks
CTV/CRV.

Initialisiert
und überwacht

Zentralbaustein
@... Hardware

Kommunikationspartner

Virtuelle
Verbindungen

Empfangsbaustein
CRV

Sendebaustein
CTV!...!...

Datenpuffer Datenpuffer

Virtuelle
Verbindungen

Regeltechnische Bausteine,
z.B. Hochlaufgeber, Regler, etc.

Fig. 5: Principle of the process data communications
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