
Preface, Contents

Product Overview

Transferring WinAC MP
to the Multi Panel

Developing and
Downloading a STEP 7
Project for WinAC MP
on the Multi Panel

Customizing WinAC MP
for Your Application

Reference

Index

SIMATIC

WinAC MP for MP370

User Manual

Edition: 1



Copyright and Safety Notification
Safety Guidelines
This manual contains notices which you should observe to ensure your own personal safety, as
well as to protect the product and connected equipment. These notices are highlighted in the
manual by a warning triangle and are marked as follows according to the level of danger:

Warning
Indicates that death, severe personal injury or substantial property damage can result if
proper precautions are not taken.

Caution
Indicates that minor personal injury or property damage can result if proper precautions are
not taken.

Note
Draws your attention to particularly important information on the product, handling the
product, or to a particular part of the documentation.

Qualified Personnel
Only qualified personnel should be allowed to install and work on this equipment. Qualified
persons are defined as persons who are authorized to commission, to ground, and to tag circuits,
equipment, and systems in accordance with established safety practices and standards.

Correct Usage
Note the following:

Warning
This device and its components may only be used for the applications described in the
catalog or the technical descriptions, and only in connection with devices or components
from other manufacturers which have been approved or recommended by Siemens.

This product can only function correctly and safely if it is transported, stored, set up, and
installed correctly, and operated and maintained as recommended.

Trademarks
Siemens®, SIMATIC®, HMI®, MP370®, and ProTool® are registered trademarks of SIEMENS AG.
WinAC MP™ is a trademark of SIEMENS AG. ActiveX® and Windows® are trademarks of
Microsoft Corporation.

Other designations used in this document are also registered trademarks; the owner’s rights may
be violated if they are used by third parties for their own purposes.
Copyright Siemens Energy & Automation, Inc., 2002
All Rights Reserved

The reproduction, transmission or use of this document or
its contents is not permitted without express written
authority. Offenders will be liable for damages. All rights,
including rights created by patent grant or registration of a
utility model or design, are reserved.

Disclaimer of Liability

We have checked the contents of this manual for agreement
with the hardware and software described. Since deviations
cannot be precluded entirely, we cannot guarantee full
agreement. However, the data in this manual are reviewed
regularly and any necessary corrections included in
subsequent editions. Suggestions for improvement are
welcomed.

Siemens Energy & Automation, ISBU
755 College Road East
Princeton, NJ 08540, USA

© Siemens Energy & Automation, Inc., 2002
Technical data subject to change.



iii

Preface
WinAC MP is a software S7 PLC for the SIMATIC MP370 and MP370Touch Multi Panels.
WinAC MP controls a network of PROFIBUS-DP devices, and ProTool provides user process
visualization and control.

WinAC MP consists of the following elements:

� WinAC MP software for the MP370/MP370Touch

� STEP 7 projects for MP370/MP370Touch

� ProTool projects with WinAC MP example screens for MP370/MP370Touch

� SIMATIC WinAC MP for MP370 User Manual (electronic)

� Authorization diskette

� Product ID letter

Audience
This manual is intended for engineers, programmers, and maintenance personnel who have a
general knowledge of SIMATIC programmable logic controllers. Knowledge of STEP 7
programming, ProTool, and WinAC is also required.

Scope of the Manual
This manual describes the features and the operation of version 3.0 of WinAC MP.

How to Use This Manual
This manual provides the following information:

� Product Overview

� System Requirements for WinAC MP

� Transferring WinAC MP to the Multi Panel

� Transferring Authorization for WinAC MP

� Removing WinAC MP and WinAC MP Authorization

� Downloading a STEP 7 Project to WinAC MP on the Multi Panel

� Controlling Your Process with WinAC MP

� Customizing WinAC MP for Your Application

� Reference Information

Other Manuals
For additional information, refer to the following manuals:

Related Manuals

Title Content
STEP 7 User Manual This manual provides information on programming in

STEP 7.
ProTool User Manuals These manuals provide basic information about the

configuration of ProTool user interface screens and ProTool
on the multi panel.
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Contacting Customer Support
You can find additional information about WinAC MP and updates to this user manual at the
Siemens Energy & Automation web site:

www.sea.siemens.com/software

This web site includes useful information, such as application notes, in the Technical Service
area.

Customer Support

North America
Telephone (800) 333-7421 (option #3)
E-mail ISBU.Hotline@sea.siemens.com

simatic.hotline@sea.siemens.com
Internet http://www.sea.siemens.com
Europe
Telephone ++49 (0) 180 50 50 222
E-Mail support@siemens.com
Internet http://www.ad.siemens.de/support
Fax ++49 (0) 180 50 50 223
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Product Overview

WinAC MP and ProTool CS
WinAC MP consists of a control engine and add-in components for ProTool CS, an example
ProTool project, and an example STEP 7 project. You work in ProTool CS on your configuration
computer (personal computer or programming device) to customize your ProTool project as
desired. Then you download the control engine and your ProTool project to the multi panel. From
STEP 7 on the configuration computer, you develop program logic, configure your hardware
devices, and download the STEP 7 project to the multi panel. The control engine on the multi
panel uses the STEP 7 program logic and acts as the controller for a network of PROFIBUS-DP
devices. The ProTool project with WinAC MP components offers process control and visualization
on the multi panel as the control engine operates.

When you install WinAC MP on your configuration computer, ProTool CS is automatically
modified: WinAC MP functions and ActiveX controls are added. Example ProTool projects
("MP370" for the keyboard unit and "MP370Touch" for the touch panel) are also installed. The
example ProTool projects contain WinAC MP functions, ActiveX controls, and two screens with
WinAC MP components.
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The first example screen is the WinAC_MP_Panel:

Figure:   WinAC_MP_Panel Screen

The WinAC_MP_Panel screen uses a combination of ActiveX controls and screen objects with
WinAC MP functions attached:  

� The "WinAC MP" ActiveX control provides a control panel that serves as your interface to
the WinAC MP control engine. The control panel provides everything you need to monitor
and operate the WinAC MP control engine: all the status indicators, plus a key switch that
allows you to change the operating mode.

� The Cycle Time area and the Min Sleep Time field are screen objects with WinAC MP
functionality. When the WinAC MP control engine is running, you can watch the last cycle
time, average cycle time, maximum cycle time, and minimum cycle time update in the
Cycle Time area. The Cycle Time screen objects are read-only. You can set the minimum
sleep time value (ms) in the Min Sleep Time field, which is a read/write field. These are
some examples of how you can configure WinAC MP functionality for your own buttons,
bitmaps, or other screen objects.

� The "Histogram" ActiveX control provides visual information about cycle time (when the
WinAC MP control engine is running) in the form of a histogram.
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The second example screen is the WinAC_MP_Function example screen:

Figure:   WinAC_MP_Function Screen

This screen shows how to use screen objects such as buttons and bitmaps, rather than the
"WinAC MP" ActiveX control, to provide a control panel interface for the WinAC MP control
engine. This is an example of how you can customize WinAC MP functionality when you build
your own screens.

You can use ProTool CS to create new screens or modify the existing screens in the example
project. To insert a "Histogram" ActiveX control, use the Histogram  object on the Screen
Objects toolbar in ProTool CS. To insert a "WinAC MP" ActiveX control, use the WinAC MP 
object on the Screen Objects toolbar. The WinAC MP functions available from ProTool CS are
explained in the topic Controlling Your Process with WinAC MP.
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Introduction to Process Control with WinAC MP
System Overview
Your control system consists of these elements:

� MP370 or MP370Touch with WinAC MP

� PROFIBUS-DP subnet

� PROFIBUS-DP I/O devices

PROFIBUS-DP Subnet

Distributed (Remote) I/O

MP370
WinAC MP

Figure:   System Overview

Getting Started
The multi panel can control your process with WinAC MP after you perform these tasks:

� Set up your system according to the system requirements.

� Use the WinAC MP software CD to install the WinAC MP software on your configuration
computer.

� Use ProSave and ProTool CS, respectively, to download the WinAC MP runtime files and
ProTool project to the multi panel.

� Use STEP 7 to develop the program logic and configure the PROFIBUS-DP devices that
are to be controlled by WinAC MP, then download the STEP 7 project to the multi panel.

� Use ProTool CS to develop any additional process screens. You can then download
these screens to the multi panel. Refer to the documentation on ProTool that was
delivered with that software. You can also use ProTool CS to modify the WinAC MP
example screens in the ProTool project that is provided when you install WinAC MP. See
the topic Using ProTool CS to Customize the Application.

When you have completed these steps, the multi panel is ready for process control. See the topic
Controlling Your Process with WinAC MP for control information.
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The following diagram illustrates the connections and data paths needed for WinAC MP
installation and transfer, STEP 7 user program development and download, ProTool screen
development, and process control:

Desktop Computer

PROFIBUS-DP Subnet

Distributed I/O

MP370

STEP 7 User Program

ProSave

ProTool CS

STEP 7

ProTool Project with
WinAC MP Example Screens

WinAC MP Runtime Files

Ethernet, Serial, MPI, or USB

Figure:   Overview of Transfers
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System Requirements
To install and use WinAC MP, you must have a configuration computer (personal computer or
programming device) with one of the following operating systems:

� Microsoft Windows 98 Second Edition

� Microsoft Windows Me

� Microsoft Windows NT 4.0 with Service Pack 5 or higher

� Microsoft Windows 2000 with Service Pack 2 or higher

� Microsoft Windows XP (Professional or Home Edition)

This configuration computer must also have the following:

� 10 Mbytes or more on the hard disk drive

� 32 Mbytes or more work memory

This configuration computer must have the following software installed, in the sequence shown:

� STEP 7 V 5.1 SP2 or higher

� ProTool CS V 6.0 or ProTool/Pro CS V 6.0

You also need:

� An MP370 or MP370Touch multi panel with 4 MB free flash memory for user application

� A standard cable connecting the Ethernet, serial, MPI, or USB ports of the configuration
computer and the multi panel

� A PROFIBUS-DP network of devices connected to the multi panel (necessary for process
control)

WinAC MP provides the following items:

� WinAC MP installation CD

� WinAC MP authorization diskette

� Product ID letter

� Electronic documentation (SIMATIC WinAC MP for MP370 User Manual)
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Transferring WinAC MP to the Multi Panel

Transfer Overview
To transfer WinAC MP from the configuration computer to the multi panel, you are required to
perform the following actions on your configuration computer and on the multi panel:

� Set parameters on the configuration computer and the multi panel for the
communications interface.

� Connect the multi panel to the configuration computer and set the multi panel to Transfer
mode. (See the hardware manual for your multi panel.)

� Use ProSave to download WinAC MP runtime files from the configuration computer to the
multi panel.

� Use ProSave to download authorization for WinAC MP from the configuration computer
to the multi panel.

� Use ProTool CS to download your ProTool project (for instance, the example project with
WinAC MP screens) from the configuration computer to the multi panel.

MP370

ProTool Project with WinAC MP
Example Screens

WinAC MP Runtime Files

ProSave
ProTool CS

Desktop Computer

Ethernet, Serial, MPI, or USB

Figure:   Download WinAC MP

After you complete these tasks, you can configure hardware devices and write program logic in
STEP 7 and download your STEP 7 project to the WinAC MP control engine on the multi panel.
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Setting Parameters for Communications
Four interfaces are supported for communications between the configuration computer and the
multi panel:

� Ethernet

� Serial

� MPI

� USB

You must set parameters in the appropriate software package (such as ProSave or ProTool) of
the configuration computer and also in the Control Panel utilities of the multi panel in order for the
devices to communicate successfully. For instance, when you download WinAC MP runtime files
or WinAC MP authorization, you use ProSave, so you must configure communications
parameters in both ProSave and the multi panel. Likewise, when you download a ProTool project,
you must ensure that the communications parameters match for ProTool and for the multi panel.
(It is not necessary for ProSave and ProTool to use the same communications protocol, unless
you wish it.)

Remote Control Option
When you edit transfer settings for the multi panel, you have the option of enabling Remote
Control. The advantage of enabling Remote Control is that you can download from the
configuration computer without having to walk over to the multi panel, physically close your
ProTool project, and set the multi panel to Transfer mode. With Remote Control, when you initiate
a download from the configuration computer, the ProTool project on the multi panel is
automatically closed and the multi panel is set to Transfer mode for you. The disadvantage is that
someone could perform a Remote Control download when the multi panel was performing control
activities with WinAC MP, thereby interrupting process activities.

Warning
If you select the Remote Control transfer option, it is possible for a user to download from the
configuration computer to the multi panel while the control engine is running.

If the control engine is connected to field equipment, interrupting its operation could cause death
or serious injury to personnel and/or damage to equipment.

Ensure that only qualified personnel have access to the configuration computer. Ensure that your
equipment is in a safe state before proceeding with a download. Always install a physical
emergency stop circuit for your machine or process.

To enable Remote Control on the multi panel, follow these steps:

1. From the Control Panel on the multi panel, open the Transfer utility.

2. Under Channel 1 (Serial), ensure that the Remote Control check box is selected.

Direct Connection
For all of the communication options described below, you must enable a direct connection on the
multi panel to the configuration computer. Follow these steps:

1. From the Control Panel on the multi panel, open the Communications utility and select the
PC Connection tab.

2. Ensure that the Enable Direct Connections To The Desktop Computer check box is selected.
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Ethernet Communication Parameters
To set up Ethernet communication, you must fill out the following parameters:
Ethernet Communication Parameters

On Your Configuration Computer... On the Multi Panel...

To Connect from ProSave
1. From the General tab of ProSave,

select the correct Device Type (MP370
or MP370 Touch) for your multi panel.

2. From the Connection list box, select
Ethernet.

3. Under Connection Parameters, supply
the IP Address or Computer Name of
the multi panel.

To Connect from ProTool
1. Open the Download Preferences (File

> Download > Preferences). The Set
Download dialog box opens.

2. Select Ethernet from the list box.
3. Supply the IP Address or Computer

Name of the multi panel.
4. (Optional) Select the Enable Upload

check box only if you need to be able
to upload ProTool projects from the
multi panel to the configuration
computer.

Edit Network Configuration
1. From the Control Panel, open the

Network Configuration utility.
2. From the Adapters tab, click on the

Properties button.
3. Supply an IP address. (This is the IP

address referenced in ProTool and
ProSave.)
* If you obtain an IP address by
choosing DHCP, you must restart the
multi panel and type ipconfig at the
MS-DOS command prompt in order to
see what the address is.
* If you specify an IP address, you
must use one provided by your
network administrator if your multi
panel is part of an Ethernet network.
You can only create your own IP
address if your multi panel is not
networked, and in that case you must
use a crossover cable connection
between the multi panel and the
configuration computer.

Edit Transfer Settings
1. From the Control Panel, open the

Transfer utility.
2. Under Channel 2, select Ethernet from

the list box.
3. Select the Enable Channel check box.
Save Your New Settings
1. From the Control Panel, open the OP

utility.
2. Click on the Save Registry button to

ensure that your configuration will be
saved. Otherwise, your settings are
reset to the default after the next
power cycle.

How to Cable An Ethernet Connection
For a networked Ethernet connection, you connect the configuration computer to the multi panel
using a hub and twisted-pair, category 5 cables. For a non-networked Ethernet connection, you
do not use a hub, and you use crossover, twisted-pair, Category 5 cables. To create a crossover
cable, you need a length of Category 5 cable, an RJ-45 connector for each end, and a crimping
tool. Wire one end normally; at the other end, connect 1 to pin 3 and 2 to pin 6.
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Serial Communication Parameters
To set up serial communication, you must connect a serial cable between the serial port on your
configuration computer and the Config/Printer port on the multi panel, and fill out the following
parameters:

Serial Communication Parameters

On Your Configuration Computer... On the Multi Panel...

To Connect from ProSave
1. From the General tab of ProSave,

select the correct Device Type (MP370
or MP370 Touch) for your multi panel.

2. From the Connection list box, select
Serial.

3. Under Connection Parameters, select
the COM port that you are using on
your configuration computer for this
connection.

4. Select the baud rate that is appropriate
for your connection.

To Connect from ProTool
1. Open the Download Preferences (File

> Download > Preferences). The Set
Download dialog box opens.

2. Select Serial from the list box.
3. Select the COM port that you are using

on your configuration computer for this
connection.

4. Select the baud rate that is appropriate
for your connection.

5. (Optional) Select the Enable Upload
check box only if you need to be able
to upload ProTool projects from the
multi panel to the configuration
computer.

Edit the Transfer Settings
1. From the Control Panel, open the

Transfer utility.
2. Under Channel 1 (Serial), ensure that

the Enable Channel check box is
selected.

Save Your New Settings
1. From the Control Panel, open the OP

utility.
2. Click on the Save Registry button to

ensure that your configuration will be
saved. Otherwise, your settings are
reset to the default after the next
power cycle.
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MPI Communication Parameters
To set up MPI communication, you must install a card (such as CP 5611 for desktop PCs or
CP 5511 for laptops) and driver on the configuration computer. You connect an MPI/PROFIBUS
cable between the 9-pin port of the card on the configuration computer and the DP/MPI/PPI port
on the multi panel, and fill out the following parameters:

Note
You cannot perform MPI/PROFIBUS-DP downloads from ProTool if the PG/PC interface in
STEP 7 is set to either MPI or PROFIBUS. If you want to perform an MPI/PROFIBUS-DP
download from ProTool, you must change the PG/PC interface in STEP 7 to something else.

MPI Communication Parameters

On Your Configuration Computer... On the Multi Panel...

To Connect from ProSave
1. From the General tab of ProSave,

select the correct Device Type (MP370
or MP370 Touch) for your multi panel.

2. From the Connection list box, select
MPI/PROFIBUS DP.

3. Under Connection Parameters, supply
the OP address that has been
assigned to the multi panel. (The OP
address is the same as the Address
parameter in the S7-Transfer Settings
utility.)

To Connect from ProTool
1. Open the Download Preferences (File

> Download > Preferences). The Set
Download dialog box opens.

2. Select MPI/PROFIBUS DP from the list
box.

3. Supply the OP address that has been
assigned to the multi panel. (The OP
address is the same as the Address
parameter in the S7-Transfer Settings
utility.)

4. (Optional) Select the Enable Upload
check box only if you need to be able
to upload ProTool projects from the
multi panel to the configuration
computer.

Edit the S7-Transfer Settings
1. From the Control Panel, open the S7-

Transfer Settings utility.
2. Select MPI from the list box.
3. Click on the Properties button.
4. Edit the Address field to assign an

appropriate station address to the
multi panel. (This is the OP address
used by the configuration computer.)

Edit the Transfer Settings
1. From the Control Panel, open the

Transfer utility.
2. Under Channel 2, select MPI from the

list box.
3. Select the Enable Channel check box.
Save Your New Settings
1. From the Control Panel, open the OP

utility.
2. Click on the Save Registry button to

ensure that your configuration will be
saved. Otherwise, your settings are
reset to the default after the next
power cycle.
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USB Communication Parameters
To set up USB communication, you must connect a USB cable between the USB port on the
configuration computer and the USB port on the multi panel, and fill out the following parameters:
USB Communication Parameters

On Your Configuration Computer... On the Multi Panel...

To Connect from ProSave
1. From the General tab of ProSave,

select the correct Device Type (MP370
or MP370 Touch) for your multi panel.

2. From the Connection list box, select
USB. (There are no other parameters
to configure.)

To Connect from ProTool
1. Open the Download Preferences (File

> Download > Preferences). The Set
Download dialog box opens.

2. Select USB from the list box.
3. (Optional) Select the Enable Upload

check box only if you need to be able
to upload ProTool projects from the
multi panel to the configuration
computer.

Edit Transfer Settings
1. From the Control Panel, open the

Transfer utility.
2. Under Channel 2, select USB from the

list box.
3. Select the Enable Channel check box.
Save Your New Settings
1. From the Control Panel, open the OP

utility.
2. Click on the Save Registry button to

ensure that your configuration will be
saved. Otherwise, your settings are
reset to the default after the next
power cycle.
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Downloading WinAC MP Runtime Files
Before you can download any ProTool project with WinAC MP components to the multi panel,
you need to download the WinAC MP runtime files. The WinAC MP runtime files include the
WinAC MP control engine.

To download the WinAC MP runtime files from your configuration computer to the multi panel,
you use ProSave. From the Windows Start menu, click SIMATIC > ProSave V6.0 > ProSave to
open ProSave.

Note
Make sure that Transfer has been selected from the Loader dialog box on the MP370 or
automatic transfer ("Remote Control") on the MP370 is enabled so that the MP370 opens a
connection for your configuration computer. You should see the message "Connecting to host" on
the MP370.

Then follow these steps.

1. Click on the General tab and select the correct device (MP370 or MP370Touch) from the
Device Type list box.

2. In the Connection list box, select the type of connection that you are using between the
configuration computer and the multi panel. (See the topic Setting Parameters for
Communications.)

3. Complete the Connection Parameters.
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4. Click on the Options tab and click on the Device Status button to verify the connection.

Note
If you have a communications problem and the MP370 is in Transfer mode, check your
physical cable connections, and check to make sure that your settings in ProSave and on
the MP370 are correct for your connection. See the topic Setting Parameters for
Communications.

5. Click on WinAC MP in the Available Options (left pane) to select it, then click on the >>
button to add it to the installed options of the MP370 (right pane). This causes the
WinAC MP runtime files to begin downloading from your configuration computer to the
multi panel.

Note
If an earlier version of WinAC MP has already been installed, you are warned that this
option is already installed. You must use the << button to remove it from the Installed
Options pane first. Then you can select WinAC MP from the Available Options and add
(re-install) it to the MP370.

For several minutes (depending on your communication method), the configuration computer
transfers files to the multi panel. The multi panel receives the files, uncompresses them, and
stores them in the RAM/flash memory storage system. While the transfer is in progress, the
configuration computer displays progress on the transfer. On the multi panel, the Transfer dialog
box updates with messages containing progress on the files that the multi panel is receiving,
uncompressing and writing to the flash file system. At the end of the transfer, a message box
confirms the success of the transfer. When the download is finished, you are prompted to reboot
the multi panel (optional).

The WinAC MP control engine is now installed on the multi panel (but you do not have a human-
machine interface to the control engine until you download a ProTool project with WinAC MP
screens).

Do not close ProSave. You still need to download WinAC MP authorization to the MP370.
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Downloading Authorization for WinAC MP
You use ProSave to transfer WinAC MP authorization from an authorization diskette inserted in
the drive of your configuration computer to the multi panel. If ProSave is not already open, click
SIMATIC > ProSave V6.0 > ProSave from the Windows Start menu.

Note
Make sure that Transfer has been selected from the Loader dialog box on the MP370 or
automatic transfer ("Remote Control") on the MP370 is enabled so that the MP370 opens a
connection for your configuration computer. You should see the message "Connecting to host" on
the MP370.

Note
You must ensure that the WinAC MP control engine is shut down when you use ProSave to
download files.

If you attempt to perform downloads from ProSave while the WinAC MP control engine is running,
the control engine process interferes with the download process. The control engine process
takes precedence and the other operation fails. You may not receive any notification that the
process has failed.

Always shut down the WinAC MP control engine before you download files from ProSave.

To transfer WinAC MP authorization to the multi panel using ProSave, follow these steps:

1. Click on the Authorize tab in ProSave.

2. Select the correct drive letter for the drive where you have inserted the authorization
diskette. The authorization is displayed in the Selection pane. The License counter
should display a value of 001 for the WinAC MP authorization, indicating that the license
is present on the diskette. (You can use the Device Status button to read the multi panel
in order to see whether an authorization has already been installed.)

3. To transfer the authorization from the diskette to the multi panel, select the product
authorization in the Selection pane and use the >> button to add it to the Installed
Options.

After the authorization transfer completes, you can exit ProSave.

Caution
Do not dispose of your authorization diskette! If you later want to reload the ProTool image on the
multi panel, or perform a backup restore, you must first remove the authorization for WinAC MP
from the multi panel (that is, transfer it back onto the diskette). The authorization can only be
transferred back onto the original authorization diskette. See the section on removing
authorization in the topic Removing WinAC MP.

Authorization for WinAC MP is not backed up when you back up the flash memory of the multi
panel, nor is it a part of the image on the multi panel. Consequently, if you do not uninstall the
existing authorization (restore it from the multi panel to the diskette) before loading a new image
or restoring from backup to the multi panel, the authorization information is erased during the load
operation, effectively causing you to lose the authorization.

From the Authorize tab in ProSave, use the << button to move an authorization license from the
multi panel (Installed Options, right pane) back to the diskette (Selection, left pane). Should your
authorization be lost, you would need to contact Siemens technical support for assistance. See
the topic Contacting Customer Support.



Transferring WinAC MP to the Multi Panel

16

Downloading WinAC MP Example ProTool Project
Note
Make sure that Transfer has been selected from the Loader dialog box on the MP370 or
automatic transfer ("Remote Control") on the MP370 is enabled so that the MP370 opens a
connection for your configuration computer. You should see the message "Connecting to host" on
the MP370.

Open the Example Project
From the Windows Start menu, click Start > SIMATIC > ProTool CS V6.0 > ProTool Pro CS to
open ProTool CS. There are separate ProTool example projects for the MP370 and the
MP370Touch. The way that you access the example projects depends on whether or not you
have selected "ProTool Integration in STEP 7" (from the File menu in ProTool).

To open the example project that is appropriate for your multi panel, use the File > Open menu
command to access the Open dialog box. Then choose the procedure that is right for you:

If you have selected ProTool Integration into STEP 7,
1. In the Entry Point list box, select Project.

2. In the Name list box, select the project that is appropriate for your multi panel ("MP370"
for the keyboard unit, or "MP370Touch" for the touch panel). The project should appear
in the Storage Path field. (The default storage path for the example projects is
C:\Siemens\PROTOOL\SAMPLES, with subdirectories for the MP370 and MP370
Touch.)

3. Click on the MP370 or MP370Touch icon to automatically display its name in the Object
Name field and its type (SIMATIC OP) in the Object Type field.

4. Click on the OK button to confirm your work and open the example project.

If you have not selected ProTool Integration into STEP 7,
1. From the Open dialog box, navigate to the PRO.PDB file that is located in the right

subdirectory for your multi panel ("MP370" subdirectory for the keyboard unit,
"MP370Touch" for the touch panel unit).

If you used the default installation locations for WinAC MP:

� The correct project for the keyboard unit is located under this path:
C:\Siemens\PROTOOL\SAMPLES\Win_AC_MP\MP370\TDOP

� The correct project for the touch panel unit is located under this path:
C:\Siemens\PROTOOL\SAMPLES\Win_AC_MP\MP370 Touch\TDOP

2. Click on the Open button to open the PRO.PDB example project file that you have
selected.
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Download the Example Project

To download the example project to the multi panel, click on the Download button  . If there
are communication difficulties, try these troubleshooting tips:

� Make sure that power is on to the multi panel and the multi panel is in Transfer mode or
automatic transfer ("Remote Control") on the MP370 is enabled. You can check the
Transfer settings on the MP370 in the Control Panel.

� Check that the cable is connected properly to the configuration computer and to the multi
panel.

� Review the topic Setting Parameters for Communications to ensure that you have
configured the connection properly.

A message box displays the status of the download, and the output window in ProTool CS states
whether the download is successful.

After a successful download, the multi panel displays a screen from the example project. The
default is the WinAC_MP_Panel screen:

Figure:   WinAC_MP_Panel Screen

The topic Controlling Your Process with WinAC MP describes the contents of the example project
in more detail.

The topic Using Your Project on the Multi Panel gives information about how to start and exit your
ProTool project, and how to start and shut down the WinAC MP control engine. However, you
must download a STEP 7 project to program the control engine before WinAC MP can be used
for process control. You can leave the example project open on the multi panel while you
download your STEP 7 project to the multi panel.
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Using Your ProTool Project on the Multi Panel
After you install the runtime files and download a ProTool project (such as the example project
with WinAC MP screens) that provides some type of control panel representation for the
WinAC MP control engine, you can view and experiment with the user interface of the control
engine. The instructions below assume that you have installed the example ProTool project on
your multi panel.

Remember that the control engine does not actually contain any program logic until after you
download a STEP 7 user program.

Start the Project on the Multi Panel
It is easy to start your ProTool project on the multi panel:

1. Ensure that the multi panel is powered on.

2. From the Loader dialog box on the multi panel, click on the Start button. ProTool opens
and your project is displayed.

Start the Control Engine
The type of multi panel you have determines how you start the control engine:

� Keyboard units: press the S3 key to start the control engine.

� Touch panel units: touch "Start WinAC MP" to start the control engine.

While the Control Engine Is Running:
The following restrictions apply while the control engine is running:

� The multi panel cannot connect to other PLCs. The WinAC MP control engine is
configured to talk to the local IP address.

� You should not perform ProSave operations or use utilities from the Control Panel of the
multi panel. (The WinAC MP control engine has priority over these other operations on
the multi panel. Such operations, if attempted, may fail without notice. Shut down the
control engine and re-attempt the ProSave or Control Panel operation.)

Note
Ensure that the WinAC MP control engine is shut down when you use ProSave to
download files (or when you use utilities in the Control Panel of the multi panel).

If you attempt to perform downloads from ProSave or use utilities in the Control Panel
while the WinAC MP control engine is running, the control engine process interferes with
the download and/or Control Panel processes. The control engine process takes
precedence and the other operations fail. You may not receive any notification that the
process has failed.

Always shut down the WinAC MP control engine before you perform a download from
ProSave or use a utility in the Control Panel of the multi panel.
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� You must not attempt to download a project from ProTool CS on the configuration
computer to the multi panel when the control engine is in RUN or RUN-P mode.

Warning
Downloading a ProTool CS configuration to the multi panel while the WinAC MP control
engine is in RUN or RUN-P mode interrupts the execution of the process.

If process equipment is not in a safe state, interrupting the execution of the process could
result in death or serious injury to personnel, and/or damage to equipment.

Shut down the WinAC MP control engine or set it to STOP mode prior to downloading
any ProTool CS configuration. Ensure that your equipment is in a safe state. Always
install a physical emergency stop circuit for your machine or process.

Shut Down the Control Engine
The type of multi panel you have determines how you shut down the control engine:

� Keyboard units: press the S4 key to shut down the control engine.

� Touch panel units: touch "Shutdown WinAC MP" to shut down the control engine.

Exit the Project
The type of multi panel you have determines how you exit the project:

� Keyboard units: press the S2 key to exit ProTool.

� Touch panel units: touch "Exit ProTool" to exit ProTool.

The Difference Between Shutting Down WinAC MP and Exiting ProTool
Exiting ProTool has no effect on the operation of the WinAC MP control engine. When you exit
ProTool, you close the project that provides you with an interface to WinAC MP. You cannot see
a representation of the control engine any longer. However, the control engine can run even if the
ProTool project is closed.

When you start the WinAC MP control engine, the power LED on the control panel representation
in the example ProTool project turns green, and it stays green until you issue the "Shutdown
WinAC MP" (S4) command. You can exit and restart ProTool on the multi panel and the power
LED will remain green.

If you want to shut down the control engine, you need to issue the "Shutdown WinAC MP" (S4)
command, which is entirely separate from the "Exit ProTool" (S2) command.
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Developing and Downloading a STEP 7 Project for
WinAC MP on the Multi Panel

Working with STEP 7
To use the WinAC MP control engine as a master on a PROFIBUS-DP network, you must
perform the following tasks:

� Create a project and a SIMATIC PC station with the SIMATIC Manager.

� Use the HW Config editor to configure the WinAC MP control engine as a WinLC
controller and configure the distributed I/O.

� Create a user program for the control program logic.

� Edit the PG/PC interface in STEP 7 so that you can use an MPI/PROFIBUS or an
Ethernet connection to download the hardware configuration and user program to the
multi panel.

STEP 7

PROFIBUS-DP Subnet

MP370

WinAC MP

STEP 7 Hardware Configuration
and User Program

Configuration Computer

Figure:   Download STEP 7 Hardware Configuration and User Program
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STEP 7 Connection Options
You can use either an MPI/PROFIBUS connection or an Ethernet connection to communicate
from STEP 7 on the configuration computer to the WinAC MP control engine on the multi panel:

� MPI/PROFIBUS  The default setting of the MPI/PROFIBUS interface of the multi panel
is MPI with a transmission rate of 187.5 Kbps. However, when you configure the control
engine on the multi panel as a PROFIBUS-DP master, the MPI/PROFIBUS interface on
the multi panel is automatically set to PROFIBUS-DP communications. This means that if
you use an MPI connection to download to the multi panel, you must take an extra step in
order to be able to perform subsequent downloads from STEP 7. You must edit the
PG/PC interface settings (change them from MPI to PROFIBUS with the corresponding
configured settings) before you can communicate from STEP 7 to the multi panel again.

� Ethernet  If you use an Ethernet connection to download the PROFIBUS-DP master
configuration to the multi panel, you do not need to change your PG/PC interface settings
in order to be able to perform subsequent downloads from STEP 7. Your STEP 7
connection uses the Ethernet port of the multi panel, and is unaffected by the
configuration of the MPI/PROFIBUS interface.

Note:
In order to configure STEP 7 to use an Industrial Ethernet connection to the multi panel,
you must have the SIMATIC NET networking software installed on your configuration
computer. (No networking software is needed on the multi panel.)
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Configuring the SIMATIC PC Station and the PROFIBUS-DP
Network
Configuring a SIMATIC PC Station in STEP 7
When you install WinAC MP on your configuration computer, the setup process installs two
STEP 7 sample projects: "MP370" and "MP370Touch"; use the one that is appropriate for your
multi panel. The sample projects are located under your ProTool installation folder:
..\ProTool\Samples\WinAC_MP\. If you wish to use the sample project, open it now and proceed
to the section entitled Defining Communication Settings and Network Properties, later in this
topic.

You can manually create a project for the WinAC MP control engine by following these steps:

1. Create a new project from the SIMATIC Manager. Select File > New and enter a project
name such as MyNewProject.

2. From the left pane of the SIMATIC Manager, select the project folder for the project
created in Step 1.

3. Use the menu command Insert > Station > Simatic PC Station to create your own
SIMATIC PC station.
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4. In the left pane of the SIMATIC Manager, double-click on the newly created station. This
causes the Configuration icon to appear in the right pane.

5. Double-click on the Configuration icon to enter the HW Config editor.



Developing and Downloading a STEP 7 Project for WinAC MP on the Multi Panel

24

6. If the HW Catalog is not already open, click on the  icon to open it.

7. From the HW Catalog, navigate to SIMATIC PC Station\Controller\WinLC. Drag the
WinLC controller to slot 2. The Properties – PROFIBUS interface DP dialog box appears.
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Defining Communication Settings and Network Properties
To configure the SIMATIC PC station as a DP master that can be downloaded to the WinAC MP
control engine on the multi panel, you must perform the following steps:

1. From the Parameters tab of the Properties – PROFIBUS interface DP dialog box, enter
the node address for the WinAC MP control engine on the multi panel. The default
address for the DP master is 2. Each node on the network must have a unique node
address between 0 and 125.

2. Click on the New button to open the Properties – New subnet PROFIBUS dialog box.
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3. From the General tab, assign a name for the network.
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4. Select the Network Settings tab. Examine the following settings and make changes if
desired:

� Highest PROFIBUS Address

(Can be reduced to improve polling speed, if you are certain you will never exceed a
certain number of stations.)

� Transmission Rate

(Default is 1.5 Mbps. Adjustable up to 12 Mbps depending on the speed requirement
of the application.)

� Profile

(Default is DP.)

For more information about PROFIBUS-DP communications and how to set up
PROFIBUS networks, refer to the SIMATIC NET PROFIBUS User Manual.

5. Click on the OK button to confirm the name and any changes to the network settings that
you have configured for the PROFIBUS subnet and close the Properties – New subnet
PROFIBUS dialog box.

6. Click on the OK button to confirm the node address that you have configured for the
SIMATIC PC station and close the Properties – PROFIBUS interface DP dialog box.
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7. (Optional) If you are using an Ethernet (TCP/IP) connection, you have to perform
additional tasks before proceeding to the next step. As an example for general TCP/IP
communication using fixed addresses, perform the following steps:

• Select an IE General from the SIMATIC PC Station folder in the Hardware Catalog
and drop it in slot 3 of the SIMATIC PC Station rack. The
Properties - Ethernet Interface IE General dialog box opens.

• In the IP Address field, enter the IP address of the multi panel. Click on the OK
button. The Properties - IE General dialog box opens.

• In the Interface Parameter Assignment Used (TCP/IP) field on the Assignment tab of
the dialog box, enter S7ONLINE. Click on the OK button.

• When the prompt "The module is not yet assigned to a network" appears, click OK.
(You do not need to assign the multi panel to a network for Ethernet communication.)

For more information about Ethernet communications and setting up Ethernet networks,
refer to the SIMATIC NET Ethernet User Manual.

Before you close the HW Config editor, configure your additional PROFIBUS nodes (slaves)

according to your application requirements. Then click on the  icon to save and compile the
configuration.

Downloading the Configuration
To download the hardware configuration to the WinAC MP control engine on the multi panel, you
must first set the PG/PC interface on the configuration computer to the type of connection,
MPI/PROFIBUS or Ethernet (TCP/IP), that you are using between the configuration computer and
the multi panel. Follow these steps to ensure that your PG/PC interface is set correctly:

1. From the SIMATIC Manager, select Options > Set PG/PC Interface.

2. Examine the Interface Parameter Assignment Used field. If it does not show the
appropriate interface parameter, click on the Select button to change the interface
selection. For example, you might need to set it to CP5611(MPI) or CP5611(PROFIBUS)
for a CP5611 card, or to a TCP/IP option that corresponds to an Ethernet card in your
PC.
Note
If you use an MPI connection for the first download, make sure that the baud rate is set to
187.5 Kbps.

3. Click on the OK button to accept the card configuration and close the window.
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To download the configuration, follow these steps:

1. Click on the  icon to download the configuration.

2. On the Select Target Module dialog box, ensure that the WinLC module (which
corresponds to the WinAC MP control engine on the multi panel) is highlighted and click
on the OK button.

3. For MPI or PROFIBUS connections, you are prompted for the Station Address of the
multi panel: use the address that is currently configured for the multi panel, not the new
address that you are assigning. (The default multi panel address, if you have not
previously made an address assignment, is MPI 2 or PROFIBUS 2.) For Ethernet
connections, you are prompted to provide the IP address of the multi panel.

A dialog box confirms whether the download is successful.

At this point, the WinAC MP control engine has received its hardware configuration, and the
MPI/PROFIBUS interface on the multi panel has been set to PROFIBUS-DP. If you used an
Ethernet connection to the multi panel, you can continue to perform Ethernet downloads to the
multi panel and do not need to make changes to the PG/PC interface settings in STEP 7.

(Optional) Changing the PG/PC Interface to PROFIBUS-DP
If you used an MPI connection to the multi panel, that connection is no longer functional (because
the port protocol on the multi panel changed from MPI to PROFIBUS-DP when you downloaded
the DP master hardware configuration).

In order to perform subsequent downloads to the WinAC MP control engine from STEP 7, you
must switch your PG/PC interface to PROFIBUS-DP,and define the communications settings
from the values you noted in the subnet properties of the PROFIBUS-DP master. Follow these
steps:

1. From the SIMATIC Manager, select Options > Set PG/PC Interface.

2. Select the interface parameter corresponding to the CP card in your configuration
computer using the PROFIBUS-DP bus profile, for example, CP5611(PROFIBUS).

3. Click on the Properties button.

4. In the Properties dialog box, enter the same values for Network Parameters that you
noted for the subnet properties:

� Transmission Rate

� Highest Station Address (was highest PROFIBUS address in subnet properties)

� Profile (DP)

Note
The Address (0) is the address of the configuration computer, not the address of the
SIMATIC PC station.
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5. Click on the OK button to confirm your work and close the Properties dialog box.

6. Click on the OK button to confirm your work and close the PG/PC Interface dialog box.

Testing the Online Connection
After you complete the network configuration, verify that the connection between STEP 7 and the
WinAC MP station is operational.
Testing the Online Connection

You can verify the connection from the SIMATIC Manager by pressing the online
icon.
If you are communicating directly over the PROFIBUS-DP network from the
configuration computer to the multi panel (not using an Ethernet connection), you
can also test the connection by selecting the Accessible Nodes icon. The
PROFIBUS node of the multi panel should appear in the list of network nodes.

If the network configuration is not online, review the steps of the network configuration and
correct any errors.

Developing and Downloading the User Program
You can now develop your control program in the STEP 7 project, creating and editing the blocks
necessary for control of your process. Download the created blocks either from the SIMATIC
Manager or from the STEP 7 option that you used to create the blocks. For detailed information
about developing a project using STEP 7, refer to your STEP 7 documentation.
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Customizing WinAC MP for Your Application

Controlling Your Process with WinAC MP
Note
This topic describes how to control your process with WinAC MP by using the example ProTool
projects. The screens from these projects can be customized (see Using ProTool CS to
Customize the Application) and so the examples in this topic may differ from your real project.

If you have successfully completed the procedures described in the topics Transferring
WinAC MP to the Multi Panel and Developing and Downloading the Project, you now have an
executable control program loaded in the WinAC MP control engine, and an interface (the
example ProTool project) from which to control it. Additionally, you may have developed screens
with ProTool CS for your specific process application. The initial screen displayed on the multi
panel when you download the example ProTool project is the WinAC_MP_Panel screen. From
this screen, you can perform all of the WinAC MP functions and view all of the WinAC MP status
indicators:

Figure:   WinAC_MP_Panel Screen
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Functions Available from the Example Screens
The table below describes the functions available from the WinAC MP example screens, and lists
the key equivalents for the MP370 keyboard unit (not necessary for the MP370 touch panel unit,
where you simply touch a function on the screen to select it).

Functions Available from the Example Screens

Key Function Name Function Description
S2 Exit ProTool Exits ProTool process visualization. This closes ProTool. It does

not shut down the WinAC MP control engine.
S3 Start WinAC MP Starts the WinAC MP control engine on the multi panel. Simply

opening the ProTool interface of WinAC MP, although it may
display a Control Panel screen, does not mean that the
WinAC MP control engine is running.

S4 Shutdown
WinAC MP

Shuts down the WinAC MP control engine on the multi panel. The
ProTool interface is still open, but the control engine is no longer
running.

S5 Tune High/ Tune
Low

Toggles between Tune High and Tune Low. If the Tune High
function is displayed, that means it is not currently in use: the
control engine is currently set to Tune Low (and vice versa).

� Tune High tunes WinAC MP to run at a higher priority than
ProTool on the multi panel.

� Tune Low tunes WinAC MP to run at the same priority as
ProTool on the multi panel.

The Set_Priorities script in the example project sets the priority to
Tune High or Tune Low based on the value of the WLC_PRIO tag.

S6 Autostart Off/
Autostart On

Toggles between Autostart Off and Autostart On. If the Autostart
Off function is displayed, that means it is not currently in use: the
control engine is currently set to Autostart On (and vice versa).
These functions affect the operating mode and keyswitch position
of the control engine when it is restarted after a power cycle or
shutdown.

� Autostart Off means that when the control engine is
restarted, the keyswitch remains in its previous position
but regardless of what the previous mode was, the
operating mode is set to STOP. The user has to manually
change the control engine from STOP to any other mode.

� Autostart On means that when the control engine is
restarted, it uses the same keyswitch position and
operating mode as when it last operated.

The Set_Start_Mode script in the example project sets the
WinAC MP start mode to Autostart Off or Autostart On based on
the value of the tag START_MODE.

S7 Cold Restart On the next startup, causes the WinAC MP control engine to
perform a cold restart by calling OB102. (If you do not configure a
restart method in WinAC MP, the control engine uses the startup
method that is configured in STEP 7.)

S8 Warm Restart On the next startup, causes the WinAC MP control engine to
perform a warm restart by calling OB100. (If you do not configure
a restart method in WinAC MP, the control engine uses the startup
method that is configured in STEP 7.)
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Functions Available from the Example Screens, continued

Key Function Name Function Description
F1, F2 Switch Between

Screens
Switches the display from one screen to the next on the multi
panel.

S12 RUN-P Put the WinAC MP control engine in RUN-PROGRAM Mode.
When the control engine is in RUN-P mode, you can:

� Upload a STEP 7 program from the control engine to your
configuration computer.

� Download a STEP 7 program from your configuration
computer to the control engine.

� Download individual STEP 7 blocks to the control engine.

� Use external software (such as STEP 7) to change the
operating mode of the control engine.

 Warning! You must not attempt to download from
ProTool CS to the multi panel when the control engine is in RUN-P
mode: doing so would interrupt process control and could cause
death or serious injury to personnel, and/or damage to equipment.

S13 RUN Puts the WinAC MP control engine in RUN Mode. In RUN mode
you can upload a program from the control engine to your
configuration computer, but you cannot download a program to
the control engine.

S14 STOP Puts the WinAC MP control engine in STOP Mode. The program
stops executing. You can perform program uploads and
downloads, and you can download from ProTool CS.

S15 MRES Resets the WinAC MP control engine memory. This includes
resetting the hardware configuration, deleting the WinAC MP
program, and resetting the memory areas (I,Q,M,T, and C).

Note
When you reset the control engine memory from the
MP370, you also reset the multi panel communication
settings to the default (MPI, 187.5 Kbps). If you want to
reset control engine memory but preserve communication
settings, perform the reset from STEP 7 instead.

Performing a Memory Reset
Any time that you perform a memory reset, you erase the STEP 7 project from the WinAC MP
control engine on the MP370. You must download your project from STEP 7 again before the
WinAC MP control engine can resume process control.

If you perform a memory reset from STEP 7 on the configuration computer, your STEP 7
communication settings are preserved. If you perform a memory reset from the multi panel, using
the MRES (S15) function of WinAC MP, the multi panel reverts to the factory default
communication settings (MPI, 187.5 Kbps). If you were not using the factory default settings for
communication between STEP 7 and the WinAC MP control engine on the multi panel, you must
edit the communication settings before you can download your project from STEP 7 again.
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Understanding the Tuning Parameters
The multi panel processor must perform both WinAC MP program execution and ProTool screen
updates and process visualization. There are two functions that affect the performance of the
WinAC MP control engine:

� Set_Priority  allows you to tune the WinAC MP control engine high or low with respect to
ProTool on the multi panel.

High priority improves the performance of the WinAC MP control engine. It causes the
WinAC MP control engine to have more processing time than ProTool on the multi panel.

Low priority improves the performance of ProTool on the multi panel. It causes the
processing time of the WinAC MP control engine to be equal to the processing time of
ProTool. The net effect is to raise the processing time of ProTool on the multi panel
insofar as the processing time of the WinAC MP control engine is lowered.

The example project provides a Tune High/Tune Low toggle button that sets the priority
of WinAC MP with respect to ProTool on the multi panel. You can use this button, or you
can create your own screen object that uses the Set_Priority function.

� Set_Sleep_Time  allows you to increase or decrease the execution time of the user
program, which has an indirect effect on all other processes that are running on the multi
panel.

A high sleep time value increases the execution time of the user program by enforcing a
sleep interval between scan cycles. The higher the sleep time value, the more processing
time that is available to processes other than the WinAC MP control engine. The net
effect is to raise the processing time of ProTool on the multi panel insofar as the
processing time of the WinAC MP control engine is lowered.

A low sleep time value decreases the execution time of the user program by decreasing
or eliminating the sleep time between scan cycles. The lower the sleep time value, the
less processing time that is available to processes other than the WinAC MP control
engine. The net effect is to lower the processing time of ProTool on the multi panel
insofar as the processing time of the WinAC MP control engine is raised.

The "minimum sleep time" value allows you to ensure that there is always a specified
amount of processing time between scan cycles available to processes other than the
WinAC MP control engine.
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The WinAC_MP_Panel screen of the example project provides output fields that display the last
cycle time, average cycle time, maximum cycle time, and minimum cycle time, as well as a tuning
histogram (the Histogram control). The WinAC_MP_Panel screen also provides an input field
where you can adjust the minimum sleep time value. You can use these fields or create your own
screen object that uses the Set_Sleep_Time function and the other cycle time display functions.

Figure:   WinAC_MP_Panel Screen
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Status Indicators
The WinAC MP Control Panel that is shown in the ProTool example project displays the normal
status indicators found on a WinLC Control Panel or on an S7-300/400 controller. These
indicators are view-only: you cannot use them to change modes or set faults in the WinAC MP
control engine.

The status indicators are as follows:

Status Indicators Available from the Example Screens

Indicator Description
ON The ON indicator turns on when the WinAC MP control engine is running.

The ON indicator turns off when a shutdown of the WinAC MP control engine
finishes saving the program and states to the flash file system.

BATF Battery fault. Always off for WinAC MP.
INTF Internal fault. This indicator lights up (solid) to show error conditions that exist

within the control engine, such as programming errors, firmware errors, arithmetic
errors, and timer errors.

EXTF External fault. This indicator lights up (solid) to show error conditions that exist
outside of the control engine, such as hardware faults, parameter assignment
errors, communication errors, and I/O fault errors.

BUSF1
BUSF2

These indicators light up (either solid or flashing) to identify fault conditions in the
communication with the distributed I/O.
Since WinAC MP supports only one PROFIBUS-DP network, BUSF1 is the only
active indicator. BUSF2 is not applicable for WinAC MP.

FRCE This indicator lights up (solid) to show that a force request in active. Not
applicable for WinAC MP.

RUN
STOP

The RUN indicator lights up when the operating mode is RUN.
The STOP indicator lights up when the operating mode is STOP.
The RUN indicator blinks with a single triangle and the STOP indicator is lighted
(solid) when the WinAC MP control engine is executing a restart.
The RUN indicator blinks with alternating triangles and the STOP indicator is
lighted (solid) when the WinAC MP program has reached a breakpoint.

All status
indicators
flashing

When all of the status indicators are flashing, the WinAC MP control engine has
encountered an error condition that cannot be fixed by resetting the memory
(MRES). To recover from this condition, you must perform the following tasks:

1. Shut down the WinAC MP control engine.
2. Restart the WinAC MP control engine.
3. Reset the memory (MRES).

Note
When you reset the control engine memory from the MP370, you also
reset the multi panel communication settings to the default (MPI). If you
want to reset control engine memory but preserve communication
settings, perform the reset from STEP 7 instead.

The example project that is supplied with WinAC MP has all of the functionality described above.
If you want to change anything on the example project screens, or put WinAC MP control
functions or indicators on any of your other application screens, refer to the topic Using
ProTool CS to Customize the Application.
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Using ProTool CS to Customize the Application
ProTool CS is the configuration system of ProTool and is used for the development of process
visualization screens. The operator uses these screens on the multi panel for controlling and
monitoring the process.

You do not need to do configuration in ProTool CS to be able to use the WinAC MP control
engine; the example ProTool project with WinAC MP screens (as transferred during installation)
contains everything you need for WinAC MP control. If you so choose, however, you can change
the example project or create a new project with screens containing WinAC MP functions. You
can also copy screens from the example project to an existing project of your own. The
WinAC MP functions and status indicators can be used on any ProTool screen.

From the Windows Start menu, click Start > SIMATIC > ProTool CS V6.0 > ProTool Pro CS to
open ProTool CS. Then you can edit your project as desired.

See the ProTool CS documentation for information about how to perform your configuration
objectives, such as changing text, color, font, or position of screen objects, and downloading
screens.
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WinAC MP Functions
The following table describes all of the WinAC MP functions that are available as object
properties when you build screens in ProTool CS. To update the display of values, you use the
Update and Get functions. To set or change values, you use the Set functions.
WinAC MP Functions Available as Object Properties in ProTool CS

Name Description
Control_WinAC_MP Start or shut down the WinAC MP control engine.
Get_Sleep_Time Update the display of the minimum sleep time of the

WinAC MP control engine (in milliseconds).
Get_WinAC_MP_Start_Mode Updates the display of the WinAC MP start mode. (In the

example ProTool project, because this function is
assigned to a toggle button, if Autostart is on, the button
on the function bar displays the choice Autostart Off. If
Autostart is off, the button on the function bar displays the
choice Autostart On.)

Set_Key_Switch Set the key switch of the WinAC MP control engine to
RUN-P, RUN, STOP, or MRES.

Set_Priority Set priority of the WinAC MP control engine in comparison
to ProTool on the multi panel. (Equivalent to Tune High
and Tune Low in the example screens.)

Set_Restart_Method Set the restart method either to cold restart (CRST) or to
warm restart (WRST).

Set_Sleep_Time Set the minimum sleep time of the WinAC MP control
engine (in milliseconds).

Set_WinAC_MP_Start_Mode Set the start mode of the WinAC MP control engine (turn
Autostart on or off).

Update_Average_Cycle_Time Update the display of the average cycle time variable (in
milliseconds).

Update_Average_Exec_Time Update the display of the average execution time variable
(in milliseconds).

Update_BATF_LED_Variable Update the status indicator of the BATF LED variable.
Update_BUSF1_LED_Variable Update the status indicator of the BUSF1 LED variable.
Update_BUSF2_LED_Variable Update the status indicator of the BUSF2 LED variable.
Update_EXTF_LED_Variable Update the status indicator of the EXTF LED variable.
Update_FRCE_LED_Variable Update the status indicator of the FRCE LED variable.
Update_INTF_LED_Variable Update the status indicator of the INTF LED variable.
Update_Key_Switch_Setting Update the display of the key switch setting.
Update_Last_Cycle_Time Update the display of the last cycle time (in milliseconds).
Update_Maximum_Cycle_Time Update the display of the maximum cycle time (in

milliseconds).
Update_Minimum_Cycle_Time Update the display of the minimum cycle time (in

milliseconds).
Update_Power_LED_Variable Update the ON/OFF status indicator of the Power LED

variable.
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WinAC MP Functions Available as Object Properties in ProTool CS, continued

Name Description
Update_Priority Updates the display of the priority, in other words, whether

WinAC MP is tuned high or low. (In the example ProTool
project, because this function is assigned to a toggle
button, if the current priority is Tune High, the button on
the function bar displays the choice Tune Low. If the
current priority is Tune Low, the button on the function bar
displays the choice Tune High.)

Update_RUN_LED_Variable Update the status indicator of the RUN LED variable.
Update_STOP_LED_Variable Update the status indicator of the STOP LED variable.

You can use ProTool CS to configure any of the WinAC MP functions in your project. Your
ProTool project must then be downloaded to the multi panel for process control.

To see how these functions are used with the WinAC MP control engine, see the topic Controlling
Your Process with WinAC MP.

Note
Functions that display a value (Get and Update functions) must be configured to the screen, or
else the screen does not show the updates. (To configure a function to the screen, you use the
Generate Screen event, which is available from the Functions tab of the screen properties.) See
the figure "Configure Get and Update Functions to the Screen." This is an additional step
(besides configuring the tag).
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Figure:   Configure Get and Update Functions to the Screen

1. Configure output field with
a tag, for instance, AvgCycl.

2. Configure the "Update
Average Cycle Time"
function with the "AvgCycl"
tag as parameter.

3. Configure the "Update
Average Cycle Time"
function as a selected
function for the "Generate
Screen" event.
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Mapping Functions for the MP370 Application
You use ProTool CS on your configuration computer to specify how you activate any particular
WinAC MP function from a ProTool application on the multi panel. During runtime, a function can
be activated when a user presses a Global Key, Soft Key, or System Key, or when one of the
following conditions occurs:

� A tag value changes

� A tag value is lower than the limit

� A tag value is higher than the limit

� A screen is entered

� A screen is exited

� A field is entered

� A field is exited

� An alarm message arrives

� An alarm message departs

� An alarm message is acknowledged

� An event message arrives

� An event message departs

� An event message is acknowledged

� An archive overflow occurs

� A screen overflow occurs

� A window overflow occurs

� A password overflow occurs

The installation of WinAC MP created a ProTool CS project that initially contains the WinAC MP
Control Panel screen and an example screen. You can edit these screens from ProTool CS, or
add additional screens to this WinAC MP project.

For mapping keys, screen changes, field changes, or any of the activation mechanisms described
above, refer to your ProTool CS documentation. For an overview of the WinAC MP functions that
you can map to activation mechanisms, see the topic WinAC MP Functions. If you are mapping a
function to an object in ProTool CS, you will be able to choose a WinAC MP function from a
function list in the Select Object dialog box.
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During configuration, you can press  or select File > Save at any time to save your file and

you can press  or select File > Compile at any time to compile your work to date. When you

have completed your screen changes, press  or select File > Download to download the
ProTool CS project to the multi panel. A download also performs a save and compile of your
configuration project.

Warning
Downloading a ProTool CS configuration to the multi panel while the WinAC MP control engine is
in RUN mode interrupts the execution of the process.

If process equipment is not in a safe state, interrupting the execution of the process could result
in death or serious injury to personnel, and/or damage to equipment.

Shut down WinAC MP or set it to STOP mode prior to downloading any ProTool CS
configuration. Ensure that your equipment is in a safe state. Always install a physical emergency
stop circuit for your machine or process.

After the file is downloaded to the multi panel, you can begin using it for process control.

Note
When you download, make sure that Transfer has been selected from the Loader dialog box on
the MP370 or automatic transfer ("Remote Control") on the MP370 is enabled so that the MP370
opens a connection for your configuration computer. You should see the message "Connecting to
host" on the MP370.

For an example of how to do function mapping, see the example topics that demonstrate how to
configure a global key or global button on the multi panel to shut down the WinAC MP control
engine.
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Example: Configuring a Global Key to Control WinAC MP
(Keyboard Unit)
This example shows how to configure a function globally for a key on the MP370 keyboard unit. If
you have a touch panel unit, see the topic Example: Configuring a Global Button to Control
WinAC MP (Touch Panel Unit).

The Start WinAC MP and Shutdown WinAC MP functions are configured locally for each screen
of the example project, but you might want to configure a global key that would work for every
screen of the project. The Control_WinAC_MP function can be used to start the WinAC MP
control engine or shut down the WinAC MP control engine. In this example, you learn how to
configure a global key in ProTool CS that uses the Control_WinAC_MP function to shut down the
WinAC MP control engine.

Start ProTool CS from the configuration computer by one of the following methods:

� Select Start > Simatic > ProTool CS V6.0 > ProTool CS.

� Click on   (the desktop icon for ProTool CS)

Follow these steps to open the WinAC MP ProTool CS project, and to configure a global function
key on the multi panel to shut down WinAC MP:

1. Select File > Open. This displays the Open dialog box.

2. Select and double-click on your project in the name list. ProTool CS opens the project.

3. Select and double-click on any screen in the project from the list of screens. The Screen
window opens to display the screen and all of the configurable keys that are available on
the multi panel keyboard unit.

4. From the main ProTool CS menu, select System > Screen/Keys.

5. From the Screen/Keys dialog box, click on the function key that you want to map to the
Shutdown WinAC MP function. The Function Key dialog box opens and the Select Object
dialog box opens above it. (If the Select Object dialog box does not open automatically,
check the Show Functions Available for Selection check box in order to cause the dialog
box to display.) Drag the Select Object dialog box aside so it does not cover up the
Function Key dialog box.

6. From the Function Key dialog box, click on the Selected Functions for Event drop-down
list box and select Press Key (). (The number enclosed in the parenthesis marks
indicates how many functions have been configured for this event on this key.)

7. From the Select Object dialog box, navigate to the WinAC MP function group, and click
on Control_WinAC_MP.

8. Click on the <<Add button. The Parameters-Control_WinAC_MP dialog box opens.

9. From the Parameters-Control_WinAC_MP dialog box, click on the Action drop-down list
box and select Shutdown WinAC MP.

10. Click on the OK button to dismiss the Parameters-Control_WinAC_MP dialog box.

11. Close the Select Object dialog box.
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12. Click on the OK button to dismiss the Function Key dialog box.

The lower corner of the key that you have configured should now display a green triangle
in the Screen/Keys dialog box, indicating that a function has been globally mapped to the
key.

13. Click on the OK button to dismiss the Screen/Keys dialog box.

The screen in the Screen window should now display the green triangle, indicating that the key
has been globally mapped. You can examine your other screens; all the screens in the project
should also display the green triangle on this key.

You have just configured a global function key to shut down WinAC MP. You can now make any
other changes that you want to the project in ProTool CS. After you finish your changes, you must
save, compile and download your configuration to the multi panel as follows:

1. Shut down WinAC MP by pressing S3 on the multi panel.

Warning
Downloading a ProTool CS configuration to the multi panel while the WinAC MP control
engine is in RUN mode interrupts the execution of the process.

If process equipment is not in a safe state, interrupting the execution of the process could
result in death or serious injury to personnel, and/or damage to equipment.

Shut down the WinAC MP control engine or set it to STOP mode before you download any
ProTool CS configuration. Ensure that your equipment is in a safe state. Always install a
physical emergency stop circuit for your machine or process.

Note
Before you download, make sure that Transfer has been selected from the Loader dialog
box on the MP370 or automatic transfer ("Remote Control") on the MP370 is enabled so
that the MP370 opens a connection for your configuration computer. You should see the
message "Connecting to host" on the MP370.

2. Click on the  icon or select File > Save to save your edited project.

3. Click on the  icon or select File > Compile to compile the project. You will see
progress indicators on the compilation.

4. Click on the  icon or select File > Download to download your project to the multi
panel. If you have not previously saved and compiled, you will be prompted by
ProTool CS to save and compile your project first before downloading.

After you have successfully downloaded the project, you can use the global key that you have
configured to shut down the WinAC MP control engine from any screen in WinAC MP.

For information on ProTool CS screen configuration, see your ProTool CS documentation. For an
overview of the WinAC MP functions see the topic WinAC MP Functions and for general
information about mapping these functions see the topic Mapping Functions for the MP370
Application.
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Example: Configuring a Global Button to Control WinAC MP
(Touch Panel Unit)
This example shows how to configure a function globally for a button on the MP370 touch panel
unit. If you have a keyboard unit, see the topic Example: Configuring a Global Key to Control
WinAC MP (Keyboard Unit).

The Start WinAC MP and Shutdown WinAC MP functions are configured locally in each screen of
the example project, but you might want to configure a global button that would work in every
screen of the project. The Control_WinAC_MP function can be used to start the WinAC MP
control engine or shut down the WinAC MP control engine. In this example, you learn how to
configure a global button in ProTool CS that uses the Control_WinAC_MP function to shut down
the WinAC MP control engine.

Start ProTool CS from the configuration computer by one of the following methods:

� Select Start > Simatic > ProTool Pro CS V6.0 > ProTool Pro CS.

� Click on   (the desktop icon for ProTool CS)

Follow these steps to open the WinAC MP ProTool CS project, and to configure a global function
button on the multi panel to shut down WinAC MP:

1. Select File > Open. This displays the Open dialog box.

2. Select and double-click on your project in the name list. ProTool CS opens the project.

3. Select and double-click on any screen in the project from the list of screens. The Screen
window opens to display the screen.

4. From the ProTool CS Screen Objects toolbar, click on the Button toolbar button, then
click on the screen in the fixed window. (By placing the button in the fixed window, rather
than the basic area, you are defining it as a global rather than a local object.) The button
appears where you clicked and the Button dialog box opens.

5. From the General tab of the Button dialog box, replace the ? in the Text box with these
words: Shut down WinAC MP.

6. Click on the Functions tab. The Select Object dialog box opens above the Button dialog
box. (If the Select Object dialog box does not open automatically, check the Show
Functions Available for Selection check box in order to cause the dialog box to display.)
Drag the Select Object dialog box aside so it does not cover up the Button dialog box.

7. From the Functions tab of the Button dialog box, click on the Selected Functions for
Event drop-down list box and select OnClick (). (The number enclosed in the parenthesis
marks indicates how many functions have been configured for this event on this key.)

8. From the Select Object dialog box, navigate to the WinAC MP function group, and click
on Control_WinAC_MP.

9. Click on the <<Add button. The Parameters-Control_WinAC_MP dialog box opens.

10. From the Parameters-Control_WinAC_MP dialog box, click on the Action drop-down list
box and select Shutdown WinAC MP.

11. Click on the OK button to dismiss the Parameters-Control_WinAC_MP dialog box.

12. Close the Select Object dialog box.
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13. If you want to modify any other properties of the button, such as color, do so now. When
you are finished, click on the OK button to dismiss the Button dialog box.

You can examine your other screens; all the screens in the project should also display
the global button that you have just configured.

You have just configured a global function button to shut down WinAC MP. You can now make
any other changes that you want to the project in ProTool CS. After you finish your changes, you
must save, compile and download your configuration to the multi panel as follows:

1. If you have already downloaded a project to the multi panel and the WinAC MP control
engine is running, shut it down. (Both screens of the example project for WinAC MP have
a Shutdown WinAC MP function that you can press in order to shut down the control
engine.)

Warning
Downloading a ProTool CS configuration to the multi panel while the WinAC MP control
engine is in RUN mode interrupts the execution of the process.

If process equipment is not in a safe state, interrupting the execution of the process could
result in death or serious injury to personnel, and/or damage to equipment.

Shut down the WinAC MP control engine or set it to STOP mode before you download any
ProTool CS configuration. Ensure that your equipment is in a safe state. Always install a
physical emergency stop circuit for your machine or process.

Note
Before you download, make sure that Transfer has been selected from the Loader dialog
box on the MP370 or automatic transfer ("Remote Control") on the MP370 is enabled so
that the MP370 opens a connection for your configuration computer. You should see the
message "Connecting to host" on the MP370.

2. Click on the  icon or select File > Save to save your edited project.

3. Click on the  icon or select File > Compile to compile the project. You will see
progress indicators on the compilation.

4. Click on the  icon or select File > Download to download your project to the multi
panel. If you have not previously saved and compiled, you will be prompted by
ProTool CS to save and compile your project first before downloading.

After you have successfully downloaded the project, you can use the global button that you have
configured to shut down the WinAC MP control engine from any screen in WinAC MP.

For information on ProTool CS screen configuration, see your ProTool CS documentation. For an
overview of the WinAC MP functions see the topic WinAC MP Functions and for general
information about mapping these functions see the topic Mapping Functions for the MP370
Application.
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Removing WinAC MP
To remove WinAC MP from your system, you must perform all of the following tasks:

� Use ProSave to uninstall the authorization license from the multi panel. (You transfer it
back to the authorization diskette. You must use the original diskette; you cannot transfer
it to any other.)

� Use ProSave to uninstall the WinAC MP runtime files from the multi panel.

� Use the Windows Add/Remove Programs utility to remove WinAC MP from the
configuration computer.

The ProTool project with WinAC MP components on the multi panel can simply be overwritten
when you download a new project to the multi panel. After you uninstall the WinAC MP runtime
files, there is no control engine on the multi panel, so the ProTool project cannot function.

Notes
Exit STEP 7 and ProTool on the configuration computer before uninstalling WinAC MP. If you
have STEP 7 or ProTool open, the uninstall process cannot remove WinAC MP-related files from
these applications.

Make sure that Transfer has been selected from the Loader dialog box on the MP370 or
automatic transfer ("Remote Control") on the MP370 is enabled so that the MP370 opens a
connection for your configuration computer. You should see the message "Connecting to host" on
the MP370.

Removing Authorization for WinAC MP from the Multi Panel
To remove the authorization from the multi panel and restore it to the authorization diskette,
follow these steps:

1. Insert the authorization diskette in the appropriate diskette drive of your configuration
computer.

2. To open ProSave, click SIMATIC > ProSave V6.0 > ProSave from the Windows Start
menu.

3. Click on the General tab in ProSave and select the correct multi panel (MP370 or
MP370Touch) from the Device Type list box.

4. In the Connection list box, select the type of connection that you are using between the
configuration computer and the multi panel.

5. Complete the Connection Parameters for your connection:

� For an Ethernet connection, supply the IP address or computer name for the MP370.

� For a serial connection, select the correct COM port and baud rate.

� For an MPI connection, supply the OP address of the multi panel.

6. Click on the Authorize tab.
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7. Click on the Device Status button to read the authorization from the multi panel. The
authorization is listed in the Installed Options (right pane).

Note
If you have a communications problem and the multi panel is in Transfer mode, check
your physical cable connections, and check to make sure that your settings in ProSave
and on the multi panel are correct for your connection. See the topic Setting Parameters
for Communications.

8. Select the correct drive letter for the drive where you have inserted the authorization
diskette. The contents of the authorization diskette are displayed in the Selection area
(left pane). The License counter displays a value of 000 for the WinAC MP authorization,
indicating that the license is not currently present on the diskette.

9. To transfer the authorization from the multi panel to the diskette, select the product
authorization in the Installed Options (right pane) and use the << button to transfer it to
the Selection area (left pane). When the transfer operation is complete, the License
counter displays a value of 001, indicating that the license is present on the diskette.

Do not close ProSave. You still need to uninstall WinAC MP runtime files.

Removing WinAC MP from the Multi Panel
To remove the WinAC MP runtime files from the multi panel, follow these steps.

1. Shut down the WinAC MP control engine on the multi panel.

2. Exit ProTool.

3. Select Transfer mode from the Loader dialog box on the multi panel.

4. In ProSave, click on the Options tab.

5. From the Options tab, click on the Device Status button to read the WinAC MP runtime
files from the multi panel. The runtime files appear in the Installed Options (right pane).

6. Click on WinAC MP in the Installed Options (right pane), then click on the "<<" button to
remove the WinAC MP runtime files from the installed options of the multi panel. This
causes the WinAC MP runtime files to be deleted from the multi panel.

Note
If the WinAC MP control engine is running on the multi panel (whether or not the ProTool
project is closed), the WinAC MP files cannot be removed. If ProSave takes a
suspiciously long time to remove WinAC MP from the multi panel, check the multi panel
to see if there is an error message saying the files cannot be removed while a WinAC MP
executable file is operating. This error message means you have not shut down the
control engine. Shut it down, exit ProTool, switch to Transfer mode, and then go back to
the configuration computer to redo the file removal from within ProSave.

7. Respond to the prompt on the multi panel about rebooting (click Yes to reboot now, No to
reboot later).

After the runtime files are removed from the multi panel, you can exit ProSave. Your ProTool
project with WinAC MP HMI components is still present on the multi panel, but it can no longer
execute, because the control engine has been removed. The project will be overwritten the next
time that you download a ProTool project from the configuration computer to the multi panel.
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Removing WinAC MP from the Configuration Computer
You use the Windows Add/Remove Programs procedure to remove (uninstall) the WinAC MP
software components from ProTool CS on your configuration computer. Follow these steps to
remove WinAC MP from your configuration computer:

1. If ProSave, ProTool, and/or STEP 7 are running, exit them.

2. Select the Start > Settings > Control Panel menu command to display the Windows
control panel.

3. Double-click on the Add/Remove Programs icon to display the Add/Remove Programs
Properties dialog box.

4. Select the entry for SIMATIC WinAC MP V3.0 and click on the Add/Remove button.

5. Follow the instructions of the dialog boxes to remove the WinAC MP software. (If the
Remove Enable File dialog box appears, click on the No button if you are unsure how to
respond.)
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Features of the WinAC MP Control Engine
The WinAC MP control engine has the following features:

� Accumulators: 4 (ACCU 1 to ACCU 4)

� Communications: PROFIBUS-DP master device

� Work memory

� Load memory (RAM)

� Distributed I/O only, no local I/O:

You can configure the size of the process-image I/O areas (I and Q memory areas) to be
either 512 bytes or 1024 bytes. These memory areas can be accessed directly by the
instructions in the user program.

Using Load (L) and Transfer (T) instructions (for statement list) or the Assign Value
(MOVE) instruction (for ladder logic) to the peripheral I/O (PI and PQ memory areas), you
can access up to 16384 bytes of inputs and 16384 bytes of outputs.

The WinAC MP control engine communicates with the distributed I/O as a PROFIBUS-DP master
device. As a master device, the WinAC MP control engine can communicate with up to 32 slave
devices (either S7-DP slaves or other DP slaves).
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Technical Specifications
The table below describes performance characteristics and technical specifications of the
WinAC MP control engine.

Performance Characteristics and Technical Specifications of WinAC MP Control Engine

WinAC MP Control Engine Description
Work memory 3 M bytes
Load memory (RAM) 1 M bytes
Accumulators 4 (ACCU 1 to ACCU 4)
Local data 16 K bytes per priority class
Clock Real-time system clock, based on the hardware clock of the

multi panel
Digital and Analog I/O Address range is 16384 for inputs and outputs (but total amount

supported is 1024 bytes for inputs and 1024 bytes for outputs)
Process image I/O
(user configurable)

� Inputs
� Outputs

512 bytes (inputs) and 512 bytes (outputs) or
1024 bytes (inputs) and 1024 bytes (outputs)

� I 0.0 to I 511.7 or I 0.0 to I 1023.7
� Q0.0 to Q511.7 or Q0.0 to Q1023.7

Memory bits
� Retentive range

(configurable)
� Preset as retentive

2 Kbytes
� MB0 to MB255

� 16 bytes (MB0 to MB15)
Counters

� Retentive range
(configurable)

� Preset as retentive

512
� C0 to C63

� 8 (C0 to C7)
Timers (only updated in
OB1)

� Retentive range
(configurable)

� Preset as retentive

512

� T0 to T127

� None
Clock memory
Bits of the clock memory
byte toggle at specific times
and are accessible from the
user program.

8 bits of clock memory (1 byte)
8 frequencies within 1 byte of M memory: address is
configurable
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Performance Characteristics and Technical Specifications of WinAC MP Control Engine, continued

WinAC MP Control Engine Description
Number of blocks
supported:

� OB
� SFB
� SFC
� Maximum number

of asynchronous
SFCs

Address ranges for logic
blocks:

� FB
� FC
� DB
� Total number of

blocks that can be
downloaded to
WinAC MP

� 15
� 7
� 52
� 20

� FB0 to FB65535
� FC0 to FC65535
� DB1 to DB65535 (DB0 is reserved)
� 2500

Nesting depth 24 per OB, with 2 asynchronous OBs (OB121 and OB122) per
priority class

PROFIBUS-DP interface:
� DP address range

� Number of DP
slaves supported

� Baud rate
� Baud rate search

(as a DP slave)
� Transfer memory

(as a DP slave)
� Maximum segment

distance

� Address range is 16384 for inputs and outputs (but total
amount supported is 1024 bytes for inputs and 1024
bytes for outputs)

� 32

� Up to 12 MBPS (*)
� Not applicable

� Not applicable

� Dependent on the baud rate (see table below)

(*) 9.6 KBPS, 19.2 KBPS, 45.45 (31.25) KBPS, 93.75 KBPS, 187.5 KBPS, 500 KBPS, 1.5 MBPS, 3 MBPS, 6
MBPS, 12 MBPS

As shown in the table below, each segment of the PROFIBUS-DP network is limited to a
maximum distance (or cable length), which is determined by the baud rate of the communication.

Maximum Segment Distance Dependent on Baud Rate

Baud Rate Maximum Cable Length
9.6, 19.2, 93.75 KBPS 1200 m (3936 ft.) with an isolated interface
187.5 KBPS 1000 m (3280 ft.) with an isolated interface
500 KBPS 400 m (1312 ft.)
1.5 MBPS 200 m (656 ft.)
3, 6, 12 MBPS 100 m (326 ft.)
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Organization Blocks (OBs) Supported
OBs are the interface between the operating system of WinAC MP and the user program. The
table below lists the OBs which are supported. The WinAC MP control engine executes OBs
according to the priority class.

Organization Blocks (OBs) Supported

OB Description Priority Class
OB1 Main program cycle 1 (lowest)
OB10 Time-of-day interrupt 2
OB20 Time-delay interrupt 3 to 6
OB35,
OB36

Cyclic interrupt 7 to 15

OB40 Hardware interrupt 16 to 23
OB80 Time error 26
OB82 Diagnostic interrupt 24 to 26 (or 28) (*)
OB83 Module remove/insert interrupt 24 to 26 (or 28) (*)
OB85 Priority class error 24 to 26 (or 28) (*)
OB86 Rack failure 24 to 26 (or 28) (*)
OB100 Warm restart 27
OB102 Cold restart 27
OB121 Programming error Priority class of the OB where the error

occurred
OB122 I/O access error Priority class of the OB that was interrupted
(*) Priority class 28 during STARTUP mode of The WinAC MP control engine, user-configurable priority class (from

24 to 26) in RUN mode.

OBs for the Main Program Cycle, Cold Restart, and Warm Restart
The table below shows OBs for the main program cycle and cold and warm restarts. The
WinAC MP control engine uses OB1 (main program cycle) for continuously executing the user
program. On the transition from STOP mode to RUN mode (or RUN-P mode), the WinAC MP
control engine executes OB100 (warm restart) or OB102 (cold restart), based either on the
hardware configuration for the WinAC MP control engine or which restart option was selected
from a dialog box displayed by the CPU panel. After OB100 (or OB102) has been successfully
executed, the WinAC MP control engine executes OB1.

OBs for the Main Program Cycle, Cold Restart, and Warm Restart
Organization Block (OB) Start Event Priority
Main program cycle OB1 1101H, 1103H, 1104H 1
Warm restart OB100 1381H, 1382H 27
Cold restart OB102 1385H, 1386H 27
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Interrupt OBs
The WinAC MP control engine provides a variety of OBs that interrupt the execution of OB1. The
table below lists the different interrupt OBs which are supported by the WinAC MP control engine.
These interrupts occur according to the type and configuration of the OB.

The priority class determines whether the WinAC MP control engine suspends the execution of
the user program (or other OB) and executes the interrupting OB. You can change the priority
class for the interrupt OBs (see the table entitled Organization Blocks (OBs) Supported, above).

Interrupt OBs

Interrupts Start Event Default
Priority

Time-of-Day Interrupt OB10 1111H (OB10) 2   (Low)

Time-Delay Interrupt
Range: 1 ms to 60000 ms

OB20 1121H (OB20) 3

Cyclic Interrupt
Range: 1 ms to 60000 ms
Recommended: > 10 ms

OB35
OB36

1136H
1137H

12
13

Hardware interrupt OB40 1141H (channel 1) 16   (High)

If the WinAC MP control engine has been configured to execute a particular interrupt OB, but that
OB has not been downloaded, the WinAC MP control engine reacts in the following manner:

� If OB10, OB20, or OB40 is missing and OB85 has not been downloaded, the WinAC MP
control engine changes operating mode (from RUN to STOP).

� The WinAC MP control engine remains in RUN mode if OB35 or OB36 is missing or
cannot be executed at the specified time.

Note
You can configure OB35 and OB36 to be executed as frequently as every 10
milliseconds (ms). If you schedule an OB to be executed every 10 ms, make certain that
the program can be executed within the time frame and also that your WinAC MP
application can process the OB within the allotted time.
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Error OBs
As shown in the table below, the WinAC MP control engine supports a variety of error OBs. Some
of these error OBs have the configured (user-assigned) priority class, while others (OB121 and
OB122) inherit the priority class of the block where the error occurred.

The local variables for OB121 and OB122 contain the following information that can be used by
the program to respond to the error:

� The type of block (byte 4) and the number (bytes 8 and 9) where the error occurred

� The address within the block (bytes 10 and 11) where the error occurred

If the start event occurs for a particular error OB that has not been downloaded, the WinAC MP
control engine changes operating mode from RUN to STOP.

Error OBs

Error  or  Fault OB Start Event Default Priority
Time-out error OB80 3501H, 3502H, 3505H,

3507H
26

Diagnostic Interrupt OB82 3842H, 3942H 26
Insert/remove module interrupt OB83 3861H, 3863H, 3864H,

3961H, 3865H
26

Priority class error:
� Start event occurs for an

OB that has not been
downloaded.

� During the I/O cycle, the
WinAC MP control engine
attempts to access a
module or DP slave that is
defective or not plugged in.

� The WinAC MP control
engine attempts to access
a block (such as a DB) that
has not been downloaded
or has been deleted.

OB85 35A1H, 35A3H, 39B1H,
39B2H

26

Distributed I/O failure: a node in
the PROFIBUS-DP subnetwork
has failed or been restored.

OB86 38C4H, 39C4H, 38C5H,
39C5H, 38C7H, 38C8H

26 (or 28)

Programming error
(For example: the user program
attempts to address a timer that
does not exist.)

OB121 2521H, 2522H, 2523H,
2524H, 2525H, 2526H,
2527H, 2528H, 2529H,
2530H, 2531H, 2532H,
2533H, 2534H, 2535H,
253AH; 253CH, 253EH

Same priority class
as the OB in which
the error occurred

I/O access error
(For example: the user program
attempts to access a module that
is defective or is not plugged in.)

OB122 2942H, 2943H Same priority class
as the OB that was
interrupted
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System Functions (SFCs) Supported
The WinAC MP control engine supports SFCs, which are logic blocks that perform basic tasks.
The table below lists the SFCs which are supported. The user program calls the SFC and passes
the required parameters; the SFC performs its task and returns the result.

The WinAC MP control engine allows a maximum of 20 asynchronous SFCs to be running. The
following asynchronous SFCs are supported: SFC11, SFC13, SFC51 (index B1, B3), SFC55,
SFC56, SFC57, SFC58, and SFC59.

Note
An asynchronous SFC is an SFC that has a "Busy" output parameter.

System Functions (SFCs) Supported

SFC Name Description Execution
Time in
microseconds

SFC0 SET_CLK Sets the system clock 44
SFC1 READ_CLK Reads the system clock 16
SFC2 SET_RTM Sets the run-time meter 9
SFC3 CTRL_RTM Starts or stops the run-time meter 9
SFC4 READ_RTM Reads the run-time meter 8
SFC5 GADR_LGC Queries the logical address of a channel 16
SFC6 RD_SINFO Reads the start information of an OB 15
SFC11 DPSYNC_FR Synchronize groups of DP slaves 10
SFC13 DPNRM_DG Reads the diagnostic data of a DP slave

DP configuration tested: one ET 200M slave with
one 8-input/8-output module and one 16-output
module

30

SFC14 DPRD_DAT Reads the consistent data from a DP slave 22
SFC15 DPWR_DAT Writes the consistent data to a DP slave 22
SFC17 ALARM_SQ Generates an acknowledgeable block-related

message
43

SFC18 ALARM_S Generates an unacknowledgeable block-related
message

52

SFC19 ALARM_SC Queries the status for the last message (SFC17 or
SFC18)

15

SFC20 BLKMOVB Copies variables 21
SFC21 FILL Initializes a memory area 1 word

50 words
100 words

22
24
26

SFC22 CREAT_DB Creates a data block 59
SFC23 DEL_DB Deletes a data block 21
SFC24 TEST_DB Provides information about a data block 10
SFC26 UPDAT_PI Updates the process-image input table

DP configuration tested: one ET 200M slave with
one 8-input/8-output module and one 16-output
module

33
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System Functions (SFCs) Supported, continued

SFC Name Description Execution
Time in
microseconds

SFC27 UPDAT_PO Updates the process-image output table
DP configuration tested: one ET 200M slave with
one 8-input/8-output module and one 16-output
module

33

SFC28 SET_TINT Sets the time-of-day interrupt (OB10) 26
SFC29 CAN_TINT Cancels the time-of-day interrupt (OB10) 13
SFC30 ACT_TINT Activates the time-of-day interrupt (OB10) 9
SFC31 QRY_TINT Queries the time-of-day interrupt (OB10) 11
SFC32 SRT_DINT Starts the time-delay interrupt (OB20) 33
SFC33 CAN_DINT Cancels the time-delay interrupt (OB20) 19
SFC34 QRY_DINT Queries the time-delay interrupt (OB20) 18
SFC36 K_FLT Mask synchronous errors 15
SFC37 DK_FLT Unmask synchronous errors 14
SFC38 READ_ERR Read the error register 14
SFC39 DIS_IRT Disables the processing of all new interrupts 13
SFC40 EN_IRT Enables the processing of new interrupts 14
SFC41 DIS_AIRT Disables the processing of new interrupts with

higher priority than the current OB
9

SFC42 EN_AIRT Enables the processing of new interrupts with
higher priority than the current OB

18

SFC43 RE_TRIGR Retriggers the watchdog timer (monitoring the
cycle time)

68

SFC44 REPL_VAL Transfers a value to ACCU1 (accumulator 1 ) 45
SFC46 STP Changes the operating mode to STOP Not applicable
SFC47 WAIT Delays the execution of the user program 1000
SFC49 LGC_GADR Queries the module slot belonging to a logical

address
13

SFC50 RD_LGADR Queries all of the logical addresses of a module 28
SFC51 RDSYSST Reads all or part of a system status list 40
SFC52 WR_UMSG Writes a user element to the diagnostics buffer 58
SFC54 RD_PARM Read the defined parameter 29
SFC55 WR_PARM Write the defined parameter 43
SFC56 WR_DPARM Write the default parameter 32
SFC57 PARM_MOD Assign the parameters to a module 30
SFC58 WR_REC Write a data record 44
SFC59 RD_REC Read a data record 43
SFC64 TIME_TCK Reads the time from the system clock 7
SFC79 SET Set a range of outputs 11
SFC80 RESET Reset a range of outputs 11
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System Function Blocks (SFBs) Supported
The WinAC MP control engine provides SFBs, which are logic blocks similar to SFCs. The table
below lists the SFBs which are supported. When the user program calls an SFB, a data block
(DB) must also be assigned.

System Function Blocks (SFBs) Supported

SFB Name Description Execution Time
in microseconds

SFB0 CTU Provides a "count up" timer 15
SFB1 CTD Provides a "count down" timer 15
SFB2 CTUD Provides a "count up/down"

timer
19

SFB3 TP Generates a pulse 16
SFB4 TON Generates an on-delay timer 16
SFB5 TOF Generates an off-delay timer 16
SFB32 DRUM Implements a sequencer 48



Reference

59

Other S7 Blocks Supported
Like other S7 PLCs, the WinAC MP control engine provides several types of logic blocks for
processing the user program: organization blocks (OBs), system functions (SFCs), and system
function blocks (SFBs). These blocks are an integral part of the WinAC MP control engine. In
addition to these system blocks, you can use the other S7 blocks to create the user program:

� Function (FC): the address range for FCs supported by the WinAC MP control engine is
FC0 to FC65535. Each FC can contain up to 65,570 bytes.

� Function block (FB): the address range for FBs supported by the WinAC MP control
engine is FB0 to FB65535. Each FB can contain up to 65,570 bytes.

� Data block (DB): the address range for DBs supported by the WinAC MP control engine
is DB1 to DB65535. (DB0 is reserved.) Each DB can contain up to 65,534 bytes.

An OB can also contain 65,570 bytes.

Note
Although the address ranges higher than 2500 are supported, the WinAC MP control engine
supports a maximum of 2500 blocks. (In other words, the total number of FBs, FCs, DBs, OBs,
and SDBs, together, cannot exceed 2500.)

For more information about OBs, SFCs, and SFBs, see the System Software for S7-300 and
S7-400 System and Standard Functions Reference Manual.



Reference

60

Execution Times of Instructions
The execution times listed in the tables below, Execution Times of Math Operations and
Execution Times of Instructions, reflect the average execution times for STEP 7 programs
running on the WinAC MP control engine. Actual execution times may vary, depending on your
system.

For the performance test, a variety of software applications was run concurrently under the
following conditions:

� The WinAC MP control engine executed a test program with 3000 Boolean operations,
reading and writing data to I/O modules over a PROFIBUS-DP network consisting of
three nodes (ET200M). In addition, the WinAC MP control engine performed calculations
to determine the distribution of performance data.

� The priority for the WinAC MP control engine was set to High.

Execution Times of Math Operations (in microseconds)

Math Operation Integer Real Double Word
Addition (+) 0.14 0.21 0.14
Subtraction (-) 0.14 0.21 0.14
Multiplication (*) 0.15 0.24 0.34
Division (/) 0.42 0.36 0.34
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Execution Times of Instructions (in microseconds)

Execution Time
 in microseconds

Instructions

Direct
addressing

Indirect
addressing

I 0.37 0.54
M 0.37 0.85
L 0.57 0.87

DB 0.54 0.82
T 1.05 1.44

Boolean operations: Memory
areas:
A, AN O, ON, X, XN

C 0.33 0.76
Boolean operations (on the
accumulator):

==I, <>I, >I, <I, >=I, <=I 0.34 0.34
Operations on the bits of the status
word:

A==0, A<>0, A>0, A<0, A>=0, A<=0 0.34 0.34
Transitional contacts:

� Edge Positive FP
� Edge Negative FN

0.64
0.64

0.64
0.64

Set/Reset operations
(bit operands)

Set S
Reset R

0.51
0.47

0.84
0.84

RLO Operations
Negate RLO NOT

Set RLO SET
Clear RLO CLR

Save RLO SAVE

0.31
0.28
0.28
0.31

0.31
0.28
0.28
0.31

Operations on Timers
Pulse timer SP
Reset (timer) R

Extended pulse timer SE
On-delay timer SD

Retentive on-delay timer SS
Off-delay timer SF

1.18
0.35
1.18
1.18
1.19
1.24

1.58
0.77
1.58
1.58
1.61
1.64

Miscellaneous:
Open DB OPN

Load L
Transfer T

1.01
0.33
0.34

1.01
0.33
0.34
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System Status List (SZL)
The information in the system status list (SZL) is stored as a set of sublists. Each sublist has a
two-word header that provides the following information about the sublist:

� The first word defines the length (size in bytes) of a record for the sublist.

� The second word defines the number of records contained in the sublist.

SFC51 (RDSYSST) accesses the entries in the system status list. For more information about the
system status list, see the System Software for S7-300 and S7-400 System and Standard
Functions Reference Manual.

The table below provides an overview of the SZL sublists, sorted according to the SZL-ID. You
use the SZL-ID and index (as hexadecimal numbers: 16#) to access the records stored in the
sublist.
Sublists of the System Status List (SZL) for the WinAC MP Control Engine

SZL-ID
(hexadecimal)

Sublist Index
(hexadecimal)

Record Contents

0000
0300

SZL-ID
All available SZL-IDs
Lists the available indices

0131
0132
0222

Information on all available SZL-IDs
Indices for SZL-ID 0131
Indices for SZL-ID 0132
Indices for SZL-ID 0222

0011
0111
0F11

CPU identification
All records of the sublist
One record of the sublist
Header information only

0001
0007

WinLC type and version number
Identification of the module
Identification of the firmware

0112

0F12

CPU features
Only those records of a group
of features

Header information only

0100
0200
0300

Time system in WinLC
System response
Language description of WinLC

0013 User memory areas Work memory, integrated Load memory, plugged-in Load
memory, maximum number of plug-in Load memories,
and size of backup memory

0014 Operating system areas Process-image input area (bytes), process-image output
area (bytes), bit memory (bytes), timers, counters, size of
the I/O address area, and total local data area for WinLC
(bytes)

0015

0115

Block types
All records of the sublist

One record, depending on
the index

0800

OBs (number and size)
DBs (number and size)
SDBs (number and size)
FCs (number and size)
FBs (number and size)
OBs (number and size)
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Sublists of the System Status List (SZL) for the WinAC MP Control Engine, continued

0019
0119

0F19

State of the module LEDs
Status of all LEDs
Status of each LED

Header information only

0002
0003
0004
0005
0006
0007
0008
000B

INTF Internal failure
EXTF External failure
RUN Run
STOP Stop
FRCE Force
CRST Complete restart
BAF Battery failure
BUSF1 Bus fault

0021
0F21

Interrupt/error assignment
(via number of assigned
OBs)
All possible interrupts
Header information only

0222
Interrupt status
Record for specified interrupt 0001

0050
Event that started OB1
Event that started OB80

0023

0123

0223

0F23

Priority class
Records for all priority
classes
Records for a specific priority
class
Records for all configured
priority classes
Header information only

0000 Priority of possible OBs

0124

0424
0524

Operating status of the
CPU
Last executed operating
status transition
Current operating status
Specified operating status

4520
5000
5010
5020
5030

Defective status
STOP status
Startup status
RUN status
HOLD status

0131 Communications
performance parameters of
the communications type
specified

0001
0002
0003
0004

0005
0009

Number of connections and baud rates
Test and startup parameters
Operator interface parameters
Object management system (operating
system function)
Diagnostics functions and diagnostics
entries
Number of run-time meters

0132 Communications status
information of the
communications type
specified

0001
0002
0004
0008

0009
000A

Number and type of connections
Number of test jobs set up
Protection levels of the WinLC
Time system, correction factor, run-time
meter, date and time of day
Baud rate  (set by means of the MPI)
Baud rate (set by means of the S7-300
backplane bus)
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Sublists of the System Status List (SZL) for the WinAC MP Control Engine, continued

0033
Diagnostic Station List
All entries

0782
Start-up events
Start-up events of all OBs of
a priority class before
processing

Priority class Event ID, priority class, and OB number

0A91

0C91

0D91

0F91

Module status information
Status information of all DP
subsystems and DP masters
Status information of a
module
Status information for the
specified station
Header information only

Start address
xxyy

Features and parameters of the module
All the modules of station yy in the
PROFIBUS-DP network xx

0092

0292

0692

0F92

Status information of the
nodes in a DP network
Target status of nodes in a
subnetwork
Actual status of the nodes in
a subnetwork
DP slaves indicating failure of
one or more modules
Header information only

0000

Subnetwork
ID

Status information for the nodes
connected to a PROFIBUS-DP network

00A0
01A0
0FA0

Diagnostics buffer
All entries (event information)
Specified number of entries
Header information only

Event information (dependent on the event)

00B1

00B3

00B4

0FB1
0FB3

Module diagnostics

Data record 0 of the module
diagnostics information
Data record 0 of the module
diagnostics information
(Complete module-
dependent diagnostics)
DP-norm diagnostics of a DP
slave
Header information for 00B1
Header information for 00B3

Start address

Rack and slot
number

Module-dependent diagnostics information
Starting address for the specific module

Rack and slot number of the specific
module
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Allowing for Scan Time "Jitter"
Based on the hardware configuration of your multi panel, and also the CPU utilization by other
software applications, the scan cycle for the WinAC MP control engine can experience "jitter"
(where the scan cycle varies from the configured minimum scan time).

Examples of Jitter in the Scan Cycle
To show typical jitter, the performance of the WinAC MP control engine was tested by running a
variety of software concurrently under the following conditions:

� The WinAC MP control engine executed a test program with 3000 Boolean operations,
reading and writing data to I/O modules over a PROFIBUS-DP network consisting of
three nodes (ET200M). In addition, the WinAC MP control engine performed calculations
to determine the distribution of performance data.

� The priority for the WinAC MP control engine was set to High.
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Figure:   Sample Jitter
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Troubleshooting
Use the table below to troubleshoot difficulties that you encounter.

Troubleshooting

Problem Cause Remedy
I installed WinAC MP
runtime files, but nothing
displays on the multi
panel.

You need a ProTool
project that supplies a
user interface in order
to view and operate the
WinAC MP control
engine.

Install the example ProTool project with
WinAC MP screens, or a customized project,
on the multi panel.

The WinAC MP software
did not transfer to the
multi panel.

Wrong cable used,
wrong ports connected,
or wrong parameters
specified.

Review the topic Setting Parameters for
Communications and correct any errors.

Ethernet communication
has stopped working.

Parameter mismatch. Check the IP address of the multi panel by
typing ipconfig at the MS-DOS control
prompt of the multi panel. Make sure it
matches the IP address used in your
connection parameters on the configuration
computer. Review the topic Setting Parameters
for Communications.

I installed the
WinAC MP runtime files
and a ProTool project,
but the control engine
doesn't really do
anything.

The control engine
contains no program
logic until you
download a user
program from STEP 7.

Review the topic Developing and Downloading
the User Program.

The WinAC MP control
engine is not
communicating with
PROFIBUS-DP device
network.

Wrong network
configuration.

Review the topic Configuring the SIMATIC PC
Station on the PROFIBUS-DP Network and
correct any errors.

ProTool performance on
the multi panel is too
low.

Ineffective tuning. Either set the priority to Tune Low to make
WinAC MP equal priority with ProTool on the
multi panel, or increase the minimum sleep
time. See the topic Controlling Your Process
with WinAC MP.

WinAC MP performance
is too low.

Ineffective tuning. Either set the priority to Tune High to make
WinAC MP higher priority than ProTool on the
multi panel, or decrease the minimum sleep
time. See the topic Controlling Your Process
with WinAC MP.
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Accumulators, 50, 51

ActiveX Controls, 1

Addresses (Siemens), iv

Authorization

Removing from the MP370, 47

Transferring to the MP370, 15

Autostart, 38

Autostart (Example Project), 32

B
BATF Status Indicator (Example Project), 36

Baud Rates, 52
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BUSF1 Status Indicator (Example Project),
36

BUSF2 Status Indicator (Example Project),
36

Buttons, Global, 45

C
Clock, 51

Cold Restart Function (Example Project), 32

Communications Options, 8

Direct Connection, 8

Ethernet, 9

MPI, 11

Remote Control, 8

Serial, 10

USB, 12

Configuring

Global Button, 45

Global Key, 43

SIMATIC PC Station, 22

Configuring Communications, 8

Connecting to Other PLCs

While the Control Engine Is Running, 18

Control Engine. See WinAC MP

Control Panel (MP370) Restrictions, 18

Control_WinAC_MP Function, 38

Controlling Process with WinAC MP, 4, 31

Controls

Histogram, 2

WinAC MP Control Panel, 2

Counters, 51

Customer Support, iv

Customizing WinAC MP Screens with
ProTool CS, 37

Cycle Time Histogram, 65

D
DBs Supported, 59

Diagnostics Buffer

System Status List, 62

Digital I/O, 51

Direct Connection to Configuration
Computer, 8

Downloading

Authorization, 15

Example Project, 16

Overview of, 7

Runtime Files, 13

E
E-Mail (Siemens), iv

Ethernet Connection, 9

Example Project

Customizing, 37

Exiting, 19

Screens, 2

Starting, 18

Transferring to the MP370, 16

Examples
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Configuring Global Button, 45

Configuring Global Key, 43

Execution Times, 60

Exit ProTool Function (Example Project), 32

EXTF Status Indicator (Example Project), 36

F
FBs Supported, 59

FCs Supported, 59

Features of the Control Engine, 50

FRCE Status Indicator (Example Project),
36

Functions, 32

Control_WinAC_MP, 38

Get_Sleep_Time, 38

Get_WinAC_MP_Start_Mode, 38

Mapping, 41

Set_Key_Switch, 38

Set_Priority, 38

Set_Restart_Method, 38

Set_Sleep_Time, 34, 38

Set_WinAC_MP_Start_Mode, 38

Update_Average_Cycle_Time, 38

Update_Average_Exec_Time, 38

Update_BATF_LED_Variable, 38

Update_BUSF1_LED_Variable, 38

Update_BUSF2_LED_Variable, 38

Update_EXTF_LED_Variable, 38

Update_FRCE_LED_Variable, 38

Update_INTF_LED_Variable, 38

Update_Key_Switch_Setting, 38

Update_Last_Cycle_Time, 38

Update_Maximum_Cycle_Time, 38

Update_Minimum_Cycle_Time, 38

Update_Power_LED_Variable, 38

Update_Priority, 39

Update_RUN_LED_Variable, 39

Update_STOP_LED_Variable, 39

G
Get_Sleep_Time Function, 38

Get_WinAC_MP_Start_Mode Function, 38

Global Button, 45

Global Key, 43

H
Histogram of Cycle Time with Jitter, 65

Hotline, iv

I
Instruction Execution Times, 60

Internet Sites (Siemens), iv

INTF Status Indicator (Example Project), 36

J
Jitter, 65

K
Keys

and Functions, 32

Global, 43

M
Mapping Functions, 41

Memory, 50, 51

Memory Reset (MRES), 33, 36

Messages

System Status List (SZL), 62

Minimum Sleep Time Value, 34

Mode of Control Engine, 32

MP370

Installing

WinAC MP Authorization, 15

WinAC MP Example, 16

WinAC MP Runtime Files, 13

Keys and Functions, 32

Removing

WinAC MP Authorization, 47
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WinAC MP Runtime Files, 48

Restrictions While the Control Engine
Runs, 18

MPI Connection, 11

MRES Function, 33

N
Nesting Depth, 52

O
OBs Supported, 53

ON Status Indicator (Example Project), 36

Online Connection, 30

Overview

Product, 1

Programming with STEP 7, 20

Transferring WinAC MP, 7

P
Performance Characteristics, 51

PG/PC Interface, 29

PLC Connections (Limitations), 18

Preface, iii

Problems, 66

Process Control with WinAC MP, 4, 31

Process Image I/O, 51

Product Overview, 1

PROFIBUS-DP

Communications, 52

Troubleshooting Problems

System Status List (SZL), 62

ProSave

Restrictions While Control Engine Runs,
18

ProTool

and WinAC MP, 1

Downloading Projects, 17

Exiting on Multi Panel, 19

Image, 15

Opening on Configuration Computer, 16

Starting on Multi Panel, 18

R
Related Documentation, iii

Remote Control of Downloading, 8

Remove WinAC MP from the MP370, 47

Requirements, 6

Reset Memory (MRES), 33, 36

Restrictions While Control Engine Runs, 18

RUN Function (Example Project), 33

RUN Status Indicator (Example Project), 36

RUN-P Function (Example Project), 33

Runtime Files

Transferring to MP370, 13

S
S7 Blocks Supported, 59

Scan Time Jitter, 65

Screens

WinAC_MP_Function, 3

WinAC_MP_Panel, 2

Serial Connection, 10

Set PG/PC Interface, 29

Set_Key_Switch Function, 38

Set_Priority Function, 34, 38

Set_Restart_Method Function, 38

Set_Sleep_Time Function, 34, 38

Set_WinAC_MP_Start_Mode Function, 38

SFBs Supported, 58

SFCs Supported, 56

Shut Down

Control Engine on Multi Panel, 19

with Global Button, 45

with Global Key, 43

Shutdown WinAC MP Function (Example
Project), 32

Siemens Customer Support, iv
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SIMATIC PC Station, 22

S-Keys, 32

Specifications, 51

Start WinAC MP Function (Example
Project), 32

Starting Project on Multi Panel, 18

Starting the Control Engine, 18

Status Indicators, 36

STEP 7

Creating a SIMATIC PC Station, 22

Programming Overview, 20

System Status List (SZL), 62

STOP Function (Example Project), 33

STOP Status Indicator (Example Project),
36

SubNet Properties, 26

Switch Between Screens Function (Example
Project), 33

System Overview, 4

System Requirements, 6

System Status List (SZL), 62

SZL.  See System Status List, STEP 7

T
Technical Service, iv

Technical Specifications, 51

Testing Online Connection, 30

Timers, 51

Times, Instruction Execution, 60

Transfer WinAC MP

Authorization, 15

Example Project, 16

Overview, 7

Runtime Files, 13

Troubleshooting, 66

System Status List, 62

Tune High Function (Example Project), 32

Tune Low Function (Example Project), 32

Tuning WinAC MP, 34

U
Uninstall WinAC MP

Authorization, 47

ProTool CS Components, 49

Runtime Files, 48
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Update_BATF_LED_Variable Function, 38

Update_BUSF1_LED_Variable Function, 38

Update_BUSF2_LED_Variable Function, 38

Update_EXTF_LED_Variable Function, 38

Update_FRCE_LED_Variable Function, 38

Update_INTF_LED_Variable Function, 38

Update_Key_Switch_Setting Function, 38
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Update_Minimum_Cycle_Time Function, 38

Update_Power_LED_Variable Function, 38

Update_Priority Function, 39

Update_RUN_LED_Variable Function, 39

Update_STOP_LED_Variable Function, 39

USB Connection, 12

Using ProTool CS, 37

W
Warm Restart Function (Example Project),

32

Web Sites (Siemens), iv

WinAC MP

Accumulators, 50

ActiveX Controls, 2

Customizing Your Project, 37

Diagnostics Buffer

System Status List, 62
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