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Safety Guidelines 
This manual contains notices which you should observe to ensure your own personal safety, as 
well as to protect the product and connected equipment. These notices are marked as follows 
according to the level of danger: 

Danger 
indicates an imminently hazardous situation which, if not avoided, will result in death or serious injury. 
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Warning 
indicates a potentially hazardous situation which, if not avoided, could result in death or serious injury. 

Caution 
used with the safety alert symbol indicates a potentially hazardous situation which, if not avoided, may 
result in minor or moderate injury. 

Caution 
used without the safety alert symbol indicates a potentially hazardous situation which, if not avoided, 
may result in property damage. 

Notice 
indicates that unwanted events or status can occur if the relevant information is not observed. 

Note 
draws your attention to particularly important information on the product, handling the product, or to 
a particular part of the documentation. 

ualified Personnel 
Equipment may be commissioned and operated only by qualified personnel. Qualified personnel 
within the meaning of the safety notices in this manual are persons who are authorized to commission, 
ground and identify equipment, systems and circuits in accordance with safety engeneering standards. 

orrect Usage 
Please note the following: 

Warning 
The device may only be used for the application cases specified in the catalog and the technical 

description and may only be used in combination with third-party equipment and components 
recommended or approved by Siemens. 
Startup must not take place until it is established that the machine which is to accommodate this 
component is conforms with the guideline 98/37 EC. 
Appropriate transport, and appropriate storage, installation and assembly, as well as careful 
operation and maintenance, are required to ensure that the product operates perfectly and safely. 
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The registered trademarks of the Siemens AG can be found in the preface.  
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Preface 

Using the manual 
This electronic manual describes the actions required to establish a modem link for 
• Downloading configuration data by means of TeleService (data transfer using 

the MPI/PROFIBUS DP port on the HMI operating unit) 
• Downloading configuration data by means of a direct modem link (data transfer 

using the RS232 port on the HMI operating unit) 
• Remote maintenance of a SIMATIC S7 automation system with ProTool/Pro 

Runtime 
• Remote maintenance of a SIMATIC S7 automation system with pcAnywhere ® 

We recommend that you print this manual if you wish to read large sections, since 
the reading rate on paper is higher than on the screen. 

Audience 
This manual is intended for commissioning engineers, service technicians and 
system administrators. They learn how a modem link (in conjunction with SIMATIC 
TeleService, for example) is installed and operated for downloading configuration 
data and remote maintenance. 

Online Help 
In support of the manual, you are given in-depth assistance, when using the 
software, in the form of an integrated online Help, which you can activate by means 
of the Help menu or by pressing F1. 

Others documents 
TeleService for S7, C7 and M7, Remote Maintenance of an Automation System, 
Manual (C79000-G7000-C525) 
The manual is printed with the TS adapter and supplied as an electronic document 
in PDF format on CD-ROM. The manual contains extensive information about 
configuring and operating a TeleService link. 
Furthermore, the manual contains tables for simplifying troubleshooting when 
problems occur. 
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Conventions 
Different font styles help you to find your way around the text: 
Motor on Text on the screen of the operating unit is shown as 

typewriting. 
Output Input and output on the screen of the operating unit are 

shown in italic type. 
File ⇒ Edit Menu options, the names of dialog boxes, tabs and buttons 

of the operating system and the application are shown in 
italic type.  
The full path of menu options is always specified. 

Trademarks 
The following designations are registered trademarks of Siemens AG: 

• SIMATIC®   
• SIMATIC HMI®   
• SIMATIC Multi Panel®   
• SIMATIC Multifunctional Platform®   
• SIMATIC Panel PC®   
• HMI®   
• MP 270®   
• ProAgent®   
• ProTool®   
• ProTool/Lite®   
• ProTool/Pro®   
• STEP7®   

 

The following designation is a registered trademark of the Symantec Corporation 

• pcAnywhere®   
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Customer and Technical Support 

Available throughout the world: 

 

 
Worldwide (Nuremberg) 

Technical Support 
(FreeContact) 
 
Local time: Mon. thru Fri. 8.00 a.m. to 
 5.00 p.m. 
Phone: +49 (180) 5050-222 
Fax: +49 (180) 5050-223 
E-mail: techsupport@
 ad.siemens.de 
GMT: +1:00 

Worldwide (Nuremberg) 

Technical Support 
(subject to charge, only with SIMATIC 
Card) 
Local time: Mon. thru Fri. 0.00 a.m. to 
12.00 p.m. 
Phone: +49 (911) 895-7777 
Fax: +49 (911) 895-7001 
GMT: +01:00 

 

Europe/Africa (Nuremberg) 

Authorization 
 
Local time: Mon. thru Fri. 8.00 a.m. to 
 5.00 p.m. 
Phone: +49 (911) 895-7200 
Fax: +49 (911) 895-7201 
E-mail: authorization@ 
 nbgm.siemens.de 
GMT: +1:00 

America (Johnson City) 

Technical Support and 
Authorization 
Local time: Mon. thru Fri. 8.00 a.m. to 
 7.00 p.m. 
Phone: +1 423 461-2522 
Fax: +1 423 461-2289 
E-mail: simatic.hotline@ 
 sea.siemens.com 
GMT: -5:00 

Asia/Australia (Singapore) 

Technical Support and 
Authorization 
Local time: Mon. thru Fri. 8.30 a.m. to 
 5.30 p.m. 
Phone: +65 740-7000 
Fax: +65 740-7001 
E-mail: simatic.hotline@ 
 sae.siemens.com.sg 
GMT: +8:00 

 
Generally speaking, the languages spoken on the SIMATIC Hotlines are English and 
German � French, Italian and Spanish are also spoken on the Authorization Hotline. 

Further assistance 

Please contact your local Siemens representative and offices if you have any 
technical queries. 
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SIMATIC Customer Support online services 

SIMATIC Customer Support offers you extensive additional information about 
SIMATIC products in its online services: 

• You can obtain general up-to-date information 
� on the Internet at  

http://www.siemens.com/simatic 
• Current product brochures, FAQs, tips and tricks, and downloads can be 

 obtained 
� on the Internet at  

http://www.siemens.com/automation/service&support  

Training Center 

We offer you suitable courses to help you get started with your automation 
systems. Contact your regional Training Center or the central Training Center at 
Nuremberg in Germany. 

Phone: +49 (911) 895-3200 

Internet: http://www.sitrain.com 

E-mail: info@sitrain.com 

Further assistance 

Please contact your local Siemens representative or offices if you have any more 
queries about SIMATIC HMI products. 

You will find the addresses: 

• in Siemens Catalog ST 80 

• on the Internet at  
http://www.siemens.com/automation/partner 

• in the Interactive Catalog CA01 
http://www.siemens.com/automation/ca01 
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1 Introduction 

Application 
During the commissioning phase or when servicing is being performed, the 
configuration computer is frequently not anywhere near the system. For it 
nevertheless to be possible to enable an exchange of data, a connection can 
be established over a transmission link (such as a modem link). 

This connection is used essentially for two applications: 

• The downloading of configuration data between the configuration 
 computer and the HMI operating unit equipped with ProTool CS 

• The remote maintenance of a process with ProTool/Pro Runtime 

The following table lists the methods possible in both applications. 

Connection method 
Transfer of 

configuration data 
(refer to Section 1.1) 

Remote maintenance 
of a process 

(refer to Section 1.2) 

TeleService 
(modem links and TS adapter 
through MPI/DP interface) 

X 
(refer to Section 1.1.1) 

X 
(refer to Section 1.2.1) 

Direct modem link 
(modem link through RS232 port) 

X 
(refer to Section 1.1.2) 

� 

pcAnywhere ® 1)  
(modem link [ ISDN ] or  
LAN connection [ TCP/IP ] ) 

   ( X ) 2) 

 
X 

(refer to Section 1.2.2) 

 
The methods are presented in the introduction to Sections 1.1 and 1.2: 

ProTool CS 
You create a ProTool project with the ProTool Configuration System (ProTool CS). 
It contains the system-specific basic settings, messages and screens that form 
part of the system. 

In this manual, the term "ProTool CS" stands for the three versions of the 
configuration software: ProTool/Pro CS, ProTool and ProTool/Lite.  

                                                      
1) pcAnywhere is a registered trademark of the Symantec Corporation 
2) For this, ProTool CS must be installed on the host system. You can copy a project created or modified on the 

"remote" PC with the file transfer integrated in pcAnywhere to the "host" PC, start ProTool on this PC and thus 
transfer the configuration data to the HMI operating unit. 

1
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1.1 Downloading configuration data 
 

Introduction 
The project in which you have set the functions of the operating unit with 
ProTool CS must be downloaded to the operating unit. The configuration 
computer has to be connected to the HMI operating unit for this to take place. 

Configuration  
 computer HMI operating unit 

 

Figure 1-1 Download principle between the PC and HMI operating unit 

The connection over the transmission path can be achieved in two possible 
ways: 

• Using TeleService through the MPI/PROFIBUS DP interface on the 
operating unit 

• Direct modem link through the serial interface on the operating unit 

TeleService 
TeleService is based on a software and a hardware component (Figure 1-2). 

The software is installed on the configuration computer. It controls the transfer 
of data between ProTool CS and the HMI operating unit (over a telephone 
network, for example). 

The hardware supports a connection from an RS232 port to a SIMATIC S7 
interface (MPI/PROFIBUS DP). 

The following table shows the devices that support data transfer with 
TeleService. 

Device family Device type 

Text-based displays OP3 

Graphic displays OP27, OP37, TP27, TP37 

Windows CE devices TP170A, TP170B, OP170B, Mobile Panel 170, 
TP270, OP270, MP270, MP270B, MP370 

Windows-based systems PC-based systems based on ProTool/Pro Runtime 

Note 
The ProTool/Pro RT loader must be active on the 
destination device. Refer in this respect to the 
Runtime documentation. 
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Direct modem link 
The modem link establishes a direct connection between the configuration 
computer and the serial interface on the HMI operating unit (Figure 1-3). 
The following table shows the devices that support data transfer with a direct 
modem link. 

Device family Device type 

Windows CE devices TP170A, TP170B, OP170B, Mobile Panel 170, 
TP270, OP270, MP270, MP270B, MP370 

Windows-based systems PC-based systems based on ProTool/Pro Runtime 

Note 
The ProTool/Pro RT loader must be active on the 
destination device. Refer in this respect to the 
Runtime documentation. 

1.1.1 Downloading with TeleService 

You have access to remote system components with ProTool CS and TeleService. 
To make this possible, TeleService connects your PC to automation components 
S7/C7/M7 on an MPI/PROFIBUS DP network over a telephone network. 

By means of this connection, you can  
� Download your ProTool configuration data to the operating unit 

olgende Dateien werden übertragen:  
Device family  Downloaded files  
Windows CE devices  *.fwd 1) 

*.pdz 2) 

Windows-based systems  *.fwd 1) 
*.pdz 2) 

� Transfer SIMATIC configuration data from STEP 7 to your PLC. 

The TeleService product includes 

� A software program (has to be installed on your configuration computer) 
� The TS adapter hardware component 
The TS adapter converts the data protocol from an RS232 port to a SIMATIC 
S7 interface (MPI/PROFIBUS DP). 

With the TS adapter, the MPI/PROFIBUS DP network parameters are set with 
the TeleService software in a parameterization session and written to the non-
volatile memory of the TS adapter. These parameters stored on the TS adapter 
are activated on establishing the online connection. 

Storage of the network parameters on the TS adapter has the advantage that 
you can communicate from any telephone connection with a node on the 
MPI/PROFIBUS DP network without the caller having to know the network 
parameters at the system end. 

                                                      
1) The  *.fwd file contains the data required by ProTool/Pro Runtime. 
2) The  *.pdz file contains the compressed data of the source file (*.pdb). It is only created and transferred if the 

"Allow Upload" button is activated in the Download dialog box. 
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Connection diagram 

  

Figure 1-2 Data transfer over ISDN/analog modem and TS adapter 

The standard modem cable is supplied together with the modem. You will find a 
cable wiring diagram in Appendix A.2. 
An extension cable must not be inserted in the connection between the adapter 
and the SIMATIC system at transfer rates of 187.5 kbps or higher. 
The analog and digital connection over the national fixed network has been 
system-tested and released. Connections over mobile telephones have neither 
been tested nor released. 

Configuration 
You will find guidance on configuration of the data transmission link in Section 3.1. 
You will find more information in the modem device manual, in the manual 
"TeleService for S7, C7 and M7 � Remote Maintenance of an Automation System" 
and in the short guide "PC adapter/TS adapter". 
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1.1.2 Downloading over a direct modem link 

With this transfer procedure, the ProTool CS configuration software initiates the 
exchange of data between the configuration computer and the operating unit. 
Downloading is performed through the RS232 port on the operating unit. 

Use of teleservice and a TS adapter are not required. STEP 7 is needed only if 
you wish to download projects integrated in STEP 7. 

Many (Hayes-compatible) standard modems (ISDN or analog) can be used as 
a modem adapter. 

Connection diagram 

 

Figure 1-3 Data transfer over a direct modem link 

The standard modem cable is supplied together with the modem. You will find a 
cable wiring diagram in Appendix A.2. 

The connection of the system modem to the HMI operating unit requires a special 
cable. You will find the cable wiring diagram in Appendix  A.3. 

Configuration 
You will find notes on configuration of the data transmission link in Section  3.2. 
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1.2 Remote maintenance with ProTool/Pro Runtime 
 

Principle 
Two different scenarios are possible for remote maintenance with ProTool/Pro 
Runtime: 

• ProTool/Pro Runtime is installed on a PC remote from the system (such as 
on the configuration computer). The user works on this PC with ProTool/Pro 
Runtime, and it directly accesses the automation system by means of 
Teleservice (including the transmission path and the MPI/DP bus of the 
system) - refer to Section 1.2.1. 

 PC Automation 
 (operator terminal) system 

  

Figure 1-4 Transmission principle for remote maintenance with TeleService 

• ProTool/Pro Runtime is installed on a PC in the system. Assisted by the 
remote control software pcAnywhere ® 1) . The user works from a remote 
PC using pcAnywhere with ProTool/Pro Runtime locally on the system (refer 
to Section 1.2.2). 

 PC PC Automation 
(operator terminal) (in the system) system 

 

Figure 1-5 Transmission principle for remote maintenance with TeleService 

Both scenarios establish a link (transmission path) between the operator's 
computer and the SIMATIC S7 automation system, over which you can directly 
access values on the connected PLC and I/O. 

As a result of this, you can view and even control the process using the 
process screens contained in your Runtime project (for example, you can enter 
setpoints by means of standard entry fields). 

If you have to access PLC data for which input/output fields have not been 
configured, you require the function Status/Force. This option is particularly 
useful during the test and commissioning phase of your project. 

 
Supported HMI control systems 
Remote maintenance can be performed solely in connection with ProTool/Pro 
Runtime on a PC hardware basis. 

                                                      
1) pcAnywhere is a registered trademark of the Symantec Corporation 
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1.2.1 Remote maintenance with TeleService 

You have access to remote system components with ProTool RT and TeleService. 
To make this possible, TeleService connects your PC to automation components 
S7/C7/M7 on an MPI/PROFIBUS DP network over a telephone network . 

By means of this connection, you can  
� Remotely maintain your SIMATIC S7 automation system. For this, the familiar 

functions of STEP 7 and Engineering Tools are available to you, comparable 
to a local MPI port. 

� Access systems, machines and PLCs and perform technical services such as 
maintenance, update service and defect analyses at a low cost from a central 
support point at all times. 

The TeleService product includes 
� A software program (has to be installed on the PC) 
� The TS adapter hardware component 
The TS adapter converts the data protocol from an RS232 port to a SIMATIC S7 
interface (MPI/PROFIBUS DP). 

With the TS adapter, the MPI/PROFIBUS DP network parameters are set with the 
TeleService software in a parameterization session and written to the non-volatile 
memory of the TS adapter. These parameters stored on the TS adapter are 
activated on establishing the online connection. 
Storage of the network parameters on the TS adapter has the advantage that 
you can communicate from any telephone connection with a node on the 
MPI/PROFIBUS DP network without the caller having to know the network 
parameters at the system end. 

Connection diagram 

  

Figure 1-6 Remote maintenance over ISDN/analog modem and TS adapter 
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The standard modem cable is supplied together with the modem.You will find a 
cable wiring diagram in Appendix A.2. 
An extension cable must not be inserted in the connection between the adapter 
and the SIMATIC system at transfer rates of 187.5 kbps or higher. 
The analog and digital connection over the national fixed network has been 
system-tested and released. Connections over mobile telephones have neither 
been tested nor released. 

Establishment of a connection by the remote system 
If a connection has to be established automatically (such as triggered by an 
event) by the automation system, you will additionally require the following 
products: 
� PRODAVE MPI v.5.0 

This software program is installed on the PC and waits for a remote system 
to call. When the call arrives, your application program is informed. 

� Function block PG_DIAL 
This function block is included in the STEP 7 library during the installation of 
TeleService. Should a remote system establish a long-distance connection to a 
PC, the application program of the system must call the function block PG_DIAL. 

You will find detailed information about this in the manual "TeleService for S7, 
C7 and M7 � Remote Maintenance of an Automation System" (Chapter 6). 

Configuration 
You will find guidance on configuration of the data transmission link in Section 3.4. 
You will find more information in the modem device manual, in the manual 
"TeleService for S7, C7 and M7 � Remote Maintenance of an Automation System" 
and in the short guide "PC adapter/TS adapter". 

1.2.2 Remote maintenance/operation with pcAnywhere 

Principle 
pcAnywhere ® is a comprehensive remote control and file transfer solution for 
service and maintenance. by using this program, you can quickly and safely 
access a PC on your system. pcAnywhere ®  features security functions for this 
which make sure that the remote controlled PC ("host") is correctly configured 
and protected in an optimum manner. pcAnywhere 1) consists essentially of two 
software function packages: 

• pcAnywhere Host 

This functionality is installed on the PC in the system that you want to 
control. It monitors access to this PC, transfers the screen data to the 
remote PC and executes operator commands on the remote PC. 

• pcAnywhere Remote 
This functionality is installed on the PC remote from the system from which 
the system is to be accessed. It displays the screed data of the host PC and 
transfers the operator commands to the host PC. 

                                                      
1) pcAnywhere is a registered trademark of the Symantec Corporation 
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The interconnection diagrams are displayed in Figure 1-7 (connection over 
LAN) and Figure 1-8 (connection over telephone network). 

No TeleService or ProTool functions are required for pcAnywhere operation. 
The work procedure and the user interface of pcAnywhere will therefore not be 
described in greater detail in this manual. If required, the detailed product 
description and the online Help of pcAnywhere are available to you. 

Connection diagram 
Two different connection concepts are available: 

1. Control of the remote PC with pcAnywhere over Intranet (LAN) 

PC (operator terminal) PC (in the system) 

 
Figure 1-7 Control with pcAnywhere over Intranet (LAN) 

 

2. Control of the remote PC with pcAnywhere over telephone network (WAN) 

PC (operator terminal) PC (in the system) 

  
Figure 1-8 Control with pcAnywhere over telephone network (WAN) 
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General notes on operation 
• If possible, you should preferably use an LAN connection. 

• Make sure your PC has high performance capability and as few as little 
active (started) tasks/programs: 

� Deactivate unnecessary processor loads (including in the background) 
such as screen savers, virus scanners, system monitor etc. 

� Make sure the hard disks on the client and server are properly fragmented 
� Especially when working with an ISDN connection you should perform 

deliberate actions to ensure you do not press keys twice. 

Example applications 
The main application option of pcAnywhere is remote control. Using 
pcAnywhere, you start the ProTool/Pro Runtime software on the remote 
computer by remote control. The read out data and system messages of the 
system are transferred by pcAnywhere to your PC, where you evaluate them. 

Note 
With pcAnywhere ®, solely screen data and keyboard and mouse data are 
transferred dependably between the host and the remote PCs. 

Configuration 
In-depth information on how to install and run the product will be found in the 
pcAnywhere user's guide and in online Help. 
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2 Hardware and software requirements 

2.1 Using TeleService 

Hardware requirements 
You require the following hardware to use TeleService:  

� A PC that satisfies the system requirements of ProTool/Pro CS and RT and 
STEP 7 

� Two modem cable between the PC and modem and between the modem and 
TS adapter, respectively (for the cable wiring diagram refer to Appendix A.2) 

� Two modems that are interconnected over a telephone line  
(for precise details refer to the description of TeleService) 

� A TS adapter v.5.0 for MPI and PROFIBUS-DP with different baud rates 
(v.3.0 only for MPI with 187.5 kBd) 

� An MPI or PROFIBUS-DP network supported by the TS adapter. 

The following PLCs are supported in a remote maintenance context: 

 SIMATIC S7-200 1) 
 SIMATIC S7-300 
 SIMATIC S7-400 

 

                                                      
1) The connection between the TeleService adapter, the SIMATIC S7-200 and the OPs must be 

established through an interface of the S7-200 submodule EM277 PROFIBUS-DP (MLFB 6ES7 
277-0AA21-0XA0) requires TeleService 5.1 or higher. 

2
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Software requirements 
You require the following software on the PC to use TeleService:  

Software program Downloading 
configurations Remote maintenance 

Operating system Win 98 SE 
Win NT with SP 6a 
Win 2000 with SP2 

STEP 7 v.5.0, v.5.1 + SP2 or higher 

TeleService v.5.0 and v.5.1 or higher 

ProTool/Pro CS 
ProTool 
ProTool/Lite 

v.6.0 
v.6.0 
v.6.0 

� 
� 
� 

ProTool/Pro Runtime � v.6.0 

PRODAVE MPI 1) � v.5.0 

 

Should these software packages not be available on your PC, install them in 
the order shown above. Follow the installation instructions of the software 
product concerned. 

If the corresponding Microsoft Service Pack is not installed on your PC, you will 
find all relevant Service packs for Windows NT 4.0 and Windows 2000, 
including Internet Explorer 6.0, on two CD-ROMs supplied with ProTool/Pro 
Runtime 6.0. 

                                                      
1 Required only for automated access to the configuration computer of a remote SIMATIC S7 

(connection buildup by the system) 
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2.2 Direct modem link 

To be used only for downloading configuration data 

Hardware requirements 
You require the following hardware for a direct modem link:  

� A PC satisfying the system requirements for ProTool/Pro CS  
A serial port (COM1 or COM2) must be available. 

� A modem cable between the PC and the modem  
(refer to Appendix A.2 for the cable wiring diagram) 

� Two modems that are interconnected over a telephone line  
(Hayes-compatible devices are recommended) 

� A modem cable to the HMI operating unit (special cable) 
(refer to Appendix A.3 for the cable wiring diagram) 

� A Windows-based HMI operating unit that supports the exchange of data. 

The following HMI operating unit are supported: 
 

Device family Device type 

Text-based displays OP3 

Graphic displays OP27, OP37, TP27, TP37 

Windows CE devices TP170A, TP170B, OP170B, Mobile Panel 170, 
TP270, OP270, MP270, MP270B, MP370 

Windows-based systems PC-based systems based on ProTool/Pro Runtime 
Note 
The ProTool/Pro RT loader must be active on the 
destination device. Refer in this respect to the Runtime 
documentation. 
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Software requirements 
You require the following software on the configuration computer to use a direct 
modem link:  

 

Software program Downloading 
configurations Remote maintenance 

Operating system Win 98 SE 
Win NT with SP 6a  
Win 2000 with SP2 

STEP 7 (optional) 1) v.5.0 or v.5.1 + SP2 

ProTool/Pro CS 
ProTool 
ProTool/Lite 

v.6.0 
v.6.0 
v.6.0 

� 
� 
� 

 

If you wish to use the functionality of SIMATIC Manager, ProTool must be 
"integrated in STEP 7" when it is installed.  

Should these software packages not be available on your PC, install them in the 
order shown above. Follow the installation instructions of the software product 
concerned. 

If the corresponding Microsoft Service Pack is not installed on your PC, you will 
find all relevant Service packs for Windows NT 4.0 and Windows 2000, including 
Internet Explorer 6.0, on two CD-ROMs supplied with ProTool/Pro CS 6.0. 

                                                      
1 If you want to download integrated projects in STEP 7, you must install STEP 7 on the 

configuration computer. 
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2.3 Using pcAnywhere 

Hardware requirements (for host and remote PCs) 
You require the following hardware for remote maintenance and remote control 
by means of pcAnywhere: 

 Remote PC Host PC 

The hardware 
requirements of the 
following products must be 
met: 

pcAnywhere v.10.5 pcAnywhere v.10.5 
and 

ProTool/Pro RT v.6.0 

Requirement for 
installation 

CD-ROM or DVD drive 

Network connection 
 
or 
 
telephone connection 

Network card 10/100 MHz including driver and Ethernet 
connecting cable 

 
 

ISDN adapter incl. driver and telephone connection 
cable 

 

Software requirements 
 

Software program Remote PC Host PC 

Operating system Win 98 SE 
Win ME 

Win NT with SP 6a 
Win 2000 with SP2 

Win XP 

Win 98 SE 
Win ME 

Win NT with SP 6a 
Win 2000 with SP2 

Internet Explorer 1) Microsoft Internet Explorer 5.5 with SP 2 or higher 

pcAnywhere v.10.5 

ProTool/Pro Runtime � v.6.0 

 

Should these software packages not be available on your PC, install them in 
the order shown above. Follow the installation instructions of the software 
product concerned. 

If the corresponding Microsoft Service Pack is not installed on your PC, you will 
find all relevant Service packs for Windows NT 4.0 and Windows 2000, 
including Internet Explorer 6.0, on two CD-ROMs supplied with ProTool/Pro RT 
6.0. 

                                                      
1) Required by pcAnywhere 
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2.4 Authorization 
 
 

A product-specific authorization (user license) is required to use the SIMATIC 
TeleService software. The protected software can only be used if the 
necessary authorization for the program or package is detected on the hard 
disk of the programming device/PC concerned. 

Installing TeleService 
Refer to the manual "TeleService for S7, C7 and M7 � Remote Maintenance of 
an Automation System" for detailed information on installing the authorization. 

For the installation, you require the copy-protected authorization diskette, which 
is supplied as part of the package. It contains the authorization for TeleService. 

You should install the authorization when prompted to do so by a 
corresponding message in the course of initial installation. 

AUTHORSW, the program required to display, install and uninstall the 
authorization, can be found on the ProTool CD-ROM. 

Caution 
Take note of the information contained in the README.TXT file in the 
Installation directory of AUTHORSW. There is the risk of the authorization 
being irretrievably lost if the notes are not followed. 

An authorization cannot be lost, for example, if a hard disk defect occurs and 
you are no loner in a position to uninstall the authorization from the defective 
fixed disk. 

Loss of authorization  
If an authorization is lost, you can fall back on the emergency authorization. It 
is similarly contained on the authorization diskette. The emergency 
authorization allows you to continue using the software for a limited period of 
time. In such an instance, the time to go until it becomes invalid is displayed on 
the screen when you start up. You should procure a replacement for the lost 
authorization within that period of time. Please contact you local Siemens 
representative for this. 
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3 Procedure and settings 

3.1 Settings downloading with TeleService 
With the transfer of configuration data, we distinguish between: 

• Transfer from the configuration computer to the operating unit (download) 

• Transfer from the operating module to the configuration computer 
 (upload) 

1) 

Requirements for transfer 
before you can start to transfer, the following criteria must be satisfied: 

 Transferring with TeleService 

1. ProTool CS, STEP 7 and Teleservice have been installed on your configuration 
computer (refer to Section 2.1 for the software requirements) 

2. Your entire project and a single,complete section has been completed and has been 
complied without error by ProTool CS : 
A file that can be executed on the operating unit is created from the project 

3. An ISDN or analog modem is connected to an unassigned COM port on your 
configuration computer 

4. Transmission facilities, adapter, and the PLC and operating unit are ready to start 

5. The operating unit is connected to the PLC. 

 
The following setting guide describes the steps that have to be taken for a 
ProTool project integrated in STEP 7. 

                                                      
1 Important requirements have to be satisfied for the "Upload" function, depending on the HMI unit. 

Refer to online Help and the equipment manual. 

3
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3.1.1 Parameterizing the PG/PC port (RS232) 

Perform the following steps: 

1. Compare your hardware configuration with Figure 1-2. Switch on all 
components. 

2. In SIMATIC Manager, choose Options ⇒ Set PG/PC Port... from the menu 
(as an alternative, this can be done on the Control Panel). 

3. In the "Used interface parameterization" selection box, select the entry "TS 
adapter": S7ONLINE (STEP7) --> TS Adapters is automatically entered in 
the "Access point" field of the application. Click Properties... 

4. On the "Local Connection" tab, select the option "Modem connection" and 
confirm your input by clicking "OK". 

Parameterization of the serial port is described together with 
parameterization of the modems. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                                                                                    
 
 
 
 
Figure 3-1 Parameterization of the PU/PC port for TeleService 
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3.1.2 Parameterizing the local modem 

Parameterization of the modem is described at length in the manual 
"TeleService for S7, C7 and M7 � Remote Maintenance of an Automation 
System" (Chapter 3) and therefore only brief details will be mentioned at this 
point. 

Note 
The register for parameterization of the local modem is also accessible through 
the Control Panel in Windows, but the changes performed in Windows do not 
have any effect on data management in TeleService. Therefore, always define 
the properties of the TeleService modem directly in TeleService. The advantage 
of this is that changes that might have been performed on the Control Panel for 
other programs do not have any effect on the settings performed in TeleService. 
As a general rule, the parameters required as set as default values so that you 
only have to check the entries to be on the safe side. 

Perform the following steps: 

1. In SIMATIC Manager, choose the Options ⇒ TeleService from the menu 
(alternatively you can choose Start ⇒ SIMATIC ⇒ STEP7 ⇒ TeleService) 
The TeleService application starts and the start window is displayed. 

2. Choose Options ⇒ Customize... from the menu. This opens a dialog box in 
which the following settings are possible: 

� The modem being used (such as MicroLink 33 6TQV) 
Only modems installed under Windows are listed. 

� Its properties 
� The local location  
� The selected parameters and the 
� Monitoring times 

 

Figure 3-2 TeleService: dialog box for modem settings 
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3.1.3 Parameterizing the remote modem  

Perform the following steps: 

1. Switch off the remote modem. 

2. Plug the TS adapter into the automation system. 

3. Connect the TS adapter to the modem using a mode cable. 

4. Connect the modem to the telephone access. 

5. Switch on the components. 

The modem is given all the parameters required operation from the TS 
adapter: 

� Data for modem initialization 
� Settings for serial transfer between the TS adapter and the modem. 
The data are set when the TS adapter is parameterized and are described 
in the section that follows. 

Note 
The default parameters of the TS adapter should guarantee successful 
operation in the majority of cases so that it is only necessary in 
exceptional cases to re-assign parameters. 

Parameterization of the TS adapter is necessary only when a modem link 
is not built up or the factors settings have to be customized optimized. 

3.1.4 Parameterizing the TS adapter 

You have the following options for parameterizing the TS adapter: 

• Parameterizing the TS adapter in direct connection (with null modem cable): 
A condition is that the TS adapter and the configuration computer are 
collocated. An interconnection diagram and a cable wiring diagram for the 
null modem cable will be found in Appendix A.1. 

• Parameterizing the TS adapter in modem connection (Figure 1-2): 
A requirement is that a modem connection can be established from the local 
configuration computer to the TS adapter. 

Note 
The TS adapter is supplied with universal default values in the parameter 
memory. When you parameterize the TS adapter, the latest values to be 
parameterized or the default values are read from the adapter and displayed in 
a dialog box (Figure 3-3) that consists of several registers. If you modify the 
parameters and exit the dialog box by clicking �OK�, the new parameter values 
on all registers of the dialog box are transferred directly to the TS adapter 
following a prompt. The old values in the parameter memory are overwritten 
and are lost. 
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With a reassignment of parameters, the data are written to the non-volatile 
memory, the checksum is recalculated and comparative reading takes place. 
The parameterization operation is not positively acknowledged until all 
precautions have been taken to ensure the parameter modification has been 
executed properly and thus survives a power failure. 

Parameterization of the TS adapter is described at length in the manual 
"TeleService for S7, C7 and M7 � Remote Maintenance of an Automation 
System" (Chapter 4) and therefore only brief details will be mentioned at this 
point. 

 
1. For parameterizing, the TS adapter must be supplied with voltage. For 

this, connect it to the MPI/DP interface of an automation system 
(S7/M7/C7) or use an external power pack. 

2. In SIMATIC Manager, choose the Options ⇒ TeleService from the menu 
(alternatively you can choose Start ⇒ SIMATIC ⇒ STEP7 ⇒ TeleService) 
The TeleService application starts and the start window is displayed. 

3. Choose Options ⇒ Parameterize adapter... from the menu. TeleService 
reads the currently set parameters from the TS adapter and display them 
in the dialog box (Figure 3-3) that opens. 

                                                                               

Figure 3-3 Parameterizing the TS adapter 
 

4. Set the required parameters on the tabs Network, Modem, Serial 
Parameters and Access Protection. For details of the possible settings 
refer to the online Help for the registers concerned. 
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5. Confirm your input by clicking �OK�. 

After clicking �OK�, the settings are stored in a non-volatile memory of the 
TS adapter following a prompt. The previous parameters are overwritten 
and are thus lost. 
The serial parameters, the modem parameters and the parameters for 
access protection are activated after the modem connection has been 
released. The modified network parameters are activated by means of the 
TS adapter the next time you go online. 

Note 
If you want to modify the current parameters, there is a risk that no further 
modem connection can be established with the modified parameters. In 
this case the TS adapter can only be parameterized when directly 
connected. 

3.1.5 Establishing a connection to a remote system 

The establishment of a connection to the TS adapter is described at length in 
the manual "TeleService for S7, C7 and M7 � Remote Maintenance of an 
Automation System" (Chapter 5.2) and therefore only brief details will be 
mentioned at this point. 

Perform the following steps: 
1. Start TeleService and open a phone book 

2. In a folder, select the system to which you want to establish a connection. 

3. Choose Connection ⇒ Establish... from the menu or double-click on the 
system to which you want to establish the connection. The Establish 
connection dialog box then opens (refer to Figure 3-4). 

 
Figure 3-4 Establishing a connection to a remote system 

4. Click the "Select" button. 
The long-distance connection is then established. 
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3.1.6 Transferring configuration data 

Perform the following steps: 

1. Start ProTool and open your project 

2. Compile an executable project: 

� Click on the icon            
� Or, start the compilation by choosing File ⇒ Compile... from the menu 
� Follow the instructions on the screen 
� A file with the extension *.fwd is created 

3. Check the download settings in ProTool: 

� Open the dialog box by choosing File ⇒ Download ⇒ Setting... from the 
menu and set the OP address required for your configuration. 

Select the check box "Allow upload" if you want to transfer the source file 
for the project as well to the operating unit in order to support a 
subsequent upload 

1). 

 

Figure 3-5 Settings for downloading configuration data 

4. Download the executable project to the operating unit 

To transfer the executable project from the configuration computer to the 
operating unit, the operating unit must be in Download mode or go 
automatically to Download mode when the transfer starts. For this, the 
corresponding Download option must be activated on the Configuration 
menu of the operating unit. 

                                                      
1 Important requirements have to be satisfied for the "Upload" function, depending on the HMI unit. 

Refer to online Help and the equipment manual. 
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When the operating unit starts up for the first time, it automatically goes to 
Download mode. With every further download operation, you can reboot 
the operating unit, should the operating unit not go automatically to 
Download mode, or configure the function Change_Mode on a function 
key or a button. You will find details in the manual for your operating unit. 

� Make sure that your operating unit is in Download mode  

� Start transferring the project by clicking             
or choosing File ⇒ Download ⇒ Start Project Download... from the 
menu bar 

After the transfer has run successfully, the operating unit starts up again 
and shows the start screen of the downloaded project. 

You can then test the project on the operating unit. 

3.1.7 Disconnecting 

When you have completed the transfer to the remote system, close all windows 
in ProTool and/or STEP 7 that are displaying online views. 

Then change to TeleService and release the long-distance connection by 
choosing Connection ⇒ Disconnect. 
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3.2 Settings for downloading over direct 
modem link 

 
The interconnection diagram is illustrated in Figure 1-3. 

Requirements for transfer 
Before you can start to transfer, the following criteria must be satisfied: 

 Requirements for downloading over a direct modem link 

1. ProTool CS and STEP 7 have been installed on your configuration computer (refer 
to Section 2.2 for the software requirements 

2. Your entire project and a single,complete section has been completed and has 
been complied without error by ProTool CS : 
A file that can be executed on the operating unit is created from the project 

3. An ISDN or analog modem is connected to an unassigned COM port on your 
configuration computer 

4. Transmission facilities and operating unit have been set up and are ready to start 
 

3.2.1 Initializing the local modem 

Perform the following steps: 

1. Start HyperTerminal by selecting and double-clicking 

 

Figure 3-6 Starting HyperTerminal (example)  
(the path structure depends on the PC installation and operating system) 
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2. Enter the name of the connection and click OK to confirm (Figure 3-7) 

3. At Connect using, select the COM port you are using and click OK to 
confirm (Figure 3-8) 

 
4. Set the port as follows and click OK to confirm. 

After closing the Settings window, HyperTerminal makes a blank input 
field available. 

 
Figure 3-9 HyperTerminal: Set the port 

 
Figure 3-7 HyperTerminal: Determine the name 

of the connection 
Figure 3-8 HyperTerminal: Select the 

COM port 
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5. Initialize the modem 

AT commands are used to set /change your modem. They are sent in 
Terminal mode of your communication software (such as HyperTerminal) 
to the modem. 

Enter the control commands to the modem directly in the input field. In 
doing so, make sure that each valid control command line begins with AT 
and ends with E.  

The list below shows the AT commands that have to be entered, using the 
ELSA MicroLink 33.6.QTV modem as an example. Enter the commands in 
the specified order: 

AT 
command 

Meaning 

AT&F Load default configuration (the modem then has the factory default 
settings). 
This command must be sent first to the modem. 

ATL1 Set "low" volume 
ATX3 Ignore dial tone to dial /display busy signal 

AT&D0 Ignore DTR status change 
AT&G2 Ringing tone enabled, guard tone 1800 Hz 
AT&K3 Flow control authorized over RTS/CTS lines 
AT&T5 Select loopback: deny request for remote digital loopback 

AT%D20 Buffer empty delay (20 = 20 seconds) 
AT\K0 Modem goes to command mode, does not send break to remote 

system 
AT\V0 No modified CONNECT messages 

You have to set the internal registers of the modem with the following AT 
commands: 

ATS00=001 Autoanswer after 1 ring pulse 
ATS07=060 Sets pause for carrier to 60 sec  
ATS10=020 Sets disable time to 20 sec  (if no carrier detected) 
ATS21=032 Bit-oriented: corresponds to commands AT&D0 and AT&C1 
ATS22=101 Bit-oriented: corresponds to commands ATL1, ATM1 and ATX3 
ATS23=156 Bit-oriented: corresponds to command AT&T5  
ATS31=194 Bit-oriented: corresponds to commands AT&G2, AT&D0 and others 
ATS38=020 Sets delay time for emptying buffer to 20 sec  
ATS41=195 Bit-oriented 
ATS48=004 Bit-oriented: corresponds to commands AT-J, AT\C and AT\K (bit 

2=1: detect phase enabled)  
ATS95=000 Bit-oriented: corresponds to commands AT\V, AT-M, AT*Q and ATQ 

 
Note. Should it not be possible to make an entry in the input field, check 
the settings in HyperTerminal:  Choose File ⇒ Properties from the menu 
and open the Settings register. 

Double-click on the ASCII Setup button and activate Echo typed character 
locally. Entered characters are then shown in the input field (refer to 
Figure 3-10). 
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Figure 3-10 Procedure for displaying entered AT commands 

 
The following example shows input with the HyperTerminal program: 

 
Figure 3-11 Example of entering AT commands 

 

6. Save the data on the modem 
Since the data have so far only been contained in the RAM, they must 
now be saved. To save the data, enter the following commands: 
 AT&W0 Data on the RAM are retentively stored in register �0� 
 AT&Y0 Retentive register �0� is permanently set as the start 

register after �Power ON�  
The modems are ready after switching off and on. 
Typically, further settings are not necessary but cannot be excluded since 
some modems deviate from the Hayes standard. 
Note: 
Execute these two commands every time after modifying parameters. 
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3.2.2 Establishing the connection 

Perform the following steps: 

1. Perform steps 1 to 5 described in the preceding section, "Initializing the 
modem": HyperTerminal shows a blank input field. 

Note that the baud rate for RMOS devices must only be 9600 bd. 
 

2. Enter the following command directly into the input field: 

 ATD T 123 123 being the telephone number to be dialed. 
Note that there must not be a blank or dash between the 
area code and the telephone number. 

3. Wait until the connection has been established and the modem is sending 
the acknowledgement. 

4. Exit the HyperTerminal program 

� Press the Exit (cross) button 
� Acknowledge the prompt with "Yes" 
Only the program is terminated, whereas the connection remains in force. 
This allows subsequent transfer of data in ProTool CS. 

 

Figure 3-12 Close the HyperTerminal  program 
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3.2.3 Transferring configuration data with ProTool CS 

Perform the following steps: 
1. Open your project in ProTool CS. 

2. On the File ⇒ Download ⇒ Setting... menu, select the Serial parameter. 
Select the COM port you are using and the transmission rate for the 
modem (19200 bd are mandatory). Click OK to confirm. 

 
Figure 3-13 Settings for serial download 

Note 
Select the check box "Allow upload" if you want to transfer the source file for 
the project as well to the operating unit in order to support a subsequent 
upload1). 

3. Make sure that your operating unit is in Download mode. You will find 
more information on this in the equipment manual for the HMI operating 
unit. 
If the operating unit is a PC, use the program  PC Loader : Start ⇒ 
SIMATIC ⇒ ProTool/Pro RT ⇒ ProTool/Pro RT Loader  
(refer to the operator's guide for ProTool/Pro Runtime, Section 5.5.2) 

4. Choose File ⇒ Download ⇒ Start Project Download on the menu: ProTool 
establishes the connection to the operating unit.  
Wait until the download operation has finished. 

                                                      
1 Important requirements have to be satisfied for the "Upload" function, depending on the HMI unit. 

Refer to online Help and the equipment manual. 

3.2.4 Disconnecting 

1. Check whether the download operation has finished. 

2. Restart HyperTerminal.  
Enter �+� three times (�+++�) within one second to reset the modem to 
Control mode. 
Note. A different ASCII character can be agreed in register S2. 

3. Enter the command �ATH�. The link is then disconnected.  
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3.3 Settings for uploading projects 

Constraint 
Projects cannot be uploaded with the TP 170A. 
Important requirements have to be satisfied for the "Upload" function, 
depending on the HMI operating unit. Refer to online Help and the equipment 
manual. 

Application 
A download operation normally transfers the executable project to the 
operating unit. If you want to use the original project data to expand the project 
or for error analysis, they must reside on the configuration computer. 

On Windows CE devices (only with external storage medium), however, you 
can not only store the compiled project but also the project itself in the source 
format so that the project can be retrieved (uploaded) later from the operating 
unit. 

Advantage: 
In this way you can subsequently perform analyses and changes to an existing 
project, even though the original configuration computer might not be available 
or the source file (*.pdb) belonging to the project is no longer present on the 
configuration unit. 

Requirements 
For a project to be uploaded later, the following criteria must be satisfied: 

 Requirements for uploading projects 

1. There must be sufficient memory on the operating unit for it to be possible to store 
the additional project data. 

2. The storage location for the source file must be set on the operating unit. The 
storage locations for the project file and the source file can be set separately: 
internal flash memory or PC card (refer to the equipment manual). 

3. The project file must be downloaded with transfer of the source file. 
 

Note 
The uploaded and decompressed project file (*.pdb) can only be opened in a 
version of ProTool whose version number is higher or equal to the ProTool 
version with which the project was created. 

Caution 
ProTool cannot check whether the source file on the operating unit really does 
belong to the project being run on it. If, at some stage or other, you really have 
performed a download operation without downloading the source file while 
doing so, there might be old project data still on the operating unit. The data 
might no longer match the current project. 
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Settings for uploading by means of TeleService 
The TS adapter settings performed for the download operation are used. 

Note the following: 

1. Check the upload settings in ProTool: 

Open the dialog box by choosing File ⇒ Upload ⇒ Setting... from the menu. 

The following dialog window opens: 

 

Figure 3-14 Upload settings  

2. Select the type of connection between the operating unit and the 
configuration device: 

� Serial: Port and baud rate  
� MPI: OP address of the operating unit  
� Ethernet: IP address or name of the computer 
Your settings will be saved and used as default values for subsequent 
uploads.  

3. Start the upload operation by choosing File ⇒ Upload ⇒ Start from the 
menu.  
The upload operation sets the operating unit to Upload mode via remote 
control.  
A requirement for this is that the type of upload being used has been 
configured on the operating unit.  

4. If the upload operation has been performed successfully, the "Save As" 
dialog box opens. 

Enter the name concerned or select an existing project so that it will be 
overwritten, and click Save. 

The retrieved project will be saved and automatically opened immediately 
in ProTool.  
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3.4 Settings for remote maintenance with 
TeleService 

Principle 
State-of-the-art automation concepts make high demands on process visualization. 
A major factor in this respect is powerful and simple process monitoring and 
maintenance by service points spatially separated from the systems. 
In ProTool/Pro Runtime (ProTool/Pro RT), ProTool features program with which 
you can run your configuration in Windows, visualize the process (Operator & 
Monitor) and access the remote PLC to perform maintenance and 
troubleshooting. 

Requirements for commissioning 
The following criteria must be satisfied before you can access the remote system: 

 Requirements for remote maintenance with TeleService 

1. ProTool/Pro RT must be installed on the service PC1). You will find the Runtime 
software on the SIMATIC ProTool/Pro CD-ROM. Its installation is described in the 
User's Guide for ProTool/Pro Runtime (Section 5.2.1). 
The hardware and software requirements are listed in the same manual (Section 2.1). 

2. The Runtime software authorization must be installed on the system before the 
Runtime software can run. 
The authorization for PCs has to be ordered separately on a license disk. 
The license is subdivided by the number of process tags, called power tags. A 
process tag contains a connection to the PLC. There are licenses for power tags 
having 128, 256, 512 and 2048 tags. There are also upgrades (power packs) for 
updating to a larger number of power tags. 

3. It must be possible to connect the PLC, on which remote control has to be performed,  
to ProTool/Pro Runtime. 
The following PLCs can be connected by means of TeleService to ProTool/Pro RT: 

SIMATIC S7 over MPI 
� S7-200 (except for S7-212) 
� S7/M7-300 (all CPUs) 
� S7/M7-400 (all CPUs) 

SIMATIC S7 over PROFIBUS-DP 2) 
� S7-200 (all CPUs having an integrated PROFIBUS-DP interface 3)  
� S7/M7-300 (all CPUs with integrated PROFIBUS-DP interface 2)  
� S7/M7-300 with CP342-5 2)  
� S7/M7-400 (all CPUs with integrated PROFIBUS-DP interface) 2)  
� S7/M7-400 with CP443-5 2)  

4. On your service PC 
1), there must be a loaded ProTool/Pro RT project with which you 

can access the STEP7 program on the remote system. 

                                                      
1) The service computer is the PC on which ProTool/Pro RT is running and which is used to establish 

the connection to the remote system. 
2) ProTool/Pro RT is the active node; communication takes place with the S7 driver 
3) Refer to Catalog ST70 
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Remote maintenance scenarios 
The interconnection diagram is illustrated in Figure 1-6. 

Two scenarios are possible for remote maintenance/Operator & Monitor: 

• The ProTool/Pro RT runtime software is installed on the same PC as the 
ProTool/Pro CS configuration software (used to create the Runtime project) 

• The ProTool/Pro RT runtime software is installed on a different PC from the 
ProTool/Pro CS configuration software. 
In this latter case the Runtime project has to be transferred from the 
configuration computer to the service computer 

1). 

Configuration software and runtime software are on the same PC 
In this scenario, the golden rule is to perform the steps described in Section 3.1 
Settings downloading with TeleService: 

1. Parameterize the PU/PC interface (refer to Section 3.1.1). 

2. Parameterize the local and remote modems (refer to Sections 3.1.2 and 
3.1.3). 

3. Parameterize the TS adapter (refer to Section 3.1.4). 

4. Establish a telephone connection to the remote system (refer to Section 
3.1.5). 

5. Open your project in ProTool/Pro CS. 

6. Start the ProTool/Pro RT runtime software directly from the running 
 
configuring software by clicking on 
You can then access the remote sy

7. Disconnect after you have finished 

                                                      
1) The service computer is the PC on which ProTool/Pro R

the connection to the remote system. 

Configuration software and Runtime are on d
In this scenario the Runtime project is on
first instance. 

1. Copy this project from the configura

The following options are available 
compiled file: 

� Copy the *.fwd file to a floppy
the service computer. If your pro
disk download 

� Floppy disk download: 
In ProTool/Pro CS, choose File 
Destination directory dialog box.
transferred to one or more flopp
Communication by Modem Link 
Start Up Instructions 

          
stem. 

your work (refer to Section 3.1.7) 

T is running and which is used to establish 

ifferent systems 
ly on the configuration computer in the 

tion computer to the service computer 
1)  

to you in Windows for transferring the 

 disk and then from the floppy disk to 
ject is too large for one floppy disk, use 

⇒ Download and select drive A:\ in the 
 The executable project file is 
y disks (file extension *.f00) 
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To unpack the compressed project file on the destination device, 
choose SIMATIC ⇒ ProTool/Pro RT ⇒ ProTool/Pro Disk Download 
from the Start menu. Select the compressed file (*.f00) in the 
Download dialog box and specify the destination directory to which you 
want to copy the unpacked project file. 

� Copy the *.fwd file over a parallel or serial cable by means of the PC 
direct connection from Windows 98 SE to the service computer. 

� Copy the *.fwd file over a parallel or serial cable by means of the data 
communication connection from Windows NT or Windows  2000 to the 
service computer. 

� Copy the *.fwd file over a network to the service computer. 
� If the service computer is connected to the configuration computer over 

an MPI/DP network, you can download the RT project with the 
ProTool/Pro RT Loader program and start it. You will find more 
information in the ProTool/Pro Runtime User's Guide (Section 5.5.2). 

Note 
Before starting a new Runtime project, delete all archive files on your service 
computer that were not created with the new project. 

1. Parameterize the PU/PC interface (refer to Section 3.1.1). 

2. Parameterize the local and remote modems (refer to Sections 3.1.2 and 3.1.3). 

3. Parameterize the TS adapter (refer to Section 3.1.4). 

4. Establish a telephone connection to the remote system (refer to Section 3.1.5). 

5. Start the Runtime software on the service computer by double-clicking on 
the compiled project file (*.fwd). 

You can then access the remote system. 

6. Disconnect after you have finished your work (refer to Section 3.1.7) 
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Appendix 

A Cable wiring diagrams 
A.1 RS232 cables (PC ⇒ TS adapter) ................................................................  A-2 
A.2 Standard modem cables (PC ⇒ modem and modem ⇒ TS adapter) .........  A-3 
A.3 Special cables (modem ⇒ HMI operating unit) ............................................  A-4 
 
 

A
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A.1 RS232 cable (PC ⇒⇒⇒⇒ TS adapter) 

RS232 cable (null modem cable) 
such as 6ES7 901-1BF00-0XA0) 

 To PC:  To TS adapter 
 9-pin sub D  9-pin sub D 
 female connector  female connector 

   
 

Interconnection diagram for direct connection of the TS adapter  

   

If an external power pack is available for the TS adapter, the TS adapter can 
be parameterized without the automation system. 
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A.2 Standard modem cables (PC ⇒⇒⇒⇒ modem and modem ⇒⇒⇒⇒ TS adapter) 

Standard mode cable for Hayes-compatible modem with 25-pin socket 
connector (enclosed with every modem) 

 

 To PC / To TS adapter:  To modem: 
 9-pin sub D  25-pin sub D 
 female connector  male connector 

  
 
If your modem is equipped with a 9-pin socket connector, the standard modem 
cable must be configured as follows: 

 To PC / To TS adapter:  To modem: 
 9-pin sub D  9-pin sub D 
 female connector  male connector 
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A.3 Special cables (modem ⇒⇒⇒⇒ HMI operating unit) 

Special cable (has to be created) 

 To modem  To HMI operating unit 
 25-pin sub D  9-pin sub D 
 female connector  female connector 

   
 

 



Release 09/02 Abbreviations 

Communication by Modem Link A-5 
Start Up Instructions 

Abbreviations 

The meanings of the abbreviations used in this document are as follows: 

ANSI American National Standards Institute 
AS 511 Driver of the PU interface on SIMATIC S5 
ASCII American Standard Code for Information Interchange 
CAPI Common Application Programming Interface 
COM Serial communications port on configuration computer 
CPU Central Processing Unit 
DP Distributed I/O 
HMI Human Machine Interface 
ISDN Integrated Services Digital Network 
LED Light-emitting diode 
Modem Modulator/demodulator 
MPI Multipoint Interface (SIMATIC S7) 
OLE Object Linking and Embedding 
OP Operator Panel 
PC Personal Computer 
PU Programming Unit 
RAM Random Access Memory 
PLC Programmable Logic Controller 
TCP/IP Transmission Control Protocol/Internet Protocol 
TP Touch Panel 
USB Universal Serial Bus 
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Glossary 

 
 
Automation system Controller in the SIMATIC S7 series (such as SIMATIC S7-

200/300/400). 

Baud rate Unit of the speed with which data are transferred. The baud rate is 
stated in bps or kbps. 

Boot Load procedure that transfers the operating system to the working 
memory of the operating unit. 

CAPI Common Application Programming Interface: Interface through which 
the programs can access ISDN devices. 

Click An event that you trigger by pressing the left button on your mouse or, 
on touch-operated devices, by briefly touching a button with the finger 
tip. 

COM interface Serial communications port on configuration computer The modem or 
operating units are connected to this interface. 

Configuration Definition of system-specific default settings, messages and screens 
with the help of the ProTool CS configuration software. 

Controller Expression covering all devices and systems with which the operating 
unit communicates (such as SIMATIC S7 or PC). 

Double-click An event that you trigger by quickly pressing the left button twice on 
your mouse or, on touch-operated devices, by briefly touching a button 
twice with the finger tip. 

Download mode Operating mode of the operating unit in which data are transferred 
from the configuration computer to the OP. 

ISDN Integrated Services Digital Network: service offered by a service 
provider for the digital transmission of data and speech. 

ISDN adapter ISDN device connected to a serial COM port to transfer data over the 
digital network. 

ISDN modem ISDN adapter with integrated analog modem functionality. 

Modem Modulator/Demodulator: communication device that allows a 
computer to send and receive data over telephone circuits. It converts 
digital pulses of the computer into analog signals, and the other way 
round. 
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Modem connection In a modem connection, the connection between the configuration 
computer, on which TeleService is installed, and the automation 
system, on whose MPI the TS adapter is plugged in, is established 
over a modem link. In this way the configuration computer is 
connected over the long-distance connection and the TS adapter to 
the MPI bus of the automation system. 

MPI The interface with multipoint capability (MPI) is the programming unit 
interface of the SIMATIC S7/M7. It supports simultaneous operation of 
several programming units, text displays, operator panels conencted 
to one or more central processing units. The nodes on the MPI can 
communicate with each other. 
On an MPI network, a separate MPI address has to be assigned to 
each node. 

Multi Panel (MP) Multi-function configurable operating unit with graphic display and 
Windows CE operating system for the operation and monitoring of 
machines and systems. 

Operator Panel (OP) Configurable operating unit for the operation and monitoring of 
machines and systems. 

PPP Point-to-Point protocol. A standard procedure for data communications 
over the Internet. PPP is used for communication between a computer 
and an Internet service provider. 

ProTool CS ProTool Configuration System. The name ProTool CS includes three 
versions of the configuration software: ProTool/Pro CS, ProTool and 
ProTool/Lite. 

ProTool/Pro RT ProTool/Pro Runtime. Process visualization software with which you 
can run the configuration created with ProTool CS on your Windows-
based system. 

RAM The RAM (Random Access Memory) is a read/write memory in which 
every memory location can be addressed individually and whose 
contents can be modified. RAMs are used as data and program 
memories. 

Retentive Data are referred to as retentive when they have the same value after 
a power supply failure as they did before the power failure.  

RS232 Standard interface for serial data transmission with a defined voltage 
level. The transmitter and the receiver are electrically connected. 

RS485 Standard interface for serial data transmission with very high 
transmission rates. 

Runtime software Refer to ProTool/Pro RT 

Set PU/PC interface �Set PU/PC interface� is an application in STEP 7 in which you can 
parameterize your COM port. For TeleService, you install the TS 
adapter and parameterize this interface depending on your 
configuration. 
 



Release 09/02 Glossary 

Communication by Modem Link A-9 
Start Up Instructions 

STEP 7 Programming software for SIMATIC S7, SIMATIC C7 and SIMATIC 
WinAC 

Transmission rate The transmission rate is the transmission speed on the telephone 
circuit. The maximum transmission rate is the main criterion for the 
performance capability of a modem. The faster data can be 
transmitted, the lower are the telephone charges. 

TS adapter The TS adapter is used to connect an automation system by means of 
a modem to a telephone network in order to prepare it for using 
TeleService. For this purpose, the TS adapter has a parameter 
memory in which different parameter records are stored for 
TeleService mode. Furthermore, the TS adapter has a switch at which 
you ca set the transmission rate for a direct connection. 
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