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Preface

Audience

The Windows Automation Center (WinAC) Basis runs on your personal computer
(PC) and provides PC-based control of your process. The WinAC Basis software
consists of the following products:

¢ Windows Logic Controller (WinLC)
e Computing software

e Tool Manager

Note

For WIinAC, the term “control engine” applies to a processor or program that
manages and manipulates data which is used to control a process or machine.
The control engine can be can be either software or hardware.

WinAC Basis provides a Windows Logic Controller (WinLC) as its control engine,
and WIinAC Pro uses a slot PLC such as CPU 416-2 DP ISA as its control engine.
The ActiveX controls provided by SIMATIC Computing communicate with these
control engines, as well as other SIMATIC controllers.

This manual is intended for engineers, programmers, and maintenance personnel
who have a general knowledge of programmable logic controllers.

Scope of the Manual

This manual describes the features and the operation of version 3.0 of the WinAC
Basis software.

How to Use This Manual

This manual provides the following information:

¢ Overview of the components of the WIinAC Basis package

¢ Installing and authorizing the WinAC software

e Getting started with the WinAC software

¢ Using the Tool Manager

This manual also provides the following reference material:

¢ WInAC and DCOM (Microsoft’s Distributed Component Object Model)

e OPC (OLE for Process Control) connections

Windows Automation Center WinAC Basis Overview
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Other Manuals

For additional information, refer to the following manuals:

Title Content
Windows Logic Controller This manual provides basic information about the
(WInLC) User Manual performance characteristics and operation of the WinLC
controller.
Computing User Manual This manual describes the SIMATIC ActiveX controls of

the Computing software.

OPC Server Interface Manual This manual describes the browsable OPC server
interface provided with the Computing software.

You can also find information about the components of the WIinAC in the online
help for the software.

Additional Assistance

If you have any questions not answered in this or one of the other STEP 7
manuals, if you need information on ordering additional documentation or
equipment, or if you need information on training, please contact your Siemens
distributor or sales office.

To contact Customer Service for Siemens in North America:
e Telephone:
— (609) 734-6500
— (609) 734-3530
e E-mail:
— |ISBU.Hotline@sea.siemens.com
— simatic.hotline@sea.siemens.com
e Internet:
— http://www.aut.sea.siemens.com/winac/
— http://www.aut.sea.siemens.com/simatic/support/index.htm
— http://www.ad.siemens.de/support/html_76/index.shtml
— http://wvww.sea.siemens.com/industrialsoftware
To contact Customer Service for Siemens in Europe:

e Telephone: ++49 (0) 911 895 7000

e Fax ++49 (0) 911 895 7001
e E—mail: simatic.support@nbgm.siemens.de
e Internet: http://www.ad.siemens.de/simatic—cs

) Windows Automation Center WinAC Basis Overview
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Product Overview 1

Chapter Overview

The Windows Automation Center (WinAC) Basis package consists of the following
products:

e The Windows Logic Controller (WinLC) software allows you to use your
personal computer like a programmable logic controller (PLC) for running your
process.

WinLC is a PC-based logic controller in the family of S7 controllers. This
controller is fully compatible with the automation tools provided by the SIMATIC
family of products, such as the STEP 7 programming software and the
Windows Control Center (WinCC).

¢ The SIMATIC Computing software provides ActiveX controls, which you can
use to create a tailored view into your process. Computing lets you use any mix
of S7 and third-party ActiveX controls not only to view, but also to modify,
process data.

e The TagFile Configurator creates tag files that allow you to use symbols for the
memory locations being accessed in the control engine. Tag files also allow you
to access data in several control engines at the same time.

In addition to these products, WinAC provides a configuration tool to quickly
change language, support legacy applications, and set up OPC communications. It
includes and a tool manager to provide quick access to software applications that
you want to use with WinAC.

Section Description Page
11 What's New in WinAC Version 3.0? 1-2
1.2 WinLC controls your process... 1-3
1.3 Computing provides access to the process data... 1-4
1.4 Tag files allow you to use symbols for the process data... 1-5
15 Tag files allow you to access multiple control engines... 1-6
1.6 Use Computing over a DCOM network... 1-7
1.7 Use OPC to connect third-party applications to Computing... 1-8
1.8 Tool Manager provides shortcuts to your programs... 1-9
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Product Overview

1.1 What's New in WinAC Version 3.0?

WInAC V.3 incorporates several new features:
¢ WinLC now communicates over PROFIBUS, Ethernet, or MPI networks.

¢ SIMATIC Computing now supports rack/slot addressing for H1, MPI, and
PROFIBUS networks. You can use rack/slot addressing in Computing and in
the tadfile.

¢ SIMATIC Computing provides new unified user controls.

¢ You can purchase the CP card for your network separately. WinAC is able to
support multiple card types.

¢ SIMATIC Computing is now available as a standalone package, separate from
WInAC Basis and WinAC Pro.

Windows Automation Center WinAC Basis Overview
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Product Overview

1.2 WinLC controls your process...

WinLC provides a computer-based solution for your automation projects. WinLC
connects a PC-based controller over a PROFIBUS-DP, Ethernet, or MPI network
to the distributed (remote) 1/O that connect to the process or automation project.

As shown in Figure 1-1, you can use the Computing software to provide access to
the process data. You can also use the standard SIMATIC products with WinLC,
such as STEP 7 and WinCC.

C T T - r— " -1
| | | ; |
Third-party - ; Optional SIMATIC .
: products {" Computing : products STEP 7 WinCC l
L 4 LT r— 4
______________ ]
0 i [ e
S| - A
CLL 1L

o

Figure 1-1 ~ Components of WinAC Basis

The CPU panel (see Figure 1-2) provides the functions for changing the operating
mode, for displaying the status of the controller, and for resetting the memory
areas.

Eile CPU Help

SIEMENS

PS

0 on
BATTF Changes the operating

mode of the controller

Displays the status of the
controller

Resets the memory areas

Figure 1-2  CPU Panel of WinLC

Windows Automation Center WinAC Basis Overview
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Product Overview

1.3 Computing provides access to the process data...

As shown in Figure 1-3, the Computing software allows you to access WIinLC in
order to monitor and modify the process data.

Computing provides several methods for accessing the process data:
¢ You can use standard ActiveX controls (OCX) that access the process data.

e You can use DCOM (Microsoft's Distributed Component Object Model) to
integrate distributed applications over a network. A distributed application
consists of multiple processes or different computers that cooperate to
accomplish a single task. (See Section 1.6.)

e You can use the OPC (OLE for Process Control) server, which allows any OPC
client application to access data in the control device. (See Section 1.7.)

[E] S7SoftContainer — [S7Soft1] EEE
File Edit View Mode Options Window Help

EF EEEEE N N EEEE R

File CPU Help

SIEMENS

.
B on

BATTF

CPU
| "~ INTF

EXTF
BUSF1
BUSF2

N\

Ready | Design

Computing

FRCE

RUN

WinLC Syely

Figure 1-3  Accessing the Process Data with Computing

Windows Automation Center WinAC Basis Overview
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Product Overview

1.4 Tag files allow you to use symbols for the process data...

A tag file provides a source of symbolic information for memory locations and
control engines. Linking to a tag file allows you to use symbolic names instead of
absolute addresses when assigning variables in Computing. See Figure 1-4.

The TagFile Configurator creates a tag file that provides a source of symbolic
information for the memory locations and control engines. The tag file can then be
used on a computer that does not have STEP 7 installed.

For more information about the TagFile Configurator, see the WinLC User Manual

or the Computing User

Manual.

=R SIMATIC Projects

The tag file includes the symbol
table and the control engine for the
STEP 7 project

Tag File é \\ /
Control Engine Symbol |STEP\)'P§h i |ComputerName
EIPC_1_WinLCV3.6- \@PC_1\WinLCV3.0\Mixer @PC_1
I ] I Tl ]
- I I -
u) a
LU 1L

Jl Distributed I/O J

Figure 1-4  Using STEP 7 Symbols to Access Data in the Control Engine

Windows Automation Center WinAC Basis Overview
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Product Overview

15 Tag files allow you to access multiple control engines...

Multiple STEP 7 programs can be mapped into a single tag file, with each program
providing access to a different computer and control engine. This allows
Computing to access data from different computers and control engines
simultaneously.

As shown in Figure 1-5, you can connect your program to control engines residing
on several different computers. You use the TagFile Configurator to insert more
than one control engine into a tag file. For more information about the TagFile
Configurator, see the WinLC User Manual or the Computing User Manual.

BREY SATIC Projects]
b Master_Mixer # p My_Drain
| @PC_2 il @PC_3
A WinLCV3.0 B WinLCV3.0
Mixer £+ Drain
Tag File % %
Control Engine Symbol |STEP7 Path | Computer Name
71pPC_2 WinLCV3.0 WinLCV3\@PC_2\WinLCV3.0\Mixer @PC_2
(IPC_3 WinLCV3.0 WinLCV3\@PC_3\WinLCV3.0\Mixer @PC_3

(N
WinLC | PC 2

A

Computing 5 )
WwinLC PC3

A )

Figure 1-5  Using a Tag File to Access Data from Several Control Engines

Windows Automation Center WinAC Basis Overview
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Product Overview

1.6 Use Computing over a DCOM network...

Microsoft’'s Distributed Component Object Model (DCOM) is a set of program
interfaces in which client program objects can request services from server
program objects on other computers in a network.

You can use DCOM for integrating distributed applications over a network. See
Figure 1-6. A distributed application consists of multiple processes or different
computers that cooperate to accomplish a single task.

For more information about using WinAC over a DCOM network, see Appendix A.

Computing

DCOM
Components

. —

I
I
I
I
I
I
I
I
I
|}

Network

DCOM
Components

I

WinLC

/10

Figure 1-6 ~ Connecting WIinAC on Several Computers across a DCOM Network
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Product Overview

1.7 Use OPC to connect third-party applications to Computing...

OLE for Process Control (OPC) provides a standard mechanism for
communicating to numerous data sources, whether they be the devices on your
factory floor or a database in your control room. OPC is based on the OLE/COM
technology from Microsoft. For more information about OPC, refer to the OPC
specification OLE for Process Control Data Access Standard, version 2.0 from the
OPC Foundation.

As shown in Figure 1-7, you can use the OPC server provided with the Computing
software to communicate with the control engine and provide access to the
process data. Computing provides an OPC server that allows any OPC client
application to access data in the control engine; Computing does not provide any
OPC client application.

The name of the OPC server is: OPCServer.WinAC

SIMATIC Computing allows you to use OPC for connecting either to a single
control engine or to several control engines. You can also connect to the control
engine over a network, such as a local area network (LAN).

For more information about configuring the OPC server, see Appendix B.

Third-party application
(OPC client)

[

]

Computing
WiInAC OPC Server:
OPCServer.WinAC
MPI server
T )
| |
WinLC | CPU 416-2 DP ISA MPI Card
i SN
]
O —
=L

Figure 1-7 Using OPC to Connect Third-Party Applications to Computing

Windows Automation Center WinAC Basis Overview
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Product Overview

1.8 Tool Manager provides shortcuts to your programs...

The Tool Manager is a toolbar that lets you consolidate all of the applications that
you want to use while working with your process data. For instance, if you plan to
use Visual Basic with WIinAC, or want to put process data into a Microsoft Excel
spreadsheet, you can insert shortcuts to those items on the Tool Manager. The
Tool Manager is especially convenient for users who do not have a mouse on their
computer, since all of the functions of the Tool Manager can be accessed by
keystrokes from one central location.

Figure 1-8 shows the Tool Manager and its shortcut icon. You can insert shortcut
icons for any of your programs into the Tool Manager tray. You then use the Tool
Manager to start these programs.

For more information about the Tool Manager, see Section 4.

Shortcut icon Tool Manager

Tool Manager

nIATIC

Tool Manager

S7 logo empty tray

Figure 1-8  Tool Manager and Shortcut Icon

Windows Automation Center WinAC Basis Overview
C79000-G7076-C219-03 1-9



Windows Automation Center WinAC Basis Overview
C79000-G7076-C219-03



Installing the Components of WInAC Basis 2

Chapter Overview

The WiInAC software provides a single setup program that installs the WinLC,
SIMATIC Computing, and Tool Manager software. There is a single authorization
disk for these products. This chapter provides the following information:

e Section 2.1 lists the requirements for installing and running the WinAC Basis
software.

e Section 2.2 provides procedural information about installing the WinAC Basis
software.

e Section 2.3 provides procedural information about uninstalling the WinAC Basis
software.

e Section 2.4 provides procedural information about installing the authorization for
WInAC Basis.

e Section 2.5 provides additional information about installing the components of
WinLC.

Note

The installation of the WinLC option requires that you install a CP 5412
communications processor board and SIMATIC NET communications software. To
install the CP 5412, you must turn off your computer and install the board. You
may want to install the CP 5412 before installing the WIinAC software.

Refer to the special notes (Section 2.5) and to the Windows Logic Controller
(WinLC) User Manual for information about installing the components of the
WinLC product.

Section Description Page
2.1 System Requirements 2-2
2.2 Installing the WinAC Software 2-2
2.3 Uninstalling the WinAC Software 2-5
2.4 Authorizing the WinAC Software 2-6
25 Special Notes for Installing the WinLC Controller 2-8
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Installing the Components of WinAC Basis

2.1

2.2

2-2

System Requirements

To run the components of WInAC, it is recommended that your computer meet the
following criteria:

e A personal computer (PC) with the following:
— Pentium processor running at 166 MHz or faster
— 64 Mbytes RAM
— Microsoft Windows NT version 4.0 (or higher)

¢ A color monitor, keyboard, and mouse (or other pointing device) that are
supported by Microsoft Windows NT

e A hard drive with 20 Mbytes of free space

e At least 1 Mbyte free memory capacity on drive C for the Setup program (Setup
files are deleted when the installation is complete.)

The product has been tested, and operated successfully, on machines as slow as
a 486 processor running at 66 MHz with 24 Mbytes RAM operating on a Windows
NT platform. Computing has also been successfully tested on high-end PCs with
dual Pentium processors.

Installing the WIinAC Software

The WiInAC software includes a Setup program which executes the installation
automatically. The screen prompts guide you step by step through the installation
procedure.

During installation, the program checks to see whether an authorization is installed
on the hard disk. If no authorization is found, a message notifies you that the
software can be used only with an authorization. If you wish, you can run the
authorization program immediately or you can continue the installation and execute
the authorization later. See Section 2.4.

Note

You must have administrator (*“ADMIN”) privileges to install the WIinAC software.

Windows Automation Center WinAC Basis Overview
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Installing the Components of WinAC Basis

Installing the Components of WinAC

Figure 2-1 shows the dialog box that allows you to choose which components to
install. Select the components that you want to install. Each component that you
have selected is installed in the same directory.

?.‘ Setup— Windows Automation Center (WinAC) Components

Please select the programs to be installed

SIMATIC [J READ ME OMB |[J Deutsch

O winLCV3.0 3MB English
SOftware 0J ComputingV3.0 3MB | O French

[J Tool Manager V3.0 3MB

— Description

WinLC V3.0 — the control engine for your process

Read me

c:\siemens\winac Browse

— Destinationdirectory

Required ond: 0 MByte  Available on d: 803 MByte

< Back | Next > | Cancel |

Figure 2-1 Installing the Components of WinAC

Note

The installation of the WinLC software requires that you install a CP 5412
communications processor board and SIMATIC NET communications software. To
install the CP 5412, you must turn off your computer and install the board. You
may want to install the CP 5412 before installing the WIinAC software.

In the future, other communications boards in addition to the CP5412 will be
available. Refer to Siemens website
http://www.sea.siemens.com/industrialsoftware for a listing of approved
communications processor boards.

Refer to the special notes (Section 2.5) and to the Windows Logic Controller
(WinLC) User Manual for information about installing the components of the
WinLC software.

Windows Automation Center WinAC Basis Overview
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Installing the Components of WinAC Basis

Starting the Installation Program

The Setup program guides you step by step through the installation process. You
can switch to the next step or to the previous step from any position. To start the
installation program, proceed as follows:

1. Insert the CD-ROM in your computer.

2. Use the Windows NT Start menu (select the Start » Run menu command) to
open the “Run” dialog box.

3. Click on the “Browse” button on the “Run” dialog box and select the installation
program (Setup.exe) on the CD-ROM.

4. Click on the “Open” button to enter the Setup.exe program into the “Run” dialog
box.

5. Click on the “OK” button to start the installation program.
6. Follow the instructions displayed by the installation program step by step.

7. When prompted by the software, insert the WinAC authorization diskette in
drive A. For more information about authorizing the WIinAC software, see
Section 2.4.

Once the installation has been completed successfully, a message to that effect is
displayed on the screen.

Note

You install the WinAC authorization on the server computer; you install the
SIMATIC Computing authorization on the client computer. If you want to run
SIMATIC Computing on a PC other than the PC running WIinLC, then you must
purchase SIMATIC Computing standalone. For more information about installing
an authorization, see Section 2.4.

If an Older Version of WinAC Has Already Been Installed

2-4

If the installation program finds another version of WinAC on the programming
device, the program reports this and prompts you to decide how to proceed by
offering the following choices:

e Abort the installation so that you can uninstall the older version of the WinAC
software under Windows NT and then start the installation again.

¢ Continue the installation and overwrite the older version with the new version.

Your software will be better organized if you uninstall any older versions before
installing the new version. Overwriting an old version with a new version has the
disadvantage that if you then uninstall, any remaining components of the old
version are not removed.

Windows Automation Center WinAC Basis Overview
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Installing the Components of WinAC Basis

Troubleshooting Any Errors That Occur during Installation
The following errors may cause the installation to fail:

e Initialization error immediately after starting Setup: The SETUP.EXE program
was probably not started under Windows NT.

¢ Not enough memory: You need at least 3 Mbytes of free space on your hard
disk.

e Bad disk: Verify that the disk is bad, then call your local Siemens
representative.

e Operator error: Start the installation again and read the instructions carefully.

2.3 Uninstalling the WinAC Software

Use the following procedure to remove the WinAC software from your computer:
1. Double-click on the “Add/Remove Programs” icon in the Control Panel.

2. Select the WinAC entry in the displayed list of installed software. Click on the
“Add/Remove..."” button to uninstall the software.

3. If the “Remove Enable File” dialog boxes appear, click the “No” button if you are
unsure how to respond.

ii Caution
If improperly transferred or removed, the authorization for the WinAC software
may be irretrievably lost.

The Readme file on the authorization diskette contains guidelines for installing,
transferring, and removing the authorization for the WinAC software. If you do not
follow these guidelines, the authorization for the WinAC software may be
irretrievably lost. Losing the authorization would prohibit you from modifying any
program that was downloaded to the WinAC and from downloading another
program to the WinAC.

Read the information in the Readme file on the authorization diskette, and follow
the guidelines in regard to transferring and removing the authorization.

Windows Automation Center WinAC Basis Overview
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2.4

Authorizing the WinAC Software

The WiInAC software requires a product-specific authorization (or license for use).
The software can be used only if the relevant authorization for the program or
software package has been found on the hard disk of the computer.

Note

You must have administrator (“ADMIN”) privileges to install the WIinAC software.

Using the WIinAC Authorization Diskette

The WInAC software includes an authorization diskette. It contains the
authorization and the AUTHORSW program which displays, installs, or removes
the authorization for running the WinAC software.

There are separate authorization diskettes for each of the SIMATIC automation
software products. You must install the authorization for each product as part of
the installation procedure for that software. For more information and rules on how
to handle authorizations, see the documentation for the specific SIMATIC software
product.

Caution

If improperly transferred or removed, the authorization for the WinAC software
may be irretrievably lost.

The Readme file on the authorization diskette contains guidelines for installing,
transferring, and removing the authorization for the WinAC software. If you do not
follow these guidelines, the authorization for the WinAC software may be
irretrievably lost. Losing the authorization would prohibit you from modifying any
program that was downloaded to the WinAC and from downloading another
program to the WinAC.

Read the information in the Readme file on the authorization diskette, and follow
the guidelines in regard to transferring and removing the authorization.

Installing the Authorization for the First Time

2-6

When you install the software for the first time, a message prompts you to install
the authorization. Use the following steps to install the authorization for the WinAC
software:

1. When prompted, insert the authorization diskette in a drive.
2. Acknowledge the prompt.

The authorization is transferred to a physical drive, and your computer registers
the fact that the authorization has been installed.

Windows Automation Center WinAC Basis Overview
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Adding an Authorization at a Later Date

If you attempt to start the WIinAC software and there is no authorization available
for the software, a message informs you of this. If you want to install the
authorization, use the AUTHORSW program on the authorization diskette. This
program allows you to display, install, and remove authorizations. The program is
menu-driven.

Note

Always enter drive C as the destination drive for the authorization for WinAC.

Removing an Authorization

If you should need to repeat the authorization (for example, if you want to reformat
the drive on which the authorization is located), you must first remove the
authorization. You need the original authorization diskette to do this.

Use the following steps to transfer the authorization back to the authorization
diskette:

1.
2.
3.

Insert the original authorization diskette in your floppy disk drive.
Start the program AUTHORSW.EXE from the authorization diskette.

From the list of all authorizations on drive C, select the authorization to be
removed.

Select the menu command Authorization » Transfer... .

5. In the dialog box, enter the target floppy drive to which the authorization will be

transferred and confirm the dialog box.

The window with the list of authorizations remaining on the drive is then
displayed. Close the AUTHORSW program if you do not want to remove any
more authorizations.

You can then use the diskette again to install an authorization.

If Your Hard Drive is Defective...

If a fault occurs on your hard disk before you can back up the authorization,
contact your local Siemens representative.

Windows Automation Center WinAC Basis Overview
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2.5 Special Notes for Installing the WinLC Controller

Installing the Components of WinLC

As shown in Figure 2-2, you must perform the following tasks to install the
components of WinLC:

¢ Install the CP 5412 communications processor card in your computer. For
information about this installation procedure, refer to the documentation for the
CP 5412. The CP 5412 card must be purchased separately.

¢ Install the SIMATIC NET software for the CP 5412. This procedure includes
installing the PROFIBUS-DP authorization on your computer. For information
about installing the PROFIBUS-DP software, refer to the documentation for the
CP 5412.

¢ Install the WinLC software. For information about this installation procedure,
refer to the SIMATIC Windows Logic Controller (WinLC) User Manual.

Note

Other communications processor boards in addition to the CP5412 will be
available in the future. Refer to Siemens website
http://www.sea.siemens.com/industrialsoftware for a listing of approved
communications processor boards.

T T T T T -1

| Distributed 110 |

| [0 ] 0 !
A

RmaRRin = L]

SIMATIC | b b Elo ol bl b |
NET [ I 1

J \U

CP 5412

PROFIBUS-DP network

Figure 2-2 Installing the WinLC Controller
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Running the WIinLC Controller without the Authorization

If you remove (or accidentally delete) the authorization for the software, the WinLC
controller continues to operate; however, you cannot modify the program being
executed and you cannot download a new program. You are still permitted to
change from RUN mode to STOP mode, and the controller continues to execute
the user program. You are still permitted to create and reload archive files.

A notification message appears every six minutes to alert you that the
authorization is missing.

Windows Automation Center WinAC Basis Overview
C79000-G7076-C219-03 2-9



Windows Automation Center WinAC Basis Overview
C79000-G7076-C219-03



Getting Started with WinAC Basis

Chapter Overview

WinAC Basis provides two basic components:

¢ WinLC: a software-based S7 programmable logic controller (PLC), also referred
to as a “control engine”

e Computing: a set of SIMATIC controls that utilize Microsoft's ActiveX

technology to access data in the control engine

You can use a sample program (provided with the STEP 7 programming software)
to help understand how to use the components of WinAC Basis.

Section Description Page
3.1 Using WInAC Basis with a Sample Program 3-2
3.2 Starting the WinLC Controller 3-3
3.3 Going On-line to WIinLC with STEP 7 3-4
3.4 Downloading a Sample Program to WinLC 3-7
3.5 Using the Computing SoftContainer to Create a Process Form 3-15
3.6 Configuring the Connections for the Process Form 3-18
3.7 Configuring the Button Controls on the Process Form 3-23
3.8 Running the Process Form with the Sample Program 3-28
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3.1 Using WInAC Basis with a Sample Program

To help you start using the components of WIinLC, this chapter provides

information about the following tasks:

e Start the WIinLC controller.

¢ Modify a sample program (provided by STEP 7) for use with WinLC and then

download the program to WinLC.

e Create a process form for the sample program, using the OLE container
(SoftContainer) and two of the SIMATIC control provided by Computing.

Figure 3-1 lists the order of the tasks required for using WinAC Basis with the

sample program.

Note

This example uses a hardware configuration that does not configure distributed 1/0
for WinLC. When you configure WinLC to control a process, you must also

configure the distributed I/O for the PROFIBUS subnet.

Using WinAC Basis with a Sample Program

Start the WinLC controller (Section 3.2)

v/ | | Connect STEP 7 to WinLC (Section 3.3)

Use STEP 7 to prepare a sample program (Section 3.4):

® Create the hardware configuration
® Copy the logic blocks
* Download the program to WinLC

¢ Use Computing to create a process form:

® Create the process form (Section 3.5)

® Configure the Button controls (Section 3.7)

® Configure the connections in the Data control (Section 3.6)

¢ Access the sample program (Section 3.8):
® Set WinLC to RUN mode

® Connect the process form to WinLC

® Turn on the input for the program

Figure 3-1  Tasks for Using WinAC Basis with a Sample Program
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In order to perform the tasks described in this chapter, you must have installed the
following software packages:

e WInLC: provides the controller that will run the sample program. WinLC is
installed as part of the Setup program for WinAC Basis. (Refer to Chapter 2 for
information about installing WinAC Basis.)

e Computing: provides the container and the ActiveX controls for creating the
process form that will access the program running on WinLC. Computing is
installed as part of the Setup program for WinAC Basis. (Refer to Chapter 2 for
information about installing WinAC Basis.)

e STEP 7: provides the sample program and the tools for creating the hardware
configuration for WinLC. Refer to the documentation for STEP 7 for information
about installing STEP 7.The recommended version of STEP 7 is STEP7 V5.0
SP3 or higher, but WinLC can be used with earlier versions of STEP 7.

3.2 Starting the WinLC Controller

To start WinLC, select the Start » SIMATIC » PC Based Control » Windows
Logic Controller menu command from the Windows NT Start menu. As shown in
Figure 3-2, the CPU panel of WinLC opens. You use this CPU panel to control the
operations of WinLC.

File CPU Help Click to display or hide the Tuning

panel
SIEMENS

PS

l ON Click the RUN, RUN-P, or STOP
| button to change the CPU
operating mode

EXTF | _| Status indicators display the
BUSE SIEEL status of the CPU (WinLC)

FRCE

RUN

STOP | MRES

Figure 3-2  Starting the WinLC Controller
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3.3

Going On-line to WIinLC with STEP 7

For this “Getting Started” example, you will be downloading a sample program
from the STEP 7 programming software to WinLC. In order for STEP 7 to
download this program, you must establish communications to WinLC. Redirecting
communications from MPI as done in earlier versions of WinLC is no longer
supported or available. Follow the procedure below that is appropriate for your
computer setup.

Connecting STEP 7 to WIinLC on the Same Computer

3-4

Use the following procedure to configure STEP 7 for communicating with WinLC
on the same computer:

1. From WinLC open the interface tool as follows: (CPU » Setting the PG/PC
Interface ).

2. Use these steps to configure STEP 7 as the local access point:

e From the “Access point of application” drop-down list, select STONLINE
(STEP 7) (Figure 3-3).

¢ From the “Interface parameter set used” drop down list, select PC Internal
(local) for the interface parameter).

STEP 7 is now configured to communicate with WinLC on this computer.

Set PG/PC Interface (V5.0) x|

Access Path |

Access Point of the Application:
| STONLINE (STEP 7) —>PC Internal (local)

(Standard for STEP 7)

Interface Parameter Assignment Used:

| PC Internal (local)

CP5611 (MPI)
CP5412A2(PROFIBUS)
TCP/IP—>3Com Etherlink Il Adapter Copy...

Delete

(communication with WinAC components in this
PG/PC)

Interfaces

Add/Remove: Select..
OK Cancel | Help |

Figure 3-3  Setting the PG/PC Interface for PC Internal (local)
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Connecting STEP 7 to WInLC on a Different Computer

As shown in Figure 3-4, you can connect STEP 7 on one computer to a WinLC on
a different computer. You must define the network connection over which STEP 7
and WinLC communicate by setting the PG/PC interface on the remote computer.

The remote computer must have STEP 7 installed, and the computer to which you
wish to connect must have WinLC installed.

Remote Computer WinLC Computer
STEP7 | WinLC [
| |
Setting the PG/PC Setting the PG/PC
Interface tool Interface tool
Network |
PC1 PC 2
HW  HW
PLC PLC
P &z —
: N

Figure 3-4  Connecting STEP 7 to WIinLC over a network
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3-6

Use the following procedure to configure STEP 7 for communicating with WinLC
on a remote computer:

1. Access the interface configuration tool through WinLC. Use (CPU » Setting the
PG/PC Interface (Figure 3-5).

Set PG/PC Interface (V5.0) x|

Access Path |

Access Point of the Application:

| S7ONLINE (STEP 7) —> CP5412A2(PROFIBUS)
(Standard for STEP 7)

Interface Parameter Assignment Used:

| CP5412A2(PROFIBUS)

PC Internal (local)

TCP/IP—>3Com Etherlink Il Adapter Copy...
Delete

(Parameter assignment of your PC adapter
for an MPI network)

Interfaces

Add/Remove: Select...
OK Cancel | Help |

Figure 3-5  Setting the PG/PC Interface

2. From the “Access Point of Application” drop-down list, select STONLINE
(STEP7?).

e For MPI communication, select the MPI interface, for example CP5611(MPI).

e For PROFIBUS-DP communication, select the PROFIBUS-DP interface, for
example, CP5412A2(PROFIBUS).

The WinLC’s PROFIBUS card must be properly configured through Setting the
PG/PC Interface before WInLC is visible to other PGs on the PROFIBUS-DP
network (S7TONLINE (STEP7) —><cardname> Profibus... . Click on the
Properties button. On the PROFIBUS tab, check “PG is the only master on the
bus.”

e For H1 communication, select your installed ethernet card, for example,
TCP/IP —> 3Com Etherlink 11l Ada... You must have the NCM Options
package for H1 communication and STEP 7 V5 SP3.

Windows Automation Center WinAC Basis Overview
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3.4

Note

NetPro cannot reconfigure the MPI or H1 addresses or the bus parameters of a
WinLC from a different computer. The required CP cards are not controlled by
WinLC. This can only be done via the local Setting the PG/PC Interface
application. The PROFIBUS node address and bus parameters can be
reconfigured remotely if a valid configuration is already in the WinLC. The WinLC
is the master of its own PROFIBUS 1/O card.

Downloading a Sample Program to WinLC

In order to download the sample program to WinLC, you must use the STEP 7
programming software to perform the following tasks:

¢ Open a sample project.

¢ Insert a PC station station into the sample project. (STEP 7 V5 SP3 supports
PC stations.)

¢ Create the hardware configuration for WinLC.
e Copy the program blocks for a sample program to the WinLC station.
¢ Download the sample program and hardware configuration to WinLC.

This section provides procedures for accomplishing these tasks. Refer to the
STEP 7 User Manual and the online help for the STEP 7 software for additional
information about using STEP 7.

Note

With STEP7 V5.0 SP3 or higher, WinLC is configured as a PC station. WinLC 3.0
has features that can only be used if configured in a PC station. In earlier versions
of STEP 7 without the service pack, you must use an S7300 station and configure
WinLC as version 2.0.

Windows Automation Center WinAC Basis Overview
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Opening a Sample Project

STEP 7 provides a sample project that you can use with WinAC Basis. Use the
following procedure to open a sample project:

1. Open the SIMATIC Manager by selecting the Start » SIMATIC » SIMATIC
Manager menu command from the Windows NT Start menu. (For STEP 7
version 4, use the Start » SIMATIC » STEP 7 » SIMATIC Manager menu
command.)

2. Select the File » Open menu command (or click on the “Open” icon) to display
the “Open” dialog box.

3. In the “Open” dialog box, select the “Sample Projects” tab.

oer

User projects 1 Libraries] Sampleprojectsj

Language:

Select the sample project “Zebra”
e STEP 7 version 5:

Name | Storage P5 ZEn01_09 _STEP7__Zebra
e STEP 7 version 4:
STEP7_ZEBRA

ZEnO1_04 STEP7__FDB_1-10 D:\SIEMEN
ZEn01_05 STEP7__LAD_1-9  D:\SIEMEN
ZEn01_06_STEP7__LD_1-10  D:\SIEMEN

ZEn01_07_STEP7_ Dist_IO DASIEXEN
ZEn01_08_STEP7__ Mix = SIEMENS\S7
ZEnO1 09 STEP7__Zebra D:\SIEMENS\S?

ZEn01_10_STEP7__Com_SFB  D:SIEMENS\S7
ﬁEnOl 11 STEP7 Com SFC1 D:\SIEMENS\SiZ
< >

Selected
User Projects
Libraries

Sample Projects Browse |

OK I Cancel | Help |

Figure 3-6  Opening the Sample Project (ZEn01_09 STEP7__ Zebra)
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4. As shown in Figure 3-6, scroll down the list of projects and select the “Zebra”
project:

— For STEP 7 version 5, select: ZEn0O1_09 STEP7__ Zebra

— For STEP 7 version 4, select: S7_ZEBRA

You may need to change the width of the “Name” column to view the full name.
5. Click on the “OK” button to open the sample project.

STEP 7 opens the sample project. See Figure 3-7.

SIMATIC Manager-ZEn01_09_STEP7__Zebra = [=][ x|

FEile Edit Insert PLC View Options Window Help
g@lﬂ glll ﬂ 5'% g_jﬁ& Q‘ ||< No Filter > [;l ﬂ@l ﬂ

&) ZEn01_09_STEP7__ Zebra

ZEnO1_09_STEP7_Zebra | [l SIMATIC 300 Station (1) T MPI(1)

Select the sample project “Zebra”

® STEP 7 version 5:
ZEn01_09_STEP7__ Zebra
STEP 7 version 4:
STEP7_ZEBRA

Press F1 for help. [ [

Figure 3-7  Sample STEP 7 Program (ZEn01_09_STEP7__Zebra)
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Inserting a PC Station into the Sample Project

Before you can create the hardware configuration for WinLC, you must insert a
station under your project. For STEP 7 Version 5, Service Pack 3, insert a PC
station. STEP 7 V5 SP3 models WInLC as a component in a PC station. (For
versions of STEP 7 prior to Version 5, Service Pack 3, you must insert a
SIMATIC 300 station.) Use the following procedure for inserting a station:

1. Select (click on) the project (ZEn01_09 STEP7__ Zebra).

2. Select the Insert » PC Station menu command to insert a station under the
project. (To insert a SIMATIC 300 station, select Insert » SIMATIC 300
Station .)

3. Select (click on) the station to display the hardware icon for the station.

Note

Certain System Data Blocks have a different structure depending on whether the
WinLC is configured in a 300 Station or a PC Station. You must inform WinLC
which station type to use via the Panel menu. In WInLC, select

CPU » Options » Customize and then select the Station Type tab. Select the
appropriate station type as shown in Figure 3-8. Failure to configure the correct
station type will cause upload/download errors.

( General [ Language |/ Station Type 1
L WinLC as a S7-300 Station
_ _ —— Select the appropriate station.
(¢ WIinLC as a PC Station

The PC Station Configuration is first available with Step7
V5.0 SP3 or greater. This setting prevents errors in uploads
and downloads.

OK Apply Cancel Help

Figure 3-8  Setting the Station Type
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Creating the Hardware Configuration for WinLC
Use the following procedure to create the hardware configuration for WinLC:

1. Select the PC station. If you have STEP 7 without the service pack, select
SIMATIC 300 station.

2. Double-click on the Hardware object to open the configuration tool of the
STEP 7 software (Figure 3-9).

SIMATIC Manager-ZEn01_09 STEP7__Zebra
File Edit Insert PLC View Options Window Help

J_|Jﬂ o|sle] &l 25 2o B [<No Filter >

€3 zEn01_09_STEP7 zebra | ] Configuration
—[ simATIC 300 Station (1)
SIMATIC PC Station (2)

1 %] =] a2

Press F1 for help. [ [ 7

Figure 3-9  Configuring the PC Station in the Sample Project

3. For a PC station:
— Double-click on the Configuration icon to open the hardware catalog.
— Select the 2nd slot in the PC display.

— Select SIMATIC PC Station » Controller from the catalog. Click on the
WinLC icon.

— Use the mouse to drag the “WinLC” object into slot 2 of the PC display

Windows Automation Center WinAC Basis Overview
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3-12

Note

With STEP7 V5.0 SP3 or higher, WinLC is configured as a PC station. WinLC 3.0
has features that can only be used if configured in a PC station. In earlier versions
of STEP 7 without the service pack, you must use an S7300 station and configure
WinLC as version 2.0. See step 4. below.

4. For a SIMATIC 300 station in a version of STEP 7 prior to V5 SP3:

— Select the Insert » Hardware Components menu command to open the
hardware catalog.

— Select and open the “SIMATIC PC Based Control 300/400 ‘" object.

— Double-click the “WiIinLC” object. If you do not have STEP 7 V5 SP3, be sure
to select WinLC V2.0.

5. In the “Properties — PROFIBUS Node DP Master” dialog box, click on the “New”
button to open the “Properties — New Subnet PROFIBUS” dialog box and enter
a PROFIBUS subnet or click OK to accept the default of PROFIBUS(1).

(Although you will not be using the subnet or configuring distributed 1/O for this
sample program, STEP 7 requires that you configure a subnet for WinLC.)

6. Click on the “OK” button to enter the default parameters for a PROFIBUS
subnet.

7. Select the PROFIBUS(1) subnet.

8. Click on the “OK” button to enter the default subnet and address and to close
the “Properties — PROFIBUS Node DP Master” dialog box. WinLC V.3.0
appears as the module in slot 2 of the rack.

9. Select the Station » Save and Compile menu command to create the sample
hardware configuration for WinLC.

STEP 7 generates the SDBs for the hardware configuration. Exit the Hardware
Configuration tool.
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Copying the Sample Program to the WIinLC Station

The original station in the Zebra project contains the logic blocks (OB1 and FC1) of
the sample user program. You will copy these blocks to the WinLC station that you
just created and configured. Use the following procedure to copy the sample
program:

1. Open the hierarchy for the SIMATIC 300 station program:

— Double-click on: SIMATIC 300-Station(1)

— Double-click on: CPU314(1)

— Double-click on: S7-Program(1)

— Double-click on: Blocks
2. Select the logic blocks of the 300 station program (OB1 and FC1).
3. Select the Edit » Copy menu command to copy these logic blocks.
4. Open the hierarchy for the PC station program:

— Double-click on: SIMATIC PC Station(1)

— Double-click on: WinLCV3.0

— Double-click on: S7-Program(2)

— Double-click on: Blocks

5. Select the Edit » Paste menu command to paste the logic blocks (OB1 and
FC1) into the PC station program.

SIMATIC Manager-ZEn01_09_STEP7__Zebra [ =[x}
File Edit Insert PLC View Options Window Help

D] Slole) sl 2 oo B Gl <vorer w =] x|

&) ZEn01_09_STEP7__ Zebra

=) zEn01_09_STEP7_zebra |1 SystemData | £3F 0B1  {J FC1
5. PC station

Copy OB1 and FC1 from the PC station
to the “PC Station” station (WinLC)

Press F1 for help. [ [

Figure 3-10 Pasting the Sample Logic Blocks into the WinLC Program (PC Station)
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Downloading the Sample Program

After you copy the logic blocks to the PC station, you can download the program to
WinLC. Use the following procedure to download the sample program:

1. Select the “Blocks” folder in the SIMATIC PC station.
2. Select the menu command PLC » Download or click on the download button.

3. When prompted to download the hardware configuration, click on the “OK”
button.

STEP 7 downloads the sample program and the sample hardware configuration to
WinLC.

SIMATIC Manager-ZEn01_09_STEP7__Zebra [ =[x}

File Edit Insert PLC View Options Window Help

Dlﬁlﬁlﬂl Ellll & ol o oEEE ||<NOFilter> uﬂm@]ﬂl

EH=) ZEno1_09_STEP7_Ze T ot Orct  vaTL
8. SIMATIC PC Station

Download button

Select the “Blocks” icon for the “PC
Station” station (WinLC) and click on the
“Download” button

Press F1 for help. [ [ 4

Figure 3-11  Downloading the Sample Program
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3.5 Using the Computing SoftContainer to Create a Process Form

Computing provides a SoftContainer, which is an OLE container for ActiveX
controls. Using the SoftContainer, you can create process forms for accessing the
control engine (such as WinLC).

The toolbar of the SoftContainer contains icons for the SIMATIC controls provided
by the Computing software. These icons allow you to insert these controls easily
onto the process form. You can also add other ActiveX controls to the process
form (and to the toolbar of the SoftContainer).

Opening a Process Form

To open the SoftContainer and the default process form, select the Start »
Simatic » PC Based Control » SIMATIC Computing Softcontainer menu
command from the Windows NT Start menu. (You can also double-click on the
icon for Computing.)

Figure 3-12 shows the SoftContainer with the default process form (S7Softl).

Select the File » Save As... menu command to display the “Save As” dialog box.
Rename the process form to Traffic_Lamp  and save the process form.

=[=]x]

[E] SoftContainer —[S7Soft1]
File Edit View Mode Options Window Help

REEEEERS n oD ER R
]
&ssonw 7 N@H

Icon for inserting a Icon for inserting a
Data control Button control

Toolbar

An empty process form
(named S7Softl)

|
Ready |Design | | A

Figure 3-12  SoftContainer with the Default Process Form
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Inserting SIMATIC Controls onto the Process Form

3-16

For this example, you insert four SIMATIC controls: a Data control and three
Button controls. The Data control connects the Button controls to WinLC, and the
Button controls access memory locations (or “variables”) in WinLC.

Use the following procedure to insert the controls onto the process form:
1. As shown in Figure 3-13, insert a Data control:

— Click on the icon for the Data control.

— Move the cursor to the process form.

— Click the left mouse button to insert the Data control onto the process form.

[=E] SoftContainer — [Traffic_Lamp] !EE
File Edit View Mode Options Window Help

Df{u] [xf=(e] [Sf2]] [ ]

Traffic_Lamp

Select the icon for the Data
control from the toolbar.

The arrow pointer changes to a
cross-hair pointer within the
container.

Click the left mouse button to
insert the control.

Ready |Design |

Figure 3-13 Inserting a SIMATIC Data Control from the Toolbar
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2. As shown in Figure 3-14, insert three Button controls onto the process form:
— Click on the Button icon on the toolbar.
— Move the cursor to the process form.

— Click the left mouse button to insert a Button control (Buttonl) onto the
process form.

Repeat to insert the other two Button controls (Button2 and Button3).

[E] SoftContainer — [Traffic_Lamp]

File Edit View Mode Options Window Help

REEFEE RS m N RS E )|

Insert three Button controls

Buttonl

|
Ready |Design | | | A

Figure 3-14 Inserting SIMATIC Button Controls
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3.6 Configuring the Connections for the Process Form

The SIMATIC controls provide dialog boxes for configuring the properties for the
control. In this example, you will use the “Properties” dialog box of the Data control
to perform the following tasks:

e Selecting the control engine (in this example, WIinLC)

¢ Assigning the variables (memory addresses) in the control engine to properties
of the ActiveX controls (in this example, the Button controls) in the process form

Accessing the “Properties” Dialog Box for the Data Control

Use the following procedure to open the “Properties” dialog box for the Data
control:

1. If the Data control in not already selected, select (click on) the Data control
(S7Datal).

2. As shown in Figure 3-15, double-click on the Data control (or click the right
mouse button to display a pop-up menu and select the S7Datal Properties
menu command) to display the “Properties” dialog box for the Data control.

[2E] SoftContainer — [Traffic_Lamp] !E E

FiIe Edit View Mode Options Window Help

General ] Englne] Connectlons] Events] Name ]

AutoConnect:

AutoConnectTimeout(ms): | 100

Default Update Rate (ms): | 100
Default Dead Band: | 0
;I Show Error Boxes:

—

Double-click on the Data control

Cancel | Apply Help

Figure 3-15 Accessing the “Properties” Dialog Box for the Data Control

Windows Automation Center WinAC Basis Overview
3-18 C79000-G7076-C219-03



Getting Started with WIinAC Basis

Configuring the Data Control to Connect to WinLC
Use the following procedure to select WinLC as the control engine:

1. In the “Properties” dialog box for the Data control, select (click on) the “Engine”
tab to display the options for selecting the control engine. See Figure 3-16.

2. Select (click on) the “Direct Connect” option.
3. In the “Control Engine” field, enter: WinLC
4. Click on the “Apply” button to configure the Data control to connect to WinLC.

Note

Clicking on the “Apply” button enters the changes you have made in the dialog
box, but keeps the dialog box open. Clicking on the “OK” button enters the
changes and closes the dialog box. For this example, keep the dialog box open for
the following procedures.

Siemens SIMATIC DataControl Properties n

General | Engine ] Connections ] Events | Name| Select the option for a direct
connection

( Connect via Tag Source

Tag Source

Browse

(¢ DirectConnect

Enter winLC as the control engine
PC Name

Control Engine anC | I
Click on the “Apply” button

/ |
OK | Cancel | Appiy | Help |

Figure 3-16 Connecting the Data Control to WinLC
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Assigning the Variables in the Control Engine to the Button Controls

3-20

You use the “Properties” dialog box for the Data control to connect the other
controls to memory locations in the control engine (WinLC). You do this by
assigning a variable (memory location) to a property of the control. Use the
following procedure to assign variables in WIinLC to the Button controls:

1.

2.

In the “Properties” dialog box for the Data control, select (click on) the
“Connections” tab.

If the controls and properties are not already displayed, expand the hierarchy
for S7Datal. See Figure 3-17.

Siemens SIMATIC DataControl Properties n

General ] Engine] Connections] Events} Name ]
Controls: Assigned Variable:
S7Softl A |
{l— S7Datal Browse... |
[+] ™

Button2
Button3

Click on the “plus” sign (or double-click on
the Data control) to display the
connections for the Button controls.

J Expand the hierarchy for the controls to
access the individual properties.

Add... Delete| Eilter... | T A

OK | Cancel | Apply Help |

Figure 3-17  Accessing the Connections for the SIMATIC Controls

3.

If the properties for Buttonl1 are not already displayed, expand the hierarchy for
Buttonl and select the Value property.

You can filter the properties to display only the Value property:

— Click on the “Filter” button to display the “Property Filter” dialog box and click
on the “Add” button to display the “Add” dialog box.

— Enter the following text in the “Add a new property” field: Value

— Click on the “OK” button to add the Value property to the filter and to close
the “Add” dialog box.

— Click on the “OK” button to add the Value property to the filter and to close
the “Property Filter” dialog box.

— Select (click on) the “Apply filter to properties” option to display only those
properties in the filter.

With the Value property for Button0.0n1 selected, enter Q0.0 in the “Assigned
Variable” field See Figure 3-18.
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5. Click on the “Apply” button to enter the assigned variable.

Siemens SIMATIC DataControl Properties n

General ] Engine] Connections] Events] Name ]

Controls: Assigned Variable:
E— S7Datal - 0.0
f]_ Buttonl —l | g

—— Alignment

- Ap%earance Browse... |
—— Enabled

—— Border Style

—— FalseCaption

— FalseColor

—— FalsePicture
— Font
—ForeColor

Select the Value property for Buttonl.

— Locked
—— PushButton

Enter Q0.0 in the “Assigned Variable”
field.

— = Automatic

: Click on the “Apply” button.
Add... Delete| Eilter... | Apply

OK | Cancel | Apply Help

Figure 3-18 Assigning the Variable for Buttonl

6. If the properties for Button2 are not already displayed, expand the hierarchy for
Button2 and select the Value property.

7. With the Value property for Button2 selected, enter Q0.1 in the “Assigned
Variable” field. See Figure 3-19.

8. Click on the “Apply” button to enter the assigned variable.

Siemens SIMATIC DataControl Properties n

General ] Engine] Connections] Events] Name ]

Controls: Assigned Variable:
H—]— Button2 ;l | q0.1
Enabled Browse... |
Value
d]— Button3
Select the Value property for Button2.
Enter Q0.1 in the “Assigned Variable”
B field.
1 Aut :
: HOMA  Click on the “Apply” button.
Add... Delete | Eilter... | Ap

OK | Cancel | Apply Help

Figure 3-19  Assigning the Variable for Button2
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9. If the properties for Button3 are not already displayed, expand the hierarchy for
Button3 and select the Value property.

10.With the Value property for Button3 selected, enter i0.0 in the “Assigned
Variable” field. See Figure 3-20.

11.Click on the “Apply” button to enter the assigned variable.

You have finished configuring the properties of the Data control. Click on the “OK”
button to close the “Properties” dialog box.

Siemens SIMATIC DataControl Properties n

General ] Engine] Connections] Events} Name ]

Controls: Assigned Variable:

H]— Button3 ;l | i0.0

|: Enabled
Value

d Automa
Add... Delete| Eilter... | [v Ap

Browse... |

Select the Value property for Button3.

Enter 1 0.0 in the “Assigned Variable”
field.

Click on the “Apply” button.

OK | Cancel | Apply Help

Figure 3-20 Assigning the Variable for Button3
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3.7

Configuring the Button Controls on the Process Form

You use the “Properties” dialog box for the Button control to define the appearance
of the control. For this example, you will configure the properties for two of the
Button controls:

e Button control 1 (Buttonl):
— When Q0.0 is off (false), the control is gray and has no caption.
— When Q0.0 is on (true), the control is red and the caption displays: STOP!
— If you click on this control, the value of the variable does not change.

e Button control 2 (Button2):
— When Q0.1 is off (false), the control is gray and has no caption.
— When Q0.1 is on (true), the control is green and the caption displays: GO!
— If you click on this control, the value of the variable does not change.

Button control 3 (Button3) remains enabled: when you click on this control, the
value of 1 0.0 changes in WinLC.

Configuring the First Button Control (Button1)

The “Properties” dialog box for the control allows you to change the label and the
color of the control for the different states of the assigned variable: True = 1 (on)
and False = 0 (off). You also use this dialog box to disable the control from writing
new values to the control engine.

Use the following procedure to configure the properties of the first Button control
(Button1):

1. Select (click on) the Button control 1 (Buttonl).

2. Double-click on Buttonl (or click the right mouse button to display a pop-up
menu and select the Button1 Properties menu command) to display the
“Properties” dialog box for the Button control.

3. Click on the “General” tab of the “Properties” dialog box to display the labels
(captions) for the control.
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4. As shown in Figure 3-21, modify the labels (captions) for the control:
— In the “TrueCaption” field, replace the text with the new caption: STOP!
— In the “FalseCaption” field, delete the text and leave this field blank.

5. Click on the check box for the Enabled property and deselect this property. See
Figure 3-21.

(When the control is enabled, clicking on the control changes the value of the
assigned variable and writes the changed value to the control engine. When
you disable the control, clicking on the control does not change the value.)

6. Click on the “Apply” button to enter these changes to Button1.

Siemens_SIMATIC_UserControls.

el CLCUES  Enter STOP! in the “TrueCaption” field.

General] Picture| Font | Color | Name | | Delete the entry in the “FalseCaption”

field.

Alignment: = ‘ = =

TrueCaption: | ON

FalseCaption: | OFF

Style: | 1 - wGrapria! | [Vl Enabled:

Appearance: [0—wFlat Deselect (cleqr the check box) the
“Enabled” option.

BorderStyle: | 0—wNone T PushButton

StretchMode: |l—WResizeImage

OK | Cancel | Apply | Help

Figure 3-21  Configuring the Caption for Buttonl1 (Button Control 1)
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7. Click on the “Color” tab of the “Properties” dialog box to display the color
assignments for the two states of the control (True or False).

8. Select (click on) FalseColor in the “Properties” box and click on the color Gray
in the “Color Palette” box. See Figure 3-22.

Siemens_SIMATIC_UserControls.Button Properties

Select the “FalseColor” property

General| Picture | Font | Color ] Name

Properties: Z3lor Set:
7 | Standard Colors

FalseColor
ForeColor
TrueColor

Color Palette:

Green
Magenta

Red

Edit Custom Color.>

Click on the “Gray” color

OK |  Cancer=——mp———

Figure 3-22  Configuring the False Color for Button1 (Button control 1)

9. Select (click on) TrueColor in the “Properties” box and click on the color Red in
the “Color Palette” box. See Figure 3-23.

10.Click on the “Apply” button to enter the changes, and click on the “OK” button to
close the “Properties” dialog box.

Siemens_SIMATIC_UserControls.Button Properties

General| Picture | - Font | Color ] Name | Select the “TrueColor” property
Properties: Color Set:
FalseColor zard Colors

ForeColor

Click on the “Red” color

Gray

Green

Magenta

Edit Custom Color... H

OK | Cancel | Apply | Help |

Figure 3-23  Configuring the True Color for Buttonl (Button control 1)
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Configuring the Second Button Control (Button2)

The second Button control is connected to QO0.1, which is the “Walk” light for the
PC Station program. Use the following procedure to configure the properties of the
second Button control (Button?2):

1.
2.

Select (click on) the Button control 2 (Button2).

Double-click on Buttonl (or click the right mouse button to display a pop-up
menu and select the Button2 Properties menu command) to display the
“Properties” dialog box for the Button control.

. Click on the “General” tab of the “Properties” dialog box to display the labels

(captions) for the control.

. As shown in Figure 3-24, modify the labels (captions) for the control:

— In the “TrueCaption” field, replace the text with the new caption: WALK

— In the “FalseCaption” field, delete the text and leave this field blank.

. Click on the check box for the Enabled property and deselect this property. See

Figure 3-24.

. Click on the “Apply” button to enter these changes to Button2.

Siemens_SIMATIC_UserControls.Button Properties

General] Picture| Font | Color | Name | | Delete the entry in the “FalseCaption”
field.
Alignment: ’g ‘ = =
TrueCaption: | WALK
FalseCaption: |
Style: | 1-wGraphice! [Z_ Enahled:
Appearance: | 0 —wFlat PEenS;tl)le;(;”(((:)ls:?(;rTe check box) the
BorderStyle: | 0—wNone " PushButton
StretchMode: | 1-wResizelmage

Enter WALKin the “TrueCaption” field.

OK | Cancel | Apply | Help |

Figure 3-24  Configuring the Caption for Button2 (Button Control 2)

7.

3-26

Click on the “Color” tab of the “Properties” dialog box to display the color
assignments for the two states of the control (True or False).

. Select (click on) FalseColor in the “Properties” box and click on the color Gray

in the “Color Palette” box. See Figure 3-25.
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Siemens_SIMATIC_UserControls.Button Properties

Select the “FalseColor” property

Color Set:
| Standard Colors

Color Palette:

Green

Magenta

Red

]

Irm

dit Custom Color...

Click on the “Gray” color

OK | Cancel | Apply | Help

Figure 3-25 Configuring the False Color for Button2 (Button control 2)

9. Select (click on) TrueColor in the “Properties” box and click on the color Green

in the “Color Palette” box. See Figure 3-26.

10.Click on the “Apply” button to enter the changes, and click on the “OK” button to

close the “Properties” dialog box.

Siemens_SIMATIC_UserControls.Button Properties

General| Picture | Font | Color ] Name |

Properties: Color Set:
FalseColor | Standard Co|

Select the “TrueColor” property

ForeColor

5

Edit Custom Color.

=
-]
|

Click on the “Green” color

OK | Cancel | Apply | Help

Figure 3-26  Configuring the True Color for Button2 (Button control 2)
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3.8

Running the Process Form with the Sample Program

For this example, you have performed the following tasks:

e Started WIinLC and redirected MPI communications to WinLC

¢ Modified the sample program and downloaded the program to WinLC
e Created the process form

You are now ready to run the sample program and access the data with the
process form.

Setting WinLC to RUN mode

3-28

To start the execution of the sample program, you set WinLC to RUN mode:
1. Display the CPU panel for WinLC.

2. As shown in Figure 3-27. click on the “RUN” or “RUN-P” button to set WinLC to
RUN mode. (You can also use the CPU » RUN or CPU » RUN-P menu
command to change the operating mode of WinLC.)

File CPU Help

SIEMENS

Click on the “RUN" or “RUN-P” button to set the
operating mode of WinLC to RUN

EXTF STOP ()

BUSF1
BUSF2
FRCE
RUN

STOP | MRES

Figure 3-27  Setting WIinLC in RUN mode
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Connecting the Process Form to the Sample Program

When you switch the container from “Design” mode to “Run” mode, you connect
the process form to WinLC.

Use the following procedure to connect the process form with the sample program
being executed by WinLC:

1. As shown in Figure 3-28, select the Run icon or use the Mode » Run menu
command to place the SoftContainer in Run mode and connect the process
form to WinLC.

2. As shown in Figure 3-28, click on the button labelled “OFF” (which is Button
control 3, or Button3) to start the cycles for the PC Station program.

Button control 1 (Buttonl) and Button control 2 (Button2) change color to reflect
the status of the outputs.

3. To disconnect the process form from WinLC, select the Design icon or use the
Mode » Design menu command to return the SoftContainer to Design mode.

[E] SoftContainer — [Traffic_Lamp] !En
File Edit View Mode Options Window Help

NEFIHFERE §|?|‘ ‘ DEEEERIEN

. Click on the Run button to
Traffic_Lam switch the container from
Design mode to Run mode.

Click on Button control 3
(Button3) to toggle input 1 0.0 on
and off.

| | | 7
Figure 3-28 Placing the SoftContainer into Run Mode

Ready | Design
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Using the Tool Manager

Chapter Overview

The Tool Manager provides quick access to the programs on your computer. The

Tool Manager is configurable: you can insert a shortcut icon for any of your

programs into the tray. You can then access that program from the Tool Manager.

Section Description Page
4.1 Creating a Toolbar for Easy Access to Your Programs 4-2
4.2 Using the Tool Manager without a Mouse 4-4
4.3 Changing the Language Setting for WinAC 4-6
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4.1

Creating a Toolbar for Easy Access to Your Programs

Figure 4-1 shows the Tool Manager and its shortcut icon. You can change the size
of the Tool Manager. You can also choose to display the Tool Manager either
horizontally or vertically.

Shortcut icon Tool Manager

Tool Manager

nlATIC

Tool Manager

S7 logo empty tray

Figure 4-1  Tool Manager

Inserting Icons into the Tool Manager

4-2

There are two methods for inserting shortcut icons into the Tool Manager:

¢ Using the Windows Explorer to “drag and drop” the program or shortcut into the
Tool Manager

¢ Using the Insert menu command of the Tool Manager (see Figure 4-2)

Note

Some shortcuts, such as the Panel application of the WinLC, pass command line
(cmdline) parameters. To insert a shortcut for these programs, you must use
Windows Explorer to drag and drop the shortcut to the Tool Manager. Using the
Insert menu command results in the command line parameter being lost.

Use the following procedure to drag and drop icons into the Tool Manager:

1. Open the Windows Explorer by selecting the Start » Programs » Windows NT
Explorer menu command.

2. Open the Tool Manager by selecting the Start » SIMATIC » PC Based
Control » Tool Manager menu command (or by double-clicking on the shortcut
icon for the Tool Manager).

3. In the Windows Explorer, select the program or shortcut whose icon is to be
inserted into the Tool Manager.
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4. Holding down the left mouse button, drag the program or shortcut to the tray of
the Tool Manager.

5. Release the left mouse button to drop the icon into the Tool Manager.

Tool Manager

estore
Icon

Click the right button of
the mouse to display the
Tool Manager menu

Horizontal
Vertical

Insert

Select Language

>

Select the Insert command to

Always On Top
Full Path Name

display a browser that allows
you to insert program icons

Fit to screen
Auto Size

into the Tool Manager

Rebuild Tool Manager

Help

F1

Exit

Figure 4-2

Inserting Icons into the Tool Manager

Use the following procedure to insert icons into the Tool Manager:

1. Open the Tool Manager by selecting the Start » SIMATIC » PC Based

Control » Tool Manager menu command.

2. Click the right button of the mouse to display the menu options for the Tool

Manager. See Figure 4-2.

3. Select the Insert menu command to display a browser for selecting program

icons.

4. Select the icons from the browser and confirm.
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Customizing the Display Options for the Tool Manager

4.2

4-4

You can use the mouse to resize the Tool Manager. You can also use the options
menu (shown in Figure 4-2) to further customize the Tool Manager:

Select either the Horizontal or Vertical menu command to choose the
orientation for the Tool Manager.

Select the Always On Top menu command to always display the Tool Manager
on top of the application, instead of being hidden behind an open application.

Select the Auto Size menu command to automatically size the Tool Manager to
the width (or height) of the screen.

Select the Full Path Name menu command to display the path name for the
shortcut icons.

Select the Rebuild Tool Manager menu command to update (refresh) the
icons for existing program or to remove the icons for programs that have been
removed or deleted.

Pressing the F1 key or selecting the Help menu command displays the online help
for the Tool Manager.

Using the Tool Manager without a Mouse

Table 4-1 lists the specific keyboard operations for various key combinations. You
can use the keyboard to access all of the functions of the Tool Manager:

Pressing the F1 key displays the online help for the Tool Manager.

Pressing the Tab key changes the focus between the S7 logo and the shortcut
icons. If the Tool Manager is running, pressing the ALT + Tab keys displays the
Tool Manager.

Pressing the Return key when a shortcut icon has the focus starts the
associated program.
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Table 4-1 Keyboard Operations for the Tool Manager

Key Combination Description

Tab Displays the Windows Taskbar: tab to the S7 logotype to
give Tool Manager the focus

Alt + Tab Alternates the focus between the S7 logotype and the
selected shortcut icon

When focus is on the S7 logotype...

Page Up or Page Down Displays the Tool Manager in a horizontal or vertical
orientation
Left arrow or Right arrow Displays the application menu when the Tool Manager is

oriented vertically

Shift + (Left or Right arrow) Move the Tool Manager left or right

Cntl + (Left or Right arrow) Moves the Tool Manager to the left or right edge of the
screen

Alt + (Left or Right arrow) Stretches or shrinks the Tool Manager when the Tool
Manager is oriented horizontally (Not available in Auto
Size mode)

Up arrow or Down arrow Displays the application menu when the Tool Manager is
oriented horizontally

Shift + (Up or Down arrow) Moves the Tool Manager up or down

Cntl + (Up or Down arrow) Moves the Tool Manager to the top or bottom edge of the
screen

Alt + (Up or Down arrow) Stretches or shrinks the Tool Manager when the Tool
Manager is oriented horizontally (Not available in Auto
Size mode)

Enter Minimizes or restores the Tool Manager

When focus is on a shortcut icon...

Home or End Sets focus to the first or last shortcut icon

Enter Runs the application of the shortcut icon that has focus
Delete Deletes the shortcut icon that has focus

Left arrow or Right arrow Tool Manager is horizontal: Moves the cursor left or right

Tool Manager is vertical: Displays the icon menu

Up arrow or Down arrow Tool Manager is horizontal: Displays the icon menu

Tool Manager is vertical: Moves the cursor left or right
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4.3

4-6

Changing the Language Setting for WinAC

The Tool Manager provides a menu command for changing the language setting
for all of the the WinAC software products. You can select between English,
French and German for the menus and dialog boxes of the WIinAC software (if all
languages were installed when you installed WinAC Basis).

Use the following procedure to change the language setting:

1. Open the Tool Manager by selecting the Start » SIMATIC » PC Based
Control » WinAC Toolmanager menu command (or by double-clicking on the
shortcut icon for the Tool Manager).

2. Click the right button of the mouse to display the menu options for the Tool
Manager. See Figure 4-3.

3. Select the Select Language menu command to display the menu for selecting
the language for WinAC. See Figure 4-3.

4. Select the language for WinAC.

5. Restart your applications to change the language for the menus and dialog
boxes for the WIinAC software.

Tool Mana\ger Click the right button of
T T the mouse to display the

Restore Tool Manager menu
Icon

Horizontal
Vertical
Insert
4
Select Language v Engish |
Always On Top French Se_lect the language for the
WinAC software products
Full Path Name German
Fit to screen Italian
Auto Size Spanish

Rebuild Tool Manager

Help F1

Exit

Figure 4-3  Changing the Language for WinAC
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Distributed Component Object Model

(DCOM)

Chapter Overview

A

WinAC allows you to communicate across networks using Microsoft's Distributed
Component Object Model (DCOM). You can use DCOM to integrate distributed
applications by way of a network. A distributed application consists of multiple
processes or different computers that cooperate to accomplish a single task.

DCOM is a set of Microsoft concepts and program interfaces in which client
program objects can request services from server program objects on other
computers in a network. The Component Object Model (COM) provides a set of
interfaces that allow clients and servers to communicate within the same computer
(running Windows 95 or Windows NT).

Section Description Page
Al Using DCOM to Expand the Capabilities of WinAC A-2
A.2 Connecting to a Specific Control Engine over DCOM A-4
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Al Using DCOM to Expand the Capabilities of WinAC

You can run the components of WinAC on a stand-alone computer, as shown in
Figure A-1. In this model, this computer provides the complete control system.

Third-party control

Siemens Button Control

Siemens Edit control

I [

| Siemens Label control
| Siemens Slider control

DCOM
Siemens S7 Data control Components

\

MPI server
PC1
1 1
| |
! !
e

WinLC CPU 416-2 DP ISA MPI Card

MPI=n

=

Figure A-1  Using WinAC Components with DCOM on a Single Computer

[—— —]
——

[ ’—‘DE:

You can also utilize Microsoft's DCOM technology to create a network of
computers that cooperate to provide the control system for a machine or process.
Figure A-2 shows how one computer running an application that uses ActiveX
controls (from Computing) can use DCOM to communicate with a different
computer that uses WinLC (or other PLCs) to control a process.

The NT operating system provides a configuration tool (dcomcnfg) for setting up
your DCOM security. Use this tool to configure the server and client computers.
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| Third-party control :
| Siemens Button Control |—
| Siemens Label control l—
| Siemens Edit control |—
| Siemens Slider control
| Siemens S7 Data control |
DCOM
Components | —
— I
Network
PC1 I
\]
_WinAC DCOM Note:
configurationtool (=  Components STEP 7 cannot connect to the
MPI server over DCOM
MPI server |
T T
| |
PC 2
WinLC CPU 416-2 DP ISA MPI Card
1 1
I —
I
' o o ;
u)
MPl=n
Server 1—? }

Figure A-2  Using WIinAC with Several Computers over DCOM

Note

You install the WinAC authorization on the server computer; you install the
SIMATIC Computing authorization on the client computer. If you want to run

SIMATIC Computing on a PC other than the PC running WIinLC, then you must

purchase SIMATIC Computing standalone. For more information about installing

an authorization, see Section 2.4.
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A.2

A4

Connecting to a Specific Control Engine over DCOM

As shown in Figure A-3, you can use the SIMATIC Data control to connect your
program to a control engine residing on a different computer.

Note

When you configure the SIMATIC Data control to connect directly to a single
control engine, you cannot connect a tag file. This means that you cannot use
symbol names for the variables in the control engine.

To use symbol names, select the option for connecting via a tag source and
browse to a tag file that contains symbols for only one control engine. Use the
TagFile Configurator for creating tag files and connecting to control engines over
DCOM. See the Computing User Manual for information about using STEP 7 and
the TagFile Configurator.

| Third-party control

| Siemens Button Control

| Siemens Label control

| Siemens Edit control

B SR N [ I

| Siemens Slider control

DCOM

| Siemens S7 Data control I

PC1

WinLC [

Figure A-3  Connecting to a Specific Control Engine over DCOM
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OLE for Process Control (OPC) B

Chapter Overview

OLE for Process Control (OPC) provides a standard mechanism for
communicating to numerous data sources, whether they be the devices on your
factory floor or a database in your control room. You can use the OPC server
provided with the Computing software to communicate with the control engine (for
example, WIinLC or CPU 416-2 DP ISA) and provide access to the process data.
Computing provides an OPC server that allows any OPC client application to
access data in the control engine; Computing does not provide any OPC client
application.

Computing implements the mandatory interfaces, as defined in the version 2.0
specification from the OPC Foundation, and also implements the IOPC
BrowseServerAddressSpace interface.

OPC is based on the OLE/COM technology from Microsoft. For more information
about OPC, refer to the OPC specification OLE for Process Control Data Access
Standard, version 2.0 from the OPC Foundation.

Section Description Page

B.1 Using OPC with Computing B-2
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OLE for Process Control (OPC)

B.1

B-2

Using OPC with Computing

OPC allows you to access data from the plant floor and integrate the data into your
existing business systems. You can use off-the-shelf tools (such as SCADA
packages, databases, spreadsheets) to assemble a system that meets your
needs. As shown in Figure B-1, OPC provides an open and effective
communication architecture which concentrates on data access and not the types
of data.

Application Application
X Y

OPC Client Interface OPC Client Interface

< : : -

y

OPC Server Computing OPC Server OPC Server
A OPCServer.WinAC c

Figure B-1  Applications Working with Many OPC Servers

Your OPC client connects to the OPC server object provided by Computing. This
connection allows you to create and manipulate OPC group objects, which
organize the data to be accessed. You can activate or deactivate a group as a unit,
or you can “subscribe” to the list in a group of items so that you can be notified
when the data change. (A group is a collection of items.) Figure B-2 shows the
connection from the OPC client application through WIinAC to the process data.

Third-party OPC client application

| Computing: OPCServer.WinAC |
WinAC |

| Control engine |

| Distributed 1/0 |

Figure B-2  Using the OPC Server to Access Your Process Data

To access the OPC server provided by the Computing software, browse to:
OPCServer.WIinAC
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Accessing memory areas (S7), OPC controls,
[B-2]

Accessing process data, OPC controls, [B-2]

Authorizing the WinLC software, transferring
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connecting to Computing,[B-2
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Component Object Model. See DCOM
Component Object Model (COM)
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Tool Manager,|[1-9) 4-1-4-7
Connecting to data via OPC,
Control engine
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OPC controls,|B-2]
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D
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Databases, sharing data via OPC,
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Display options for Tool Manager,

Distributed applications (DCOM)]| 1-1
[A-1-A-22

Distributed Component Object Model. See
DCOM
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(pcom)[ 1-1H1-9[A-1-A-22
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Getting started with WinAC, connecting STEP
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Getting started with WinAC Basis| 3-]
starting WinLC,
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Keyboard (with Tool Manager)
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Memor
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Monitoring and modifying data, OPC controls,
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Network communications, using DCOM,
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Off-the-shelf applications, OPC controls,
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OPC specification,
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OPC specification,
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Product overview, OPC (Ole for Process Third-party OCX, OPC controls,
Control),[B-2] Tool Manager[1-9[4-1-4-7
display options, |4-4
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S drag and drop,

S7 controllers, OPC controls,[B-2] ke rggg::j %022:22’5
Server object (OPC), y P
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SIMATIC 300 station, WIinLC I/O configuration, WIinAC

m connecting STEP 7 to WinLC
Specifications, OLE for Process Control, on a different computer,|3-5
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Starting WinLC,[3-3] pcom[1-1-f1-9[A-3-{A-4]
STEP 7 starting WinLC,

connecting to WinLC STEP 7
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downloading a sample program,
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Tool Manager, —4-7 WiInAC Basis, Getting started,
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Windows Logic Controller. See WinLC
T WinLC
accessed by OPC controls, [B-2]

Technical information, OLE for Process connecting to STEP 7’

Control,[B-1]
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To

SIEMENS ENERGY & AUTOMATION INC

ATTN: TECHNICAL COMMUNICATIONS M/S 519
3000 BILL GARLAND ROAD

PO BOX 1255

JOHNSON CITY TN USA 37605-1255

From

Name:

Job Title:

Company Name:
Street:
City and State:

Country:

Telephone:

Please check any industry that applies to you:

Automotive Pharmaceutical

Chemical Plastic
Electrical Machinery
Food

Instrument and Control

Pulp and Paper
Textiles
Transportation
Other

I [ I I U [ |

Non-electrical Machinery

I [ [ U [ N R

Petrochemical
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Remarks Form

Your comments and recommendations will help us to improve the quality and usefulness of our
publications. Please take the first available opportunity to fill out this questionnaire and return it
to Siemens.

Please give each of the following questions your own personal mark within a range from 1 (very
good) to 5 (very poor).

Do the contents meet your requirements?
Is the information you need easy to find?
Is the text easy to understand?

Does the level of technical detail meet your requirements?

NN

ok~ w0 Dd PR

Please rate the quality of the graphics and tables.

Additional comments:
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