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Safety Guidelines

This manual contains notices which you should observe to ensure your own personal safety, as well as to protect
the product and connected equipment. These notices are highlighted in the manual by a warning triangle and are
marked as follows according to the level of danger:

!
Danger

indicates that death, severe personal injury or substantial property damage will result if proper
precautions are not taken.

!
Warning

indicates that death, severe personal injury or substantial property damage can result if proper
precautions are not taken.

!
Caution

indicates that minor personal injury or property damage can result if proper precautions are not
taken.

Note

draws your attention to particularly important information on the product, handling the product, or to
a particular part of the documentation.

Qualified Personnel

Only qualified personnel  should be allowed to install and work on this equipment Qualified persons are defined
as persons who are authorized to commission, to ground, and to tag circuits, equipment, and systems in
accordance with established safety practices and standards.

Correct Usage

Note the following:

!
Warning

This device and its components may only be used for the applications described in the catalog or
the technical description, and only in connection with devices or components from other
manufacturers which have been approved or recommended by Siemens.

This product can only function correctly and safely if it is transported, stored, set up, and installed
correctly, and operated and maintained as recommended.

Trademarks

SIMATIC , SIMATIC NET   and SIMATIC HMI  are registered trademarks of SIEMENS AG.

Third parties using for their own purposes any other names in this document which refer to trademarks might
infringe upon the rights of the trademark owners.

We have checked the contents of this manual for agreement with the
hardware and software described. Since deviations cannot be pre-
cluded entirely, we cannot guarantee full agreement. However, the
data in this manual are reviewed regularly and any necessary cor-
rections included in subsequent editions. Suggestions for improve-
ment are welcomed.

Disclaimer of LiabilityCopyright � Siemens AG 2000 All rights reserved

The reproduction, transmission or use of this document or its
contents is not permitted without express written authority.
Offenders will be liable for damages. All rights, including rights
created by patent grant or registration of a utility model or design, are
reserved.

Siemens AG
Bereich Automatisierungs- und Antriebstechnik
Geschaeftsgebiet Industrie-Automatisierungssysteme
Postfach 4848, D-90327 Nuernberg

  Siemens AG 2000
Subject to technical change.
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Preface

Purpose of the Manual

This manual ”CFC for S7” provides you with the information you require to use the
CFC configuration tool in conjunction with CPUs in SIMATIC S7 programmable
controllers (PLCs).

For a complete description of CFC for other systems, you also require the
supplementary CFC descriptions for the particular system (for example, “CFC for
M7”, “CFC for SIMADYN D”)

How Sections for Specific Systems are Indicated

If sections, paragraphs or even individual sentences in this S7 manual relate solely
to S7 users, this is indicated by [S7] . This means that the information is relevant
only to S7 or is different in other systems. In this case, if you use a different PLC,
you will find the information you require in the manual for your specific system. 
If the [S7]  label is in a title, the entire section applies only to S7; if the label is at
the start of a paragraph, the paragraph is solely relevant to S7. In lists, the [S7]
label applies only to the particular list.

Audience

This manual is intended for personnel involved in configuring, commissioning, and
service.

Validity of the Manual

This manual is valid for CFC software version 5.2 and higher.

Standard

The CFC software is based on the international standard DIN EN 61131-3 (IEC
1131-3) for programming languages for programmable logic controllers.

Conventions

References to other documentation are indicated by numbers in slashes /.../.
Based on the number, you can check the full title of the documentation in the
References at the end of the manual.
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Further Support

If you have any questions about using the software described and cannot find an
answer here, in the online help, or in the ”readme” file, please contact the Siemens
representative in your area.

If you have any questions or comments on this manual, please fill out the remarks form
at the end of the manual and return it to the address shown on the form. We would
be grateful if you could take the time to answer the questions giving your own personal
opinion of the manual.

To help you to become familiar with working with PLCs, we offer a range of courses.
Please contact your regional training center or the central training center for more
information.

SIMATIC Customer Support Online Services

The SIMATIC Customer Support team offers you substantial additional information
about SIMATIC products via its online services:

• General current information can be obtained from:

– the Internet  under http://www.ad.siemens.de/simatic

• Current product information leaflets and downloads which you may find useful
are available:

– the Internet  under http://www.ad.siemens.de/simatic-cs

– via the Bulletin Board System  (BBS) in Nuremberg (SIMATIC Customer
Support Mailbox) under the number +49 (911) 895-7100.

To access the mailbox, use a modem with up to V.34 (28.8 Kbps) with
parameters set as follows: 8, N, 1, ANSI; or dial in via ISDN (x.75, 64 Kbps).

• You can find your local customer service representative for Automation & Drives
in our customer service representative data bank:

– in the Internet  under
http://www3.ad.siemens.de/partner/search.asp?lang=en
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SIMATIC Customer Support Hotline

Open round the clock, worldwide:

Johnson City

Nuremberg

Singapore

SIMATIC Hotline

Worldwide  (Nuremberg)

Technical Support

(FreeContact)

Local time: Mon.-Fri. 7:00 to 17:00

Phone: +49 (180) 5050-222

Fax: +49 (180) 5050-223

E-Mail: techsupport@
ad.siemens.de

GMT: +1:00

Worldwide  (Nuremberg)

Technical Support

(fee based, only with 
SIMATIC Card)

Local time: Mon.-Fri. 0:00 to 24:00

Phone: +49 (911) 895-7777

Fax: +49 (911) 895-7001

GMT: +01:00

Europe / Africa  (Nuremberg)

Authorization

Local time: Mon.-Fri. 7:00 to 17:00

Phone: +49 (911) 895-7200

Fax: +49 (911) 895-7201

E-Mail: authorization@
nbgm.siemens.de

GMT: +1:00

America  (Johnson City)

Technical Support and
Authorization
Local time: Mon.-Fri. 8:00 to 19:00

Phone: +1 423 461-2522

Fax: +1 423 461-2289

E-Mail: simatic.hotline@
sea.siemens.com

GMT: -5:00

Asia / Australia  (Singapore)

Technical Support and
Authorization
Local time: Mon.-Fri. 8:30 to 17:30

Phone: +65 740-7000

Fax: +65 740-7001

E-Mail: simatic.hotline@
sae.siemens.com.sg

GMT: +8:00

The languages of the  SIMATIC Hotlines are generally German and English, in addition, French, Italian and Spanish are
spoken on the authorization hotline.
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Essentials of CFC

Introduction

This chapter provides you with basic information about CFC, shows how it fits into
the STEP 7 software package, describes the block concept, and explains the steps
required from creating the project structure to testing the program.

For a description of installation, authorization, and starting up the CFC software,
refer to the readme file shipped with the CFC package.

1
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1.1 General

What is CFC?

CFC (Continuous Function Chart) is a graphic editor that can be used in
conjunction with the STEP 7 software package. It is used to create the entire
software structure of the CPU from ready-made blocks. When working with the
editor, you place blocks on function charts, assign parameters to them, and
interconnect them.

Interconnecting means, for example, that values are transferred from one output to
one or more inputs during communication between the blocks.

How the Package Works

In the CFC editor, you work with graphic tools: You select ready-made blocks from
the pool of blocks, drag them to the chart (that serves as your drawing board) and
then interconnect them using the mouse. You do not need to be aware of details
such as algorithms or the assignment of machine resources but can concentrate
solely on the technological aspects of your configuration.

The run-time properties of the blocks have default settings but these can be
adapted individually for each block. Since individual blocks or whole groups of
blocks can be copied or moved from chart to chart, you can save a considerable
amount of time. Interconnections between the blocks are retained.

Once you have created all the functions you require, you can create executable
machine code with a simple mouse click, download the code to the PLC, and test it
with the CFC test functions.

Blocks

You can take the blocks you require in CFC from block libraries or other projects or
you can create the blocks yourself.
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1.2 [S7] CFC in the STEP 7 Environment

SIMATIC Manager

The SIMATIC Manager is used for all PLCs as the graphic interface to coordinate
the tools and objects. The SIMATIC Manager manages tools and data and is used,
for example, for creating and modifying a project structure (CPU, CFC charts) and
to start the CFC Editor.

S7-3xx
S7-4xx

SIMATIC Manager

CFC
STEP 7 tool

WinCC

OS

Figure 1-1 CFC in the STEP 7 Environment

Further Components

Depending on your programmable controller, you can use further components, for
example different language packages for creating block types and tools for creating
input data for the CFC charts such as I/O data that you can reference from within
CFC.
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1.3 The CFC Chart

To establish the terminology we will be using, the section below describes the CFC
chart and its elements.

Charts and Chart Partitions

The basic working unit of the CFC editor is the chart. Each chart has a name that
is unique in the CPU. You can create charts either in the SIMATIC Manager or
directly in the CFC editor.

Each chart consists of up to 26 chart partitions. A newly created chart consists of a
single chart partition, further chart partitions can be added.

Sheets and Sheet Bars

Each chart partition consists of six sheets arranged in two columns of three in the
CFC editor (see Figure 1-2). A sheet consists of a central working area and sheet
bars containing the sheet and interchart references. On the working surface, you
can position and interconnect blocks or further charts.

Overflow Page

If there are so many interconnections to other sheets, so that not all entries can be
included because the sheet bar is full, an overflow page is created automatically.
The overflow page is an extension of the sheet bars and contains no further
objects.

Nested Charts

A CFC chart can be nested in another CFC chart (chart-in-chart technique). This
allows hierarchical structures to be created. Each nested chart can be opened just
like any other chart, edited, and individually modified.

A chart can be “encapsulated” for further use; in other words, it is given chart I/Os.
For each chart, you can decide which block I/Os are available at the chart I/Os.

For further information about creating nested charts, refer to this manual, Chapter
3 or look in the online help.
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Chart Overview and Sheet View

You can change between the chart overview and the sheet view at any time.

The overview is useful for copying and moving blocks/charts and for inserting
larger blocks. Since, however, certain details cannot be displayed in this view, for
example the names of inputs and outputs, certain functions are only possible in the
sheet view.

With the zoom functions, you can change the size of the view in regular steps
between the smallest and largest display.

Display of a Chart

You can customize the display of the various chart elements. You can, for
example, decide whether the type name or the FB/FC assignment is displayed in
the block headers and whether the data type and I/O name or the comment is
displayed for I/Os. You can also select how parameters, addresses, and
connections are displayed. 
For more detailed information, refer to the online help.

Example of a Chart Overview

Figure 1-2 shows an empty CFC chart (6 sheets) in the chart or overview display.

Sheet 1

Sheet 2

Sheet 3 Sheet 6

Sheet 5

Sheet 4

Central working area Sheet bars

Figure 1-2 CFC Chart at the Overview Level
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Example of the Sheet View

Figure 1-3 shows the sheet view of a CFC chart with 4 interconnected blocks:

distur1

setpo1

manvar

Figure 1-3 CFC Chart at the Sheet Level
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1.4 Blocks in CFC

Functions in the Form of Blocks

In CFC, you work with ready-made blocks that have a specific function. You place
these function blocks in the chart, interconnect them, and assign parameters to
them.

The Block Type

A type definition that specifies the algorithm, the type name, and the data interface
(the input and output parameters) exists for each function block.

The type name  is an abbreviation or acronym of the function, for example:

– CTUD (COUNT UP and DOWN) for the function of an edge-controlled count
up/count down counter.

– COUNT_P, a counter that counts up or down (depending on the setting) at
the positive edge of a binary signal.

– ADD_R, a simple function that adds input values and applies the sum to the
output.

The type definition also specifies the data types  of the input and output
parameters. These input and output parameters are known as block inputs and
block outputs since this is how they appear in the graphic display of the block.
The data type of an input or output specifies the values it can adopt, for example: 
BOOL Boolean type, can only adopt the values 0 or 1.
STRING Character string type, can contain a string of characters as its
value. There are also other data types, refer to the Appendix, Table A-2.

The Block Instance

When you place a block in your CFC chart, you create a block instance by
inserting this block type in the chart. Instance in this sense means that it is an
instance or usage of the selected block type.

You can create any number of block instances from a particular block type. You
can assign names to these block instances, interconnect them, and assign
parameters to them without changing the functionality specific to the type.

One advantage of this type instance concept is, for example, that following later
central changes to the block type, these changes can be automatically made in all
the corresponding block instances.
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[S7] Complex Blocks (multiple instance blocks)

Functions can also be put together using different subfunctions. These
subfunctions themselves are blocks and are put together to form a complex block.
A controller block can, for example, contain a message block and an operator
control block (multiple instance block). In such a call hierarchy, the calling block is
known as the parent block and the called block is the child block.

Using CFC, you can create these blocks by interconnecting different blocks
(functions) and assigning suitable parameters in a chart. You then compile the
chart as a block type (see Section 3.9.2).

Blocks with a Variable Number of Block Inputs

In CFC, there are blocks whose number of inputs is variable and can be changed
in the CFC chart (generic block). A block with a variable number of inputs is, for
example, the AND block.

Block Families

Blocks are grouped together according to their functional properties to form block
families. When it is created, each block receives a family identifier. The following
blocks, for example, make up block families:

– the conversion blocks for adapting various data types 
CONVERT (BO_BY, BY_DW, W_DW, ... etc.)

– the multiplexer blocks = 
MULTIPLX  (MUX8_R, MUXn_DI, ... etc.)

– the blocks with math (floating point) functions
MATH_FP (SQRT, ADD_R, ... etc.)

The names of the block families are used, among other things, as a criterion for
sorting blocks in the CFC catalog.

[S7] Organization Blocks

The interface between the operating system of the CPU and the user program are
the tasks known in S7 as organization blocks (OBs). Using these OBs, specific
program sections can be executed at certain times and in certain situations. There
are OBs for CPU startup (cold restart, hot restart), for process interrupts, for cyclic
interrupts (with different time bases) etc.

Organization blocks or tasks are not blocks in the sense understood in CFC; they
can neither be inserted nor edited in CFC. In CFC, the OBs are displayed when
you edit the run sequence (see Section 3.7.1).



Essentials of CFC

1-9
CFC for S7 
A5E00083002-02

Further Distinctions

Blocks also differ in their type. When a block is created, it must be “declared” as a
function block (FB), a function (FC) or a basic operation (BOP).

• An FB is a block with memory; in other words, the data exist during processing
from cycle to cycle and can be accessed. To make this data accessible, a data
block (DB) is created for each block instance. In a complex block, the FB has
further subsidiary FBs for which only one common DB is created.

• An FC is a block without memory; in other words, the values generated by the
block are processed immediately. No data block is required here. An FC does
not have default values at the outputs.

• A BOP (like the FC) is also a block without memory. Basic operations are
program components in CFC that are entered as SCL statements during
compilation and are used for simple functions such as AND, OR etc.

Special Case: Overlapping Blocks

Overlapping blocks are blocks that have been inserted or moved to a chart and do
not have adequate space. In this case, they overlap other objects completely or
partly.

Overlapping blocks are displayed in light gray and without visible block I/Os until
they are relocated at a free position on the sheet. Existing interconnections and the
entries in the sheet bar of overlapping blocks are also invisible, but nevertheless
exist.

Special Case: Unplaced Blocks

Unplaced blocks are blocks that are accessed from an SFC chart but that no
longer (or not yet) exist in the chart. These blocks are virtual and therefore do not
exist functionally.

The unplaced blocks are arranged in the CFC charts in which they were originally
placed. They are kept in a separate catalog from where you can place them in the
chart again.

Virtual blocks are displayed in the catalog of unplaced blocks with the index “R” (R
= reference).
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1.5 The Catalog

Catalog of Blocks, Charts and Libraries

Blocks and charts that you want to insert in the CFC chart (using drag-and-drop)
can be taken from a catalog.

The catalog consists of a window in which the existing block families, libraries etc.
are listed (tree structure). The range displayed depends on the PLC and the
installed libraries.

You can switch from window to window using the buttons visible at the lower edge
of the window:

Blocks : Here, you will find the existing (imported) blocks and BOPs
sorted according to families and the blocks of the current program
that you can insert in the chart.

Libraries :Here you will find the block libraries from which you can
insert new blocks into the chart. The libraries known to the
SIMATIC Manager are displayed.

Charts : Here, you will find the CFC charts of the current program
that you can insert (copy) or open.

Unplaced blocks : Here, you will find the blocks of the current
program that are not (or no longer) displayed in a CFC chart (for
example virtual blocks). The CFC chart to which the blocks are
assigned is also displayed here.

The catalog windows “Blocks”, “Libraries” and “Charts” contain a text box that you
can insert in a chart just like a block.

In the lower part of the catalog, you will find the following buttons:

Find block or chart : You can specify a block or chart name in the
box and search for it with the “Find” button. The folder (for example of
the block family) in which the object is located is opened.
You only need to type the first few letters. The search stops when an
object with these letters is found. During the search, a dialog box with
a progress bar is displayed. Here, you can also stop the search if it
takes too long.

Close folders : Below the “Find” button there is a “Close” button.
With this button, you can close all the open folders in the catalog.
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1.6 [S7] Operator Control and Monitoring

During operation of the process, messages are generated on the PLC that need to
be passed on to the operator control and monitoring system (PCS 7).

With the message configuration in CFC, you can configure event-dependent
messages, their texts, and attributes directly in the block.

While configuring the PLC, you create data that are required on the OS for
communication between the PLC and OS; in other words, for operator control and
monitoring. You can transfer the data to the OS in the SIMATIC Manager.

Message Blocks

When you insert a block with message capability into the CFC chart, a message is
created automatically. This block has a message structure with default attributes
and message texts; in other words, the PLC sends the message when an event
occurs without any extra configuration on the part of the user. The signals that
form messages can also have associated values that allow dynamic values to be
entered in the message texts.

You can edit the attributes (such as message class, message type) and the
message texts for the individual block instances with the message configuration
functions (Special Object Properties: “Messages”). If the “Messages” button is not
activated, the block is not capable of sending messages.

Operator Control Blocks

All the message blocks for PCS 7 have an attribute for operator control and
monitoring (S7_m_c). Texts can be selected and edited for blocks with inputs that
allow operator input. You can start the dialog with the “Operator Control and
Monitoring...” button in the Object Properties of the block. The “operator control
and monitoring” attribute of CFC blocks (instances) can also be modified. To
modify this property, select or deselect the “Operator control and monitoring” option
in the object properties of the block.

PLC-OS Communication

When you have completed configuring the messages, the data required on the OS
for communication between the PLC and OS is transferred to the OS. This data is
transferred to one or more destination operator stations and is used on these
stations by graphic objects or faceplates. To make this transfer, the “PLC-OS
Engineering” software package must be installed.

For more detailed information on transferring data, refer to the online help.
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1.7 Steps in Configuration

Order of the Steps

1. Create the project structure

2. Create blocks and import them to CFC (optional)

3. Insert blocks in the chart

4. Set parameters for the blocks and interconnect them

5. Adapt the run-time properties

6. Compile the CFC charts

7. Download the CFC program

8. Test the CFC program

Creating the Project Structure

To work with CFC, you must create a chart folder below the program (folder for the
system-specific program) using the SIMATIC Manager.

You create the individual CFC charts in the chart folder either using the SIMATIC
Manager or directly in the CFC editor.

[S7]  When you create the project structure, you are supported by the “New
Project” wizard (depending on the setting either the STEP 7 wizard or the PCS 7
assistant). The PCS 7 assistant creates the project in the component view and in
the plant view. As default, the PCS 7 assistant also creates a CFC chart.

Creating Blocks (optional)

CFC works with ready-made blocks. These can be blocks from libraries, other
programs, or types you created yourself. For more information about creating
blocks, refer to the manual on creating block types.

Importing Blocks

The way in which block types are included and, in some cases, imported depends
on the PLC.

For more detailed information, refer to Section 3.3.1.

Inserting Blocks in the Chart

Blocks are inserted in the chart by dragging them from the catalog. This creates a
block instance with a name that is unique throughout the chart. You can create any
number of block instances from each block type.

For more detailed information, refer to Section 3.3.4.
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Setting Parameters and Interconnecting Blocks

You can assign parameters to the inputs and outputs of the blocks or you can
interconnect them either with other blocks or with shared addresses. (Shared
addresses are connection partners located outside the CFC chart, for example in
S7: peripheral I/O signals, memory bits, timers, counters, and shared data blocks.)

Interconnecting means that values are transferred from one output to one or more
inputs during communication between the blocks or other objects.

For more detailed information, refer to Section 3.5.

Adapting Run-Time Properties

The run-time properties of a block decide how the block is included in the run
sequence within the entire structure of the PLC. These properties are decisive for
the response of the PLC in terms of reaction times, dead times, or the stability of
time-dependent structures, for example closed loops.

When it is inserted, each block is assigned default run-time properties. The block is
installed in a task at a position that you yourself can select. You can change the
position at which the block is installed and other attributes later if necessary.

For more detailed information, refer to Section 3.7.

Compiling the CFC Chart

During compilation as a program, all the charts of the active CPU are converted to
machine code. Different compilers are used depending on the destination PLC; the
call is, however, identical. If you compile as a block type, only the individual chart is
compiled.

For more detailed information, refer to Section 3.9.

Downloading the CFC Program

After compilation, you can download the CFC program to the CPU.

For more detailed information, refer to Section 3.10.

Testing the CFC Program

After compiling and downloading the program you can test it. The range and type
of test functions available differs from PLC to PLC. In the test mode, you are
connected online to the programmable controller.

For more detailed information, refer to Section 4.3.
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Getting Started

Introduction

This chapter “Getting Started” is intended as a primer for newcomers to CFC who
want to get to know the package quickly.  The example is divided into various tasks
and guides you step-by-step from the simplest configuration jobs to the creation of
a chart with chart I/Os and blocks in CFC.

Note

You will find a ready-made example in the SIMATIC Manager as follows:
File > Open...  > Register: “Sample projects” tab > ZDt04_01_CFC (German).
(English: ZEn ..., French: ZFr..., Spanish: ZEs..., Italian: ZIt...)

In this example, it is assumed that CFC will be used in the STEP 7 environment.
This means that the STEP 7 standard package, SCL, and CFC are installed. The
PLC used is either S7-300 or S7-400.

You can create the sample project “CFCEXA_2” described below with the
SIMATIC Manager.

2
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2.1 Creating a Closed-Loop Control with a Simulated Process

2.1.1 Creating the Project

This section describes the steps involved in creating a project with the menu
commands of the SIMATIC Manager. You configure the hardware with HW Config
(this can be done later but must be done before you download to the CPU). This
example is restricted to the S7 program:

• In the toolbar, select  or File > New . 
In the “New” dialog box, enter the project name “CFCEXA_2” and enter it with
“OK”.

• With the project folder selected, click the menu command Insert > Program >
S7 Program . 
The S7 program is created in the “Component View” with a source files folder,
block folder, and symbol table.

• With the S7 Program folder selected, click the menu command Insert > S7
Software > Chart Folder . 
The chart folder is created.

• With the chart folder selected, click the menu command Insert > S7 Software
> CFC. 
A chart “CFC1” is created; Give this the name “Control”.

• Double-click the CFC chart to open it.

All the requirements for working with the CFC editor have now been satisfied.
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2.1.2 Creating a Chart

Aim

You will now create a controller with process simulation in which the process is
simulated by a sliding average value. You will use two blocks for this, SAMP_AVE
and CONT_C. The SAMP_AVE block forms the average value from a number of
input values and the CONT_C is a PID controller that controls this variable average
value.

CONT_C
Continuous PID

Contr

OB35
1/-

R SP_INT

R PV_IN

R MAN

R GAIN

TI TN

TI TV

LMN R

0.0

SAMP_AVE
Sliding averag

Process

R IN

I N OUT R

20.0

20s

10s

2.0

0

30

OB35
2/-

Here, an average value is formed from the last 
30 values of “Contr” output LMN and
passed from “Process” output OUT 
to “Contr” input PV_IN.

LMN passes the 
manipulated value
to the “Process” input
IN

The “Process ” block simulates the process The “Contr ” block controls the process variable

BO_ MAN_ON

R DEADB_W

Inserting the Blocks

• Open the catalog  if it is not already open (default).

• In the catalog, click the button  of the libraries. Here you can open the

CFC Library . This is a collection of block libraries.

• Now open the folder ELEM_300. This is a library with blocks suitable for the
S7-3xx CPU. If you are using the S7-4xx CPU, open the folder ELEM_400.
You can drag blocks from the list that appears to the chart.

• Click CONT_C, hold down the mouse button and drag the block to the chart.
Position it to the top right on sheet 1.

• Then take the block SAMP_AVE  and position it on the left beside the CONT_C
block.

• Double-click a free position close to the two blocks to change to the sheet view
(or, in the toolbar click ).

In the sheet view, you can see the blocks as graphic objects with a header and
several I/Os on the body. The I/Os (inputs left, outputs right) are displayed as fields
with the I/O name and data type.
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Interconnecting the Blocks

Now interconnect the blocks as follows:

• On the SAMP_AVE block, click the output OUT and then click the input PV_IN
on the CONT_C block.

• On the CONT_C block, click the output LMN and then click the input  IN on the
SAMP_AVE block. 
As an alternative, you can also drag a block output to the input with which you
want to connect it using the mouse.

The two blocks are now interconnected.

Changing the Appearance of the Blocks.

The blocks are displayed in the chart with all their I/Os (inputs and outputs) as
dictated by the block type. In our example, however, we do not require all the I/Os
and to make the display simpler and clearer we want to make the unnecessary
I/Os invisible in the chart. In the same dialog, we will also change the block names.

• Double-click the block header of the CONT_C block: The “Properties” dialog
box is opened for this block. The name (“1”) is already selected and you can
type in the new name “Contr” immediately.

• Now select the “Inputs/Outputs” tab. Using the horizontal scroll bar, go right
until the “Not displayed” column appears.

• Click the first selection cell, hold down the mouse button, and drag the mouse
pointer vertically to the end of the column: The entire column is selected. With
the mouse pointer in the selected area, click the right mouse button and select
the “Set” command in the menu.

All unconnected I/Os are set to “Not displayed”. Some I/Os will, however, be
needed later in the test mode to input values. We will make these visible again.

• In the “Not displayed” column, click the check boxes of the following:

MAN_ON

SP_INT

MAN

GAIN

TN

TV

DEADB_W.
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Setting Parameters for the I/Os and Selecting Them for Testing

• In the “Inputs/Outputs” tab, go to the column “Watched” and set all the visible
I/Os including the interconnected output LMN.

• In the “Value” column, enter “20” for SP_INT
(this is the default setpoint for the controller). 
Close the Object Properties by clicking “OK”.

You can also set parameters directly for an individual I/O:

• Double-click the block input MAN_ON of the controller.

• In the “Value” box, change the “1” to “0”. 
This disables the “Manual Mode” that would interrupt the control loop.

• Close the dialog box by clicking “OK”.

Follow the same procedure with the SAMP_AVE block (using the Properties dialog
of the individual I/Os or in the Properties dialog of the block as described below).

• Double-click the SAMP_AVE block header. Name this block “Process”.

• In the “Inputs/Outputs” tab, set the input N in the “Watched” column.

• In the “Value” column, enter the value “30” for N. 
(This is the number of input values to be used for the average value.)

• Close the dialog box by clicking “OK”.

The blocks are now interconnected and have the parameters required for our
process simulation.
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2.1.3 Compiling and Downloading the Chart

The next step is to compile the chart as a program.

• Select the following symbol in the CFC toolbar    

• or Chart > Compile > Charts as Program . 
In the dialog box that appears, set “Compile: Entire program”. Complete the
dialog with “OK”. 
Compilation is now started and the progress is displayed in a dialog box.
Confirm the final message with the S7 logs with “Close” (you can ignore the
displayed warning).

Note:  
The next step is only possible if you have configured and connected a CPU of the
type S7-3xx or S7-4xx to your PC. The setting of the key switch on the CPU must
be: RUN-P.

• To download the program to the CPU, select the button  
 or PLC > Download . 
In the dialog box, select the type of download (this is already set: “Entire
program”).

Before you download the program, the CPU is set to STOP (after a prompt that
you answer with “Yes”) and any blocks already on the CPU are deleted. The
download is displayed in a further dialog box. After downloading the programs
successfully (with no errors), a message is displayed to show that downloading is
complete and asking you whether you want to restart the CPU. If you answer
“Yes”, you can return the CPU to the “RUN” mode.

The CPU changes to the RUN mode. The program is loaded and can now be
tested.
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2.2 Testing the Program

In the test mode, you can monitor the values of the block I/Os and change the
values of the block inputs. The values registered for testing are shown on a yellow
background.

If you change some of the parameters, you can monitor the controller response, for
example how the manipulated value approaches the setpoint and settles.

Changing to the Test Mode

Before you change to the test mode, change the mode from “Process Mode” to
“Laboratory Mode” (“Test > Laboratory Mode”). This means that all block I/Os are
automatically activated for “Watching”.

Note: In the “Process Mode”, the default setting is no I/O registered for watching.
In this test mode, you would have to select the relevant blocks and register them

explicitly for watching (by clicking  ).

Activating the Test Mode:

• Click   or select Debug > Test Mode.

Changing Values Online

You can set a different setpoint for the example, as follows:

• On the controller, double-click the SP_INT input and set a different value (<100)
as the internal setpoint in the dialog box that follows.

• Click “Apply” so that the value is adopted and the dialog box remains open for
further changes.

After you have made a few changes and observed the control response, close the
dialog box with “OK”.

You can, for example, influence the speed of the settling at the block inputs:

GAIN (Proportional gain, determines the control gain)

TN (Reset time, determines the I-action)

TV (Derivative time determines the D-action)

If you change “GAIN” to a lower value and “TN” to a longer time, the dynamic
response of the controller is changed and the control response of the example is
more “sluggish”.

With the MAN_ON block input, you can interrupt the control loop and switch over
to “Manual Mode” (=1). The manipulated value (in other words the value at the
output LMN) is then set by the value of the MAN input.
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The Result

In this part of the example, you have got to know the elementary aspects of
configuring in CFC. You have created a project with the SIMATIC Manager,
created a CFC chart, and inserted blocks from a library. You have interconnected
the blocks and set parameters. You have created an executable program and
downloaded it to the CPU. In the test mode, you were able to monitor and modify
the dynamic response of the control loop.

 



Getting Started

2-9
CFC for S7 
A5E00083002-02

2.3 Making Changes to the Chart

We will now leave the test mode.

• You change to the edit mode by clicking the   button in the toolbar.

2.3.1 Changing the Run-Time Properties

Introduction

The blocks of a chart have certain run-time properties. These run-time properties
determine when and in which order the blocks are executed on the CPU. To
structure their execution, the blocks are installed in OBs. 
In this example, the default installation of the blocks is in OB35 (cyclic interrupt 100
ms) and because they are also involved in a restart, they are installed in OB100
(warm restart).

So that you do not need to worry about the run sequence for every block, CFC
installs the blocks one after the other after a particular block. This block is also the
“Predecessor for Installation” for blocks installed later. In the CFC status bar (to the
bottom right in the window), you can see which block is currently the “Predecessor
for Installation”.

You can change the run sequence of the blocks (by installing them in another OB)
or structure them differently by putting the blocks together to form a run-time
group. You can assign attributes to the run-time group that decide the scan rate of
the OB cycle and the phase offset with which the blocks are executed.

Changing the Run-Time Properties

You want the blocks to be executed in a different sequence. The test mode is
deactivated, you now call the run-time editor with the run sequence.

• Click the button in the toolbar    or select 
Options > Run Sequence .

A new window is opened displaying all the OBs. Objects have already been
installed in OB100 and OB35 as can be seen by the + in a box in front of the OB
icon.

• Select OB35. The blocks are displayed in the right-hand detailed window.

• Keep the mouse pointer on OB35 and now select the Insert Run-Time Group
menu command with the right mouse button. A dialog box is displayed.
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• Make the following entries in this dialog box:

NAME: Group1
Comment: U8_PV0
Scan rate: 8
Phase offset: 0 (default retained)

• Apply your entries with “OK”.

• Click OB35 and select the two blocks in the detailed window. Drag these to the
new “Group1” folder in the left window.

When you drag the blocks, they can be installed either in or after the folder. You
will then be asked whether or not you want to install the blocks within the group.

• Answer the question with “Yes”.

With the setting you have made for the scan rate, the blocks are now executed
every eighth run; In other words with the basic cycle for OB35 of 100 ms they will
be executed every 800 ms. 
The phase offset can be used to achieve a better distribution of load on the CPU
when you have blocks in several run-time groups. Since this is irrelevant in our
example, the phase offset remains inactive.

Copying Blocks within the Chart

As a practical exercise, you will now copy the content of sheet 1 to sheet 2 and
continue editing there. When you copy interconnected blocks, the interconnections
between the blocks are retained, external interconnections are however lost.

• Change back from the run sequence to chart editing. 
To do this, click any point in the chart window 
(CFCEXA_2\S7 Program(1)\...\\Control) or press 

 again and change to the overview by clicking .

• In sheet 1, hold down the left mouse button and draw a lasso around the
interconnected blocks. The blocks are now selected (blue).

• Remain on the selection with the mouse pointer, hold down the Ctrl key and
drag the blocks to sheet 2 (below sheet 1).

• Select the “Contr1” block, copy it and insert it in the same sheet again. The
block is called “Contr2”.
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Changing the Interconnection

• Click the connecting line or the output LMN of “Contr1” and press the “Del” key.
The connection to input IN of “Process1” is deleted.

• Click LMN of “Contr1” and then SP_INT of “Contr2”. 

(Later, you will learn a more elegant method of “rewiring” without deleting and
interconnecting again).

• Click LMN of “Contr2” and then  IN of “Process1”.

• Click OUT of “Process1” and then  PV_IN of “Contr2”.

With the blocks positioned as shown, the interconnection appears as follows:

CONT_C
Continuous PID

Contr

OB 35
1/4

R SP_INT

R PV_IN

R MAN

R GAIN

TI TN

TI TV

LMN R

0.0

20.0

20s

10s

2.0

0 BO MAN_ON

CONT_C

Continuous PID

Contr

OB 35
1/5

R SP_INT

R PV_IN

R MAN
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Compiling, Downloading and Testing Changes

The chart must be compiled again and then downloaded to the CPU.

• Select the    button in the toolbar.
In the dialog box, set the option “Compile: Changes only” and click “OK”.
Compilation is started, confirm the logs message with “Close”.

• To download the program, select the    button.
In the dialog box, set “Download: Changes only” and confirm with “OK”.

When you download changes (as opposed to the entire program) the CPU does
not need to be set to STOP. 
Caution! If you are working with a real project, make sure that you are familiar
with the information in “Reasons for STOP when Downloading Changes Online”
in the online help.

(Help > Contents , “Index” Tab: Type in “Reasons for” and click the “Display”
button.)

After downloading, you can return to the test mode and test your modified
program.

The Result

In this part, you have learnt that the blocks of the CFC chart have certain run-time
properties on the CPU and that you can modify them. You have also seen that
substructures known as run-time groups can be used in the run sequence and
which attributes you can assign to them.

You have copied blocks within a chart and seen that the interconnections between
the blocks are retained. You have modified interconnections and once again
created an executable program. You have seen the difference between
downloading the entire program and downloading changes only.
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2.4 Creating Chart I/Os and a Chart-in-Chart

In the following section you will create chart I/Os for a CFC chart and insert this
chart in a different CFC chart.

2.4.1 Creating a Chart with Chart I/Os

The chart I/Os of a chart can be used to “encapsulate” CFC charts for further use.
When you create the chart I/Os, you can specify which block I/Os are relevant for
interconnection with other charts or blocks and must be applied to chart I/Os.

Preparations

• Create a new chart by clicking    in the toolbar. In the dialog box, enter the
object name : “Sim_reg” and confirm with “OK”. The new chart is displayed.

• By clicking    in the toolbar, the chart “Sim_reg” and the chart “Control” are
displayed one beside the other.

• Set the overview display for both charts by clicking   .

• Copy the blocks of sheet 1 of the “Control” chart to sheet 1 of the  “Sim_reg”
chart in the same way as you did when copying blocks within a chart.

• Close the “Control” chart and change to the sheet view (sheet 1) of the
“Sim_reg” chart.

• Open the run sequence.

• Select Group1 and then select the blocks “Sim_reg\Contr” and
“Sim_reg\Process” in the detailed window.

• Drag these blocks to OB35.

• Now close the run sequence again.

• Select the “Process” block in the “Sim_reg” chart. Using the right mouse button,
select “Predecessor for Installation”. In the list that then appears, select OB35
and confirm with “OK”.
All further blocks installed in OB35 will be installed after “Sim_reg\Process” you
can see this in the CFC window to the bottom right in the status bar.

• Open the block catalog in the catalog by clicking the   button and open the

block family MULTIPLX .

• Drag the block SEL_R to sheet 1 and give it the name “Switch” (in the
Properties dialog).



Getting Started

2-14
CFC for S7 

A5E00083002-02

To include the “Switch” block in our example, you must now “rewire” an existing
interconnection; In other words you modify an interconnection without deleting the
existing one.

• On the “Contr” block, select the PV_IN input, hold down the mouse button and
drag the I/O to “Switch” IN1. The output OUT of  “Process” is now connected to
 IN1 of “Switch”.

As an alternative, you could also delete the existing connection and create new
interconnections.

The output of “Switch” must now be connected to the input for the process variable
of “Contr”.

• Connect “Switch” OUT with “Contr” PV_IN.

The “Switch” now switches depending on the value of the input K, the value of the
input IN0 (K=1) or IN1 (K=0) to output OUT.

In a real project, this would allow you to switch over between a process simulation
(IN1) and a real process (process value from the process connected to IN0).

Creating Chart I/Os for the Chart

You now create the chart I/Os for the chart. These are then connected to the
selected block I/Os.

• Click the button in the toolbar   or select 
View > Chart Inputs/Outputs . 
The dialog for editing chart I/Os is opened and “docked” to the upper part of the
chart window.

• In the left-hand window, click the Block Icon of the inputs IN. The block inputs
are displayed in the right-hand window (currently empty).

• In the working field of the chart, select the MAN_ON block I/O on “Contr”, hold
down the Ctrl key and drag the I/O to the right window of the chart I/Os to the
“Name” box. The I/O is then entered with all its properties.

• Follow the same procedure with all further inputs (see table).

• Change the name of I/O K of the “Switch” block in the chart I/Os by
double-clicking in the “Name” box. Enter SIM here. Instead of  IN0, enter PV
(Process value).

• In the left window of the chart I/Os, click on the block icon of the outputs OUT.
Select the LMN output on the “Contr”, hold down the Ctrl key and drag the I/O
to the right window of the chart I/Os to the “Name” field.
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The chart I/Os then appear as follows:

Block: Block input Data type Block output Data type

Contr MAN_ON BOOL LMN REAL

SP_INT REAL

MAN REAL

GAIN REAL

TN TIME

TV TIME

DEADB_W REAL

Switch SIM (previously: K) BOOL

PV (previously:
IN0)

REAL

The sheet bar displays the I/O names and comments, I/O type, and data type
applied to the chart I/Os.

You have now created all the chart I/Os for the chart.

You can now close the window of the chart I/Os by clicking   again and can
“tidy up” the chart to make it clearer to read.

• Move the blocks in the chart so that as few connection lines as possible cross
over other lines. One possible arrangement is shown below.

Process

Switch

Contr
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2.4.2 Inserting a Chart in Another Chart

The chart “Sim_reg” created in the previous configuration step with chart I/Os will
be inserted in another chart. Create the new chart as follows:

• Click  in the toolbar. In the dialog box, enter “Top Chart” in Object name:
and confirm with “OK”. The new chart is displayed.

• Open the “Charts” catalog by clicking the button  .

In a tree hierarchy (apart from the text element) you will see the charts “Top
Chart”, ”Control” and “Sim_reg”.
Note:  If a catalog only contains the text element and the message 
“! (no hierarchy folder exists)” then you have set the option “Display catalog with
plant hierarchy” in the Options > Customize > Display...  dialog box. Since the
project was created without the plant hierarchy, this option must be disabled
(click the check box: The check mark is removed).

• Select the “Sim_reg” chart and drag it to the working area of “Top Chart”. The
original chart is copied.

• Change to the sheet view.

The chart with its chart I/Os appears like a block and can
be recognized as a chart by its icon.

So that you can see that this is a copy of the previously created chart, open it by
selecting it and then selecting the Open Chart  command using the right mouse
button. In the title bar, you will recognize that this is a “nested chart” by the path:
...\\Top Chart\Sim_reg .

In the catalog of the charts, a + box is displayed in front of “Top Chart”. By clicking
the box (or double-clicking the chart icon), you can open up the tree and the
hierarchy of the chart becomes visible: The “Sim_reg” chart is displayed in this
branch.

To return to the top chart, you can select “Open Parent Chart” with the right mouse
button or select the path for the “Top Chart” in the “Window” menu.

The Result

In this part, you have learnt how to edit a chart so that it has chart I/Os that allow it
to be interconnected to other block I/Os and to be used as often as required. You
have seen how a chart can be inserted like a block with the chart-in-chart
technique. You have seen that, in contrast to the block, the inserted chart can be
opened and modified.

With the chart-in-chart technique, you can create nested charts and therefore
create a structure according to technological aspects with greater clarity.
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2.5 Creating a Block Type

Normally, the entire chart folder containing the open chart is compiled. This
produces a program that can be downloaded to a CPU. You can, however, also
compile a single chart and create a block type from it. This is then placed in the
block library or in the S7 program so that it can be used again.

Compiling a Chart as a Block Type

You will now compile the original chart “Sim_reg” as a block type.

• Close all the charts (Window > Close All ).

Make sure that you open the Original chart  “Sim_reg” that is located at the same
hierarchical level as the charts “Top Chart” and “Control”.

• Select the “Sim_reg” chart in the “Charts” catalog and open it with “Open Chart”
using the right mouse button. 

• Select Chart > Compile > Chart as Block .

A dialog appears in which you can enter further information.

• In the “Properties Block Type” box, enter the following:

FB number: 110
Name (header): REG_1
Family: CONTROL
Author: TEST
Version (header): 0.1

and confirm with “OK”.

The compilation is started and progress is indicated in a dialog. When compilation
is complete, the block “FB110” is located in the block folder.

Entering the Block in the Symbol Table

The block is listed as “FB110”. To assign a symbolic name to the block, you must
enter it in the symbol table.

• Select Options > Symbol Table . The symbol table is opened.

• In the first free line, enter the symbol name REG_1 and as the address FB110.
As comment, enter example1 .

• Save the changes (Symbol Table > Save ) and close the symbol table.

FB110 now has the symbolic name REG_1.
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2.5.1 Testing the Block

The next step is to create a new chart and to insert the block REG_1  in it.

• Create a new “Test” chart as described in Section 2.4.2.

• Press the “F5” key (or View > Update ) so that CFC reads the changes in the
symbol table and the block folder.

• Open the S7 program in the catalog of the blocks. Here, you will see the new
block type REG_1.

• Insert REG_1  into the “Test” chart by dragging it with the mouse and change to
the sheet view. You will see the block I/Os as you created them as chart I/Os.
The EN and ENO I/Os are added by the system (so that the block can be
activated and deactivated).   These I/Os are invisible (default). To display them,
you must switch them to visible in the Object Properties, “Inputs/Outputs” tab.

• Now compile the charts as a program   .

• Download the program to the CPU  
 (entire program, with a cold restart on the CPU).

• Then change to the test mode    to monitor and modify the I/Os of the
block.

With the SIM input, you can toggle between internal simulation (= 0) and
external process value (of the PV input) (= 1).

Final Comments

In this brief example, you have got to know a few of the possibilities available with
CFC. The exercises have illustrated how simply and conveniently you can create a
program for an automation task that can then be run on the CPU.

Once you have worked through this example, you will know CFC well enough to
start tackling more complex tasks.

The following chapters and the comprehensive online help of CFC will provide you
with more information.
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Working with the CFC Editor

Overview

This chapter describes how to configure an entire software structure for a CPU
using the CFC editor.

Requirements:

Using the SIMATIC Manager, you have created a project with a program folder for
a specific PLC (for example an S7 program for SIMATIC S7) including a chart
folder.

Note

CFC is “upwards compatible”, this means that programs modified with other tools
and not with the CFC editor lead to inconsistencies.

Restrictions for multi-users in network operation: 
Several users can work on one project. This allows configuration, testing, and
commissioning of PLCs to be performed at different locations or in a PC network
(multi-user mode).

If several people want to work on a project at different locations, the project can be
divided up, edited, and put back together again (branch-and-merge). If the PCs are
connected in a network, remember that one PLC must only be edited by one user
at any one time. 
For more detailed information, refer to the online help.

3
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3.1 Handling Charts

Creating a Chart

You normally create a chart with the SIMATIC Manager; this is, however, also
possible directly in the CFC editor (“Chart > New” menu command). The name
must be unique on the CPU (this is checked by the system) and can be a
maximum of 22 characters long.

Opening a Chart

You can open a chart with the SIMATIC Manager . Select a project and the project
folder, open the charts folder and double-click the required chart to open it and
start the CFC editor at the same time.

In the CFC Editor , the “Chart” menu always displays the last four charts that you
edited (and closed) as a menu item. If you select one of these names, the
corresponding chart is opened or if it is already open it is displayed.

You can open a chart that is not displayed in the “Chart” menu by selecting the
“Chart > Open” menu command, selecting the project in the dialog box, selecting
the program folder and the chart folder and opening the selected chart by
double-clicking it.
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Copying/Moving a Chart

Copying  entire charts allows you to duplicate or move structures or substructures
you have tested, even to other CPUs.

When you copy/move charts, the resources (block types, FBs and FCs including
symbols and the system attributes and the called blocks of multiple instance
blocks), are also copied if they do not already exist in the destination.

Remember that the Copy/Move function has effects on existing interconnections
and blocks etc. If a block type in the destination CPU is incompatible with the block
type you are copying (number, order, name, and data types of the block I/Os), the
chart will not be copied.

In this case, before you copy the chart again:

– You must copy the relevant block type either to the block folder of the source
program or to the block folder of the destination program.

– Select the block type in the “Chart Folder” box with the menu command
“Options > Block Types...” and make a central block type change with the
“New Version” button.

The copied blocks retain the run-time properties of the blocks from the source
CPU; in other words, they are installed in the run sequence as they were installed
in the source CPU. If no task with the same name exists on the destination CPU, a
log with the missing tasks is output and the copy function is rejected.

When copying charts, remember that interconnections to shared addresses are
also copied depending on the default setting. You can make this setting in the
“Settings for Copying/Moving” dialog box (menu command “Options > Customize >
Copy/Move...”).

CFC charts can also be copied/moved between different target systems (for
example SIMATIC S7 � SIMATIC M7). Once again, the block types used in both
target systems must be identical; in other words, they must be compatible since
they are also copied.

Closing/Deleting Charts

Since all the changes in the chart are saved immediately, you can close the chart
or exit the editor at any time.

You can delete a CFC chart in the SIMATIC Manager.
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3.2 Creating a Chart

In its original form (after it has been inserted in the chart folder), a CFC chart
consists of a chart partition with 6 sheets without further chart partitions. You can
rename such a chart and extend it.

You can add chart I/Os to a chart (see Section 3.2.3) so that, for example, it can
be interconnected with other charts or inserted inside another chart where it can be
interconnected with blocks. If you use the chart-in-chart technique (inserting charts
with chart I/Os in another chart), you can create nested charts (see Section 3.2.4).

A chart can also be inserted into another chart without chart I/Os (for example
when you want to create the chart I/Os later).

3.2.1 Adapting Chart Properties

In the “Properties CFC Chart” dialog box, you can set properties such as the chart
name, author, and comment for the active chart.

In CFC, you can display this dialog box with the “Chart > Properties...” menu
command.

For further information and information about assigning names in PCS 7, refer to
the CFC online help.

3.2.2 Inserting and Deleting Chart Partitions

You can add further chart partitions to the CFC chart at any time if it is not large
enough for your needs.

When you insert a chart partition, you can decide whether the new chart partition
is inserted before the current chart partition or whether it should be appended as
the last chart partition. A chart can consist of up to 26 chart partitions; they are
identified in alphabetical order (A - Z). The alphabetical identifier of the individual
chart partitions can change if you insert further chart partitions.

If, for example, the “CFC1” chart consists of a single chart partition, this is given
the letter “A”. If you insert a further chart partition before this chart partition, the
new “first” chart partition becomes “A” and the previous one now becomes “B”.
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Chart partition A

Chart partition C
Chart partition B

Chart partition D

Chart “CFC1”

Figure 3-1 Chart with Chart Partitions

Depending on the view (sheet or overview), the ID of the current chart partition is
displayed along with the sheet number or with “Overview” in the status bar.
Example:

Sheet view: Overview:B/Sheet 3 B/Overview

You can only delete  the active chart partition. If the active chart partition is empty,
it is deleted after you select the “Edit > Delete Chart Partition” menu command. If
the chart partition contains objects, you will be prompted for confirmation before it
is deleted.

3.2.3 Creating a Chart with Chart I/Os

You can provide a chart with I/Os to extend your options such as

• Installation in a different chart (nested charts, see Section 3.2.4) and
interconnecting with other charts or blocks

• Compiling it as a block type

You assign the selected I/Os of the internal blocks contained in the chart or the
nested charts to the chart I/Os.

The “Chart Inputs/Outputs” Window

You create the chart I/Os in a separate CFC window.

With the “View > Chart Inputs/Outputs” menu command or the  button in the
toolbar, you can open (and close) the “Chart Inputs/Outputs” window.

The procedure for creating chart I/Os is described in detail in the example in
Section 2.4.1.
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System Attributes

Just as in blocks, you can also assign system attributes to the individual chart I/Os
of a chart.

A chart with chart I/Os does not have system attributes itself (apart from those of
the I/Os). You can assign these attributes when the chart is compiled as a block
type (see Section 3.9.2).

Notes

• You can only interconnect unconnected I/Os with the chart I/Os if the I/Os have
a compatible data type.

• If an I/O is already interconnected, it is not possible to change the data type.

• Chart outputs cannot be assigned parameters if they are interconnected.
Remedy: You assign parameters to the output of the block; this value is then
entered for the corresponding chart output.

• With inputs, you can assign the chart I/O to several block/chart inputs.

Assigning I/Os when the Charts are Already Installed

You can also extend a chart with chart I/Os later by adding further chart I/Os. If this
is a nested chart (see also 3.2.4); in other words, a chart that is already installed in
another chart, the added I/Os can lead to positioning conflicts. In this case, the
nested chart is displayed as an overlapping chart just like an overlapping block; in
other words, light gray and without I/Os.

Once the chart is positioned at a free location, the I/Os and interconnections are
visible again.



Working with the CFC Editor

3-7
CFC for S7 
A5E00083002-02

3.2.4 Creating Nested Charts

You can insert a CFC chart in another CFC chart. This allows you to create a
program structured according to your technological requirements using
standardized sections that can be used again and again.

The charts nested in another chart can be opened and modified in the Edit mode
and can be run and monitored in the Test mode.

The chart containing further charts is the top chart. In the SIMATIC Manager, you
can only see the top chart in the chart folder. The maximum nesting depth for
nested charts is 8 (top chart + 7 levels of nested charts).

Inserting a Chart in a Chart

You can insert a new nested chart from the block catalog (icon:  new chart) by
dragging it to the current chart where you can then edit it.

To allow charts to be used like blocks in CFC, they are displayed in the chart
catalog in a tree structure. From here, you can drag-and-drop a chart to the
currently open chart. When you insert the chart, it is copied to the chart along with
its own nested charts (if it contains further nested charts).

You can also move parent charts to the chart by dragging them with the mouse
while holding down the Shift key. In this case, they are not copied but moved. In
the catalog, the chart is now no longer at its previous location but is shown in the
hierarchy of the active chart.

Navigating in a Chart

To open a nested chart, select the chart within its parent chart and select the
“Open Chart” menu command with the right mouse button or in the “Edit” menu.
You can also open the chart by double-clicking a free position in the body (not the
header or I/O). By repeating this, you can work down to the lowest chart nested in
the hierarchy.

To move up through the hierarchy (as far as the top chart), select the nested chart
and then select the “Open Parent Chart” menu command with the right mouse
button or in the “Chart” menu.

You can also open a chart in the chart catalog. Select a chart and then select the
“Open Chart” menu command with the right mouse button.

Copying a Nested Chart to a Different CPU

You can copy a nested chart and paste it in the chart on another CPU. The position
at which the blocks are inserted is decided by the “Predecessor for Installation” of
the destination chart. Run-time groups are not copied.
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Copying and Deleting

If you want to delete a nested chart from its parent chart but not from the chart
folder (you may have modified it and want to use it later at a different point), you
can first copy it into the chart folder. With the chart open (active), select the “Chart
> Copy to Chart Folder” menu command. The chart is copied and inserted in the
chart folder with a new name. You can now delete the chart within a chart as usual.

Interconnecting

If the nested chart has I/Os, you can interconnect it in the chart with other nested
charts, with blocks, or with shared addresses.

How to assign block I/Os to the chart I/Os is described in Section 2.4.1. You can
use the same procedure when you want to connect the chart I/Os of nested charts
to chart I/Os of charts higher up in the hierarchy.

You can also make this interconnection if you select a block/chart I/O and then
select “Connection to Chart I/O...” with the right mouse button or in the “Insert”
menu. The “Chart Inputs/Outputs” window does not need to be open. A dialog box
is displayed with the list of all available I/Os; in other words if you have selected an
input, a list of chart I/Os of the type “IN”, and if you have selected an output, a list
of the type “OUT”.

Note

Remember that the chart you have inserted by dragging it from the chart catalog
to the current CFC chart is a copy. This nested chart no longer has any
relationship to the original chart; in other words, modifications that you make in
one of the charts are only available in that chart.
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3.3 Handling Blocks

Blocks for CFC

A basic pool of blocks is shipped with CFC. You can add further blocks from
libraries or other projects.

Help

The online help provides you with a description of the blocks shipped with CFC
that you can display by clicking the block with the “Help arrow” (in the CFC chart or
in the catalog of blocks or libraries) or by pressing F1 for the selected block.

Note

[S7] The library “CFCLIBS (V4)” or “CFC Library” contains the blocks for the CPU
3xxx in the “ELEM_300” folder. These blocks cannot be run on a CPU 4xxx.

3.3.1 [S7] Importing Blocks

Importing into CFC

By importing, existing blocks are made known to CFC. You can only use such
blocks in CFC.

You can import blocks by inserting them from the catalog (disguised import) or
explicitly with the “Options > Block Types...” menu command.

Explicit importing is always useful when you require a lot of different blocks.
Afterwards, inserting from the catalog is much faster since disguised importation is
no longer necessary.

You would use the “Block Types...” dialog, for example when you want to import a
number of blocks from the user program (block folder) into the chart folder. You
would also use this dialog when you have modified blocks (type modification) in the
block folder that exist with the same name in the chart folder and need to be
updated in the chart folder.

You can select the blocks you require in the “Offline block folder” box and then
import the blocks to the chart folder by dragging them with the mouse or using the
“-->” button. If a block already exists in the chart folder, a message is displayed.
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3.3.2 [S7] Importing a New Version

If, following a block type change, you want to use the modified blocks for the
previously used old block types, the new block types must be imported into the
chart folder. The block instances used in the CFC chart can then be adapted to the
modified block types (central block type change). 
Blocks are imported as follows:

• When you insert a modified block type from the S7 program or the block library
into the chart.

• Using the “Options > Block Types...” menu command in the “Block Types”
dialog. Here, you select the block to be imported from the list of source files
(“Block Folder Offline”) and then drag the block to the “Chart Folder” list (or click
the “-->” button).

Using a New Version

If a block type with this name exists in the chart folder, the “Import New Version”
dialog box with a message outlining the consequences and the version information
of both blocks is displayed. If you answer the question “Do you still want to use the
new version of the block types?” with “Yes” all the corresponding block instances
will be adapted. If you answer with “No”, no adaptation takes place. Three separate
situations can be distinguished:

1. Changes that require neither downloading the entire program or retransferring
PLC-OS data because the changes are only relevant within the ES. In some
circumstances, “harmless” changes do not require downloading again, in the
worst case, a delta download in the RUN mode is adequate.

2. Changes that are relevant to the OS and therefore require a PLC-OS data
transfer (for example after changing a message text).

3. Changes in which the structure was modified, for example, adding I/Os and/or
messages. This has the following consequences:

– Interconnections and parameter settings can be lost.

– The only option is to download the entire program; in other words, the CPU
must be changed to STOP.

– If the block is intended for operator control and monitoring (in other words, it
will be executed on the OS), a PLC-OS data transfer is also necessary.

– If you want to retain parameter settings on the PLC, the chart must be read
back before downloading again.

Note

The central block change is not made if the category of the block type has been
changed (for example FB <--> FC).

The idea of central block type changes relates to FBs and FCs. The types of
BOPs cannot be changed since they are an integral part of CFC.



Working with the CFC Editor

3-11
CFC for S7 
A5E00083002-02

Same Version

If you import block types and the same version already exists in the chart folder,
you will be informed that you do not need to import and will see a list of the
identical block types.

Blocks in Libraries

If you have made a type change to blocks that were previously only in the library,
please remember to include the blocks in the S7 program (block folder) first before
you update the blocks in the chart folder with “New Version”.

If you have made a type change to blocks within the S7 program (in the block
folder), please remember that the library is also updated.

Log of the Block Types

The modifications resulting from a central type change are logged and
automatically displayed following the update. You can also display the log again
and, if required, print it out with the “Options > Logs...: Block Types” menu
command. If modifications to block instances are necessary, you can use the log to
help you saving both time and reducing the risk of errors.

Tolerant Type Import after Data Type Extension

If the data type for a block type is extended, all data of the I/O are retained during
a central type change if the old data type can be mapped on the new one without
conversion. This applies to:

BYTE --> WORD
BYTE --> DWORD
WORD --> DWORD
INT --> DINT
STRING1n --> STRINGn+m (e.g. STRING16 --> STRING32)

Note:
Remember that the existing interconnections to these I/Os are nevertheless lost as
a result of the central type change.
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3.3.3 Effects of Type Changes on Block Instances

Note the Effects!

The automatic modification of block instances of the updated block type can have
effects that you should always take into account. It is possible that parameter
assignments and SFC accesses are lost if a block I/O is deleted or modified (for
example a different data type or different name).

Effects of Changes on Block I/Os

• An I/O is added
The change is also made in the block instances and the default is set for the
system attributes. If there is no longer room at this position after increasing the
size of a block, the block becomes an “overlapping block”.

• An I/O is deleted
The I/O is removed from the block instances. If the I/O is interconnected, the
interconnection (or an SFC access) is also deleted. The deleted interconnection
(or deleted SFC access) is entered in the log of the changes.

• Order of the I/Os is modified
The order of the I/Os is taken into account and the interconnection, parameter
assignment, and attributes are retained.

• Data type of an I/O is modified
All the assigned parameters and interconnections of this I/O are lost. This
situation occurs when you delete and then recreate an I/O.

• Name of the I/O is modified
All the assigned parameters and interconnections of the I/O are lost. The
reference to the old name cannot be established automatically by the system.
This situation can occur when you delete and recreate an I/O.

Effects of Changing System Attributes

If you modify attributes, the effects can be summed up in the general rule: 
What cannot be modified for a specific instance is automatically modified in the
instances as a result of a type change.

Effects on Other Functions

• It is no longer possible to download changes only (only the entire program).

• The “Read Back Chart” function is no longer possible, since the blocks on the
PLC no longer match the configuration in CFC.
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[S7] Effects on WinCC

• If a block type is changed, DBs with new DB numbers can be created by
compressing and compiling. To ensure online access is retained, the data must
be transferred to WinCC again.

• If block I/Os intended for operator control and monitoring are affected (attribute
S7_m_c=true), the following rules apply:

– If an I/O is added, this is known in WinCC following the PLC-OS transfer and
can be used in WinCC.

– If an I/O is deleted, the WinCC tag no longer exists. The existing
interconnection(s) must also be deleted in WinCC.

– If the name of an I/O is changed, the name of the WinCC tag also changes.
The interconnections of the picture elements, block icons and faceplates
must be adapted.

• Whenever a change is made that affects WinCC, a new PLC-OS transfer is
necessary.
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3.3.4 Inserting Blocks in the Chart

Inserting in a Chart

You can insert blocks both in the sheet view and in the overview.

You can select a block type in the catalog of the libraries, the blocks, or the
unplaced blocks and drag it to your chart.

If you drag the block to a position where there is not enough space for the current
block size, it is inserted as an “overlapping block”. The block I/Os of overlapping
blocks are not visible and the header and body are displayed in light gray. Once
you move this block to a free position, it is displayed as normal.

Inserting from the Libraries Catalog

In S7, when you insert the block types from the libraries catalog they are implicitly
imported into CFC.

Block I/Os with Changed System Attributes:  
If you insert a block from the library into the chart and the system recognizes that
the system attributes are different from those of the existing block when it copies
the block to the block folder, the “Insert Function Block” dialog box opens.

In this dialog, you can open the “Match System Attributes” dialog box. Here you
can see all the I/Os with different attributes.

By selecting the attribute value “source” or “destination (old)” you can decide
whether the I/O of the imported block (destination (new)) will have the attribute
value of the source or the “old” destination.

Inserting from the Blocks Catalog

Blocks from the S7 program are automatically imported into CFC when you insert
them in the chart. They then also appear in a family of CFC blocks. The icon for
the blocks appears differently depending on whether the block is already known to
CFC; in other words whether it was imported or not.

These blocks in the S7 program are not yet known to CFC (even if a block of this
type has already been imported). This means that when you want to insert a block
from the S7 program into the chart, a check is always made to determine whether
the block has already been imported.

Blocks that have already been imported are in one of the block families or, if the
block is not assigned to a family (specified in the header), it will be in the “Other
Blocks” folder.
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Note

Inserting blocks from the block families is the fastest way of placing blocks in your
chart since no check is required. You should always select this method when a
block type has already been imported.

Specifying Run-Time Properties

When you insert a block, its run-time properties must also be specified, for
example the point at which the block is inserted in the run sequence.

Default rule: The block is always inserted after the block displayed in the status
bar.

You can change the installation position by selecting the block that will count as the
“predecessor” for the next block to be installed and then selecting the menu
command “Edit > Predecessor for Installation”.

The current insert point is displayed to the right in the status bar. It displays the
task name as well as the chart and block name after which the next block will be
installed in the run sequence when a block is inserted in the CFC chart.

For more detailed information about run-time properties, refer to Section 3.7.

Aligning Blocks in the Chart

You can automatically align blocks inserted and selected in the chart even if they
are already interconnected. (Menu command: “Edit > Align > Left / Right / Top /
Bottom”). Exception: This menu command does not work if overlapping blocks are
selected.

The blocks are aligned at the visible edge of the block graphic (not the frame of the
selected blocks). The block furthest to the left or right or nearest the top or bottom
decides where the blocks are aligned.

If the alignment leads to a conflict, for example blocks overlapping, a message is
displayed and the old situation retained. In this case, no blocks are aligned, not
even those that normally could have been.

Inserting and Editing a Text Box

You can drag a text box (icon:  Text) from the block catalog to any position in the
chart. You can enter text after you have opened the text box with a single click.
You can adapt the size of the box to the text you have entered.

For more detailed information about editing the text box, refer to the online help.
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3.3.5 Copying and Moving Blocks

You can copy or move blocks within a chart or to other charts. It is also possible to
copy or move several or all the blocks of a chart together. This allows you to
duplicate tested substructures quickly and without errors.

It is possible to copy blocks to a different CPU. The effects on the functionality are
the same as those when copying charts to a different CPU.

The copied blocks are inserted in the other chart at the same position one grid to
the right and down. At the same position means that the block is also inserted in
the sheet with the same sheet number. 
If objects are already located at this position, the blocks are displayed as
overlapping blocks, otherwise they are displayed normally. You can then move the
blocks to the required position (this is not absolutely necessary since even
overlapping blocks can be executed on the PLC).

In terms of the run-time properties and run sequence, the behavior when copying
is the same as when inserting from the catalog; in other words, the insert point is
determined by the “predecessor for installation”. 
If the blocks were installed in run-time groups, the run-time groups are not copied.

As far as possible, block names are retained. If there is a conflict, numbers are
appended to the names.

Refer to the information in the online help.

3.3.6 Deleting Blocks

If you delete blocks, all interconnections between the deleted blocks and objects
that you have not deleted are lost.

If an output is connected to a block that you are not deleting, a warning is
displayed. If you decide to delete, instead of the capped interconnections, the
inputs of the block that is not deleted are assigned the default parameter values.
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3.4 Editing Blocks

Editing blocks in the chart means modifying their properties.
Properties can relate both to an entire block or to individual inputs and outputs.
The setting of properties of inputs and outputs is described in Section 3.5.

3.4.1 Setting Object Properties

The  “Properties - Blocks” dialog box contains tabs with which you can set
properties. These are as follows:

“General” Tab

All the properties that you assigned when you inserted the block (and the
system-specific options in the “Special Object Properties” and “Import/Export
Assistant” boxes).

The Name of the block is unique throughout the entire chart and is displayed in the
block header (maximum 16 characters).

The Comment  is a freely selectable text that appears in the block header. A
maximum of 14 characters of this comment are displayed in the block header. In
small blocks, the comment is not displayed.

“Inputs/Outputs” Tab

You can assign parameters to block I/Os, add comments to them, include them in
the watch list etc. see also Section 3.5.

3.4.2 Changing the Number of I/Os.

If the block has a variable number of inputs and the same data type, for example
NAND, OR etc., you can change the number of block inputs using the “Edit >
Number of I/Os...” menu command.

The number of inputs is adapted according to what you select in the dialog box. If
inputs are added, there may no longer be enough space for the block, in this case,
it is displayed as an overlapping block so that you can move it (within the chart).
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3.5 Modifying the Properties of Inputs and Outputs

You can modify the properties of the block I/Os. Two different dialogs are available
for this purpose:

• The dialog to edit all I/Os  of a block is in the “Inputs/Outputs” tab of the
“Properties - Block” dialog box that you can display by double-clicking the block.
In the “Inputs/Outputs” tab, you will see all the properties of the I/Os in table
form.

• For a single I/O , open the “Properties - Input/Output” dialog box by
double-clicking the required block I/O. 
Depending on the properties and data type of the I/O, the dialog box will contain
different information some of which can be edited and some of which is read
only.

3.5.1 Inverting a Block Input

Binary inputs can be inverted. After inversion, “0” becomes “1” and “1” becomes
“0”. This is only possible with interconnected inputs.

Setting the Inversion

You invert an interconnected binary input by selecting the input and clicking the
 button in the toolbar.

As an alternative, you can also double-click the block input to open the Properties
dialog box and then select the “Inverted” option.

Clearing an Inversion

To cancel the inversion, repeat the functions described above.

You can also cancel the inversion by deleting the interconnection at the input or
moving it to another input or making a new connection to the input.

Points to Note:

• If you copy a signal from an inverted input to another input, the new input is not
automatically inverted. You must invert an input explicitly.

• If you move an interconnection from an inverted input to a non-inverted input,
the new input is not automatically inverted and the inversion is canceled at the
input that is no longer interconnected.

• Inputs assigned to a chart I/O cannot be inverted. 
Solution: Insert a NOT block into the connection.
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3.5.2 Value Identifiers

In addition to the identifiers “Text for 0” and “Text for 1” for the Boolean values 0
and 1, value identifiers are also possible for some numeric data types (BYTE; INT,
DINT, WORD, DWORD).

Creating Value Identifiers

Using the value identifiers for the parameter values of the block or chart I/Os, you
can define symbolic names. You make this definition with the system attributes
(“S7_string_0” to “S7_string_25”) when you create the block type or when you
create the chart I/Os.

The text for “S7_string_0/1” can have a maximum of 16 characters and for
“S7_string_2 to 25” it can have 8 characters. Only 8 characters are displayed. If
you use more than 8 characters, you can decide which characters are displayed.
You do this by including the “=” character in the text.

• If the equality sign (=) is included in the text, the first 8 characters to the right of
the equality sign are displayed.
Example: Motor=ON; Motor=OFF4567890; ON or OFF45678 is displayed.

• If the text does not include the equality sign, the first (left) 8 characters are
output.

Displaying and Modifying in the Chart

With the data type BOOL, the value identifiers for “Text for 0” and “Text for 1” can
be changed in each instance if the system attribute is defined at the I/O of the
block type. With all other data types, no individual modification in an instance is
possible.

In the chart, you can decide whether the symbolic value identifier or the absolute
value is displayed. In the “Customize Layout” dialog box, you can activate or
deactivate the “Parameter: Value identifier” (“Options > Customize > Layout...”).

If value identifiers are defined for an I/O, you can select them in the properties
dialog. The “Value” box then contains an additional button to open the drop-down
list box. The selected value identifier is then displayed at the I/O.
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3.6 Interconnections

In a CFC chart, an interconnection is the connection between

• an output of a block/chart and

– one or more inputs of another or the same block or chart

– an output of a chart

– a run-time group (only BOOL data type)

– objects outside the CFC data management (for example shared addresses)

• an input of a block/chart and

– a chart I/O (within a chart)

– objects outside the CFC data management (for example shared addresses).

• The data types of the input and output must be compatible. The interconnected
blocks/charts can be in the same sheet, in different sheets of the same chart, or
in different charts belonging to the same CPU.

Note

Each interconnectable input or output of a block is displayed with a connector pin
in the chart. Inputs that cannot be interconnected because they have the attribute
“S7_link := false” can be recognized because the connector pin is missing. 
Such inputs cannot be interconnected either with the I/O of a block or nested chart
nor with shared addresses. If, however, the CFC chart has chart I/Os, it is possible
to connect such inputs to a chart I/O of its own chart.

You can also modify (rewire), copy, and delete these interconnections. By tracking
signals (see 3.6.4) and using the sheet bar jumps, you can navigate through the
chart.

Interconnections from one sheet to another or from one chart to another can be
created easily by opening several windows at the same time and using the sheet
view.

Note

Certain interconnection rules apply to block I/Os of the following data types: ANY,
STRING, STRUCT, and DATE_AND_TIME: 
For more information, read the interconnection rules in the online help.
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3.6.1 Interconnections to Shared Addresses

Shared addresses are connection endpoints located outside the CFC charts. The
different PLCs recognize different shared addresses (for example in [S7]  shared
data blocks, I/O signals, memory bits, timers, counters).

You can specify the addresses in symbolic or absolute form. You must, however,
keep to certain conventions. A sheet bar entry with a connection to the destination
block is then created.

If you use symbolic addressing, the symbols of the addresses must exist in the
symbol table. For more detailed information about possible interconnections and
examples of symbolic and absolute addresses, refer to the online help.

3.6.2 Interconnections to Run-Time Groups

You can disable and enable run-time groups dynamically. This means that an
output value of a block decides whether a particular run-time group is executed or
not. To achieve this, you connect the binary output of a block with the enable
attribute of the run-time group.

Inserting Interconnections

With the “Insert > Interconnection to Run-Time Group” menu command, you
display a dialog box with a list of all the tasks on the CPU and a list with the
corresponding run-time groups. After selecting the required run-time group
(double-click), the interconnection is entered in the sheet bar.

Deleting Interconnections

If you delete the run-time group, the interconnection is automatically deleted. The
Enable attribute of the run-time group is set to “1” again.

To delete the run-time group, select the small field in the sheet bar and press “Del”.
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3.6.3 [S7] Interconnecting with SFC Charts (CFC in PCS 7)

SFC Access

A special form of interconnection is direct SFC access from actions or transitions
to inputs or outputs (of the block or nested chart) in the CFC chart.  This type of
SFC access can be “rewired” in the CFC chart; in other words, it can be moved
from one I/O to a different I/O with a compatible data type. If the I/O is
interconnected, you can decide whether only the SFC access or also the
interconnection will be moved.

• Only move the SFC access : Hold down the ALT key and drag the selected I/O
to the required new I/O. The SFC access symbol is moved to the new I/O; any
existing interconnection is not moved.

• Move interconnection and SFC access : Drag the selected I/O to the required
new I/O. A message is displayed asking whether you want to move the SFC
accesses as well. If you answer with “yes”, the interconnection and the SFC
access are moved, if you answer with “no” only the interconnection is moved.

• Delete the SFC access : You cannot delete an SFC access in the CFC chart.

In the CFC chart, a marker on the block I/O indicates these SFC accesses. Write
and read access are indicated differently.

A marker above the I/O means “read access” and below the I/O means “write
access”. The color of the marker is the same as used to indicate the data type of
the connection.

SFC References

You can display the SFC references in the “Properties - Inputs/Outputs” dialog. If
the I/Os involve SFC access, this dialog box contains the “SFC Access...” button
with which you can display a dialog box with the list of SFC references.

Double-click the name of a listed SFC chart to open the relevant chart where the
referenced object is displayed as selected.
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3.6.4 Handling Interconnections

Tracking Signals

Even when there are a lot of interconnections displayed in a sheet, you can
nevertheless track the path of an individual connection.

Click the line or the large field in the sheet bar, all the lines and sheet bar entries,
including those in overflow pages, that are connected to the selected line start to
flash. You can track signals along branched lines and beyond connectors.

To stop the flashing, simply click a free position in the chart.

Jump from a Sheet Bar

If you double-click the large field in the sheet bar, you can move quickly to the
interconnected block on the other sheet or in the other chart.

The sheet or chart in which the connected block or nested chart is located
appears. With block interconnections, signal tracking is activated (line flashes),
with nested charts, the relevant chart I/O is selected.

If the destination of the jump is an overlapping block the block alone is fetched to
the center of the screen and selected. Since I/Os and connecting lines cannot be
displayed, signal tracking is not possible in this situation.

With the “Edit > Go To > Jump Back” menu command, you return to the point at
which you started the jump even if you have closed the selected chart or have
deleted the block.

Copying Interconnections

To copy an interconnection, select the connected input, press and hold down the
Ctrl key and the left mouse button and then drag the mouse pointer to the required
input (of the same type). When you have reached the required input, release the
mouse button first and then the Ctrl key. A further connection is created.

Copying in this way is extremely convenient particularly when the interconnection
originates in a block from a different chart, since you do not need to find the
source.

Modifying an Interconnection (Rewiring)

You can move existing interconnections from one input to another input or from
one output to another output.
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• Input:

Position the mouse pointer on the input whose interconnection you want to
move to a different input and hold down the mouse button. Then drag the
mouse pointer to the other input (of the same type) and release the button. The
connection line is redrawn.

• Output:

– If you have multiple interconnections, they will all be moved to this output.

– If you drag the interconnection with an address to an output that is already
connected to the same address, a warning is displayed. You can decide
whether to retain the interconnection with the original block or delete it.

If you want to rewire an interconnection that is also accessed by an SFC chart, you
will be asked if you want to move the SFC access as well.

Deleting Interconnections

You delete an interconnection as follows:

• Multiple interconnections:

–  If you want to delete all the interconnections  of an output, select the
output or the connection line(s) and select the “Edit > Delete” menu
command or press the DEL key.

– If you want to delete one of several interconnections  of an output, select
the input and press the DEL key
or
position the mouse pointer on the sheet bar entry of the output and click the
right mouse button. The small field before the sheet bar entry is selected.
Select “Delete Interconnection(s)” in the context-sensitive menu and the
interconnection to the input will be deleted. You can, of course, also click the
small field in the sheet bar directly and delete the relevant interconnection
with DEL or with “Edit > Delete”.

• Single interconnection:

You can select the output, the input or the connecting line and delete the
interconnection with the “Edit > Delete” menu command or with the DEL key.

Note: An SFC access cannot be deleted in an SFC chart.

3.6.5 Structures

Using a structure, any data can be put together in a tree structure and then applied
to a block I/O. In the block display, a structure has an I/O name and a type; the
type is “ST”.
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A structure is made up of several elements (with a nesting depth of up to 8 levels):

• Elementary data type (BO, WO, .. )

• Structure

A structure element contains the following information:

• Type (of the elementary data type, otherwise “ST”)

• The name

• The value (only with the elementary data type)

Interconnecting

A block I/O with a structure can only be interconnected with another structure and
not with an elementary data type. The structures to be interconnected must be
compatible; in other words, the order, the data type, and the element name of the
elementary data types contained must be identical. The names of the structures
can be different.

The elements within a structure cannot be interconnected separately, only the
block I/O can be interconnected as an entire structure.

For more detailed information, refer to the online help.

Editing the Elements of the Structure

You can display the object properties of the structure or of an elementary data type
in the structure and edit it (assign parameters).

Double-click the block I/O to display the “Select Structure Element” dialog. In the
structure that appears, select the element you want to edit and open the Properties
dialog with the “Properties” button (or by double-clicking the element). You can
display the dialog box both in the Edit and in the Test mode.

If you want to watch a structure in the test mode, you can include individual
structure elements in the dynamic display by opening the “Select Structure
Element” dialog box (context-sensitive menu “Include in Dynamic Display”).

Note:

• In structures, the system attributes for “operator control and monitoring” or
“message” must not be used at any point.

• Structures cannot be edited in SFC.

• A block I/O with a structure cannot be interconnected with a shared address
that refers to an entire data block (DBx); interconnections to structures within
the DB are possible (DBx.name_st).
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3.7 Run-Time Properties of the Blocks

There are several ways in which you can display the run-time properties; either for
an individual block or for the entire CPU.

Single Block

The run-time properties of each block are displayed in the part of the block header
on a colored background.

AND
TE_EN

OB 33
2 / 3

Task name

Position of the run-time group in the task
or 
position of the block in the task

Position of the block in the run-time group
(for a block in a task, “-” is displayed here)

Run-time properties field

Figure 3-2 Block with Run-Time Properties Field

If the block is installed more than once, the last position at which the block was
installed manually is displayed.

Entire CPU

You can obtain a complete view of the run sequence as follows:

• By double-clicking the run-time properties box in the block header. 
The run-time editor is started and the task in which the block is installed (first
point of installation) is opened in the run sequence window. The relevant block
is selected.

• By selecting the “Edit > Run Sequence...” menu command or clicking   .
The run-time editor is started and the window with the run sequence is
displayed. If a block was selected, the task in which the block is installed (first
installation point) in the run sequence is opened. The relevant block is selected.
In this window, you can edit the run sequence of the entire CPU (see Section
3.7.1).

• By selecting the “Options > Chart Reference Data...” menu command. A
separate application with its own window and menu commands/toolbar buttons
is started. In the “Run Sequence” view (activated with “View > Run Sequence”

or by clicking the  button), the complete run sequence of the current CPU
is displayed (with comments and run-time attributes). The tasks in which
objects are installed are opened. You can print out the view of the run sequence
as a list. 
In this window, you cannot edit the run sequence.
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Installing in a Task

When you insert blocks in a chart, each block is assigned run-time properties. It is
therefore installed in a task. The insert point is decided by the “Predecessor for
Installation”. The default insert position can be after a block or a run-time group in
the task. If the predecessor is a run-time group, the default insert position can be
after or in the run-time group.

Each block must be installed at least once. A block can be installed in several
tasks, however only once per task.

3.7.1 Editing the Run Sequence

With the “Edit > Run Sequence” menu command or by clicking   in the toolbar

or by double-clicking the run-time properties field in the block header, you open the
window for the run sequence.

The chart window is not closed. Using the “Window > Arrange” function, you can
display both windows or switch over between them.

The left-hand part of the window contains the complete structure (tasks, run-time
groups, and blocks); the right-hand side contains details. The installed objects are
displayed in four columns (name, type) along with the installation positions and
comments.

You can drag an installed object to a different position in the run sequence with the
mouse or copy it by dragging and holding down the CTRL key.

You can also drag a block from the CFC chart to the required position in the run
sequence.

In the window of the run sequence, you can search for the insert point of an object
by selecting the “Edit > Find” menu command. In the dialog box, you can select the
object you want to find using the option buttons (Task, Group, SFC or Block).

To find a block installed in the run sequence in the CFC chart, select it and then
open the context-sensitive help with the right mouse button and select “Go To
Chart” (or select the same function in the “Edit” menu). The chart is opened and
the block shown as selected in the sheet view.

For more detailed information on working with the run-time editor, refer to the
online help.
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3.7.2 Run-Time Groups

Applications

Run-time groups are optional. They are used to structure tasks (OBs). The blocks
are installed sequentially in the run-time groups.

With the run-time groups, you can do the following:

• Remove or reconnect selected blocks for execution on the PLC. (Run-time
groups are activated or deactivated using a block output of the data type
“BOOL”).

• Execute selected blocks with a specific scan rate (every nth number of cycles)
and/or with a phase offset to achieve better load balance on the CPU.

• If OBs contain a large number of installed blocks, these can be put together in
smaller units.

Advantage:  Instead of creating one “large” FC when you compile each OB,
“smaller” FCs are created depending on the number of run-time groups.

If the program is modified later, only the run-time groups/FCs that actually
contain modified blocks are given the “modified” ID. 
This means that later delta compilations and online downloads of changes take
far less time.

Creating a Run-Time Group

You create a run-time group by selecting the task in the left-hand window in which
the run-time group will be installed or the object following which the run-time group
will be installed. With the “Insert > Run-Time Group” menu command, you start the
“Insert Run-Time Group” dialog. Here, you can specify the properties of the
run-time group.

Editing and Deleting Run-Time Groups

You can also edit run-time group properties later.

To edit , select the run-time group (in the left or right window) and then select the
“Edit > Object Properties...” menu command.
In the “Object Properties” dialog box, you can modify the name/comment and the
values entered for phase offset and scan rate.

You can delete  run-time groups only when they contain no objects. To delete a
group, select the run-time group and then select the “Edit > Delete” menu
command.

If the deleted run-time group was selected as the “Predecessor for Installation”, the
insert position becomes the next element of the task before the deleted group, or if
no further element exists, the start of the task.
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3.8 [S7] Generate Module Drivers

To allow signal processing in PCS 7, a function is available that automatically
generates the required module drivers and interconnects them after you have
configured the hardware with HW Config and configured the technological
functions in CFC. You can use this function as follows:

• You can set the option in CFC in the “Compile Charts as Program” dialog box.
The module drivers are then generated before compilation.

• With the chart folder selected, you can activate the function in the SIMATIC
Manager with the menu command “Options > Charts > Generate Module
Drivers...”.

The driver and message concept described here can only be used for CPUs of the
S7-400.

Driver and Message Concept

For this functionality, blocks types are used that have the effect of separating the
hardware and software configuration:

• The channel-specific blocks (CH blocks) are inserted in the CFC chart and
interconnected by the user with appropriate signal names from the symbol
table. The CH block is a signal preprocessing block that can have parameters
assigned and be interconnected independent of the hardware. This makes it
part of the technological functions and it is always processed along with them. 
There are four different types for the signal preprocessing of analog input
values (CH_AI), analog output values (CH_AO), digital input values (CH_DI),
and digital output values (CH_DO). 
For more detailed information on the functions and functionality of the CH
blocks, refer to the context-sensitive help (F1) for the block.

• The multichannel blocks (MOD blocks) for the module-specific functions are
created (in other words, inserted in a system chart from a block library),
assigned parameters and interconnected automatically by the system. 
The MOD block is also known as a diagnostic block. It handles all special
situations such as startup and error situation, for example providing process
control messages and the value status (1 = good, 0 = bad) of the signals.

• To ensure that not all MOD blocks report a rack failure if a rack fails, a RACK
block is also used automatically per rack in addition to the diagnostic block. 
The RACK block is then responsible for signaling in this case; in other words,
the MOD blocks recognize in OB86 that the situation is being dealt with and do
not signal the rack failure.

• The SUBNET block controls the run-time groups for each configured DP chain
and is used to shorten the acyclic OB execution times. If an event occurs, only
the blocks actually involved are called. The SUBNET block is also included
automatically.

• The PO_UPDAT block ensures that the start values written to the process
image by the CH_AO and CH_DO blocks are sent to the output modules when
the CPU is restarted. This means that these values are effective immediately
when the CPU changes to RUN.
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• The MSG_CSF message block is intended to prevent errors (for example rack
failure, module failure etc.) from changing the CPU to the stop mode in PCS 7
process control systems. To allow this, the special OBs are generated and
MSG_CSF installed in them.

For more detailed information on the functions, functionality, and signaling behavior
of the RACK and SUBNET blocks, refer to the context-sensitive help (F1) for the
relevant block.

How “Generate Module Drivers” Works

A system chart is generated automatically and the MOD, RACK, SUBNET blocks
and the process control message block MSG_CSF along with the PO_UPDATE
block for outputting the process image are inserted. The system chart has the
name “@1” and can contain up to a maximum of 52 blocks (2 blocks per chart
partition). If more blocks are generated, a further system chart is created with the
name “@2” etc.

When you generate the module drivers for the first time; in other words, the driver
blocks or the MSG_CSF are not yet in the CFC data management, the blocks are
imported from the libraries . The blocks are first looked for in the path specified in
the “Settings - Generate Block Drivers” dialog box. If a block is not found in a
specified path, the standard paths specified by the setup of the PCS 7 libraries are
checked.

Note: This method prevents new versions of block types being used in the
program if blocks with the same name already exist in the CFC data management.
This prevents a central block type change for these blocks.

The MOD blocks for one rack and the RACK block are installed in run-time groups.
These blocks and the run-time groups are identified in the run sequence by the
“@” character preceding the name.

Note

Objects identified by the “@” character should not be modified by the user, but
should only be manipulated using the “Generate Module Drivers” function. In the
same way, MOD, RACK and SUBNET blocks should not be inserted manually.

Driver blocks created by the user must be inserted from the block catalog. If “@”
blocks are copied, these are deleted the next time the “Generate Module Drivers”
function is executed.

The MOD blocks are installed not only in the acyclic error OBs but also in OB1.
This ensures that they are also executed following an online download (since in
this case, OB100 is no longer run). The run-time group has a scan rate of 16; in
other words, the blocks are executed only every 16th time that OB 1 is run to
prevent unnecessary load on the CPU.
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The system checks whether the PO_UPDAT block exists in CFC.

– If it does not exist, it is imported from the library and inserted in the system
chart. It is installed at the last position in OB100.

– If the block already exists, the system makes sure that it is installed in
OB100 after the driver blocks and that it is deleted from all other OBs.

The system checks whether an MSG_CSF exists in CFC.

– If this is not the case, it is imported from the “PCS 7 Technology\Blocks”
library, inserted in the system chart and installed in the run sequence in
cyclic interrupt OB35 and in the startup/special OBs OB 72, OB 80, OB 81,
OB 83, OB 84, OB 85, OB 86, OB 87, OB 100, OB 121, and OB 122.

– No warning is displayed if there is more than one MSG_CSF.

New Block Types

If a new PCS 7 library  with modified block types is installed, initially, this has no
effects on blocks already in use.

If, however, you want to update the blocks, follow the steps outlined below:

• Delete all @ system charts in the chart folder.

• Select the “Options > Block Types...” menu command and delete the relevant
blocks in the “Chart Folder” window (select the blocks and click the “Remove”
button).

• In the component view of the SIMATIC Manager, start the “Generate Module
Drivers” function. 
New system charts are then created and the driver blocks from the new library
are used since they now no longer exist in CFC (the library is entered in the
“Settings” dialog box). If the MSG_CSF is not found in this library, it is searched
for in the path entered during setup (standard path).
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Model Session, Version 1

• The user configures the hardware with the symbolic names of the I/O signals.
The signal names are entered directly in the symbol table by HW Config (select
module, menu command in HW Config: “Edit > Symbols...”).

• The user configures the technological functions in CFC, using the CH blocks
that must be interconnected with the signal names from the symbol table
(“Insert > Interconnection to Address...”).

• The user starts the function that creates, interconnects, and assigns
parameters to all module drivers in the SIMATIC Manager with the menu
command “Options > Charts > Generate Module Drivers...”. The following
phases are run through automatically:

– All the channel blocks (CH_AI, CH_AO, CH_DI, CH_DO) used in the CFC
charts are identified. Then all the symbols (name and address)
interconnected with the “Value” I/Os are identified. Using the addresses of
the symbols in the symbol table, the corresponding module and the channel
of the module are identified from the hardware configuration data. Based on
the module type, the corresponding MOD block type is obtained and a block
instance then created in the system chart for each I/O module.

– The parameters required for the MOD blocks are obtained from the HW
Config data and entered in the block instances (also in the SUBNET block
for optimizing the run time in the error OBs).

– The interconnection between the channel-specific output on the MOD block
and the corresponding input on the CH block is created. If the module
supports “value status”, the address of the value status is obtained and
interconnected with the CH block.

If changes are made in the configuration (hardware or software), the changes must
be processed using the “Generate Module Drivers” function. The existing driver
blocks are then not deleted and recreated but simply have parameters reassigned.
Blocks that are no longer required are deleted (except for those included by the
user) and additional required blocks are created. If block types have already been
imported those from the CFC data management are used and not those from the
library.

Model Session, Version 2

• The user configures the technological functions in CFC. Here, the CH blocks
are used and they are interconnected symbolically with the signal names by
entering the signal names in the dialog (“Insert > Interconnection to
Address...”).

• The user configures the hardware with the symbolic names of the I/O signals.
The signal names are entered directly in the symbol table by HW Config (select
module, menu command in HW Config: “Edit > Symbols...”).
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Tip on configuring the hardware:

If you configured the software first and have already interconnected the block I/Os
with the symbolic names of the I/O signals (“Interconnection to Address...”) and
then want to configure the hardware, you can copy the symbol names used in the
“Cross-References of Addresses” list and use them in HW Config.

Procedure:

• Select the “Options > Chart Reference Data...” menu command in CFC and
then open the list of cross-references with “View > Cross-References of
Addresses”.

• Select and copy the required symbol name in the “Symbol” column of the
cross-reference list (Edit > Copy or CTRL + C). 
The symbol name is copied to the clipboard.
Note:  You can recognize symbols that have not yet been assigned to hardware
since they have no entry in the “Address” column.

• Open the SIMATIC station of the current project in the SIMATIC Manager
(Open Object).

• Arrange the open windows (CFC and HW Config) on the screen.

• Select the relevant module in HW Config and open the dialog box using the
“Edit Symbols...” command in the context-sensitive menu.

• Select the “Symbol” field in the line with the required hardware address and
paste the copied symbol name from the clipboard with CTRL + V.
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3.9 [S7] Compiling

When the CFC chart is complete, the SCL code is generated and converted to
machine code. You can compile the chart (in other words all the charts of the chart
folder) as a program or an individual chart as a block type.

3.9.1 [S7] Compile Charts as Program

During compilation, the charts of the active CPU are converted to machine code. In
S7, the SCL Compiler is used.

You start the compiler with the “Chart > Compile > Charts as Program...” menu
command or by clicking the  button in the toolbar.

Relationships

If you want to control the assignment of resources on the PLC using the
“Customize Compilation” function, it is important understand the relationships
explained below.

The structure you configure in CFC is mapped to the S7 machine objects FC and
DB.

FCs are required to call the blocks processed in the CFC chart according to the
configured run sequence, as follows:

• One FC for each OB used

• One FC for each run-time group

DBs are used as follows:

• An instance DB is created for each instance of an FB.

• To store interim results for example from FCs, CFC-internal DBs are created.
One of these DBs is required per data type. When the maximum length (4
Kbytes) is reached, a further DB is created.
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Notes on the SCL Compiler

Note the following points about compiling charts in conjunction with the SCL
compiler:

• With CFC, you can create SCL source files that are too large for the SCL
compiler. This can occur when there are too many blocks installed in a task or
run-time group. The FC containing the block calls becomes too large and the
SCL Compiler signals: 
“Internal symbol list full”.

Remedy: Distribute the blocks in more run-time groups. During compilation,
more smaller FCs are created since the blocks of one group are called in their
own FC.

• Compiling extremely large CFC structures can take an extremely long time in
the SCL compiler; in some cases there may be no progress visible for several
minutes.

What is Compiled?

When you compile, you can choose between two options:

• Range: Entire program
If you compile the entire program, all the PLC resources (the content of the
entire chart folder) is compiled regardless of whether changes have been made
or not.

• Range: Changes
If you compile the changes, only the PLC resources that have changed since
the last compilation are compiled. Changes are solely changes in content
(interconnections, block attributes, number of inputs etc.), but not the
movement of objects within the chart. By selecting “changes only” the time
required for compilation is significantly shorter and this should be the setting
you normally choose.

Note: When you compile the changes, only the changes are checked. If you
want to check the entire program, start the consistency check.

“Generate Module Drivers” Option

If this option is set, the module drivers for the existing signal-processing blocks
are generated and connected to them prior to compilation.

The “Settings” button opens a further dialog box in which you can select the
library of the module drivers and control the diagnostic messages for the MOD
and RACK blocks.
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“Update Sampling Time” Option

If blocks have an I/O for the sampling time (in PCS 7 blocks, the input
SAMPLE_T, attribute “S7_sampletime = true”), the sampling times can be
updated.

If you set the “Update the sampling time” option (in the compilation dialog), the
system checks which cyclic interrupt OB the block is installed in before
compiling. The cycle time of the OB is then written to this input. If the block is
installed in a run-time group, the scan rate is also taken into account when the
sampling time is calculated.

“Delete Empty Run-Time Groups” Option

If this option is set, empty run-time groups are deleted prior to compilation.

Such empty run-time groups can arise from copying and Branch&Merge.

Customize Compiler (SCL)

In the “Compile” dialog, you can display a dialog box using the “Settings” button
and adapt the compilation to your requirements. The options you can set for the
SCL Compiler are as follows:

• Generate reference data
Reference data are created automatically during compilation. This does,
however, increase the time required for compilation. You require the reference
data, for example, to calculate the local data requirements.

• Optimize object code
This optimization produces a shorter code and therefore reduces memory
requirements. This, in turn, reduces the run time although the compilation times
are slightly longer.

• Monitor array limits
During run time, a check is made to make sure that the array indexes are within
the range permitted for the array. This increases reliability, however extends the
run time.

• Create debug information
Information is generated that is required for debugging with the high-level
language debugger. The memory required by the program and the run times on
the PLC are increased slightly.

Saving Settings without Compiling

You can save the settings in the dialog box without starting compilation (“Save
Settings” button). This can, for example, be useful if you want use batch
processing for compiling/downloading for several PLCs. See also Section 3.11.
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Consistency Check

During compilation, a consistency check is made automatically. You can also start
this check manually, for example before you overwrite an old executable CFC
program by compiling.

During the consistency check and compilation, logs are created that you can
display in CFC (see Section 5).

Preparing for Compilation

With the “Options > Customize > Compilation...” menu command, you can call a
dialog box in which you can reserve FC and DB numbers for your own use. These
ranges are then not used by CFC (prohibited areas for CFC).

For explanations of the dialog and further information about the settings, refer to
the online help.

After Compiling

When the compilation is completed (or aborted), the “Logs” dialog box is displayed.
The entire compilation is logged here including warnings and errors. Based on the
log, you can check whether compilation was correct and can print out the log with
the “Print” button.

You can also display the log again and, if required, print it out with the “Options >
Logs...” menu command.

Note

Compiling the entire program does not necessarily mean a complete download. If
the program was already loaded on the CPU prior to compiling, it is possible to
download the changes only.
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3.9.2 [S7] Compile Chart as Block Type

You can create block types from existing CFC charts that you want to use more
than once. You can assign system attributes to these block types.

In this case, you start the compiler with the “Chart > Compile > Chart as Block...”
menu command; a dialog box with two tabs is then displayed.

In the “General” tab, you can specify the properties of the block type before you
compile (FB number, name, family, author, and version) and specify the PLC on
which the block will be used (S7-300 or S7-400).

You can optimize the code. For the optimization, you can choose between “local
data requirements” and “download changes in RUN”:

• Local requirements:
With this type of optimization, a change in the chart does not increase the local
data requirements, since all temporary variables are stored in the instance DB
(VAR area). This does, however, lead to a change in the structure of the
instance DB and to a change in its interface time stamp. In this case, no online
download of changes is possible.

• Downloading changes in RUN:
With this type of optimization, if there is a change in the chart, the temporary
variables are stored in the VAR_TEMP area, as far as possible. As far as
possible means that all interim results in the data flow are stored here. Only the
interim results that are not in the data flow (for example in feedback loops)
continue to be stored in the VAR area (instance DB). The advantage of this
optimization is that not all changes lead to a change in the interface time stamp
of the instance DB, so that in most cases the changes can be downloaded
online. One disadvantage is that the local data requirements are increased.

As an option, you can also activate the know-how protection. As a result of this,
the algorithm of the block can only be seen and, if required, modified when the
suitable SCL source files exist.

Using the “Customize Compiler (SCL)” button, you can adapt the compilation to
your own requirements (see above).

In the “Attributes” tab, you can enter the system attributes for the block type (for
example the system attribute “S7_blockview” value “big”).

For further information, refer to the online help.
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3.10 Downloading the User Program to the PLC

To test a user program for a CPU and to start it up, it must be downloaded to the
PLC. 
The program is downloaded to the CPU assigned to the active chart.

Note

With the programs created in CFC, you must always download to the PLC from
CFC, since only the download function of CFC guarantees the consistency of the
configuration data with the PLC data.

The same download function is also used if you select the “PLC >
Compile/Download Programs” menu command in the SIMATIC Manager.

On the other hand, copying blocks in the “Offline Block Folder” to insert them in
the “Online Block Folder” is not permitted.

Downloading

To download the user program, select the “PLC > Download” menu command (or
click the button in the toolbar  ).

A dialog box is then displayed in which you select the type of download and start a
further dialog for options.

If download-relevant changes have been made to the program, a message is
displayed indicating that the program must first be compiled and you are asked
whether you want to compile and then download.

[S7] Download

You can download a program in one of two ways: “Entire program” or “Changes
only”. If you select “Entire program”, all loadable objects of the program are
downloaded; if you select “Changes only”, you download only the changes since
the last download.

The “entire program” can be downloaded in the STOP or RUN-P modes. In the
RUN-P mode, the CPU is set to STOP after a prompt for confirmation and all the
blocks it contains are cleared. After successful downloading, the message “Do you
want to restart the CPU?” appears; answer with “Yes” to trigger a warm restart.

You can download “changes” in the “RUN-P” CPU mode. The correct download
order with the granularity required for the data to be downloaded is maintained.
Please note that there is no absolute guarantee that the CPU will not change to the
STOP mode due to inconsistencies. 
The system runs a wide range of checks that prevent a download if an error is
detected. Refer to the CFC online help “Downloading the User Program to the
PLC” and the topic “System Support for Avoiding Causes of CPU STOP”.
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Note on H CPUs:  If the H CPU is in the solo mode, for example after the failure of
a CPU and there was a CPU failover, an online access results in a selection dialog
being displayed. In this dialog, you can select the required CPU. In the redundant
mode, this dialog does not appear.

Note on F systems: You can only download programs with modified F
components after entering an F password. Without this legitimization, downloading
is aborted.

!
Caution

Further causes of a stop are listed in the online help topic “Reasons for STOP
when Downloading Changes Online”. Please read this topic before you download
changes online to the CPU in the “RUN-P” mode.

Option: Include user data blocks

If this option is set (default setting) when you download changes, the data blocks
that are not in the CFC area are handled as follows:

• They are included in the download if the time stamp is different or data blocks
have been added.

• They are deleted on the CPU if they do not exist in the S7 program.

If you want the user data blocks to be ignored when downloading changes,
deactivate the option.

This can have the following consequences:

• If a user data block exists in the S7 program but does not exist on the CPU,
downloading will be aborted with an error message.

• If the user data block exists on the CPU but no longer exists in the S7 program
a warning is displayed; this is also the case if the user data block in the S7
program differs from the block on the CPU. Correct execution of the program is
then the user’s responsibility.

Saving Settings without Downloading

You can save the settings in the dialog box without starting the download (“Save
Settings” button). This can, for example, be useful if you want use batch
processing for compiling/downloading for several PLCs. See also Section 3.11.
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3.11  [S7] Compiling and Downloading to Several PLCs

Using batch processing, you can compile and/or download all the S7 programs of a
project containing a chart folder.

This function is particularly useful when you need to compile and download
programs for several PLCs. Examples:

• Distributed engineering: All the configured data are copied to the master project
where they are compiled and downloaded.

• Central block type change: A block type used in several PLCs needs to be
changed. After importing the block type into the CFC data management of the
PLCs, all the charts must be compiled and downloaded.

To make sure that the job is executed without stopping, you should check and
adjust the settings in the compilation and download dialogs. In these dialogs, you
can save the settings (“Save Settings” button) without actually starting the
compilation or download.

Note on F Systems:
Downloading programs with modified F components is only possible after entering
an F password. The job for this program is canceled all following jobs continue to
be executed. Downloading programs with unchanged F components does not
require a password; in other words the job is executed. Compiling programs with
modified F components is possible however they cannot be downloaded.

Sequence
In the SIMATIC Manager, select the “PLC > Compile/Download Programs...” menu
command.

All the programs are listed in the dialog box in the form of a job table. You can
decide whether each program will be compiled and/or downloaded. Status displays
indicate whether or not the job was executed free of errors.

The “Compile” and “Download” jobs display their own dialog boxes when they are
executed. Here, you can cancel the particular job with the “Cancel” button. A
message is then displayed asking you whether you want to cancel the
compilation/download of all remaining programs. If you answer “no” only the
compilation or download of the current program is canceled and you go on to the
next program in the job list. If you answer with “yes”, the entire operation is
canceled; in other words, no further job is executed.

If you cancel all the jobs, the status display for “Aborted by user” is displayed in the
line of the aborted program; the other jobs that have not been executed retain their
selection identifiers.

If the job for a program was aborted due to an error, this does not affect the other
jobs. Exception: If a compile job is aborted, the program cannot be downloaded.

Once the job list has been worked through, the dialog box remains open so that
you can see the results based on the status displays.

If you require more detailed information about the actions and errors, you can view
the logs of each individual program by selecting the status display box and clicking
the “Logs” button.
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3.12 [S7] Reading Back Charts

Modified Data

You can save (read back) the parameters of all CFC charts contained in the chart
folder of the active chart and whose PLC data were changed (for example limit
values or control parameters changed by operator input from an OS with WinCC).

Reading Back

You start the read back function with the “Chart > Read Back....” menu command.
If you select “Program of the CPU” as the source in the “Read back” dialog box,
the program on the CPU (online block folder) is read back to the chart folder with
the current parameters.

Another method of reading back when you previously read out the data from the
CPU using the SIMATIC Manager (with the “PLC > Upload Station” menu
command) is to specify “Program Offline” as the source in the “Read Back” dialog
box. The data are then read from the offline block folder and written to the chart
folder.

In either case, in the dialog you can select whether you want to read back all
parameters of the block inputs or only the parameters assigned the system
attribute for “operator control and monitoring” (S7_m_c:=’true’).

Notes on Reading Back

• If the block types used in CFC were modified later, the blocks on the CPU no
longer match the (modified) configuration in CFC. When you read back the
chart, a message is displayed with the list of blocks that have a different time
stamp. You can then decide whether to continue reading back or not.
Incompatible blocks are, however, not read back.

• If charts contain nested charts, the nested inputs (assignment to the chart I/Os)
of the nested charts cannot be read back.

• Values of FC inputs and the data types ANY, ARRAY, POINTER, UDTYPE are
ignored during the read back.

• If values are modified on the PLC and the chart is then read back, these
modified values are marked as downloaded, in other words if you then
download changes to the CPU, these values are not included.

• Certain blocks can be excluded from the read back function (for example
BATCH blocks). In this case, the block type has the attribute S7_read_back :=
’false’. The attribute cannot be modified for specific instances.

• Note on H CPUs:  If the H CPU is in the solo mode, for example after the
failure of a CPU and there was a CPU failover, an online access results in a
selection dialog being displayed. In this dialog, you can select the required
CPU. In the redundant mode, this dialog does not appear.
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Test and Commissioning

Overview

To support you when commissioning a new project, the CFC editor includes test
functions allowing you to monitor and, if necessary, modify the block I/Os on the
PLC.

4
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4.1 General

The CFC editor has two operating modes: The Edit mode and the Test mode.

• In the Edit mode, you configure the entire software structure for a CPU offline
(see also Section 3 “Working with the CFC Editor”).

• When you change to the Test mode, you can monitor and assign parameters to
the block I/Os; in other words, monitor and modify values online.

During a test, there must be a unique assignment between objects in the graphic
program representation and the physical addresses on the CPU. For this reason,
in the Test mode, in contrast to the Edit mode, you cannot make changes that
affect the structure of the user program (for example inserting or deleting blocks,
changing interconnections from inputs and outputs etc.).

Further Test Functions

• To allow you to monitor specific block I/Os in different blocks and charts of a
CPU at once, you can collect these I/Os in a dynamic display window and
display the constantly updated values.

• In addition to the direct test functions, there is also a group of functions that
help you to prepare for test and startup, for example displaying module
information, setting the time of day etc.

Requirements:

To use the test and commissioning functions, the user program created in the CFC
editor must first be compiled free of errors and downloaded to the CPU.
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4.2 Functions Before and During the Test

In addition to the direct functions, there are also other functions that you will find
helpful for testing and commissioning. These include the following:

• General functions such as “Set Time and Date”

• Functions that support you during system diagnostics and troubleshooting, such
as displaying the mode or module information.

These functions are described below.

4.2.1 Comparing the Time Stamp of the CPU Program

You can display the time stamp of the loaded user program with the “PLC >
Compare...” menu command.

Three time stamps are displayed in the dialog:

• The last download-relevant change

• Last offline program change

• Last online program change

Note

The “Last download-relevant change” time stamp is also changed by assigning
parameters to block I/Os in the Test mode.

The user program that you downloaded to the CPU is only identical with the user
program in CFC and the machine code when all the time stamps are identical.

From the time stamps that match or do not match, you can see where changes
have been made in the user program and can decide whether you need to
recompile or download again.

4.2.2 Starting and Stopping the CPU Program

You can start or stop the CPU program by selecting the “PLC > Operating Mode...”
menu command and then clicking the appropriate button “Cold Restart”/“Hot
Restart”/”Warm Resart” or “Stop” in the dialog box.

This function is identical to the corresponding function of the SIMATIC Manager.
This procedure is described in the online help of the SIMATIC Manager.
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4.2.3 Clearing/Resetting a CPU

Clearing or resetting means that the entire user program on the CPU and all the
existing connections are deleted. The CPU must be in the STOP mode.

This function is identical to the corresponding function in the SIMATIC Manager
described in the online help of the SIMATIC Manager.

Note

If you download the entire  user program, all the blocks on the CPU are deleted
after you confirm a prompt. In this case, you do not need to clear the CPU
memory first. When you clear the CPU memory, not only the user data of the CPU
but also the connections to the module are deleted.

4.2.4 Set Time and Date

You can set the “Date and Time” on a particular CPU by selecting the “PLC > Set
Time and Date...” menu command.

This function is identical to the corresponding function in the SIMATIC Manager
described in the online help of the SIMATIC Manager.

4.2.5 Displaying Module Information

You can display the current status of the CPU module with the “PLC > Module
Information...” menu command.

This function is identical to the corresponding function in the SIMATIC Manager
described in the online help of the SIMATIC Manager.
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4.3 Working in the Test Mode

To support you during commissioning, the CFC editor provides test functions that
allow you to monitor and influence the execution of the blocks on the CPU and, if
required, to change settings.

The Test mode relates to the CPU belonging to the currently active chart.

Changing the Watch Cycle

I/Os that are watched in the Test mode, are updated cyclically with the values from
the CPU.

The default for the update cycle time of these I/Os is two seconds. This setting is
CPU-specific; in other words, it applies to all charts of the current chart folder.

You can change the cycle time in the Edit or Test mode, as follows: “Debug > Test
Settings...” opens a dialog box in which you can set the time for the watching
cycle.

Test Modes

Testing can be done in one of two modes:

• Process Mode

• Laboratory Mode

You can select the mode for the test in the Edit mode using the menu commands
in the “Debug” menu. It is not possible to change over once you are in the Test
mode.

In the process mode , the communication for online dynamic display of the blocks
is restricted and causes only limited extra load on the CP and bus. When the Test
mode is activated, all blocks have the status “watch off”.

The laboratory mode  allows convenient and efficient testing and commissioning.
In the laboratory mode, in contrast to the process mode, communication for online
dynamic display of CFC charts is unrestricted. When the Test mode is activated, all
blocks have the status “watch on”. You can monitor the I/Os registered for testing.

[S7] Note on H CPUs

If the H CPU is in the solo mode (for example due to the failure of a CPU) and a
CPU failover has taken place, when there is an online access, a selection dialog is
displayed. In this dialog, you can select the required CPU. In the redundant mode,
this dialog does not appear.
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Activating the Test Mode:

Select the “Debug > Test Mode” menu command or click the button  in the
toolbar. The Test mode is activated. You can now activate the debug menu
functions; Most of the functions of the Edit mode become inactive.

If the user program has been modified in the meantime, a message will be
displayed when you change to the Test mode.

Deactivating the Test Mode

When you deactivate the Test mode, the test functions become inactive and the
functions of the Edit mode are activated again.

You deactivate the Test mode by clicking the button   again in the toolbar or
by selecting the “Debug > Test Mode” menu command.
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4.4 Monitoring and Assigning Parameters to Block I/Os

I/Os that are registered for testing, are supplied with the current values from the
CPU in the Test mode if “watch” is activated for these I/Os.

When you activate the Test mode, the “watch on”  function for CFC charts in

the “laboratory mode” is automatically activated.

This means that in the Test mode, you can display the development of the values
of block /chart I/Os registered for display; in other words, the values are read out
cyclically from the CPU and displayed. You can modify the options for this dynamic
display and the parameters of the I/Os in the Test mode.

In the “process mode”, the “watch off” function    is automatically activated.

This means that you must first select the blocks for dynamic display (in the chart)
that you want to monitor; following this, you select “watch on”.
If, on the other hand, there is an overload, you can remove individual blocks/charts
from the watch list (select the block/chart and then the “watch off” menu
command).

Caution:  If watching is deactivated and you select an I/O to register for the test
with  , monitoring is activated for this and all previously registered I/Os of this

block.

When you activate the test mode, the connections to the CPU are established for
all I/Os listed in a dynamic display window. You activate the “watch” function with a
check mark in the “Watch” column for the individual I/Os.

Note

• You cannot watch block I/Os that are not stored in DBs. This also applies, for
example, to unconnected inputs of FCs or BOPs and for outputs of the data
type STRING, DATE_AND_TIME, ANY.

• In the Test mode, function blocks (FBs) do not indicate the value of the
connected source at interconnected inputs if EN=0 is set. The value with which
the block was last executed is displayed at these interconnected inputs.
Remember that the value of interconnected inputs can change when EN=0 is
set to EN=1. FCs and BOPs, on the other hand, always show the value of the
interconnected source.



Test and Commissioning

4-8
CFC for S7 

A5E00083002-02

4.4.1 Block and Chart I/Os in the Chart Window

Adding/Removing I/Os in the Watch List

In the Edit mode or in the Test mode (process or laboratory mode), you can
register individual block or chart I/Os for testing by selecting the I/O and then the
“Debug > Inputs/Outputs > Add to Watch List” menu command or by clicking the

  button in the toolbar.

In the Test mode, watching is also activated at the same time; in other words, the
I/O is shown on a yellow background and is displayed with its current value. If
watching had been deactivated for this block/chart previously, the watch function is
activated for all other I/Os that were previously added to the watch list.

You can remove I/Os from the watch list by selecting the I/O and then selecting the
“Test > Remove from Watch List” menu command or by clicking the 
  button in the toolbar.

As an alternative: You can also select and deselect I/Os of a block/chart for
testing in the Edit mode by displaying the “Object Properties” for a selected block
and selecting or deselecting the I/Os in the “Watched” column in the
“Inputs/Outputs” tab.

Note

You should avoid watching too many I/Os at one time, otherwise there is a large
communication load on the bus and on the CPU. If the load is too great (for
example >500 in the 1s watch cycle), the watchdog may respond; The I/O values
are then marked as temporarily “disturbed”.
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Activating and Deactivating I/O Watching

You activate watching (display of the current values of an I/O) of the block/chart
I/Os in the watch list as follows:

• Automatically by activating the laboratory test mode.

• With the “Test > Watch On” menu command or by clicking the  

 button in the toolbar. In the laboratory mode, this function applies to all

blocks; in the process mode only to the blocks previously selected in the chart.

• By selecting the “Test > Watch Off” menu command or by clicking the  

button, you can deactivate watching; in other words, the values of the I/Os are
no longer updated. 
In the laboratory mode, this applies to all blocks; in the process mode only to
the blocks selected in the chart.

All the input and output values activated in the watch list are updated within the
monitoring cycle.

Representation of the Values

The values are displayed beside the I/Os according to their data type. They are
shown on the screen on a colored background.

• Asterisks black on yellow   = values when changing to dynamic display

• Value black on yellow  = values read from the CPU

• #### on a red background  = while the dynamic values from the CPU cannot
be supplied (problem)

Setting Parameters for I/Os

While the test mode is active, you can modify the values of all unconnected inputs.
Before the modified value is adopted on the CPU, its validity is checked.

Please note that parameters modified in the Test mode are always included in the
CFC data management.
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4.5 The Dynamic Display

In the Test mode, the values of block and chart I/Os can be displayed dynamically
in a separate window. This is possible for the elementary data types (BO, W, R, ...)
and for structures (see Section 3.6.5, Structures).

The Dynamic Display Window

The dynamic display window can be opened and arranged in the window of the
CFC editor along with any chart windows. You can adjust the size of the window.
There is only one dynamic display window without a separate menu for all the
charts of a CPU. When the window is closed (or when the CFC editor is exited) the
content is saved (only the static content, not the values) and loaded again when
you open the window.

The dynamic display window is activated and deactivated with “View > Dynamic
Display”. This is divided into columns (you can vary the width) and includes the
following titles and information:

– Status:
In this column, a status message is displayed (for example CPU fault, value
error, ....).

– Watch
In a check box, you can decide whether or not the I/O is watched; in other
words, whether or not the value is displayed dynamically.

– Chart  displays the name of the chart. If the chart is a nested chart, the
names of the higher-level charts (parents) are also shown (for example,
Topchart\Sim_reg ).

– Block  Shows the name of the CFC block or nested chart (for example,
switch, controller, ...)

– I/O Shows the name of the I/O (for example LMN, IN1, ...)

– Value  shows the actual value of the block I/O read from the CPU (if the
check box is set in the “Watch” column). If there are problems with a value
#### is displayed.

– Unit  Shows the text for the selected unit (if it exists) (for example s, %, ...)

– Comment  shows the comment for the I/O (if it exists).

Tip:  If the text cannot be displayed completely because the column is not wide
enough, you can see the complete text in a screen tip by positioning the mouse
pointer on the column entry.
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4.5.1 I/Os in the Dynamic Display Window

Inserting I/Os

You can insert I/Os into the dynamic display in the Edit or in the Test mode. The
way in which this function works is analogous to adding and removing block/chart
I/Os in the chart window.

You can include I/Os from an open chart in the dynamic display window as follows:

• Select the required block I/O and then select “Debug > Inputs/Outputs > Include
in Dynamic Display”.

• Drag the required chart I/O to the dynamic display window with the mouse.

Block I/Os with data type STRUCT: Before the I/O is entered in the dynamic
display, a dialog box is displayed in which you can select the structure element for
the value to be displayed.

Deleting I/Os

Select the relevant line or lines in the dynamic display and remove it (or them) with
“Edit > Delete” or the DEL key.

Watching Values

You can watch or monitor the values of block or chart  I/Os without opening the
relevant charts. 
The value is displayed dynamically (on a yellow background) according to the
selected watch cycle when:

• The test mode is activated,

• The I/O (or element of a structure) has been enabled for watching (selection in
the “Watch” column)

• The connection to the CPU is established.

If an error is affecting a value, this is displayed as #### and the value of an I/O that
cannot be monitored is displayed as  ------.
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Documentation

Overview

This chapter provides you with an overview of how to create comprehensive
documentation for your CFC configuration structure. This includes the following:

• The chart

• The chart reference data

• The logs

5
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5.1 Printing a Chart

With the print function, you can print the current chart in CFC. You can set the
layout you require (“Chart > Page Setup...”) and display a preview (“Chart > Print
Preview”) of the chart as it will be printed on the printer.

Printing the Active Chart

With the “Chart > Print” menu command, you print the active chart on the default
printer.

A dialog box is opened in which you can select what you want to print, for example
“sheet”, “current chart partition”, “all chart partitions”.

If the chart has chart I/Os, the chart I/Os will be printed on a separate page in a
table (containing all the relevant information such as data type, invisible, ...). If
there are too many I/Os to fit on one page, further pages are printed.

With the “Options” button in this dialog box, you can display further print options.
Regardless of the current layout in the chart (can be set with “Options > Customize
> Layout...”), in this dialog, you can specify how the addresses, I/Os, and
information from the block headers will appear in the printout.
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5.1.1 Footers

Printing with DOCPRO

With the DOCPRO optional package, you can print the CFC chart (or the CFC
charts) along with footer data. In the footer data, a distinction is made between
global data and local data specific to a chart.

You can enter the global data for the project using DOCPRO or the SIMATIC
Manager; the local chart-specific data must be entered with the CFC editor.
Remember that the data specific to a chart overwrite the entries of the global data
for the particular chart.

You can also enter data specific to a chart even when you have not installed the
DOCPRO optional package. This data is saved and can be printed later when
DOCPRO is available for print jobs.

The footer  includes a fixed field with the continuous page number of the print job.
With jobs up to 99 pages, both the consecutive number and the total number of
pages is shown; for example, 2/14. 
If the job covers more than 99 pages, the total number of pages is not shown
however the page number is followed by a “+” to indicate that there are more
pages to come; for example 1+ .... 7+ etc. 
The number of the last page is followed by a “-”; for example 127-.

In the global footers, you can enter keywords  that are replaced by the actual texts
when you print out. The current texts are taken from the Object Properties of the
chart (for example chart comment, date created etc.). The keywords you can use
and their meaning (origin) are explained in the online help for CFC.

Footer Data for a Specific Chart

With the “Chart > Footers...” menu command, you display a dialog box with several
tabs: “Part 1” to “Part 4” and “Free Fields”.

Here, you can make entries in the active fields, such as: 
Type of document, Date created, Document number, Date modified, Free texts etc.
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5.2 Chart Reference Data

Overview

With the “Options > Chart Reference Data...” menu command or by clicking the

 button in the toolbar, you can start an application with which you can display
and print a variety of information in list or tree form (see 5.2.1).

These lists help you to check your configuration structure.

Various Versions

A list created once by the system is not updated automatically. Each list provides
information about the status of the project at the time the list was created. Several
versions of these lists can be opened at the same time.

If required, you can update the list using the “View > Update” menu command or
with the “F5” key.

Further Functions

You can generate lists not only of the project currently being edited in CFC, but
also access all other CFC projects. This allows you to compare several projects.
Lists of several projects can be opened at the same time.

With the “Edit > Find...” menu command, you can search for terms (text strings) in
the active window. If a term is found, the location is displayed. 
If you double-click the name in the first column, you can open the chart in which
the point of use is located. The relevant object is then selected.

Documentation

Along with the printed charts, the reference data provide you with complete
documentation of your configuration structure.

Export

You can save the generated list as a file in the CSV format (for example for use in
EXCEL) with the “Reference Data > Export...” menu command.
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5.2.1 Lists of the Chart Reference Data

You can display and print the following chart reference data:

• Run Sequence 
Graphic display of the entire run sequence of a CPU.

• Cross-References of Addresses 
The list includes all the global addresses used in the project with the elements
that access them.

• Cross-References of CFC I/Os (SFC access only)
The list includes the accesses by all SFC charts to the CFC block I/Os.

• Cross-References of Run-Time Groups 
The list includes the accesses to all run-time groups by all CFC and SFC
charts.

• Cross-References of SFC (SFC only)
The list includes the accesses to all SFC charts by all SFC charts.

• Cross-References of Block Types 
The list includes block types used and their locations (CFC chart).

• S7 Resource Allocation 
The list includes the assignment between CFC configuration objects and S7
resources.

• Block Call Hierarchy 
Displays a graphic representation of the call hierarchy of all blocks in the
current program.

• Statistics 
Graphic display of the numbers of all CFC and SFC objects and S7 resources
used as well as the time stamp of the current program.

For a detailed description of the lists and the meanings of the columns, refer to the
online help of CFC.

Note:

In the “Cross-References for CFC” list, no cross-references from CFC to CFC are
listed, since these correspond to the connections between CFC charts and can be
seen clearly in the CFC documentation.
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5.3 Logs

The logs do not belong to the documentation of the configuration structure but can
provide important information during configuration and trial startups if errors occur.

For further information on the logs, refer to the online help of the “Logs” dialog box.
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Technical Specifications

A.1 [S7] Technical Specifications

Hardware Requirements

• SIMATIC PG or PC

• Pentium

• RAM at least 128 Mbytes 
(recommended 64 Mbytes or more)

• Hard disk (free space) approx. 200 Mbytes (less RAM memory)

• Graphics card VGA 640 x 480
(recommended: SVGA 1024 x 768 or higher)

• MPI connection for online operation

• SIMATIC S7-300, S7-400

Software Requirements

• Microsoft Windows 95 
(with Service Pack 1)
or

• Microsoft Windows 98
or

• Microsoft Windows NT
(with Service Pack 3)

• STEP 7

• SCL Compiler

A
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A.2 Field/Name Lengths and Conventions

Table A-1 Name Lengths 

Object Length Remarks

Chart 22 Must not include the following characters: 
 \  .  ”  %

Chart comment 255 All ANSI characters are permitted.

Run-time group 22 Character set as for ”chart”

Task 22 Character set as for ”chart”

Block type 8 Determined by STEP 7.

Comment for 
block instance

80 All ANSI characters are permitted.

Parameter name 24 Determined by STEP 7.
The 1st character must not be a number (0 - 9).

Parameter comment 80 All ANSI characters are permitted.

Name of the block
instance

16 Must not include the following characters: 
 \  .  ”  % 

Global variables 24 Characters determined by the symbol editor; all
permitted even blanks and special characters except 
” .
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A.3 [S7] Data types

Table A-2 Data Type in SIMATIC S7  

Abb. Keyword Meaning Bits

A ANY Pointer to data element 80

BO BOOL Logical number 1

BY BYTE Sequence of 8 bits 8

C CHAR Single character 8

CR COUNTER Number of an S7 counter 16

D DATE Date 16

DB BLOCK_DB Number of a DB 16

DI DINT Double integer 32

DT DATE_AND_TIME or DT Date and time 64

DW DWORD Sequence of 32 bits 32

FB BLOCK_FB Number of an FB 16

FC BLOCK_FC Number of an FC 16

I INT Integer 16

P POINTER Pointer to memory area 48

R REAL Floating-point number 32

S STRING Text string of any length 256 bytes

SD BLOCK_SDB Number of an SDB 16

SN STRING[n] Text string with maximum n characters, 1 � n �
253

ST STRUCT Parenthesis for elementary data types and other
structures (nesting depth: 8)

T TIME_OF_DAY or TOD Timer 32

TI TIME Duration 32

TR TIMER Number of an S7 timer 16

T5 S5TIME Duration in S5 format 16

W WORD Sequence of 16 bits 16

For a detailed description of the data types, refer to the online help.
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Abbreviations

C / C++ High-level language for programming computers

CFC Continuous Function Chart

CPU Central Processing Unit

DB Data Block

ES Engineering System

FB Function Block

FC Function Code (function block without memory)

HID Higher level designation

IEA Import/Export Assistant

LAD Ladder Diagram

OB Organization Block

OS Operator Station

OCM Operator Control and Monitoring (WinCC)

B



Abbreviations

B-2
CFC for S7 

A5E00083002-02

PC Personal Computer

PCS 7 Process Control System (SIMATIC)

PG Programming Device

PH Plant Hierarchy

PLC Programmable (Logic) Controller

SFB System Function Block

SFC Sequential Function Chart

SINEC Siemens Network Architecture

STEP 7 Software development environment for SIMATIC S7 / M7

STL Statement List
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Glossary

A
In S7 the tasks are implemented as � organization blocks (OBs).

Absolute addressing

If data is addressed in absolute form, the absolute address is used to access the
value with which the operation will be performed.  Example: The address Q4.0
identifies bit 0 in byte 4 of the process output image (PIQ).

Access

Chart elements or block I/Os can access addresses, charts, block I/Os, or run-time
groups. A distinction is made between read and write access.

Address

An address is the identifier of the location of data or an area containing data,
examples: input I12.1; memory word MW25; data block DB3. An address is part of
a STEP 7 instruction and tells the processor what it should perform an operation
on. Addresses can be specified in absolute or symbolic form.

In SFC, the address is part of a statement (step) or condition (transition).
B

Basic operation

Basic operations (BOPs) are permanent objects in the system that perform simple
functions such as AND, OR etc. They are represented in CFC as blocks.

Block:

Blocks are separate parts of a user program that are distinguished by their
function, their structure or purpose.

CFC works with ready-made block types that are placed (inserted) in a CFC chart.
When a block type is inserted in the chart, a block instance is created. These block
instances and their graphic representation are blocks in the sense of CFC.

By positioning them on a free location in the sheet, they become normal blocks
again including their previous interconnections.
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Block category

The block category identifies different forms of blocks. Block categories include, for
example, data blocks (DBs), function blocks (FBs), and functions (FCs).

Block I/O

Block input or block output

Block input

Block I/O that can be interconnected with block outputs and � addresses of the
same data type or can have parameters assigned to it.

Block instance

A block instance is the implementation of a block type. A block type inserted in a
CFC chart becomes a block instance. When it is inserted, the block instance is
assigned run-time properties and is given a name that is unique within the chart.

Block header

The top part of a block when displayed in CFC. It contains the name and the task
assignment (run-time property).

Block library

� Library

Block output

Block I/O that can be interconnected with block inputs and � addresses of the
same data type.

Block type

Block types are ready-made program sections that can be used in a CFC chart (for
example, controllers, multiplexers etc.). When they are inserted, block instances
are created. You can create any number of block instances from a block type.

The block type determines the characteristics (algorithm) for all implementations of
this type. The name of the block is entered in the symbol table.
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C

CFC

Continuous Function Chart.

1. Function chart (CFC chart) with the graphic interconnection of technological
functions (blocks).

2. An editor for plant/oriented, graphic configuration of automation tasks. Using
CFC, entire software structures are created (CFC charts) from ready-made
blocks.

Chart

Document in which continuous automation functions are created with the CFC
configuration tool or in which sequential control systems are created with SFC.

Chart folder

Folder in the project structure containing charts of a user program.

Chart overview

The overview of a CFC chart or chart partition with its six sheets.

Chart partition

Part of a CFC chart. A CFC chart is subdivided into a maximum of 26 chart
partitions (named A to Z) each with 6 sheets.

Component view

Device-oriented view in the SIMATIC Manager. The project is displayed with its
components (station, module, program ... ); 
alternative to the � Plant View.

Connector

The connection point on the block with a reference to the I/O to which it is
connected. Connectors are used when no more connecting lines can be drawn on
a sheet because it is already full. The connectors allow complex CFC structures,
including those extending to other sheets, to be displayed completely.

Consistency Check

Checks the consistency of block types, shared addresses etc. of the chart folder.
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Control block for SFC

With the SFC control block (SFC_CTRL), you can query the status of an SFC
chart and influence its execution in CFC. The control block is inserted in the CFC
chart, interconnected, and assigned parameters. It has its own run-time properties
and can be modified (along with the SFC chart) in the run sequence. The control
block must always be installed immediately before an SFC chart in the run
sequence.

CPU

The CPU (central processing unit) is a module in the programmable controller on
which the user program is stored and run. It contains the operating system and the
communications interfaces.

Cycle time

The cycle time is the time required by the CPU to execute the user program once.
D

Data block (DB)

Data blocks are data areas in the user program containing user data. There are
shared data blocks that can be accessed by all logic blocks and instance data
blocks that are assigned to a particular FB call. In contrast to all other blocks, they
contain no instructions.

Data type

A data type specifies how the value of a variable or constant at a block I/O will be
used. ”BOOL”, for example, defines a binary variable and ”INT” defines a 16-bit
fixed-point variable.

Download-relevant change

A modification in the CFC/SFC chart is download-relevant when it causes a
change in the user program of the CPU (for example a change to an
interconnection). Changes that are not download-relevant involve, for example,
block positions and comments.

Dynamic display

In the dynamic display, input and output values of a block in a CFC chart or
address values in an SFC chart are updated from the CPU in the Test mode.
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Dynamic display window

Window in CFC for monitoring selected block I/Os on CPUs.
E

Edit mode:

(Alternative to the � Test mode) In CFC, blocks can be inserted, copied, moved,
deleted, assigned parameters, or interconnected.

Enable attribute

The enable attribute is a run-time attribute. It activates or deactivates a � run-time
group or an SFC chart.  As long as it is deactivated (FALSE), the run-time group /
the SFC chart is not executed regardless of any other conditions.

The enable attribute can be set dynamically. In this case, the output value of a
CFC block or the statement in an SFC action decides whether the run-time group
or SFC chart is activated or deactivated.

F

Function (FC)

(FUNCTION) According to IEC 1131-3, functions are logic blocks without  memory.
A function allows parameters to be transferred in the user program. Functions are
suitable for programming frequently recurring complex functions, for example
calculations. 
See also � Block category.

Function block (FB)

(FUNCTION BLOCK) According to IEC 1131-3, a function block is a logic block
with static data. An FB allows the transfer of parameters in the user program.
Function blocks are suitable for programming frequently recurring complex
functions, for example closed-loop controls. Since an FB has a memory (instance
data block), its parameters (for example outputs) can be accessed at any time and
any point in the user program. 
See also � Block category.

H

Higher level designation (HID)

This is made up of the hierarchical path of the � plant hierarchy.

I

Import/Export Assistant (IEA)

Software component in PCS 7 for handling models (and replicas of the models).
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Installation and commissioning

The CFC/SFC editors provide test functions to allow you to monitor, modify, and
change parameter settings on the PLC during installation and commissioning.

Interconnection

This connects a block/chart I/O with another element. The value of the
interconnected input is fetched from the other end of the interconnection during run
time.

Interface

The interface consists of the inputs and outputs of a block or a chart that can be
interconnected and assigned parameters.

L

Library

A folder for objects that can be used again and again. A library is not
project-related. Blocks are made available in block libraries sorted according to
certain criteria (block families, alphabetical order etc.).

Local data

Local data are data assigned to a logic block that are listed in its declaration
section or its variable declaration.

M

Message class

The message class determines the properties of a message. In SIMATIC PCS 7,
there are the following message classes: alarm, warning, tolerance, PLC and OS
process control message, process message, operator prompt, and operator
message.

Message configuration

Creating messages with their attributes and texts. Messages can be configured in
CFC/SFC.

N

Nested chart

A CFC chart that is inserted in another CFC chart (nested or top chart). Nested
charts are not displayed in the SIMATIC Manager.
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O

Online/Offline

In the SIMATIC Manager, objects of the programmable controller are displayed in
the online view and the objects of the ES in the offline view. Online, there is a data
connection between the PLC and the programming device/PG, offline there is no
connection.

Operating mode

1. The programmable controllers of SIMATIC S7 can adopt the following modes:
STOP, STARTUP, RUN and HOLD.

2. (SFC) The sequential control system can operate in the following modes IDLE,
RUN and HOLD.

Operating system

General term for all the functions that control and monitor the execution of the user
programs, the distribution of resources to the individual programs, and the
maintenance of the operating mode in conjunction with the hardware (for example
standard operating system MS-WINDOWS, real-time operating system M7
RMOS32).

Organization block (OB)

Organization blocks form the interface between the operating system of the CPU
and the user program. The order of execution of the user program is specified in
organization blocks.

An organization block corresponds to a � task.

OS

Operator Station. A station for controlling and monitoring the process. In PCS 7,
the WinCC software system is used for the OS with which all the process
monitoring and control functions can be implemented.

Overlapping Block

Overlapping blocks are blocks that could not be inserted completely at a free
position on the sheet. They cover other objects partly or completely. Overlapping
blocks are displayed in the chart in their full size but without block I/Os and in light
gray. Existing I/Os are not visible in this display form (nor are the entries in the
sheet bar), they do, however, exist.

The same applies to nested charts.
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Overflow Page

(CFC) If there are so many entries in the � sheet that there is no more space in the
sheet bars, an overflow page is automatically created. An overflow page consists
only of the � sheet bars with entries and contains no other objects.

P

Parameter

A parameter is

1. the value of a CFC block/chart I/O.

2. a variable of an S7 logic block (actual parameter, formal parameter)

Phase offset

The phase offset shifts the point of activation of the run-time group within a task by
a defined time compared with the basic cycle. Phase offset allows a uniform
distribution of load within the CPU. See also � scan rate.

Plant hierarchy (PH)

A hierarchy structured according to technological aspects.

Plant view

View in the SIMATIC Manager based on technological aspects (plant, unit, function
...); alternative to the � component view.

PLC

PLC is used as a general term for the unit containing the CPUs on which the user
program runs. In this case, it includes S7 programmable controllers and M7
automation computers.

Process control point

The smallest unit in process control. This handles processing functions of a
process variable such as closed-loop control, display, alarm generation etc.

Process image

Reserved areas in the RAM of the CPU. Signal states of the input and output
modules are entered here.



Glossary

Glossary-9
CFC for S7 
A5E00083002-02

Process variable

The process variable is a neutral object in terms of resources. It is used to connect
the PLC configuration world (STEP 7, CFC ...) with the OS configuration world
(WinCC). It contains information about its location during run time (for example the
network address and the memory area on the PLC) as well as information on
specific OS-relevant properties.

Program

General term for S7 and M7 programs.

Programmable controller

A programmable controller (PLC) is a controller in SIMATIC S7, a compact device
(PLC with integrated operator controls) SIMATIC C7, or a SIMATIC M7 automation
computer.

Programming device (PG)

Portable and compact personal computer specially designed for use in an industrial
environment. A programming device is completely equipped for programming
SIMATIC programmable controllers.

Project

A folder for all the automation solutions regardless of the number of stations or
modules and how they are networked.

R

Reference data

Chart reference data are data available to the user in addition to the graphic chart
display in the form of lists, for example the list of accesses to shared addresses or
the block hierarchy calls.

Resources

Resources are pools of objects (FBs, FCs, DBs, OBs, bit memory, counters, timers
etc.) that can be accessed when configuring and setting parameters for a
CFC/SFC chart.

Run-time attribute

Each � run-time group has run-time attributes that control its activation. The group
passes on these attributes to all the blocks it contains.
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Run-time group

Run-time groups are used to structure � tasks. The blocks are installed
sequentially in the run-time groups. Run-time groups can be activated and
deactivated separately. If a run-time group is deactivated, the blocks it contains will
no longer be activated.

Run-time properties

The run-time properties of a block decide how the block is included in the run
sequence within the entire structure of the PLC. These properties are decisive for
the response of the PLC in terms of reaction times, dead times, or the stability of
time-dependent structures, for example closed loops.

S

S7 program

A folder for the � symbol table, the blocks, the source files, and the charts for the
programmable S7 modules.

Scan rate

The scan rate is a � run-time attribute. It specifies whether a � run-time group is
executed every time a task is executed or only every nth time. See also � phase
offset.

SCL

A high-level language similar to Pascal complying with IEC 1131-3 for
programming complex solutions on a PLC, for example algorithms and data
processing jobs.

Sequential control system

A sequential control system switches from one step to the next dependent on
conditions. In PCS 7, sequential control systems are implemented with SFC
charts.

SFC

An SFC chart represents a � sequential control system that runs as a separate
control system within the programmable controller.
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Shared address

Shared addresses are objects that can be accessed by every logic block (FC, FB,
OB). They include bit memory (M), inputs (I), outputs (Q), timers (T), counters (C),
and elements of data blocks (DB). To access shared addresses, you can use
absolute addresses or symbols.

Shared data block

This is a data block that can be accessed by all blocks in the program. Each CFC
block instance can therefore read the shared data from the block or write data to
the block.
 

Sheet

Subdivision of a chart partition. A � chart partition consists of 6 sheets. The sheet
represents a working area (with sheet bars), on which blocks can be placed,
assigned parameters, and interconnected.

Sheet bar

Margin at the right and left edges of a CFC chart. The sheet bars contain:

• references to connected objects (block/chart interface, address, and run-time
group) that are not located on the active sheet

• the number of the connector reference when the connecting line cannot be
drawn to the sheet bar because the chart is full.

SIMATIC Manager

Graphic user interface for SIMATIC users under Windows 95/98/NT. The SIMATIC
Manager is used, for example, to create projects and access libraries.

Structure

A structure is a structured � data type made up of various elements. An element
itself can be an elementary or a structured data type.

Symbol

A symbol is a name defined by the user according to certain syntactical rules. After
its purpose has been defined (for example to represent a variable, data type, jump
label, block), it can be used in programming and in operator monitoring and control.

Example: address : I5.0, data type: BOOL, symbol: Emer stop.
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Symbol table

Table for assigning symbols (= name) to addresses for shared data and blocks. 
Examples: Symbol Address

Emer stop I1.7, 
Control FB24

Symbolic addressing

If data is addressed using symbols, the � address to be processed is specified as
a symbol (not as an absolute address). Symbols are assigned to addresses in the
symbol table.

T

Task

Tasks form the interface between the operating system of the CPU and the user
program. The order of execution of the user program is specified in tasks. In M7,
the tasks are mapped on RMOS tasks

A task corresponds to an organization block (OB) in S7.

Test mode

(Alternative to the � Edit mode) Mode of CFC/SFC for testing and optimizing user
program running online on the CPU.

Top chart

A CFC chart that is not nested in another chart and can be displayed in the
SIMATIC Manager ( � nested charts).

U

Update cycle

In the Test mode, this specifies the intervals at which the watched block I/Os are
updated.

V

Value identifier

Symbolic substitute (text) for defined values of block I/Os of the data types BOOL,
BYTE, INT, DINT, WORD and DWORD.
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Index

A
Adding/removing I/Os in the watch list, 4-8

B
Basic operation, 1-9
Batch compilation/downloading, 3-41
Block comment, 3-17
Block family, 1-8
Block I/O, setting values, 4-9
Block input, inverted, 3-18
Block instance, 1-7
Block libraries, 1-10
Block type, 1-7
Block type change, central, 3-10
Blocks

aligning, 3-15
copying, 3-16
deleting, 3-16
importing, 3-9
moving, 3-16
new version, 3-10
overlapping, 1-9
unplaced, 1-9

BOP, 1-9
Branch-and-merge, 3-1

C
Catalog, 1-10
Changes, compiling, 3-35
Changing the watch cycle, 4-5
Chart, 1-4

copying, 3-3
creating, 3-2
open, 3-2

Chart I/Os, 3-5
Chart partition, 1-4
Chart partitions, inserting/deleting, 3-4
Chart reference data, 5-4
Chart-in-chart, 3-7
Commissioning, preparing, 4-3

Compile
block type, 3-38
program, 3-34

Compiling, 3-35
batch processing, 3-41
changes, 3-35

Consistency check, 3-37
Copying

chart, 3-3
to a different CPU, 3-16

CPU program
starting, 4-3
stopping, 4-3

Customize compiler (SCL), 3-36

D
Data transfer PLC-OS, 1-11
Data type extension, 3-11
DB, 3-34
Delete empty run-time groups, 3-36
Displaying module information, 4-4
DOCPRO, 5-3
Download

batch processing, 3-41
program, 3-39

Downloading F programs, 3-40, 3-41
Driver and message concept, 3-29
Dynamic display, 4-10

E
Edit mode, 4-2
Enable attribute, 3-21

F
FB, 1-9
FC, 1-9, 3-34
Footers, 5-3
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G
Generate module drivers, 3-29, 3-35
Generic block, 1-8

H
H CPU

downloading, 3-40
read back, 3-42
testing, 4-5

I
Importing blocks types, 3-9
Include user data blocks, 3-40
Interconnection

copying, 3-23
delete, 3-24
to chart I/Os, 3-5
to run-time group, 3-21
to SFC charts, 3-22
to shared addresses, 3-21

K
Keywords (DOCPRO), 5-3

L
Laboratory mode, 4-5
Libraries, 1-10
Logs, 5-6

M
Message block, 1-11
Multi-user mode, 3-1
Multiple instance block, 1-8
Multiple users , 3-1

N
Nested chart, 1-4, 3-7

O
Object properties, 3-17
Operator control and monitoring, 1-11

Operator control block, 1-11
Optimize code, 3-38
Organization block, 1-8
Overflow page, 1-4
Overlapping blocks, 1-9
Overview, 1-5

P
PLC-OS communication, 1-11
Predecessor for installation, 3-27
Printing a chart, 5-2
Process mode, 4-5

R
Read back, 3-42
Resetting a CPU, 4-4
Resources on the PLC, 3-34
Run sequence, editing, 3-27
Run-time group, 3-28

creating, 3-28
interconnecting, 3-21

Run-time properties, 3-26

S
Set time and date, 4-4
SFC access, 3-22
Shared address, 3-21
Sheet, 1-4
Sheet bar jump, 3-23
Sheet view, 1-6
Signal tracking, 3-23
SIMATIC Manager, 1-3
STEP 7 environment, 1-3
Structure, 3-24
System attributes

for chart I/Os, 3-6
matching, 3-14

T
Test, preparing, 4-3
Test mode, 4-2, 4-6
Test modes, 4-5
Text box, 3-15
Time stamp, 4-3
Tolerant type import, 3-11
Top chart, 3-7
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U
Unplaced blocks, 1-9
Update sampling time, 3-36
User program, downloading, 3-39

V
Value identifier, 3-19

W
WinCC, 3-13
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�

Siemens AG
A&D AS E 81

Oestliche Rheinbrueckenstr. 50
D-76181 Karlsruhe
Federal Republic of Germany

Please check any industry that applies to you:

� Automotive

� Chemical

� Electrical Machinery

� Food

� Instrument and Control

� Nonelectrical Machinery

� Petrochemical

� Pharmaceutical

� Plastic

� Pulp and Paper

� Textiles

� Transportation

� Other _ _ _ _ _ _ _ _ _ _ _

From:

Your Name: _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

Your Title: _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

Company Name: _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

Street: _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

City, Zip Code _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

Country: _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

Phone: _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
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Additional comments:

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

Remarks Form

Your comments and recommendations will help us to improve the quality and usefulness
of our publications. Please take the first available opportunity to fill out this questionnaire
and return it to Siemens.

Please give each of the following questions your own personal mark within the range from
1 (very good) to 5 (poor).

1. Do the contents meet your requirements?

2. Is the information you need easy to find?

3. Is the text easy to understand?

4. Does the level of technical detail meet your requirements?

5. Please rate the quality of the graphics/tables:
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